Subject: [ietf-provreg] Certificate Validation and Subject Analysis

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 5 Dec 2006 08:13:29 -0500

I received a question from an IESG member about EPP implementations and
X.509 digital certificate validation.  What are implementers doing with
the certificate subject name information when validating the
certification path of a client or server?  Is the name being examined
and/or used for authentication or access control purposes?

-Scott-

---

From: Hugo Koji Kobayashi <[email-masked]>
Date: Tue, 5 Dec 2006 15:58:38 -0200

Scott,

Our (.br Registry) server implementation uses the Subject's Common
Name to carry an unique client identifier that is used to authenticate
clients in a multiple match authentication (EPP <clID> and <pw>, IP
address, and certificate).

Hugo

---

From: "Dan Maharry" <[email-masked]>
Date: Wed, 6 Dec 2006 10:35:49 -0000

Scott,

.coop uses the common name of the digital certificate along with the IP
address used to connect to our servers as well as password and user id
to log onto the EPP server. If any of the four don't match, the client
can't log in.

Dan

Dan Maharry
Technical Manager
Midcounties Co-operative Domains Ltd 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Hollenbeck, Scott
Sent: 05 December 2006 13:13
To: [email-masked]
Subject: [ietf-provreg] Certificate Validation and Subject Analysis

-Scott-

------------------------------------------------------------------------
--------
This Message has been Scanned by SurfControl(c) Email Filter
------------------------------------------------------------------------
--------

The Midcounties Co-operative is an innovative co-operative business, owned by its customers and staff in the 9 counties it spans. We trade in a
number of retail sectors including food, travel, funerals, motors, childcare, pharmacy, post offices and IT. We are proud to be a successful
co-operative, founded on co-operative values and principles that co-ops share throughout the world.

This e-mail is confidential and is for the named recipient(s) only. If you are not the named recipient(s) please do not disseminate or copy this
e-mail, but please delete it and any copies from your computer. The Midcounties Co-operative has taken reasonable precautions to ensure that
any attachment to this e-mail has been checked for viruses. However, we cannot accept liability for any damage sustained as a result of
any such viruses and advise you to carry out your own virus checks before opening any attachment. Furthermore, we do not accept responsibility for any
change made to this message after it was sent by the sender. 

*** The Midcounties Co-operative works to protect our environment ***  
*** Please don't print this e-mail unless you really need to ***

This Message has been Scanned by SurfControl(c) Email Filter