Subject: Re: [ietf-provreg] new epp commands?

From: "Gould, James" <[email-masked]>
Date: Tue, 19 Jan 2010 07:34:57 -0500

Jaap,

I believe that this was by design.  We use reports for providing this kind of information.  Using the provisioning protocol as a query protocol for what could be lists of millions of objects is not a good use of the protocol. 

JG

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Ulrich Wisser <[email-masked]>
Cc: EPP Provreg <[email-masked]>
Sent: Tue Jan 19 07:08:39 2010
Subject: Re: [ietf-provreg] new epp commands? 

My two cents in-line
    
    here at .SE many registrars asked for lists of their 
    domains/hosts/contacts. Obviously there are no commands in the standard 
    to extract lists of objects from the epp server.

These registrars don't have an administration on there own?
    
    Before proposing new commands I'd like to ask why there aren't any such 
    commands? Has it been a deliberate decision or didn't just nobody ask 
    for it?

It has been deliberate not to turn EPP into yet another whois
protocol. Also, not all registries do have this data because not
all are "thick registries".

	jaap
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
List run by majordomo software.  For (Un-)subscription and similar details
send "help" to [email-masked]

---

From: Edward Lewis <[email-masked]>
Date: Wed, 20 Jan 2010 13:22:03 -0500

5-10 years ago...EPP was for the input, IRIS was for the output.

The idea was that EPP would cover the add/delete/mods to the database 
(and yes, limited info) but "bulk" retrievals would be left to 
another protocol.  IRIS came along for that, essentially a 
replacement for WhoIs (and RWhoIs).  After IRIS was mostly developed, 
"domain checking" came along - the desire to see if a domain name was 
available - and there was a lightweight (UDP) addition made to IRIS 
to cover that.

What's important to keep in mind in "understanding" this is that this 
happened during a time when domain name registries were still in 
their infancy as well as the entire business of registering domains. 
And yes, most of the thinking then was based what became ICANN's 
shared registry model.

At 7:34 -0500 1/19/10, Gould, James wrote:
Jaap,

I believe that this was by design.  We use reports for providing this 
kind of information.  Using the provisioning protocol as a query 
protocol for what could be lists of millions of objects is not a good 
use of the protocol.

JG

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Ulrich Wisser <[email-masked]>
Cc: EPP Provreg <[email-masked]>
Sent: Tue Jan 19 07:08:39 2010
Subject: Re: [ietf-provreg] new epp commands?

My two cents in-line

    

         jaap

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis             
NeuStar                    You can leave a voice message at +1-571-434-5468

As with IPv6, the problem with the deployment of frictionless surfaces is
that they're not getting traction.