Subject: [provreg] Fwd: New Version Notification for draft-tan-epp-launchphase-01.txt

From: Wil Tan <[email-masked]>
Date: Tue, 18 Oct 2011 01:36:11 +1100

Dear colleagues,

Gavin and I have published a new version of the draft:
http://tools.ietf.org/html/draft-tan-epp-launchphase-01

This is mostly Gavin's work, with the following changes:

- element names are now in camelCase
- renamed <trademark> to <claim>
- a "preValidated" attribute of <claim> element
- there can be one or more <claim> elements

As usual, we'd love to hear any feedback that you may have.

-- 
.wil
Cloud Registry <http://www.cloudregistry.net>

---------- Forwarded message ----------
From: <[email-masked]>
Date: Fri, Oct 14, 2011 at 3:16 AM
Subject: New Version Notification for draft-tan-epp-launchphase-01.txt
To: [email-masked]
Cc: [email-masked], [email-masked]

A new version of I-D, draft-tan-epp-launchphase-01.txt has been successfully
submitted by Wil Tan and posted to the IETF repository.

Filename:        draft-tan-epp-launchphase
Revision:        01
Title:           Launch Phase Mapping for the Extensible Provisioning
Protocol (EPP)
Creation date:   2011-10-14
WG ID:           Individual Submission
Number of pages: 19

Abstract:
  This document describes an Extensible Provisioning Protocol (EPP)
  extension mapping for the provisioning and management of domain names
  during the launch phase of a domain name registry.

The IETF Secretariat

---

From: Ulrich Wisser <[email-masked]>
Date: Thu, 20 Oct 2011 11:47:55 +0200

Dear Wil and Gavin,

great work!

I do have some "minor" comments:

1. After a claim has been invalidated an applicant may submit additional 
data offline or through an update and the claim goes from status invalid 
to valid or maybe even pending.

2. There is no possibility to update an application. There should be an 
lp:add lp:rem and lp:chg. Of course there could be restrictions based on 
the application status.

3. I would prefer more server considerations. "Server has to ensure that 
in the presence of an lp:xxx the command is processed as an launch phase 
application and not as ordinary domain:xxx command."

/Ulrich

> From: ** <[email-masked] <mailto:[email-masked]>>
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>,
> [email-masked] <mailto:[email-masked]>
>
>
> A new version of I-D, draft-tan-epp-launchphase-01.txt has been
> successfully submitted by Wil Tan and posted to the IETF repository.
>
> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg

---

From: Gavin Brown <[email-masked]>
Date: Mon, 24 Oct 2011 17:18:48 +0100

Hi Ulrich,

> to valid or maybe even pending.

This is a good point. It may be that having a State Transition diagram
is impractical, as out-of-band processes could result in more
transitions than it's possible to represent.

> lp:add lp:rem and lp:chg. Of course there could be restrictions based on 

I think this would be worth supporting.

> application and not as ordinary domain:xxx command."

Another good point.

Thanks,

-- 
Gavin Brown
Chief Technology Officer
CentralNic Ltd
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Ltd is a company registered in England and Wales with company
number 4985780. Registered Offices: 35-39 Moorgate, London, EC2R 6AR.