Subject: Re: [provreg] Has the EPP world really changed?

From: "Jiankang YAO" <[email-masked]>
Date: Wed, 29 Aug 2012 15:01:39 +0800

a.. From: Patrik Fältström <patrik at frobbit.se> 
  b.. To: Edward Lewis <Ed.Lewis at neustar.biz> 
  c.. Cc: IETF Provreg Mailing List <provreg at ietf.org> 
  d.. Date: Fri, 24 Aug 2012 16:50:07 +0200 
  e.. In-reply-to: <a06240801cc5d3fc5e1b5 at [10.33.203.101]> 
  f.. References: <alpine.DEB.2.00.1208241025280.16452 at softronics.hoeneisen.ch> <a06240800cc5d39505e3a at [10.33.203.101]> <1E021559-D8A8-41DA-BDAC-B6DF57A6C0D6 at frobbit.se> <a06240801cc5d3fc5e1b5 at [10.33.203.101]> 
  g.. List-id: EPP discussion list <provreg.ietf.org> 

--------------------------------------------------------------------------------

>>On 24 aug 2012, at 16:31, Edward Lewis <Ed.Lewis at neustar.biz> wrote:

...>> In some cases, the registrars weren't implementing anything, so the number of extensions didn't matter.  They just got the code and put it in place.
>>CNNIC'registrars use different clients for different registries. For .CN, the registrar uses the EPP client (source code) provided by CNNIC to connect CNNIC's EPP server.The registrar also uses the .HK's client to connect to .HK.Based on my estimate, most registrars will use different clients to connect different registries. They will be unlikely to use the same client to connect to the different registries evenif those registries run the EPP protocols.Jiankang Yao
>Of course, if you are lucky!

 >  Patrik

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 29 Aug 2012 10:01:24 +0200

On 29 aug 2012, at 09:01, Jiankang YAO <[email-masked]> wrote:

> Based on my estimate, most registrars will use different clients to connect different registries. They will be unlikely to use the same client to connect to the different registries even
> if those registries run the EPP protocols.
> 

Interesting. This is definitely not the situation in Europe. Because of that, the registrars must develop clients that work towards all registries they have interest in doing buisness with.

   Regards, Patrik

---

From: "\"Michele Neylon :: Blacknight\"" <[email-masked]>
Date: Wed, 29 Aug 2012 08:09:35 +0000

> Interesting. This is definitely not the situation in Europe. Because of that, the registrars must develop clients that work towards all registries they have interest in doing buisness with.

Agreed 

We have one client that handles all registries we integrate with

I can't imagine any sane reason why we would want to maintain multiple ones.

Regards

Michele

--
Mr Michele Neylon
Blacknight Solutions
Hosting & Colocation, Brand Protection
http://www.blacknight.com/
http://www.dotwhat.co/
http://blog.blacknight.com/
http://mneylon.tel/
Intl. +353 (0) 59  9183072
Locall: 1850 929 929
Direct Dial: +353 (0)59 9183090
Fax. +353 (0) 1 4811 763
Twitter: http://twitter.com/mneylon
-------------------------------
Blacknight Internet Solutions Ltd, Unit 12A,Barrowside Business Park,Sleaty
Road,Graiguecullen,Carlow,Ireland  Company No.: 370845

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 29 Aug 2012 10:16:27 +0200

> I can't imagine any sane reason why we would want to maintain multiple ones.

We have one _provisioning_system_ that our customers use (the actual domain name holders). That provisioning system must be able to communicate directly via epp with all registries that the holders of the domain names want to manage. For all other registries, the customers get crappy service by us because lack of epp triggers a manual process regarding interaction between the registrar and the registry.

So it should be in a _mutual_ interest for both registries and registrars that epp implementations is as easy as possible to multiple registries and not only one.

Sure, I can see a business model where a registry by having a Very Different Epp Implementation believe they are "locking in" registries to them. That is sort of true, but it does not lock in the registrants which ultimately do decide what registries (and registrars) they do business with.

   Patrik

---

From: "\"Michele Neylon :: Blacknight\"" <[email-masked]>
Date: Wed, 29 Aug 2012 08:24:42 +0000

Patrik

If a registry wants to be "special" and they're not Verisign then why would registrars integrate with them?

In a newTLD world registrars are not going to be able to integrate with ALL registries and will have to be selective about which extensions they choose to carry and which ones they integrate with first.

If we are offered a list of registries we'll integrate with the "simpler" ones first, because it takes less time and costs less money and has lower risk ie. we're less likely to run into weird issues that cause headaches for us and our customers .. which in turn costs us money

Assuming that registrars will deal with a registry's weird implementation might work where there is a monopoly type situation and the registrar has a strong business reason to do so, but when there is no monopoly type scenario they're not going to ..

Regards

Michele