Subject: Re: [provreg] Launch Phase EPP Extension Version 02 Posted

From: Keith Gaughan <[email-masked]>
Date: Fri, 10 Aug 2012 17:13:11 +0100

On Fri, Aug 10, 2012 at 02:23:17PM +0000, Gould, James wrote:

> I've been working with Wil Tan and Gavin Brown on updating the Launch Phase EPP
> Extension Mapping to support the two models (ICANN and ARI/Neustar) along with
> the models that were previously defined in the Launch Phase EPP Extension
> Version 01.  You can find the draft at the URL http://www.ietf.org/id/
> draft-tan-epp-launchphase-02.txt.  This is a straw man draft to kick off the
> discussions as the tmch-tech list works out the model.  I've already posted a
> message on the tmch-tech list to start the discussions there.  

Small nit: quite a number of the stanzas have namespace declarations for
http://www.w3.org/2001/XMLSchema-instance, but with no schema locations
specified on the relevant elements or any other attributes from that namespace
being used. Is there any reason why XSI is being used in the example stanzas?
Just curious.

-- 
Keith Gaughan, Development Lead
PGP/GPG key ID: 82AC3634
Blacknight Internet Solutions Ltd. <http://blacknight.com/>
12A Barrowside Business Park, Carlow, Ireland
Registered in Ireland, Company No.: 370845

---

From: "Gould, James" <[email-masked]>
Date: Fri, 10 Aug 2012 16:28:31 +0000

Keith,

This is following what has been done with the EPP RFC's.  Is there
anything that you notice different with the XML samples included in the
Launch Phase EPP Extension than with the EPP RFC's?

--
  
JG

James Gould
Principal Software Engineer
[email-masked]
 
703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

On 8/10/12 12:13 PM, "Keith Gaughan" <[email-masked]> wrote:

>_______________________________________________
>provreg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/provreg

---

From: Keith Gaughan <[email-masked]>
Date: Fri, 10 Aug 2012 18:04:23 +0100

> Launch Phase EPP Extension than with the EPP RFC's?

It's use in the EPP RFCs was dropped in the rfc493x series of updates to the
specs. For instance in http://tools.ietf.org/html/rfc4930, appendix C:

   11.  Removed text describing use of the XML Schema schemaLocation
        attribute. This is an optional attribute that doesn't need to
        be mandated for use in EPP.

I'm raising this more because it may be unintentionally assumed to be required
(which it isn't). There's at least one (ccTLD) registry operator we deal with
who incorrectly assumes it's required.

As I said, it's a small nit.

K.

---

From: Wil Tan <[email-masked]>
Date: Wed, 15 Aug 2012 16:14:49 +1000

Hi Keith,

> As I said, it's a small nit.
Thanks for catching it. I've removed these from the working copy so the
next version will no longer have the XSI attributes.

.wil