Subject: [provreg] Application and TMCH drafts

From: Chris Wright <[email-masked]>
Date: Wed, 23 Jan 2013 13:35:30 +1100

All,

Attached are the alternative drafts mentioned earlier.

These drafts take a different approach to the Verisign draft, however it does pull together concepts from other documents, and previous feedback we have given to Verisign on their draft which has been incorporated (that is why there are similarities).

Separating TMCH from launch activities is the first difference. Decoupling these, separation of concerns, is good software engineering practice. By separating the TMCH, and other 'data' from the actual application, this promotes the most reuse of the application draft - it allows the launch (application) draft to be used by registries that do not require TMCH integration (ccTLDs, IDN ccTLDs etc), or require different trademark field, for example, to the ones described in the Verisign draft.

Features of the Application draft:

*         Application draft allows for submission of applications for domain names either during a sunrise, land rush or other periods

*         Applications can be used for sunrise, land-rush and even release of reserved names after go-live, during general availability

*         Application check command can be used to check availability of names during an application period (allows releases of sets of names during general availability) - this could be the launch of new IDN languages or release of previously held back names etc

*         We improve the use of status values by making them specific about what actions can and can't be taken, so that clients of not require external knowledge about the 'meaning' behind a particular 'state' which may also vary between registries, thus complicating Registrars lives further

*         Does not dictate phase requirements, allowing registries to decide own business models for launch

*         Does not mandate data that is to be passed with applications (like trademark data or other information)- different extensions should be used for describing data to be sent with applications, data that is sent with applications may be the same data that is to be sent with domain creates for example, the TMCH draft is an example of a draft that defines data that is to be sent with an application (or could also be sent with a domain create for someone running a first come, first server sunrise and thus not requiring 'applications' at all) -  most registries already implement a 'key-value-pair' extension of sorts to facilitate the transfer of arbitrary data (from the protocol perspective)

Features of the TMCH draft:

*         TMCH is isolated draft and doesn't tie supporting of applications to support of TMCH - this enables TMCH data to be passed with just a domain create command or a domain create that uses the application extension as well, allowing first come first servers, or applications, or any other thing that a registry may dream up - the TMCH is not coupled to an domain 'application process'

*         TMCH draft defines base64 transport for SMD only, reducing options, thus simplifying implementation - this allows the format of the SMD to be locked down independent of the this draft, and addresses issues with XML signature validation - it also allows non XML format SMDs to be used if deemed required (given TMCH specification is not locked down yet)

We feel these documents are smaller, simplified and, in our opinion, easier to understand.

Please note we are submitting these drafts through IETF processes at the moment.

Thanks

Chris Wright
Chief Technology Officer

ARI REGISTRY SERVICES
Melbourne | Los Angeles
P   +61 3 9866 3710
M  +61 401 873 798
E   [email-masked]<mailto:[email-masked]>
W  www.ariservices.com<http://www.ariservices.com/>

ARI Registry Services is an evolution of AusRegistry International.
Follow us on Twitter<http://twitter.com/#!/ausregistryint>
The information contained in this communication is intended for the named recipients only. It is subject to copyright and may contain legally privileged and confidential information and if you are not an intended recipient you must not use, copy, distribute or take any action in reliance on it. If you have received this communication in error, please delete all copies from your system and notify us immediately.

---

From: Chris Wright <[email-masked]>
Date: Wed, 23 Jan 2013 13:38:01 +1100

Re-sending - removing signature and disclaimer - apologies.

Thanks

Chris

From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Wright
Sent: Wednesday, 23 January 2013 1:36 PM
To: [email-masked]; [email-masked]
Cc: Wodjenski, Sharon
Subject: [provreg] Application and TMCH drafts

All,

Thanks

Chris