Subject: [provreg] Uniform Poll Responses for Launch Phase Results

From: <[email-masked]>
Date: Thu, 28 Feb 2013 10:15:30 -0700

Hi, All.  I've been catching up today on the good work that is being done by so many in this group to nail down a functional common standard to support TLD launch phases via EPP.  Thank you for all you are doing in this regard!

From a registrar perspective, there's a feature that I would find enormously helpful in facilitating TLD launches - poll messages to indicate when a domain application reaches a terminal state: allocated, rejected, or other.

Historically, for TLD launches, one of the most labor-intensive steps in the process for Go Daddy has been reconciling the results of sunrise and landrush phases by either processing a spreadsheet emailed to us by the registry or performing repeated whois queries to try to find out whether the domain has been allocated to us or not.  Both of these approaches are more manual than my liking.

As we approach the onrush of gTLD launches, we will be collaborating with our registry partners to provide poll messages to communicate the outcomes of domain applications, and it would be beneficial for all of us in the industry, I think, if the attributes of such poll messages were common across all TLDs.

Question 1 - Is it reasonable to expect that gTLD applications could culminate in a poll message communicating the outcome back to the requesting registrar?

Question 2 - If so, do the following <poll> response examples seem suitable: adhering to existing EPP standards AND containing sufficient information to sync up with the registrar?

------------------------------------------------------------

<poll> response when a launch phase application is allocated

------------------------------------------------------------

<?xml version="1.0" encoding="UTF-8" standalone="no"?>

<epp xmlns="urn:ietf:params:xml:ns:epp-1.0">
<response>
<result code="1301">
<msg>Command completed successfully; ack to dequeue</msg>
</result>
<msgQ count="5" id="12345">
<qDate>2000-06-08T22:00:00.0Z</qDate>
<msg>Application allocated.</msg>
</msgQ>
<resData>
<obj:appData xmlns:obj="urn:ietf:params:xml:ns:obj-1.0">
<obj:name>example.llc</obj:name>
<obj:apID>abc123</obj:applicationID>
<obj:apStatus>allocated</obj:trStatus>
</obj:appData>
</resData>
<trID>
<clTRID>ABC-12345</clTRID>
<svTRID>54321-XYZ</svTRID>
</trID>
</response>
</epp>

------------------------------------------------------------

<poll> response when a launch phase application is rejected

------------------------------------------------------------

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<epp xmlns="urn:ietf:params:xml:ns:epp-1.0">
<response>
<result code="1301">
<msg>Command completed successfully; ack to dequeue</msg>
</result>
<msgQ count="5" id="12345">
<qDate>2000-06-08T22:00:00.0Z</qDate>
<msg>Application rejected.</msg>
</msgQ>
<resData>
<obj:appData xmlns:obj="urn:ietf:params:xml:ns:obj-1.0">
<obj:name>example.llc</obj:name>
<obj:apID>abc123</obj:applicationID>
<obj:apStatus>rejected</obj:trStatus>
</obj:appData>
</resData>
<trID>
<clTRID>ABC-12345</clTRID>
<svTRID>54321-XYZ</svTRID>
</trID>
</response>
</epp>

Thanks,

Jeremy Bushlack

Director, Software Development

Registrar Services
GoDaddy.com
[email-masked]
http://www.godaddy.com
319-294-3934

I value service, simplicity, and facts. How am I doing? Reply to my supervisor, Roger Carney ([email-masked]).

---

From: Rubens Kuhl <[email-masked]>
Date: Thu, 28 Feb 2013 14:21:57 -0300

> Question 1 - Is it reasonable to expect that gTLD applications could culminate in a poll message communicating the outcome back to the requesting registrar?

Yes. We cannot see ourselves not sending a poll message. But what are you suggesting is a very interesting idea of having it standardized. There is value in not having 1400 different poll messages... 

>         <obj:apID>abc123</obj:applicationID>

What's the ID syntax reference on the current draft-tan ? 

Rubens

---

From: Luis Muñoz <[email-masked]>
Date: Thu, 28 Feb 2013 12:34:14 -0500

> Historically, for TLD launches, one of the most labor-intensive steps in the process for Go Daddy has been reconciling the results of sunrise and landrush phases by either processing a spreadsheet…

More manual and way more expensive. Definitely having the poll message at the end of the process seems like the right thing to do.

Best regards

-lem

---

From: "Gould, James" <[email-masked]>
Date: Thu, 28 Feb 2013 17:39:00 +0000

I view an application as a domain in pendingCreate status, so I believe that the pending action poll message, per RFC 5731, is appropriate to notify the result of the application.  Using the <launch:infData> extension, it can provide the specific status and application identifier.  Do you believe that it makes sense to also include the poll messages for the intermediate state transitions?

Below could be the successful application:

   S:<?xml version="1.0" encoding="UTF-8" standalone="no"?>
   S:<epp xmlns="urn:ietf:params:xml:ns:epp-1.0">
   S:  <response>
   S:    <result code="1301">
   S:      <msg>Command completed successfully; ack to dequeue</msg>
   S:    </result>
   S:    <msgQ count="5" id="12345">
   S:      <qDate>2013-04-04T22:01:00.0Z</qDate>
   S:      <msg>Application successfully allocated.</msg>
   S:    </msgQ>
   S:    <resData>
   S:      <domain:panData
   S:       xmlns:domain="urn:ietf:params:xml:ns:domain-1.0">
   S:        <domain:name paResult="1">example.tld</domain:name>
   S:        <domain:paTRID>
   S:          <clTRID>ABC-12345</clTRID>
   S:          <svTRID>54321-XYZ</svTRID>
   S:        </domain:paTRID>

   S:        <domain:paDate>2013-04-04T22:00:00.0Z</domain:paDate>
   S:      </domain:panData>
   S:    </resData>

   S:    <extension>
   S:      <launch:infData
   S:       xmlns:launch="urn:ietf:params:xml:ns:launch-1.0">
   S:        <launch:phase>sunrise</launch:phase>
   S:          <launch:applicationID>abc123</launch:applicationID>
   S:          <launch:status s="allocated"/>
   S:      </launch:infData>

   S:    </extension>

S: <trID> S: <clTRID>BCD-23456</clTRID> S: <svTRID>65432-WXY</svTRID> S: </trID> S: </response> S:</epp>

Below could be the unsuccessful application:

   S:<?xml version="1.0" encoding="UTF-8" standalone="no"?>
   S:<epp xmlns="urn:ietf:params:xml:ns:epp-1.0">
   S:  <response>
   S:    <result code="1301">
   S:      <msg>Command completed successfully; ack to dequeue</msg>
   S:    </result>
   S:    <msgQ count="5" id="12345">
   S:      <qDate>2013-04-04T22:01:00.0Z</qDate>
   S:      <msg>Application rejected.</msg>
   S:    </msgQ>
   S:    <resData>
   S:      <domain:panData
   S:       xmlns:domain="urn:ietf:params:xml:ns:domain-1.0">
   S:        <domain:name paResult="0">example.tld</domain:name>
   S:        <domain:paTRID>
   S:          <clTRID>ABC-12345</clTRID>
   S:          <svTRID>54321-XYZ</svTRID>
   S:        </domain:paTRID>

   S:        <domain:paDate>2013-04-04T22:00:00.0Z</domain:paDate>
   S:      </domain:panData>
   S:    </resData>

   S:    <extension>
   S:      <launch:infData
   S:       xmlns:launch="urn:ietf:params:xml:ns:launch-1.0">
   S:        <launch:phase>sunrise</launch:phase>
   S:          <launch:applicationID>abc123</launch:applicationID>
   S:          <launch:status s="rejected"/>
   S:      </launch:infData>

   S:    </extension>

S: <trID> S: <clTRID>BCD-23456</clTRID> S: <svTRID>65432-WXY</svTRID> S: </trID> S: </response> S:</epp>

It would make sense to include something around the poll messaging in the draft.  What are the thoughts to this?

Jim

________________________________
From: [email-masked] [[email-masked]] on behalf of Rubens Kuhl [[email-masked]]
Sent: Thursday, February 28, 2013 12:21 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [provreg] Uniform Poll Responses for Launch Phase Results

Em 28/02/2013, às 14:15:000, <[email-masked]<mailto:[email-masked]>> escreveu:

Rubens