Subject: [provreg] Fwd: New Version Notification for draft-brown-epp-fees-01.txt

From: Gavin Brown <[email-masked]>
Date: Mon, 09 Dec 2013 18:18:13 +0000

Changes since the last version:

   1.  Restore the <check> command extension; either <check> or <info>
       can be used.

   2.  added extension elements for <create>, <renew>, <transfer> and
       <update> so that the server can reject the command if the fee is
       incorrect.

G.

-------- Original Message --------
Subject: New Version Notification for draft-brown-epp-fees-01.txt
Date: Mon, 09 Dec 2013 09:58:47 -0800
From: [email-masked]
To: Gavin Brown <[email-masked]>

A new version of I-D, draft-brown-epp-fees-01.txt
has been successfully submitted by Gavin Brown and posted to the
IETF repository.

Filename:	 draft-brown-epp-fees
Revision:	 01
Title:		 Registry Fee Extension for the Extensible Provisioning Protocol
(EPP)
Creation date:	 2013-12-09
Group:		 Individual Submission
Number of pages: 27
URL:
http://www.ietf.org/internet-drafts/draft-brown-epp-fees-01.txt
Status:          http://datatracker.ietf.org/doc/draft-brown-epp-fees
Htmlized:        http://tools.ietf.org/html/draft-brown-epp-fees-01
Diff:            http://www.ietf.org/rfcdiff?url2=draft-brown-epp-fees-01

Abstract:
   This document describes an Extensible Provisioning Protocol (EPP)
   extension mapping for registry fees.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.

---

From: Bruno Prémont <[email-masked]>
Date: Thu, 19 Dec 2013 09:16:30 +0100

>        <update> so that the server can reject the command if the fee is

We have some registrars who wish to be able to check their account
credit balance via EPP.
Would it make sense to include their balance in these fee responses?

e.g.  ...
      <fee:currency>EUR</fee:currency>
      <fee:fee>5.00</fee:fee>
      <fee:balance>1500.50</fee:balance>
      ...

In addition it might be worth allowing inclusion of information
about taxes (VAT within EU).

Bruno

-- 
Bruno Prémont <[email-masked]>
Ingénieur système et développements

Fondation RESTENA
6, rue Coudenhove-Kalergi
L-1359 Luxembourg

Tél: (+352) 424409
Fax: (+352) 422473
http://www.restena.lu     http://www.dns.lu

---

From: Gavin Brown <[email-masked]>
Date: Thu, 19 Dec 2013 09:36:47 +0000

Hi Bruno,

It may make sense to allow a <fee:balance> object in transform command
responses - I'll consider this for the next version. However, there are
existing extensions for account balance querying. Unfortunately they
have not been published as I-Ds yet, but I am working on persuading the
authors to do so.

G.

CentralNic Group plc is a company registered in England and Wales with
company
number 8576358. Registered Offices: 35-39 Moorgate, London, EC2R 6AR.

---

From: Luis Muñoz <[email-masked]>
Date: Thu, 19 Dec 2013 09:38:10 -0500

On Dec 19, 2013, at 4:36 AM, Gavin Brown wrote:

> responses - I'll consider this for the next version.

This should be optional so that Registries can choose to add that task to the processing of the transform command or not depending on their specific implementations.

Best regards

-lem

---

From: Gavin Brown <[email-masked]>
Date: Thu, 19 Dec 2013 14:45:26 +0000

Agreed.