Subject: [provreg] EPP Domain Contacts

From: Mike O'Connell <[email-masked]>
Date: Wed, 4 Dec 2013 07:13:10 +0200

All,

I came across an issue the other day around Domain Contacts, specifically, the domain contact element contains an optional attribute 'type' which can be one of [tech, billing, admin]. The problem here is that the attribute is optional with no assumed default. 

Does anybody use the domain contact element without the 'type' attribute? 
Does anybody use a default value for the 'type' attribute when it is not provided?

Apologies if this is a old/duplicate topic.

Regards,

Mike

--

If you don't know where you are going, any road will get you there.

---

From: Corey Goldfeder <[email-masked]>
Date: Tue, 3 Dec 2013 21:26:12 -0800

We at Charleston Road Registry return a 2306 for contacts without type. (In
other words, we enforce type as a required attribute by policy rather than
by schema).

On Tue, Dec 3, 2013 at 9:13 PM, Mike O'Connell <[email-masked]> wrote:

> All,
>
> I came across an issue the other day around Domain Contacts, specifically,
> the domain contact element contains an optional attribute 'type' which can
> be one of [tech, billing, admin]. The problem here is that the attribute is
> optional with no assumed default.
>
>
>    1. Does anybody use the domain contact element without the 'type'
>    attribute?
>    2. Does anybody use a default value for the 'type' attribute when it
>    is not provided?
>
>
> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg
>
>

---

From: Mike O'Connell <[email-masked]>
Date: Wed, 4 Dec 2013 08:35:57 +0200

On 04 Dec 2013, at 7:26 AM, Corey Goldfeder <[email-masked]> wrote:

> We at Charleston Road Registry return a 2306 for contacts without type. (In other words, we enforce type as a required attribute by policy rather than by schema).

Agreed - I've put a policy check in place to prevent it. I just wonder if the spec should be slightly clearer about the type usage.

---

From: Alexander Mayrhofer <[email-masked]>
Date: Wed, 4 Dec 2013 07:55:06 +0000

In the gTLD configuration of our Registry, we do require the contact type to be either  "tech" or "admin". We don't allow for "billing" type contacts, since any billing goes via the registrar.

Alex

Von: provreg [mailto:[email-masked]] Im Auftrag von Mike O'Connell
Gesendet: Mittwoch, 04. Dezember 2013 06:13
An: [email-masked]
Betreff: [provreg] EPP Domain Contacts

All,

  1.  Does anybody use the domain contact element without the 'type' attribute?
  2.  Does anybody use a default value for the 'type' attribute when it is not provided?

Regards,

Mike

--

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 4 Dec 2013 09:31:26 +0100

Without saying it being good or bad, as Frobbit that I work with is not a registrar to .AT, in general as a registrar I would like to be able to register billing contact as well (or rather, I would like to be able to fetch billing info). The downside with your policy is that if the domain is transferred from one registrar to another, the information on billing info must be moved out of band of the actual transfer (that is via the registry).

   Patrik

On 4 dec 2013, at 08:55, Alexander Mayrhofer <[email-masked]> wrote:

> In the gTLD configuration of our Registry, we do require the contact type to be either  „tech“ or „admin“. We don’t allow for “billing” type contacts, since any billing goes via the registrar.
>  
> Alex
>  
>  
> 	• Does anybody use the domain contact element without the 'type' attribute? 
> 	• Does anybody use a default value for the 'type' attribute when it is not provided?
>