Subject: [provreg] Inconsistency in number of status values in draft-tan-epp-launchphase-12 ?

From: Patrick Mevzek <[email-masked]>
Date: Wed, 05 Mar 2014 16:23:08 +0100

Hello,

the text says :
Certain status values MAY be combined.  For example, an application
   or registration may be both "invalid" and "rejected"

the schema says :
<complexType name="infDataType">
       <sequence>
         <element name="phase" type="launch:phaseType"/>
        <element name="applicationID"
         type="launch:applicationIDType"
         minOccurs="0"/>
        <element name="status" type="launch:statusType"
         minOccurs="0"/>

so maybe a maxOccurs="unbounded" should be added there ?
or maxOccurs="7" to be extra conservative ?

-- 
Patrick Mevzek

---

From: "Gould, James" <[email-masked]>
Date: Wed, 5 Mar 2014 15:36:21 +0000

Patrick,

Good catch. My recommendation is for the text to be tightened up to
support only a single status, since the status really reflects the status
or state within the state diagram of Figure 1.  Adding support for
multiple statuses in the XML schema would make it more difficult for the
client to determine the state of the application. Thoughts?

-- 
 
JG

James Gould
Principal Software Engineer
[email-masked]
 
703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

On 3/5/14, 10:23 AM, "Patrick Mevzek" <[email-masked]> wrote:

>_______________________________________________
>provreg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/provreg

---

From: Gavin Brown <[email-masked]>
Date: Wed, 05 Mar 2014 16:26:29 +0000

+1. Our implementation only supports a single status. Are there any
implementations which require this design?

I'll add this point to my slides for discussion tomorrow.

G.

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company
number 8576358. Registered Offices: 35-39 Moorgate, London, EC2R 6AR.

---

From: Mike O <[email-masked]>
Date: Thu, 6 Mar 2014 06:34:47 +0200

+1, We've coded according to the Schema, multiple statuses would require a redesign...

--

If you don't know where you are going, any road will get you there.

On 05 Mar 2014, at 5:36 PM, Gould, James <[email-masked]> wrote:

> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: Wil Tan <[email-masked]>
Date: Fri, 7 Mar 2014 19:44:01 +1100

> implementations which require this design?

+1 we should keep it simple. already the spec supports quite a few use
cases, so unless this is a blocker for a common scenario we should not
allow multiple status values.

.wil