Subject: Why two Ethernet Types for PW + MTU question

From: Dawn Xie <[email-masked]>
Date: Wed, 13 Nov 2002 18:44:30 -0500

There was a discussion on whether two PW types (Ethernet and Ethernet
VLAN) is needed a couple months ago. Was there any conclusion reached on
that discussion? From the newest draft
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-control-protocol-01.txt,
it does not look like a conclusion is reached.

Without the conclusion, there is difficulty to support the following PW
case:

   | CE1 |--untagged--| PE1 |----------| PE2 |--VLAN--| CE2 |

The PW at PE1 side accepts untagged Ethernet, and the PW at PE2 side
accepts 802.1Q tagged frames.  It is a quite useful and common scenario.
Now there are two issues:

1. What PW-type PE1 and PE2 shall advertise? If PE1 advertise Ethernet
(0x0005) and PE2 advertise Ethernet VLAN (0x0004), the PW will not be
established based on the draft, isn't it?
2. How PE1 and PE2 advertise MTU? If PW agrees on MTU equals to X, and a
frame of size X reaches PE2 from PE1, PE2 will need to insert 4 bytes
for the VLAN tag, and the new frame size may become more than the link
between PE2 and CE2 can handle.

Any recommendation on solving the issues? One way to solve issue 1 is to
remove the need of two Ethernet types. One way to solve issue 2 is that
PE2 needs to make sure that the MTU it has negotiated with PE1 is 4
bytes smaller than it is actually able to transmit between PE2 and CE2..

-- Dawn

---

From: "Yaron Raz" <[email-masked]>
Date: Thu, 21 Nov 2002 02:47:01 +0200

Dawn,

The second option you propose (in item 1) makes the PW carry VLAN on one direction and untagged on the other. There is no such Eth wire, and therefore should not be such virtual wire.
The original solution proposed by Andy keeps the tagging as an NSP, which would also be the case if the network was pure EThernet (a tagging bridge).

> -----Original Message-----
> From: Dawn Xie [mailto:[email-masked]]
> Sent: Thursday, November 14, 2002 9:15 PM
> To: Andrew G. Malis
> Cc: [email-masked]; [email-masked]
> Subject: [PWE3] Re: Why two Ethernet Types for PW + MTU question
> 
> 
> Andy:
> 
> Thank you for the response. Still there is confusion:
> 
> 1. There is an alternative to your suggestion: For frames 
> from CE2 to CE1, PE2
> will not strip the VLAN tag and will pass the frame as is to 
> PE1, PE1 will then
> strip the VLAN tag; for frames from CE1 to CE2, PE1 will pass 
> the frame to PE2
> and PE2 will add the VLAN tag. Two alternatives (your 
> suggestion and this one)
> will both work, but totally incompatible. Has PWE3 decided to 
> standardize one, or
> either one of them is fine? If either one of them is fine, 
> there will be an
> interoperability issue.
> 
> 2. I think it is fine to signal Ethernet (0x0005) in this 
> case. What I am really
> confused is in what situation, do we need to signal Ethernet 
> VLAN (0x0004) type?
> Does anyone know any case where Ethernet VLAN type needs to 
> be used, that
> otherwise things will break?
> 
> Thanks.
> 
> -- Dawn
> 
> "Andrew G. Malis" wrote:
> 
> > Dawn,
> >
> > In this case, you should signal Ethernet (0x0005) in both 
> directions, and
> > MTU without the tag.  It's up to PE2 to strip the tag on 
> ingress from CE2
> > and add the tag on egress to CE2.  This allows CE2 to have 
> PWs to multiple
> > other CEs, one per VLAN tag, and the tag only has 
> significance between CE2
> > and PE2.  VLAN-capable equipment must be able to handle the 
> extra four
> > octets between CE2 and PE2 (see Figure C-6 in 801.1Q).
> >
> > Cheers,
> > Andy
> >
> > -------
> >
> > At 11/13/2002 06:44 PM -0500, Dawn Xie wrote:
> >

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3