Subject: Re: RE: Is PWE a layer?

From: Mustapha Aissaoui <[email-masked]>
Date: Wed, 21 May 2003 16:35:55 -0400

Peter,

"Busschbach, Peter B (Peter)" wrote:
> 
> > -----Original Message-----
> > From: Shahram Davari [mailto:[email-masked]]
> > Sent: Wednesday, May 21, 2003 2:43 PM
> > To: 'Busschbach, Peter B (Peter)'; 'Yaakov Stein'; Mark Seery
> > Cc: [email-masked]
> > Subject: RE: [PWE3] RE: Is PWE a layer?
> >
> >
> > >a) TTL > 2
> > >Eric Rosen made the point that there are cases in which it
> > >makes sense to splice PWs together and switch based on the PW
> > >label. IMO, that turns the "PW layer" into an MPLS layer.
> > >(It makes you wonder why there is a PW layer in the first
> > >place. Why not define how to adapt client traffic to MPLS
> > >(i.e. remove the demultiplexing function from PWE) and leave
> > >it to the service provider to decide whether there is a need
> > >for additional aggregation via MPLS label stacking.)
> >
> > If PW labels could be switched like MPLS labels, then why
> > can't MPLS-ping be used to test it?
> >
> 
> Shahram,
> 
> My statement should be read in the context of the question: is PW an adaptation function or a network layer in itself. My point was: if you use intermediate nodes to switch based on the PW Label, then it becomes a network layer in itself.
> 
> Can one use Ping to test it? Yes, of course. Was there anything in my mail that gave you the impression that I thought one couldn't?
> 
> I still have a question about Ping, though. Is it the intention that >Ping messages be sent periodically? The vccv draft doesn't specify this. >IMO, for fault management you need a periodic connectivity check and you >need to define how you determine that there is a defect. Is it when you >miss one reply or only after missing multiple replies? Frankly, you need >a state machine as defined in Y.1711.

A Ping mechanism is similar to a connectivity verification
mechanism. This is not suited for alarm indication/suppression. It
is intended to be mostly proactive and can have a significant
processing impact on the node for monitoring a large number of
entities. 
Let us consider again the scenario of ATM-MPLS-FR service
interworking, with local termination of ATM and FR at each PE. If
the ATM port in the ingress PE fails, you need to generate a
reactive alarm indication on all PWs which are sourced on this port
to inform the remote PE of the defect. You need to be able to do
that without injecting connectivity verification traffic. A
lightweight mechanism such as I.610 AIS/RDI or Y.1711 FDI/BDI is
more suitable.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 22 May 2003 15:35:43 -0400

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Busschbach, Peter B (Peter)
> Sent: Wednesday, May 21, 2003 2:52 PM
> To: 'Shahram Davari'; Busschbach, Peter B (Peter); 'Yaakov 
> Stein'; Mark Seery
> Cc: [email-masked]
> My statement should be read in the context of the question: 
> is PW an adaptation function or a network layer in itself. My 
> point was: if you use intermediate nodes to switch based on 
> the PW Label, then it becomes a network layer in itself.
> 
> Can one use Ping to test it? Yes, of course. Was there 
> anything in my mail that gave you the impression that I 
> thought one couldn't?
> I still have a question about Ping, though. Is it the 
> intention that Ping messages be sent periodically? The vccv 
> draft doesn't specify this. IMO, for fault management you 
> need a periodic connectivity check and you need to define how 
> you determine that there is a defect. Is it when you miss one 
> reply or only after missing multiple replies? 

	This is more of an operational issue.
My team and I have spoken to over 25 operators about VCCV and 
LSP Ping, and all 25 give me preciesely different answers about 
how often they want to run either tool. It depends largely on 
the application being used, as well as the SLA. Based on these
data points, the VCCV draft does not specify any periodicity.

> Frankly, you need a state machine as defined in Y.1711.

	This is contrary to the aforementioned customer 
input I have received.

	--Tom

> Peter
> 
> > -Shahram
> > 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>