Subject: IMPORTANT: Strategy for VPN work in IETF

From: Alex Zinin <[email-masked]>
Date: Sun, 4 May 2003 00:11:52 -0700

Folks,

Since San Francisco IETF meeting the IESG has been considering the
situation in the SUB-IP area and in the PPVPN Working Group in particular.

Such close attention to this WG was triggered by numerous concerns that
the IESG members received from the WG participants about limited and
slow progress within the WG despite the efforts of the WG chairs and its
members. The IESG also used this opportunity to consider the IETF area 
that the PPVPN work would fit best.

After much deliberation, the involved ADs (Bert, Thomas, and I) are 
considering the following organizational changes in order to improve WG 
focus and productivity and ensure faster progress of the VPN-related work:

 1. Split of Layer-2 and Layer-3 VPN work in separate Working Groups.

    The L2 and L3 VPN work spaces are each big enough to warrant a separate 
    WG. While concentration of all VPN-related work in a single forum was 
    the right thing to do to ensure coordination of efforts when the PPVPN 
    WG was created and L2 VPN work came in, such concentration is causing
    scaling problems within the WG at this moment. 

    Migration of work into two separate WGs for L2 and L3 VPN technologies
    with more specific WG charters will help to focus discussions, prevent 
    staff and meeting time overloading, and will aid faster progress of 
    corresponding technologies.

 2. Migration of the VPN-related work to the Internet area.

    As previously discussed, VPN-related work could be argued to belong
    to more than one area. Tunneling mechanisms are the property that
    gravitates this work to the Internet area, which is where we believe
    the VPN work should go.

    As part of this move, we are also considering moving PWE3 into INT, 
    so that L2TPEXT, PWE3, and thew new VPN WGs are operating in the same
    area.

Based on the above considerations, we are considering the following steps:

 1. Two new WGs--L2VPN and L3VPN--will be created in the Internet area.
    The mailing lists will be established and the discussion of the proposed 
    charters of the new WGs will be initiated shortly.

 2. Once the charters of the new WGs are agreed upon and approved by the IESG,
    creation of the L2VPN and L3VPN WGs and shutdown of the PPVPN WG will be
    performed simultaneously. PPVPN WG documents will be migrated to the 
    corresponding new WGs.

It is our intention to complete this process by the Vienna IETF meeting. 
Also, these changes are being made for management reasons and are not intended 
to be a "reset" on WG activities or to halt or interrupt progress on current 
ongoing WG activities.

We'd like to hear from the WG members if they see any fatal flaws with
the proposed approach. Please send us your feedback by May 11th.

Regards,

--
Alex Zinin
IETF SUB-IP Area Co-Director

---

From: "Nagarajan, Ananth [CC]" <[email-masked]>
Date: Mon, 5 May 2003 10:05:22 -0500

Any effort to speed up the work in the WG is welcome.  The idea seems logical, but should have been done as soon as the ppvpn WG started accepting L2VPN within the charter.  Right now, I am afraid it would create another administrative delay  in the work - because the L3 work is more or less done.  (I am anticipating that in the next few months, the WG will concentrate fully on L2 work).
 
If, in fact, the WG does split, then we also need to think about what to do with a few documents such as the generic reqts draft, that will be ready for IESG last call this week, that really is an umbrella document for both L2 and L3 VPNs.  Similarly, I think we have the terminology draft too that we need to determine what to do with.
 
Thanks,
Ananth

	-----Original Message----- 
	From: Alex Zinin [mailto:[email-masked]] 
	Sent: Sun 5/4/2003 2:11 AM 
	To: [email-masked] 
	Cc: [email-masked]; Wijnen, Bert (Bert); Thomas Narten; Peterson, Jon; Allison Mankin 
	Subject: IMPORTANT: Strategy for VPN work in IETF

	Folks,

	

	

	

	

	
	Regards,

---

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 5 May 2003 19:04:04 +0300

>   so that L2TPEXT, PWE3, and the new VPN WGs are operating in the same
>   area.

The PWE3 charter specifically states that PWE3
will coordinate with the following WGs:
          L2TPEXT, DIFFSERV, AVT, CCAMP, PPVPN, MPLS, TEWG, ROHC .

Scrutinizing this list, four are in SUB-IP, three are in TSV,
and one in INT.

  l2tpext (INT),  diffserv (closed - was TSV),  avt (TSV),
  ccamp (SUB-IP),  ppvpn (SUB-IP), mpls (SUB-IP),
  tewg (SUB-IP),  rohc (TSV)

After the proposed change, and removing the (now closed) diffserv WG
from the list, the new count will be three SUB-IP, three INT,
and two TSV.

  l2tpext (INT),  avt (TSV),  ccamp (SUB-IP),  l3vpn (INT),  l2vpn(INT), 
  mpls (SUB-IP),  tewg (SUB-IP),  rohc (TSV)

In actuality, the interaction with avt and rohc has been tenuous
(note how few PWE drafts mandate RTP!),
so inter-area links would be palliated by moving PWE to either
SUB-IP or INT.

Since the SUB-IP area is defined as temporary
and hence its augmentation not desirable,
the suggested path with regards to PWE3
seems to be a logical one.

My only concern is regarding network congestion issues.
It has been stated that PWE was originally placed in the 
transport area due to that area being the proper place to handle
congestion avoidance and mitigation.
As the WG has only recently stated to seriously consider
these issues, we should give some thought as to how
to keep them in focus even after an area transplant.

Y(J)S

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 5 May 2003 13:24:29 -0400

Alex,

> members. 

[clipped...]

Wouldn't be more appropriate to first discuss what these 
concerns are and if they are indeed justified concerns, and
solicit feedback from the wg to discuss options or
improvements on how to move the wg forward and get consensus 
on that. If I recall, similar open approach has been taken for 
sup-ip area in Atlanta meeting.

Kind of hard to be *confident* that the proposed reorganization 
will actually address the raised concerns without actually
knowing what these concerns are in the first place! 

After all, the amount of work after the split is exactly 
the same as before the split if not bigger (given that
l3vpns work is almost done and the split will
introduce additional administrative overhead).

Hamid.

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 05 May 2003 13:12:46 -0700

Alex,

>     scaling problems within the WG at this moment.

As was pointed by other folks, there is practically no L3 VPN
related activities now. Practically all the discussion is about L2
VPN, or to be even more precise, above VPLS. Just count the number
of messages posted to the list over the last 12 months related to
L3 VPNs vs L2 VPNs.

With this in mind please explain how moving L3 VPN into a separate
WG would help to address the scaling problems that you mentioned
above.

>     corresponding technologies.

As I mentioned above - there isn't any discussion on L3 VPN technologies.
The WG focuses on L2 VPN, and mostly on VPLS.

Are you suggesting that the WG need more discussion on L3 VPNs (e.g., 
2547bis) ?
 
> Also, these changes are being made for management reasons and are not
> intended to be a "reset" on WG activities or to halt or interrupt progress 
> on current ongoing WG activities.
>

I find the justifications for the steps you suggested above highly dubious 
(to say the least). The absence of solid justifications is one of the
fatal flaws of the proposed approach.

Yakov.

---

From: Alex Zinin <[email-masked]>
Date: Mon, 5 May 2003 14:38:40 -0700

George,

 Interesting that you mention this... I actually believe that if a WG
 consistently needs more than one meeting slot, it is a good sign of
 it having more on its plate than can efficiently deal with or poor
 management of the meeting time.

 Cheers.

-- 
Alex

Monday, May 5, 2003, 2:19:31 PM, George Swallow wrote:
> I don't see the need for two work groups.  Just encourage the
> chairs to get two meeting slots (until the level of activity settles
> down).

> ///George

> ========================================================================
> George Swallow             Cisco Systems                  (978) 936-1398
>                            1414 Massachusetts Avenue
>                            Boxborough, MA 01719

---

From: George Swallow <[email-masked]>
Date: Tue, 06 May 2003 10:42:03 -0400

Alex -

>  management of the meeting time.

I thought the IESG was concerned about the overall number of
Workgroups.  They are much easier to create than to shut down.  So if
meeting twice per IETF for a short while until the work settles down
lets you have one less, seems like a good idea.

...George

---

From: "Peterson, Jon" <[email-masked]>
Date: Mon, 5 May 2003 12:28:56 -0400

[snip]
> to keep them in focus even after an area transplant.

After the proposed relocation of this group to the Internet Area, a
Transport Area Advisor would be appointed to PWE3 to provide continuing
guidance on transport issues, including congestion.

Jon Peterson
NeuStar, Inc.
Transport Co-AD

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Tue, 6 May 2003 17:01:31 -0400

Ananth,

>If, in fact, the WG does split, then we also need to think about 
>what to do with a few documents such as the generic reqts draft, 
>that will be ready for IESG last call this week, that really is 
>an umbrella document for both L2 and L3 VPNs.  Similarly, I think 
>we have the terminology draft too that we need to determine what to do
with. 

The bgp auto-discovery draft covers as well
both layer-3 and layer-2 vpns. 

But besides the "what to do with these common drafts 
question?", we need to ask ourselves why these drafts
were created in the first place. For example isn't
the generic requirement document covers common 
requirements for layer-2 and layer3 vpns. The simple 
existence of these drafts indicate that there is
a belief within the wg that layer-2 and layer-3 vpns
share something in common such as service attributes, topology, 
security, etc (documented in this draft).

On that topic, if later on there are proposals that
apply to both layer-2 and layer-3 vpns, where these
proposals need to be captured, on what charter...
One way or the other, the 'link', whatever that might be
(protocols, service characteristics, etc), between layer-2 
and layer-3 work needs to be taken into account and splitting
the wg will somehow eliminate the need to explore
this side of the vpn problem.

Hamid.

---

From: "Paul Knight" <[email-masked]>
Date: Wed, 7 May 2003 12:56:24 -0400

Hi Alex,

The proposed split seems to put very little emphasis on the "PP" of PPVPN.

The proposed focus on technologies for L2 and L3 is likely to seriously
disrupt the focus on the "Provider Provisioned" concept, where much of the
value comes from aiming for interoperation across all major VPN
technologies.  Of course, we could have PPL2VPN and PPL3VPN, but as has been
pointed out, we then need to coordinate the "PP" parts across the two WGs.  

VPN customers want a bundle of VPN services, and don't really care whether
it is L2 or L3 (or L1) or some mixture.  VPN service providers want an
interoperable toolkit which they can use to design services that they can
differentiate in various ways to attract VPN customers. PPVPN is providing a
forum to define the operation of the VPN tools.  Regardless of L2 or L3
technologies, there is a need for simple and interoperable mechanisms for
VPN membership and discovery, security considerations, SLA verification, and
a host of management areas.  These mechanisms are being defined, clarified,
and debated in PPVPN mostly without regard to the specific L2 or L3
approaches.  They should not be either dropped, or split across two WGs.

Yes there is a lot of work in the group, but if it gets fragmented and
things slip through the cracks, then we will be forcing the VPN service
providers, vendors, and customers to do much more work and spend much more
time in the long run.

In terms of meeting logistics, we will find that many of the same people
will be attending and developing drafts for the proposed L2 and L3 WGs, so
we will have to make sure that they don't overlap... Just the same as if we
plan extended meeting times for the current PPVPN when it is needed.

Finally, I'm closely involved with two areas of work in L3 VPNs in PPVPN,
and we are getting to the point where much of the basic work is stable, so
the L3VPN may not justify a dedicated WG for much longer, although it does
need a WG in which to operate.

I would suggest planning for a longer meeting in Vienna (if the agenda
justifies it) and bringing this proposal up for discussion there.

Regards,
Paul

> Sent: Sunday, May 04, 2003 3:12 AM
> Since San Francisco IETF meeting the IESG has been 
> considering the situation in the SUB-IP area and in the PPVPN 
> Working Group in particular.
> 
> Such close attention to this WG was triggered by numerous 
> concerns that the IESG members received from the WG 
> participants about limited and slow progress within the WG 
> despite the efforts of the WG chairs and its members. The 
> IESG also used this opportunity to consider the IETF area 
> We'd like to hear from the WG members if they see any fatal 
> flaws with the proposed approach. Please send us your 
> feedback by May 11th.
> 
> Regards,
> 
> --
> Alex Zinin

---

From: Thomas Narten <[email-masked]>
Date: Wed, 07 May 2003 13:57:18 -0400

Scott W Brim <[email-masked]> writes:

> Having related but small, focused WGs is fine as long as communication
> between them is mandated and kept flowing.

Complete agreement, and keeping that communication going is something
I will be watching for. That is also an argument for putting pwe3 and
the ppvpn groups together (and also l2tpext) in the same area since
they all do relate to varying degrees.

Thomas

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Wed, 7 May 2003 14:08:52 -0400

Thomas, Eric,

> 
> Thomas> The above could be read as indicating that the 
> discussion/urgency of
> Thomas> the L2 work is pushing out or drowning out discussion 
> on L3 topics.
> 
> Yes, I do think so. 

To be more precise, the discussions were mostly on vpls service,
and since l2vpn includes services other than vpls, this could
be read as well that vpls discussion/urgency is pushing out or
drowning out discussions on other l2vpn services. In that
respect, creating a new l2vpn wg will not make the situation any 
better.

Hamid.

---

From: [email-masked]
Date: Wed, 7 May 2003 22:13:36 +0100

Hamid Ould-Brahim wrote 07 May 2003 19:09

Thomas, Eric, 

NH=> Excellent observation Hamid.  It would seem to me that a L2 VPN service
should be nothing more than some form of co pkt-sw managed BW service.  This
could then be the common *default* VPN solution on which additional *client*
layer VPN services (be they IP (rfc2547) or ethernet (VPLS)) can be
considered (see my recent posting to Alex which suggested such a view).
However, even though I can see logic in grouping together the common server
layer aspects and then adding specific client layer aspects as needed, maybe
this is not so attractive to some?

regards, Neil

---

From: Alex Zinin <[email-masked]>
Date: Wed, 7 May 2003 16:40:54 -0700

George,

> Workgroups.  They are much easier to create than to shut down.

I think the overall number of the WGs is a lesser concern.

> So if meeting twice per IETF for a short while until the work
> settles down lets you have one less, seems like a good idea.

Agreed, provided that this is not a consistent situation and that the
agenda time is not used for slideware, but to discuss real issues the
WG is facing, verify consensus on document modifications, etc., i.e.,
the real stuff.

Alex

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 12 May 2003 10:59:37 -0700

Hamid,

> drowning out discussions on other l2vpn services. 

Agreed. In fact, if the justification for splitting the PPVNP WG
into two is to allow discussion for L3 services, then following
the same line of reasoning there should be not one, but two L2 VPN
WGs, one for L2 VPN services (other than VPLS), and one for VPLS.
Yet, the IESG said nothing about having two L2 VPN WGs. Perhaps the 
IESG would be kind enough to explain this inconsistency.

> In that respect, creating a new l2vpn wg will not make the situation any 
> better.

Agreed.

Yakov.

---

From: Loa Andersson <[email-masked]>
Date: Tue, 13 May 2003 07:52:19 +0200

Yakov,

just because something is "too big", you don't need to split each and
every atom.
"logical extremes" does not very often make sense in disucssion on
how to organize a work load, we should look for opitmization

in this context "splitting" makes perfetly sense

/Loa

Yakov Rekhter wrote:
< snip >

-- 
/Loa

mobile + 46 739 81 21 64
email: [email-masked]

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 13 May 2003 19:06:22 -0400

I agree Loa. The argument doesn't make much sense.
I think the point is to optimize the work load not
create administravia.

	--Tom

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Loa Andersson
> Sent: Tuesday, May 13, 2003 1:52 AM
> To: Yakov Rekhter
> Cc: Hamid Ould-Brahim; Thomas Narten; Alex Zinin; 
> [email-masked]; [email-masked]; Wijnen, Bert (Bert); 
> Peterson, Jon; Allison Mankin
> Subject: Re: [PWE3] Re: IMPORTANT: Strategy for VPN work in IETF
> 
> 
> Yakov,
> 
> just because something is "too big", you don't need to split 
> each and every atom. "logical extremes" does not very often 
> make sense in disucssion on how to organize a work load, we 
> should look for opitmization
> 
> > Agreed. In fact, if the justification for splitting the 
> PPVNP WG into 
> > two is to allow discussion for L3 services, then following the same 
> > line of reasoning there should be not one, but two L2 VPN 
> WGs, one for 
> > L2 VPN services (other than VPLS), and one for VPLS. Yet, the IESG 
> > said nothing about having two L2 VPN WGs. Perhaps the IESG would be 
> > kind enough to explain this inconsistency.
> > 
> > 
> >>In that respect, creating a new l2vpn wg will not make the 
> situation 
> >>any
> >>better.
> > 
> > 
> > Agreed.
> > 
> > Yakov.
> > 
> > 
> > 
> > 
> 
> 
> -- 
> /Loa
> 
> mobile + 46 739 81 21 64
> email: [email-masked]
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>