Subject: Why can't send Label release message when receiving lable withdraw message

From: "Zhou Yun(163)" <[email-masked]>
Date: Thu, 29 May 2003 09:20:15 +0800

In draft-ietf-pwe3-control-protocol-02.txt, it is said that"If at any time after a Label Mapping message has been received, a corresponding Label Withdraw or Release is received, the action taken is the same as for any Label Withdraw or Release that might be received at any time. Note that receiving a Label Withdraw should not cause a corresponding Label Release to be sent." 
Why can't response Label release messsge when receiving Label withdraw message? How the downstream knows that the upstream has released this label then it can reuse this label?

---

From: Eric Rosen <[email-masked]>
Date: Fri, 30 May 2003 10:02:57 -0400

> "Note that  receiving a  Label Withdraw should  not cause  a corresponding
> Label Release to be sent."   Why can't response Label release messsge when
> receiving  Label withdraw  message?   How the  downstream  knows that  the
> upstream has released this label then it can reuse this label?

This is  just an  error in  the specification.  Per  RFC 3036,  the Withdraw
should be followed by a Release. 

However,  it  is  not  necessarily  a  good  practice  to  reuse  the  label
immediately upon receiving  a release, as there could  be packets in transit
with the label.