Subject: RE: PWE3 Arch/CW & RTP Order (Rough Consesus?)

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 12 May 2003 12:58:25 -0400

> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]] 
> Sent: Monday, May 12, 2003 12:42 PM
> To: 'Ali Sajassi'; [email-masked]'; 'Mustapha Aissaoui'; 
> 'David Allan'
> Cc: 'Sasha Vainshtein'; 'George Swallow'; 'Danny McPherson'; 
> [email-masked]
> Subject: RE: [PWE3] PWE3 Arch/CW & RTP Order (Rough Consesus?)
> 
> 
> Ali,
> 
> 
> >>1) Each layer's OAM only tests that layer's connectivity.
> >
> >Good, at least we agree that much :-)
> 
> Good.
> 
> >
> >>2) In X over Y layer, in which X is the customer traffic
> >>and Y is the service provider tunnel, customer should have 
> its X OAM, 
> >>and service provider should have its Y OAM. But the service 
> provider 
> >>cannot test whether his X/Y mapping is done correctly or 
> not without 
> >>doing segment X OAM. This is required for if provider wants 
> to detect 
> >>a mapping fault before customer complaints.
> >
> >Lets make sure we are talking about the same segment and that is the
> >segment between two PEs. There is a one-to-one relationship 
> >between PW and 
> >attachment circuit in VPWS and PW status can be mapped into AC 
> >segment OAM. 
> 
> Correct. 
> 
> >When, you transport FR over ATM (FRF.5) this is how it is done
> >and ATM PVC 
> >status is used (I am not aware of any special FR OAM segment running 
> >between the two PEs). Now how is it different for MPLS PW ? 
> >Maybe you want 
> >to tell me what is done in FRF.5 that cannot be done for FR 
> over MPLS.
> 
> FR does not have proper OAM. So we shouldn't base MPLS on 
> deficiencies of FR.
> 
> >
> >
> >
> >>Now regarding PW, we can test both PSN label and PW label 
> using MPLS 
> >>OAM. Customer can also test its connection (let's say ATM VC) using 
> >>ATM OAM. But the only way that provider can check the 
> correct mapping 
> >>between customer ATM VC to PW label, is by running segment ATM OAM 
> >>between PEs. VCCV does not help you for doing so.
> >
> >How do you check the mapping between FR VC and ATM VC when you
> >have FRF.5 ?
> 
> You can't. FR has poor OAM. 
> 
> >How do you check the mapping between an ATM physical port and
> >a PW when the 
> >service is port based ?
> 
> You can use ILM instead.
> 
> >
> >
> >>Now please tell me what VCCV can do that the OAMs I described above 
> >>can't do better.
> >
> >As I said before VCCV for MPLS PW is analogous to ATM VC OAM
> >and LSP OAM is 
> >analogous to ATM VP OAM. Now tell me, do you think we only 
> >need LSP tunnel 
> >OAM and not PW OAM.
> 
> I didn't say we only need LSP tunnel OAM. I said we can have 
> both LSP tunnel OAM and PW label OAM using LSP-ping or 
> anything else. LSP-ping for the PW label is analogous to ATM 
> VP OAM. And if you needed deeper test you could use ATM 
> segment OAM to test even the mapping of VCs to PW. No you 
> tell me what problems you can detect with VCCV that you can't 
> detect with LSP-ping over the PW label?
	
	The LSP ping capability cannot be negotiated
during the VC set up using vanilla LSP ping. Use of 
VCCV can be used to automate the CV as a natural "feature" 
of the VC. Moreover, since VCCV provides an OAM "container"
that allows for several types of OAM payloads depending
on the PSN/VC combination if you like. This allows it to 
handle all cases in a generic way from the OSS/UI perspective.
So one big advantage is that if your OSS is accustomed to talking 
to VCCV, then it doesn't matter what the PSN/VC combination is.
Given your example, in many cases you can only do X/MPLS with just 
LSP ping.

	Let me complicate things for you further. Which probablems 
cannot be caught with VC/L2TPv3 using ICMP ping (i.e.: 
without VCCV)?

	--Tom

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 12 May 2003 15:50:07 -0400

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Shahram Davari

	Well, this is the first that I have heard of
this. Given how long FR has been implemented, I 
would hope that if it really were, that dissatified
SPs would have complained. 

> You can't. FR has poor OAM. 

	In your opinion it does.  Again, I haven't heard
from operators that it does.

	--Tom

> -Shahram
> >-Ali
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>