Subject: Implementation agreement for Y.1711-like OAM approach to PWE/MPLS (was: Is PWE a layer - thread)

From: Mark Seery <[email-masked]>
Date: Fri, 30 May 2003 10:27:05 -0700 (PDT)

Jack,

If enough carriers and vendors are interested in
pursuing this, then I think what you suggest would be
very beneficial to the industry. It is possible
another organization like the MPLS Forum is doing this
- I don't know because I haven't been involved in it -
I have copied Andy in case he knows (Andy we are
discussing things such as applying a Y.1711 aproach to
MPLS/PWE OAM, bounding the number of layers that it is
applied to, and FR/ATM/MPLS OAM interworking).

I suspect that because the real solution that some
have expressed is applying this mechanism to MPLS and
not to PWE, then this is the wrong working group to
ultimately resolve this problem in. The best we can do
within this working group is get in the way of
something that is seen as undesirable at another
"layer" - that being PWE.

But before progressing this idea I would like to
direct a few questions to the chairs: Danny, and
Stewart. 

Danny/Stewart,

1) A Y.1711 approach to OAM seems not to be consistent
with the way the IETF has historically approached
solutions to these types of problems. As such, what is
your view on whether a proposal such as this would be
acceptable to the IESG, even if a rough consensus
within the WG was achieved to progress it for PWE?

2) Is the development of an implementation agreement
consistent with the current charter of the working
group.

Thanks,
Mark

--- Jack Pugaczewski <[email-masked]> wrote:
> Then this looks like a great forum to get ideas out
> and explore the proper
> means for implementation aggrements.  Now is the
> time to define these
> mechanism between Layer 2 (Frame Relay, ATM,
> Ethernet, etc.) and MPLS.  This
> functionality will be essential in the deployment of
> a quality network that
> can be properly and efficiently maintained.
> 
> PJMWBGJJREGTATALDBJHJHSLDHGSDWJAMY

---

From: "David Allan" <[email-masked]>
Date: Fri, 30 May 2003 14:15:34 -0400

Mark:

Independent of the process and culture questions there are some technical
issues to be addressed independent of the solutions, we're a few steps short
of :

1) We require a mechanism to distinguish OAM flows in PWs. The discussion is
moving in a direction whereby there is a requirement to support multiple
flows or combinations of the same (LSP-PING, Y.1711, other) depending on
operator sensibilities.

2) The mechanism needs to work and have useful OAM characteristics (aka fate
sharing) in the presence of all known (or alluded to) ECMP mechanisms (which
I believe uniquely impact PWs over MPLS unless folks have bizzare plans for
L2TPv3 ;-). This means no reserved labels or appearance as an IP packet
directly as MPLS/PW payload for any OAM tools, or aliasing as an IP packet.

IMHO this pushes us directly into the MPLS PID space as the only tractable
compromise solution that meets the criteria above (we needed more header
bits somewhere and it has to be somthing new :-( ). It complicates life as
PW control words now pretty much become mandatory. 

This has a number of benefits as it can also apply to MPLS as a layer
independent of the PW application, so it would appear that both MPLS and PWs
in general have a mechanism for muxing OAM (and possibly control) flows with
payload.

So the above being said, some practical steps that facilitate getting to
your proposal  are:

1) Agree on the above requirements
2) Devise a converged MPLS/PW PID approach that permits multiple OAM tools
to be employed over PWs and LSPs
3) Get the requisite missing PIDs from IANA for tools we wish to have as
candidiates

cheers
Dave

> -----Original Message-----
> From: Mark Seery [mailto:[email-masked]] 
> Sent: Friday, May 30, 2003 1:27 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [PWE3] Implementation agreement for Y.1711-like OAM 
> approach to PWE/MPLS (was: Is PWE a layer - thread)
> 
> 
> Jack,
> 
> acceptable to the IESG, even if a rough consensus within the 
> WG was achieved to progress it for PWE?
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: [email-masked]
Date: Fri, 30 May 2003 22:47:25 +0100

Mark, 
> applied to, and FR/ATM/MPLS OAM interworking).
NH=> Your comments here seem to indicate that you regard Y.1711, or maybe
any outputs from the ITU, as something other bodies can pass judgement on as
they see fit.  Is this correct?  Note SG13 have already got a draft Rec on
ATM/MPLS OAM network and service interworking in the pipeline.  Shall we
also check to see if this is fit for purpose too?

regards, Neil

---

From: [email-masked]
Date: Fri, 30 May 2003 22:47:26 +0100

Mark,

<snipped>
> solutions to these types of problems.
NH=> Can I just do a sanity check on what you have just requested.  IETF are
now working on co-pkt-sw and co cct-sw technologies and you think this has
some 'historical precedent' in IETF from which you feel the chairs can give
some value judgement?  This is clearly not the case IMO.  

regards, Neil

---

From: Mark Seery <[email-masked]>
Date: Fri, 30 May 2003 16:39:15 -0700 (PDT)

Dave,

Thanks for the feedback much appreciated.

Mark

---

From: Mark Seery <[email-masked]>
Date: Fri, 30 May 2003 16:41:23 -0700 (PDT)

Sorry Neil, did not mean to imply that.

I did not mean to imply that the IETF could tell the
ITU  what to standardize - in fact quite the opposite.
What I meant to ask was whether the IESG would be
likely to adopt an approach like this as its own.

if it was an inappropriate question to ask, then my
apologies again.

Mark

---

From: Mark Seery <[email-masked]>
Date: Fri, 30 May 2003 16:41:54 -0700 (PDT)

Fair point.

Mark