Subject: ATM Transparent Cell - LAST CALL

From: Stewart Bryant <[email-masked]>
Date: Mon, 29 Nov 2004 14:28:20 +0000

This is the start of two week last call for

PWE3 ATM Transparent Cell Transport Service
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-cell-transport-01.txt

Last call will end Tuesday 14th December 2004

Stewart

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 29 Nov 2004 18:23:33 +0200

Andy, Stewart and all,
I suggest to consider the following minor edits to the draft 
in question:

1. Specify that the PW Type to be used for the service in
   question MUST be 0x0009 (ATM n-to-one VCC cell transport)
   as per IANA allocation draft 

2. Specify that:
   - if Maximum Number of concatenated ATM cells is
     not part of the Interface Parameters field of FEC 128 or
     of the Interface Parameters TLV going with FEC 129, 
     cell concatenation MUST NOT be used
   - if this parameter is specified, the number of concatenated 
     cells per PW packet used by the PE receiving its value 
     MUST NOT exceeed the value distributed by the peer PE

3. Add a normative reference to the IANA allocation draft 
   (for the PW type and Interface Parameter ID)

4. Clarify which failures (only the physical port?, any other?)
   at one end of the PW must be reported to the peer PE, and
   which status values in the Status TLV must be used for this 
   purpose. E.g., is there any linkage between ILMI on the
   CE<-->PE link and status reports across the PW?

IMHO these edits would prevent any ambuiguities in future.
They would also make the already existing reference to the
Control Protocol draft meaningful (today it is only used
to specify that "no new security issues are added" -
rather vague, IMHO, since setup/maintenance of the PWs
is not mentioned at all.

I also suggest to consider collapsing Section 4.2.2
of the Control Protocol draft (replacing it with the
informative reference to the ATM Transparent Cell draft)
to avoid duplication. But this is not directly related 
to the Last Call of the ATM Transparent Cell draft.

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, November 29, 2004 4:28 PM
> To: pwe3
> Subject: [PWE3] ATM Transparent Cell - LAST CALL
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 29 Nov 2004 14:38:38 -0500

Sasha,

Thanks for your comments.

Comment 1 will be incorporated into my post-last-call revision.

Comment 2 - isn't that already specified in the control and ATM encaps 
drafts?   Why repeat it here?

Comment 3 - OK.

Comment 4 - physical interface failure is probably all we need to act 
on.  ILMI signaling will be transported transparently, and the PE doesn't 
act on it.  Status codes 2 and 4 are probably the relevant codes depending 
on direction.  Optionally, the pseudowire labels can be withdrawn.

Your last comment (on section 4.2.2) is also a good one, but is out of my 
control.

Cheers,
Andy

---------

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 30 Nov 2004 09:07:51 +0200

Andy and all,
Please see a few brief comments inline.
Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> From: Andrew G. Malis [mailto:[email-masked]]
> Sent: Monday, November 29, 2004 9:39 PM
> To: Sasha Vainshtein
> Cc: 'Stewart Bryant'; Andrew G. Malis (E-mail); pwe3
> Subject: RE: [PWE3] ATM Transparent Cell - LAST CALL
> 
> 
> Sasha,
> 
[Sasha] Great!
> drafts?   Why repeat it here?
[Sasha] The control protocol draft mentions it in Section 4.2.2;
if this section is collapsed (as I hope), it would be lost.
I also think that the related text in Section 4.2.2 of
the Control Protocol draft

<quote>
   If the Egress PE PE2 supports
   cell concatenation the ingress PE, PE1, should only concatenate cells
   up to the "Maximum Number of concatenated ATM cells" parameter
   received as part of the FEC element.
<end quote>

does not express the requirement properly (non-capitalized "should"
is not an IETF requirement of any sort!).
Last, but not least, I have not found any explicit reference to the
expected behavior if the interface parameter in question is not
present. And there is, IMHO, a valid alternative - to say that this
interface parameter is MANDATORY while establishing ATM N-to-one
PWs. So I'd think it should be specified explicitly and, preferably,
in one document.
> on direction.  Optionally, the pseudowire labels can be withdrawn.
[Sasha] This is as I expect it to be. It would be nice, IMHO,
if the draft were saying it explicitly.
> 
> Your last comment (on section 4.2.2) is also a good one, but 
> is out of my control.
>
[Sasha] I understand. Luca, can you please consider this?