Subject: FW: TTL value of VC Label?

From: "Vach Kompella" <[email-masked]>
Date: Tue, 16 Nov 2004 18:38:15 -0800

Stewart,

Here's the beginning of the thread.  I support the change which was
pretty much what we had agreed to at that time.  The thread runs from
4/30/2003 through 5/7/2003, when Danny asked for the following text
(suggested by Luca) to be the replacement text:

----------------------------
On 5/7/03 3:49 PM, "Luca Martini" <[email-masked]> wrote:

> How about this ?
> 
> "The setting of the TTL value in the PW
> label is application dependent, however in a strict point to point 
> application the TTL should be appropriately set to 2"

I like this.  Does anyone have objections to updating the current
document with something along these lines?

-danny
----------------------------

-Vach 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Yaron Nachman
> Sent: Wednesday, April 30, 2003 12:23 AM
> To: [email-masked]'
> Cc: Eli Angel; Ilya Vershkov
> Subject: [PWE3] TTL value of VC Label?
> 
> 
> Hi,
> 
> I have just noticed that in the yesterday-updated 
> draft-martini-l2circuit-encap-mpls-05.txt, the TTL value to 
> be placed by an Ingress LER on the VC Label is 2. I have 
> noticed in the past that it was changed to 255.
> 
> So, is it 2 or 255? or even some other value??
> 
> Thanks,
> 
> Yaron Nachman
> 
> SEABRIDGE Ltd.
> Tel:       972-9-7751359
> Fax:      972-9-7751212
> E-mail:  [email-masked]
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Vach Kompella" <[email-masked]>
Date: Tue, 16 Nov 2004 19:02:15 -0800

Actually, looking at it more carefully, is the question you are asking
that the "TTL should be appropriately set to 2" be stricken?  If so,
yes, it should.

The thread I thought you were referring to is the one below, which
brought up the original change to the text.  I cannot find any
subsequent threads that discuss removing the TTL=2 part.

-Vach 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Vach Kompella
> Sent: Tuesday, November 16, 2004 6:38 PM
> To: [email-masked]
> Subject: FW: [PWE3] TTL value of VC Label?
> 
> 
> Stewart,
> 
> Here's the beginning of the thread.  I support the change 
> which was pretty much what we had agreed to at that time.  
> The thread runs from 4/30/2003 through 5/7/2003, when Danny 
> asked for the following text (suggested by Luca) to be the 
> replacement text:
> 
> I like this.  Does anyone have objections to updating the 
> current document with something along these lines?
> 
> -danny

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 17 Nov 2004 10:24:14 +0000

> subsequent threads that discuss removing the TTL=2 part.

Yes, I can only find the mail that said put it in, and
cannot find any mail that say take it out. Hence my question to the
list.

It looks like a consensus for removal, but I will let the issue
run for the traditional two weeks, then Danny and I will declare
consensus one way or the other.

- Stewart

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 17 Nov 2004 13:41:00 +0200

Stewart and all,
I am not sure that striking out any reference to TTL=2
in the PW label is justified.

As Eric has explained in this thread, the only reason
for striking it out is that stitched PWs would not
work. This is obviously correct, but, please note,
that stiched PWs are not in the Charter (at the moment)
and, what is not important, do not comply with the PWE3
architecture as presented in the document we are now
discussing! 

In fact, setting TTL=2 is perfectly aligned with the current
PWE3 architecture (and this is why it has been mentioned
in the document)! 

Of course, we are now discussing enhanced architecture that
would incorporate stitched PWs. But this would require a
consistent architecture document, and not just removal of
a couple of lines from the current one!

What is wrong in the current document, is, IMHO, the ambiguous 
reference to "strict point-to-point applications": as defined 
in this architecture, the PWs are always point-to-point!

E.g., this text suggests that setting TTL=2 would not work 
for PWs connecting Virtual Switch instances in VPLS applications.
Which is, IMHO, incorrect even for Hierarchical VPLS as defined in
http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-vpls-ldp-05.txt.

So, may be a less drastic editing could suffice? E.g., what about
the following text:

"The setting of the TTL value in the PW label is application 
dependent. Within the scope of this document, setting TTL 
to 2 is recommended as a precaution against mis-forwarding".

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Wednesday, November 17, 2004 12:24 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [PWE3] TTL value of VC Label?
> 
> 
> 
> 
> Vach Kompella wrote:
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 17 Nov 2004 10:09:04 -0500

> a couple of lines from the current one!

	Lets not be so pedantic. 8) A directive that we know
would definitely preclude stitched PWs from functioning
correctly when we know well that we will be doing stitched
PWs here (in one form or another) sounds like a bad idea.

	--Tom

---

From: Shahram Davari <[email-masked]>
Date: Wed, 17 Nov 2004 08:08:47 -0800

Sasha,

When we say application specific and don't mandate TTL=2, 
means you could set TTL=2 for the non-stitching p2p case.

-Shahram

> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Sasha Vainshtein
> Sent: Wednesday, November 17, 2004 6:41 AM
> To: 'Stewart Bryant'
> Cc: [email-masked]; [email-masked]
> Subject: RE: [PWE3] TTL value of VC Label?
> 
> 
> Stewart and all,

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 17 Nov 2004 18:55:50 +0200

Shahram and all,
As you may have noticed, my message started
with the words "I am not sure that ...".

IMO, there was a certain reasoning behind the initial
suggestion of setting the PW Label TTL to 2 in the
non-stitching case. Unfortunately, this reasoning
did not make it to the document, only the conclusion
we now want to remove. But the reasoning still makes
sense to me when taken in the right scope (single-hop
PWs) - and I would not like to loose it completely.

One can say that this reasoning is trivial and easy
for reconstruction by any interested reader. But is it
really so? I'd say that setting TTL to 2 and not to 1
was questioned on this list, and an explanation
(referring to common HW implementations) was provided...
So it may be not all that trivial as it seems!

At the same time your recent question about non-usage
of the Uniform model for tunnels carrying PWs and the
discussion it triggered indicate to me that there 
is more than one aspect of the problem to be considered.
In theory it would be nice if this issue were captured
properly in the document (consider the "Discussion"
clauses in RFC 1812 as an example). This is probably
too late to do now, though...

Regards,
                                  Sasha Vainshtein

> From: Shahram Davari [mailto:[email-masked]]
> Sent: Wednesday, November 17, 2004 6:09 PM
> To: Sasha Vainshtein; 'Stewart Bryant'

---

From: Luca Martini <[email-masked]>
Date: Wed, 17 Nov 2004 12:03:12 -0700

TTL is a matter of local policy. Some people might want ttl=2 some  
ttl=64 some ttl=128 ...

I do not believe that the design should mandate what it is ....

it would be equivalent to mandating what the IP ttl should be ....

my 2c
Luca

Shahram Davari wrote:

>>>>Actually, looking at it more carefully, is the question you 
>>>>        
>>>>
>>>are asking
>>>      
>>>
>>>>that the "TTL should be appropriately set to 2" be 
>>>>        
>>>>
>>stricken?  If so,
>>    
>>
>>>>yes, it should.
>>>>
>>>>>>label is application dependent, however in a strict 
>>>>>>            
>>>>>>
>>point to point
>>    
>>