Subject: Title for encapsulation Drafts.

From: Luca Martini <[email-masked]>
Date: Thu, 11 Nov 2004 14:06:40 -0700

It was brought to my attention,in the pwe3 meeting, that
The Title of the encapsulations drafts is not consistent across 
different documents.
The most common is "Blah over IP/MPLS Networks".

Example:
"Encapsulation Methods for Transport of Ethernet Frames Over IP/MPLS Network
s"

One suggestion is to change this to Blah over PSN. However this will 
probably not pass the IESG review as it not a well known acronym , and 
it cannot be expanded. ( or at least I believe so )

The true representation is Blah over MPLS ....
This is short and to the point , so  I propose that except for the TDM 
drafts , we change all the titles to this format.

Any other suggestions on how to proceed ?

Thanks.
Luca

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 11 Nov 2004 16:25:42 -0500

> The true representation is Blah over MPLS ....

This sounds good to me. The Blah over L2TPv3 documents exist in l2tpext anyway.

- Mark

> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 14 Nov 2004 20:52:54 +0200

[Luca] One suggestion is to change this to Blah over PSN. 
However this will probably not pass the IESG review as it not a well
known 
acronym , and it cannot be expanded. ( or at least I believe so )

PSN is the term we have been using in PWE work,
and is presently used in the title of the CESoPSN draft.

[Y(J)S] The problem with that is the requirement for PWs to be
PSN agnostic. Why do we need the PW architecture and requirements
draft for Blah over MPLS ?

[Mark] This sounds good to me. The Blah over L2TPv3 documents exist 
in l2tpext anyway.

[Y(J)S] So it turns out that ONLY the TDM drafts
(SAToP, TDMoIP and CESoPSN), which explicitly
allow MPLS, L2TP, and even UDP/IP,
are true PWs.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 14 Nov 2004 14:50:53 -0500

Yaakov,

>[Luca] The true representation is Blah over MPLS ....
>

No, it's just that the other encaps (Ethernet, etc.) have separate 
encapsulation specs for MPLS and L2TPv3.  The TDM specs combined them into 
one.  They're all "true PWs".  Luca's naming suggestion (Blah over MPLS) is 
the best.

Cheers,
Andy

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 16 Nov 2004 11:48:55 +0200

> No, it's just that the other encaps (Ethernet, etc.) have 
> separate encapsulation specs for MPLS and L2TPv3.  The TDM 
> specs combined them into one.  They're all "true PWs".  
> Luca's naming suggestion (Blah over MPLS) is the best.

Andy, 

My problem is with the following statement in the PWE charter:

  Tunnels for PWE3 encapsulations will use IP (both versions), L2TP,
  or MPLS.  PWE3 will coordinate closely with the L2TP WG and its
  technologies.  PWE3 pseudo wires will have the same specification
  for all underlying PSNs (i.e. there will not be specific adaptation
  of a pseudo wire technology for MPLS that is distinct from what is
  used for IP and L2TP, or differences will be the minimum necessary
  and will be called out clearly).

So not only have we deprecated IP (per our liaison to ITU-T SG13)
we are now saying that PWs do not have to have a single specification
for the two remaining PSN types, but rather there are separate documents
in two different WGs. 

And other than the architecture document, I haven't seen clear calling
out 
of the differences anywhere EXCEPT in the TDM documents 
(e.g. draft-ietf-pwe3-tdmoip has consecutive sections 
explicitly showing the encapsulations for IP, MPLS, and L2TPv3).

So I guess in our rechartering we should fix this paragraph.
We need to remove plain IP. And since L2TP is not being handled
here, we should really only explcitly talk about MPLS,
although we may reference L2TP documents.
Then Luca's suggestion is precisely correct.

Am I the only one who feels that something went wrong here?

Y(J)S

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 16 Nov 2004 12:41:14 +0200

Yaakov and all,
Please see inline.

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> -----Original Message-----
> From: Yaakov Stein [mailto:[email-masked]]
> Sent: Tuesday, November 16, 2004 11:49 AM
> To: Andrew G. Malis
> Cc: pwe3; W. Mark Townsley; Luca Martini
> Subject: RE: [PWE3] Title for encapsulation Drafts.
> 
> 
>  
[Sasha] I disagree. IP tunnels are not related to UDP and hence
have not been deprecated by our liaison in question. E.g.,
http://www.ietf.org/internet-drafts/draft-ietf-mpls-in-ip-or-gre-08.txt
(aready in the RFC Editor queue) describes an IP tunneling mechanism that
can be used for carrying PWs. L2TP is yet another IP tunneling mechanism 
that be used for carrying PWs.
c
> for the two remaining PSN types, but rather there are 
> separate documents in two different WGs. 
>
[Sasha] I AGREE with Yaakov that this looks like an explicit Charter
violation.  
> out of the differences anywhere EXCEPT in the TDM documents 
> We need to remove plain IP. 
>
[Sasha] On the contrary: I think that L2TP should be removed
from list of PSN tunnel types since, as written today, it 
implicitly suggests that L2TP uses some tunneling of its own 
that is not IP (which, IMHO, is incorrect).

Of course, it would not mean that L2TP as a DEMULTIPLEXING method
with an associated signaling protocol cannot or should not be used
by PWs. 

>
> And since L2TP is not being handled
[Sasha] I think that we sometimes still fail to make the
proper distinction between MPLS as the PW DEMULTIPLEXING method
(which can be used with different tunneling technologies) and
MPLS as the PSN TUNNELING method. Until we sort this out,
"speaking onluy about MPLS" will not really help.

> although we may reference L2TP documents.
[Sasha]
> Then Luca's suggestion is precisely correct.
[Sasha] I do not think this is a good suggestion (but, of course,
everybody is entiled to his/her opinion).
May I propose, as an alternative,
"Blah over Pseudo-wires"?

---

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 16 Nov 2004 06:29:33 -0500

>>We need to remove plain IP. 

IP set parallel to L2TP and MPLS (if you consider "MPLS" as including the suite 
of protocols which can distribute MPLS labels) has pretty much been the misnomer 
form the start. An IP tunnel in its strictest form here is simply a pair of PE 
IP addresses. I think it has been demonstrated that you need some signaling, 
perhaps layers of signaling, in order to perform the task at hand. LDP, RSVP, 
BGP, L2TPv3 are all protocols that have been proposed and/or deployed, in one 
form or another, to perform PW setup for different types of PWs. RTP, BFD, and 
VCCV have each been proposed to perform additional functions for different types 
of PWs. Each handle particular tasks in their own way, and require different 
experts (and at times different WGs) to make sure the extension is done in a 
manner which fits in with other uses of the protocol.

- Mark

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 16 Nov 2004 16:04:54 +0200

> [Sasha] I disagree. IP tunnels are not related to UDP and 
> hence have not been deprecated by our liaison in question. 
> E.g., 
>
http://www.ietf.org/internet-drafts/draft-ietf-mpls-in-ip-or-gre-08.txt
(aready in the RFC Editor queue) describes an IP tunneling mechanism
that can be used for carrying PWs. 
> L2TP is yet another IP tunneling mechanism that be used for carrying
PWs.

[YJS] 

Nowhere does the charter say "IP tunnels",
it just says "IP".  I believe that at the beginning everyone
understood "IP" as plain TCP or UDP/IP (as used in AVT), 
and not MPLS in GRE over IP.
Had that been the intention I think it would have been made specific.

<snip>

[YJS] 

I was being facetious here.
I suggested precisely this at the meeting.

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 16 Nov 2004 16:18:07 +0200

Yaakov and all,
Please see more inline.

Regards,
                                  Sasha Vainshtein

> Sent: Tuesday, November 16, 2004 4:05 PM
> To: Sasha Vainshtein
> Cc: pwe3; W. Mark Townsley; Luca Martini; Andrew G. Malis
PWs.

> [YJS] 
>
> Nowhere does the charter say "IP tunnels", it just says "IP".  
>
[Sasha]Well, to be precise, the charter says:
<quote>
  Tunnels for PWE3 encapsulations will use IP (both versions), L2TP,
  or MPLS.  
<end quote>
To me this sounds very close to "IP/L2TP/MPLS tunnels", but ...
> 
> I believe that at the beginning everyone
[Sasha] I see that you give the benefit of doubt to the people who have
drafted the original Charter 3+ years ago. Unfortunately, the original 
intention - regardless of how we reverse engineer it today - 
is hardly all that relevant to the curent reality. The best we can hope
for is to express our opinion in a less ambiguous way when it comes
to actually re-writing the Charter.

> I suggested precisely this at the meeting.
[Sasha] I withdraw any priority claims here and
gladly defer to you. I still think, though, that 
this is a very reasonable suggestion fully aligned 
with the current Charter, and I do not remember 
any strong reasons against being brought up at 
the meeting or after it.
...snipped to the end ...

---

From: Eric Rosen <[email-masked]>
Date: Tue, 16 Nov 2004 09:30:18 -0500

> I believe that  at the beginning everyone understood "IP"  as plain TCP or
> UDP/IP (as used in AVT), and not MPLS in GRE over IP. 

That belief is incorrect.  

While  the  charter  itself  does  not mandate  a  particular  IP  tunneling
technology, L2TPv3 was  foisted on us very early  as the preferred solution.
Mark was named  "technical advisor" to ensure that  we wouldn't forget about
it, and I even  believe that one of the WG chairs  was chosen because he was
at the time working on L2TP solutions. 

Frankly, it would never even have occurred to me that someone would advocate
"plain TCP  or UDP".  And given the  long, long discussion the  WG had about
signaling,  one would think  that anyone  who advocated  UDP as  a tunneling
protocol would have mentioned the issue of signaling UDP tunnels.

---

From: Danny McPherson <[email-masked]>
Date: Tue, 16 Nov 2004 11:06:58 -0700

> That belief is incorrect.

I'm not sure folks figured it for MPLS/GRE/IP, but I suspect most
didn't figure it for TCP or UDP/IP.  Though I do seem to recall
Eric recommending TCP once :-)

> at the time working on L2TP solutions.

Actually, I think that chair was chosen because he wasn't religious
about the tunneling/demux mechanism -- unlike most of the folks
involved at the time (and today :-)

> protocol would have mentioned the issue of signaling UDP tunnels.

I think the closest we came to UDP was DCCP/RTP.  And the
liaison statement is somewhat in error suggesting that our charter
defines "UDP/IP as a possible ..." explicitly.

-danny