Subject: IP Pseudo-wires

From: Stewart Bryant <[email-masked]>
Date: Wed, 17 Nov 2004 14:23:41 +0000

I have been thinking about the IP PW type that
we call up in the control draft.

This is allowed to run over MPLS without the CW
in order to allow ECMP. However I am concerned
that this then breaks routing in the "client"
layer.

If you allow ECMP, then the routing hellos
will not go the same path at the data, and
thus will not do their job. So you could
have incomplete connectivity in the PW, but
routing in the "client" layer would not know,
and would not take appropriate action.

There is also the issue of the IS-IS hellos
needing to be carried that was bought up in the
L2VPN WG.

I think that we need to give serious thought to
removing the IP encap material from the control
draft and writing a stand-alone draft that
gives proper consideration to all the issues
of carrying an IP PW.

- Stewart

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 17 Nov 2004 09:35:53 -0500

...and lets call that draft as 
draft-balus-pwe3-ip-pseudowire-01.txt.. :-)

/himanshu

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Wednesday, November 17, 2004 9:24 AM
> To: pwe3
> Subject: [PWE3] IP Pseudo-wires
> 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 17 Nov 2004 16:42:26 +0200

Stewart and all,

I also have strong doubts regarding the current text on IP PW
in the control protocol draft.

1. The text Section 4.6 "IP Layer2 Transport" states that

<quote>
   IP interworking is implementation specific, part of the NSP 
   function [ARCH], and is outside the scope of this document.
<end quote>

However, looking at
http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-arp-mediation-00.txt
I conclude that IP interworking (or at least its ARP mediation component) 
cannot be restricted to the NSP and hence cannot be fully implementation 
specific.

2. As noted by Stewart, it is impossible to roun IS-IS across IP PWs if,
   as described in the control protocol draft, CW is not used. If the CW
   were used, then one could run IS-IS hellos in the appropriate 
   "associated channel" of the PW, otherwise an explicit applicability 
   statement limiting usage of IP PWs should be present somewhere.

I hence support Stewart's suggestion about removing the text on
IP Layer 2 PWs from the control protocol draft. 

Regards,
                                  Sasha Vainshtein
email:                         [email-masked] <mailto:[email-masked]> 
phone:                       +972-3-7569993 (office)
fax:                            +972-3-6487779
mobile:                      +972-52-8674833 

> Sent: Wednesday, November 17, 2004 4:24 PM
> To: pwe3

---

From: Mustapha Aissaoui <[email-masked]>
Date: Wed, 17 Nov 2004 11:42:24 -0500

All,
I initially suggested to Luca to remove the statement that did not
allow the control word. Thinking about it now, I support taking the
IP PW encapsulation text out of the control draft. I assume the IANA
codepoint will be maintained for the purpose of signaling.

I believe the draft below is a good starting point for the
specification of this PW type.

Mustapha.
------------

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 17 Nov 2004 18:54:22 +0200

> I have been thinking about the IP PW type that we call up in 
> the control draft.
> 
> This is allowed to run over MPLS without the CW in order to 
> allow ECMP. However I am concerned that this then breaks 
> routing in the "client" layer.

It is also "out of charter".

The charter only mentions :

    Ethernet (DIX Ethernet (100M, 1G, 10G), IEEE 802.3, 802.1q (VLAN)
    Frame Relay
    ATM
    TDM (e.g. DS1, DS3, SONET)
    MPLS (over IP or L2TP only)

Y(J)S

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Wed, 17 Nov 2004 12:02:55 -0500

> draft-balus-pwe3-ip-pseudowire-01.txt.. :-)

Yes, indeed.

Hamid.

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 17 Nov 2004 19:33:33 +0200

Yaakov and all,
I would not worry about THIS Charter violation.
We have already accepted the draft on HDLC and PPP PWs 
as a WG document (presumably based on consensus to add
these to the next Charter revision). So there is some
precedent here on doing some work that still is not,
but presumably soon will be chartered

Regards,
                                  Sasha Vainshtein

> From: Yaakov Stein [mailto:[email-masked]]
> Sent: Wednesday, November 17, 2004 6:54 PM
> To: Stewart Bryant; pwe3
> Subject: RE: [PWE3] IP Pseudo-wires
> 
> 
>

---

From: "Florin Balus" <[email-masked]>
Date: Wed, 17 Nov 2004 14:00:28 -0500

Actually Luca told me in Washington he was going to remove the "control word
MUST NOT be used" text from the control draft following the enclosed email.

Also I mentioned during Himanshu's presentation at the L2VPN meeting we were
going to update the suggested format for IS-IS to make use of the
"Associated Channel" type introduced by the latest version of the pw cw
draft... The draft is currently suggesting the use (in a similar fashion) of
the equivalent field in the encapsulation proposed in VCCV.

Stewart,
Let me know if the current text addresses your concerns.
Regards,
Florin

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Mustapha Aissaoui
> Sent: Wednesday, November 17, 2004 11:42 AM
> To: Shah, Himanshu
> Cc: pwe3; 'Stewart Bryant'
> Subject: Re: [PWE3] IP Pseudo-wires
> 
> 
> All,
> I initially suggested to Luca to remove the statement that 
> did not allow the control word. Thinking about it now, I 
> support taking the IP PW encapsulation text out of the 
> control draft. I assume the IANA codepoint will be maintained 
> for the purpose of signaling.
>