Subject: RE: AD review of draft-ietf-pwe3-cw-01.txt - comment 3

From: "Ron Cohen" <[email-masked]>
Date: Fri, 18 Feb 2005 13:57:48 -0800

Stewart,

Than what is it? Is CEP-CW a PW-CW?

Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stewart Bryant
Sent: Friday, February 18, 2005 10:36 AM
To: pwe3
Subject: [PWE3] AD review of draft-ietf-pwe3-cw-01.txt - comment 3

 >       When a PW-CW is used, it SHOULD have the following preferred
form:

 > s/SHOULD/has/
 >
 > This document should just say this is how it is done. If something  >
else is done, its not a PW-CW anymore.

I propose that we accept the change.

Stewart

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Sun, 20 Feb 2005 00:15:16 -0500

Stewart,
I believe it is important to acknowledge that some PW encpasulations may not
adhere to the preferred PW-CW format, nonetheless they comply to this BCP
because the first nibble is all zero's. Striclty speaking, all what is
required is to comply to the Generic PW-CW. From that perspective, the CEP
Adaptation Header and the CW used in ATM 1:1 cell mode are compliant.

I propose that we modify the sentence below as follows:
"When a PW-CW is used, it MUST adhere to the Generic Control Word. It is
however strongly recommended that it also follows the following format:"
 
Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stewart Bryant
Sent: Saturday, February 19, 2005 3:28 PM
To: Stewart Bryant
Cc: 'pwe3'; Ron Cohen
Subject: Re: [PWE3] AD review of draft-ietf-pwe3-cw-01.txt - comment 3

In view of Ron's comment I have left the follwoing text unchanged in this
rev:

"When a PW-CW is used, it SHOULD have the following preferred form:"

However I think that we do need to address the issue of ECMP and VCCV (see
below) and we may need to revisit following a second AD review.

Stewart

Stewart Bryant wrote:

> Ron Cohen wrote:
> Well it's certainly not a prefered CW.
> 
> However the prefered CW mode will surely need to be specified in the 
> SONET/SDH draft text to fix the following
> problems:
> 
> 1) With the non-standard first nibble it may get ECMPed
> 
> 2) You can't use VCCV without running a CEP-PW over a preferred CW 
> because you can't otherwise discriminate between a VCCV and a SONET 
> packet.
> 
> Now as to the CW draft, what do others think, should the text be:
> 
> "When a PW-CW is used, it SHOULD have the following preferred form:"
> 
> or
> 
> "When a PW-CW is used, it has the following preferred form:"
> 
> or maybe
> 
> "When used, the preferred PW-CW form is:"
> 
> Stewart
> 
>>
>> Ron
>>
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of Stewart Bryant
>>  > This document should just say this is how it is done. If something