Subject: RE: Control protocol draft - section 5.3.1 change to PW status.

From: "Mustapha Aissaoui" <[email-masked]>
Date: Thu, 24 Feb 2005 10:01:28 -0500

Rishi,
I am not sure you have read my response to your message last week. I was
telling you the case of N:1 VC-to-PW is hypthetical. The current ATM draft
only deals with a single VC per PW when using the N:1 cell mode
encapsulation encapsulation. In other words, the ATM VC and the ATM PW are
peers. The server layer is the PSN tunnel.

Now, if one wants to implement a true N:1 VC-to-PW, then the PW becomes a
server layer to the ATM VCs. The PW is pre-established and is used as a
tunnel. In that case, you will not withdraw the PW label in response to
administrative or operational state of the individual ATM VCs.

Mustapha.

-----Original Message-----
From: Kulkarni, Hrishikesh (Hrishikesh) [mailto:[email-masked]]
Sent: Thursday, February 24, 2005 4:04 AM
To: 'Mustapha Aissaoui'; 'Shahram Davari'; 'Luca Martini'
Cc: [email-masked]; [email-masked]
Subject: RE: [PWE3] Control protocol draft - section 5.3.1 change to PW
status.

Mustapha,

The problem of when multiple AC are going through a singe N:1 PWE3 remains
unsolved.
if we withdraw the label when one AC is admin down, what about other AC.

Rishi

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Mustapha Aissaoui
> Sent: Wednesday, February 23, 2005 8:39 PM
> To: 'Shahram Davari'; 'Luca Martini'
> Cc: [email-masked]; [email-masked]
> Subject: RE: [PWE3] Control protocol draft - section 5.3.1 change to
> PW st atus.
>
>
> Shahram,
> This is why I asked that we should only withdraw the label when the AC
> is administrativley DOWN when the label withdraw method is used.
> Operational
> status should be updated by AIS/RDI which gets passed transparently if
> the label is not whithdrawn.
>
> Mustapha.
>
> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: Wednesday, February 23, 2005 9:45 AM
> To: 'Luca Martini'; Mustapha Aissaoui
> Cc: [email-masked]; [email-masked]
> Subject: RE: [PWE3] Control protocol draft - section 5.3.1 change to
> PW st atus.
>
> Luca,
>
> > >Luca,
> > >However, it all appears that if the label withdraw PW status
> > method is used,
> > >then a label is withdrawn if say a AIS cell is received from
> > the local ATM
> > >network or LMI indicated a fault. Am I wrong?
> > >
> > >
> > >
> > yes. This is correct, then the remote end would re-generate the AIS
> > alarm.
> >
>
> How does the other end know whether this is an administrative
> withdrwal for removing the service (in which case it should not
> generate
> AIS) or it is a
> withdrawal caused by a fault (in which case it should generate AIS)?
>
> -Shahram
>
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Luca Martini <[email-masked]>
Date: Thu, 24 Feb 2005 13:43:28 -0700

>if we withdraw the label when one AC is admin down, what about other AC.
That PW type has not been defined. So once it is defined the problem can 
be solved.

Luca

>>st atus.
>>This is why I asked that we should only withdraw the label 
>>when the AC is
>>administrativley DOWN when the label withdraw method is used. 
>>Operational
>>status should be updated by AIS/RDI which gets passed 
>>transparently if the
>>label is not whithdrawn.
>>
>>Mustapha.
>>
>>Subject: RE: [PWE3] Control protocol draft - section 5.3.1 
>>change to PW st
>>atus.
>>
>>Luca,
>>
>>    
>>
>>>>Luca,
>>withdrwal for
>>removing the service (in which case it should not generate 
>>AIS) or it is a