Subject: AD review of draft-ietf-pwe3-cw-01.txt - comment 1

From: Stewart Bryant <[email-masked]>
Date: Fri, 18 Feb 2005 18:31:38 +0000

In response to

http://www1.ietf.org/mail-archive/web/pwe3/current/msg06660.html

 > All IP packets [RFC791][RFC1883] start with a version number that is
 > checked by LSRs performing deep packet inspection. To prevent the
 > incorrect inspection of packets, PW packets carried over an MPLS PSN
 > SHOULD NOT start with the value 4 (IPv4) or the value 6 (IPv6) in
 > the first nibble [BCP].
 >
 >
 > Better (?):
 >
 > To prevent the incorrect processing of packets carried within a PW,
 > PW packets carried over an MPLS PSN SHOULD NOT start with the value
 > 4 (IPv4) or the value 6 (IPv6) in the first nibble [BCP], as those
 > are assumed to carry normal IP.

I propose that we accept this revision.

Stewart

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 20 Feb 2005 14:15:16 +0200

> I propose that we replace "deep packet inspection" with "MPLS 
> payload inspection" throughout the draft.

Both terms imply possibly inspecting more than just the first nibble.

Since we have defined the first nibble as the 
PW Associated Channel Type, 
why not simply say "inspection of the PW Associated Channel Type".
(Perhaps we need an abbreviation, e.g. PWACT.)

For IP packets the IANA registry will have PWACT=4 or PWACT= 6,
so the terminology will be accurate.

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 20 Feb 2005 14:17:42 +0200

>  > All IP packets [RFC791][RFC1883] start with a version 
> number that is  > checked by LSRs performing deep packet 
> inspection. To prevent the  > incorrect inspection of 
> packets, PW packets carried over an MPLS PSN  > SHOULD NOT 
> start with the value 4 (IPv4) or the value 6 (IPv6) in  > the 
> first nibble [BCP].
>  >
>  >
>  > Better (?):
>  >
>  > To prevent the incorrect processing of packets carried 
> within a PW,  > PW packets carried over an MPLS PSN SHOULD 
> NOT start with the value  > 4 (IPv4) or the value 6 (IPv6) in 
> the first nibble [BCP], as those  > are assumed to carry normal IP.

Per my previous email, I find it easier to have the values
4 and 6 listed in the PWACT registry, and to enforce correct values
for the PWACT.

Y(J)S

---

From: Stewart Bryant <[email-masked]>
Date: Sun, 20 Feb 2005 21:33:52 +0000

> 4 and 6 listed in the PWACT registry, and to enforce correct values

I did not think that we needed to create a first nibble registry, since
we only have two values (0 and 1), and we are really stealing space
from the IP version registry.

PWACT refers to the 16 bit field.

Stewart

> 
> Y(J)S
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
>