Subject: Re: Control protocol draft - section 5.3.1 change to PW st atus.

From: Luca Martini <[email-masked]>
Date: Fri, 25 Feb 2005 12:10:28 -0700

Yes, as I said before the MAY will have more chances of passing the 
AD/IESG review.
here is the text :

----------------------------------------------------------
.Pc "Use of Label Mappings."
The PEs MUST send PW label mapping messages to their peers as soon as the PW
is configured and administratively enabled, regardless of the attachment
circuit state. The PW label should not be withdrawn unless the user
administratively configures the pseudo wire down (or the PW
configuration is deleted entirely). Using the procedures outlined in this
section a simple label withdraw method MAY also be supported as a legacy
means of signaling PW status. In any case if the Label mapping is not
available the PW MUST be considered in the down state.

Once, the PW status negotiation procedures are completed and if they result
in the use of the label withdraw method for PW status communication, and
this method is not supported by the PE, then the PW MUST be disabled and a
label release message MUST be sent to the remote PE with the following 
error:

"Label Withdraw PW Status Method Not Supported"

If the label withdraw method for PW status communication is selected for the
PW, it  will result in the PW label mapping message being advertised only if
the attachment circuit becomes active.
The PW status signaling procedures described in this section MUST be fully
implemented.
----------------------------------------------------

I also corrected the spelling error that Tom pointed out.

Luca

Shahram Davari wrote:

>I will also go with MAY.
>
>-Shahram
>
>  
>
>>-----Original Message-----
>>From: Andrew G. Malis [mailto:[email-masked]]
>>Sent: Friday, February 25, 2005 7:58 AM
>>To: David Allan
>>Cc: "'Benny Ammitzboll'"; [email-masked]; Thomas D. Nadeau; Shahram
>>Davari; [email-masked]; [email-masked];
>>Busschbach, Peter B (Peter); Luca Martini
>>Subject: RE: [PWE3] Control protocol draft - section 5.3.1 
>>change to PW
>>status.
>>
>>
>>OK, I give in to Benny and Dave.  Let's incorporate Benny's 
>>clarification 
>>and make the "SHOULD" a "MAY".
>>
>>Thanks,
>>Andy
>>
>>-----------
>>
>>At 2/25/2005 07:24 AM -0500, David Allan wrote:
>>
>>    
>>
>>>>I think we have to spell out very clearly that the label
>>>>withdraw is not the way to signal AC state to the remote PE.
>>>>For this reason I also think the SHOULD should just be a MAY.
>>>>        
>>>>
>>>I agree with this. There are clearly consequences to a label 
>>>      
>>>
>>withdraw that
>>    
>>
>>>must be supported, but it should not be used to communicate 
>>>      
>>>
>>AC state (and
>>    
>>
>>>IMO administative state).
>>>
>>>Dave
>>>      
>>>

---

From: Luca Martini <[email-masked]>
Date: Fri, 25 Feb 2005 12:10:52 -0700

Luca