Subject: Re: Clarification Requestedd: draft-ieft-pwe3-vccv-03 (Sec tion6)

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 8 Feb 2005 11:26:14 -0500

On Feb 8, 2005, at 11:09 AM, Florin Balus wrote:

>
>
> Tom,
> Not sure I am clear on what you're saying: let's assume that for PWID 
> 40 PE1 supports OAM option X and PE 2 doesn't.
>
>  Are you saying that PE1 and PE2 should reject the incoming LM 
> messages from the remote peer because OAM option X does not match?

	No.  It should accept them just fine, and remember what preferences the
remote PE sent it.  It should then ONLY send that type of VCCV when/if
the PW comes up to that peer.

	--Tom

> Or that they should accept the LMs but should both revert to the 
> common denominator (i.e. no OAM option X)?
>
>  Regards,
> Florin
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of Thomas D. Nadeau
> > Sent: Tuesday, February 08, 2005 3:38 AM
> > To: Mark Aberdeen
> > Cc: [email-masked]
> > Subject: Re: [PWE3] Clarification Requestedd:
>  > draft-ieft-pwe3-vccv-03 (Section6)
> >
> >
> >
> > On Jan 25, 2005, at 10:36 AM, Mark Aberdeen wrote:
> >
> > > Section 6, Page 8 states the following:
> > >
> > >    "The receiving PE agrees to accept any of the indicated
> > >    OAM types and options by virtue of establishing the PW.  If
> > >    it does not or cannot support at least one of the options
> > >    specified, it MUST not establish the PW."
> > >
> > > Does this simply mean that the receiving PE will not complete the
> > > label mapping?  Or is the PW be established and with no OAM 
> support?
> >
> >       OAM parameters are advertised by one router to the other
> > to indicate which VCCV types it can support and is expecting
> > to receive; there is no negotiation per se.  Once both sides
> > have indicated which VCCV "mode" they support, both sides
> > know which modes to both send to their peer, and what to
> > expect from them.
> >
> >       I am updating the draft to make this more clear.
> >
> >       --Tom
> >      
> >
> > > --
> > >
> > > Mark Aberdee, B.E., B.Sc., P.Eng.
> > > 7670 RSP Software Development
> > > Alcatel Canada
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > pwe3 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pwe3
> > >
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> >
> >

---

From: "Florin Balus" <[email-masked]>
Date: Tue, 8 Feb 2005 11:09:06 -0500

Tom,
Not sure I am clear on what you're saying: let's assume that for PWID 40 PE1
supports OAM option X and PE 2 doesn't. 

Are you saying that PE1 and PE2 should reject the incoming LM messages from
the remote peer because OAM option X does not match?

Or that they should accept the LMs but should both revert to the common
denominator (i.e. no OAM option X)? 

Regards,
Florin

> > label mapping?  Or is the PW be established and with no OAM support?
>