Subject: Re: Control protocol draft - section 5.3.1 change to PW st atus.

From: Luca Martini <[email-masked]>
Date: Thu, 24 Feb 2005 10:30:57 -0700

Busschbach, Peter B (Peter) wrote:

>  
>
>>-----Original Message-----
>>From: Benny Ammitzbøll [mailto:[email-masked]]
>>Sent: Wednesday, February 23, 2005 4:29 AM
>>To: Luca Martini; [email-masked]
>>Cc: [email-masked]; [email-masked]
>>Subject: RE: [PWE3] Control protocol draft - section 5.3.1 
>>change to PW
>>status.
>>
>>
>>Sorry if I jump in in the middle of this, but I believe that 
>>Neils point is
>>that the PW is the server and what the PW carries inside is 
>>the client. This
>>also IMO means that the AC is client and the state of the AC 
>>should not
>>affect the server layer, i.e. the PW.
>>
>>I think it would help to stress more clearly in section 5.3.1 that the
>>coupling between AC state and PW state is NOT the desired 
>>behaviour, but it
>>is only there because of backwards compatability with non-standard
>>equipment.
>>
>>My proposal for a new text:
>>
>>   The PEs MUST send PW label mapping messages to their peers 
>>as soon as
>>   the PW is configured and administratively enabled, 
>>regardless of the
>>   attachment circuit state. The PW label should not be 
>>withdrawn unless
>>   the user administratively configures the PW down (or the 
>>PW configuration
>>   is deleted entirely). If the Label mapping is not 
>>available the PW MUST
>>   be considered in the down state.
>>
>>   For backwards compatability a simple label withdraw method 
>>MUST also be
>>    
>>
>
>I have made this point in an earlier email, but I think it is worth repeating. I believe that this MUST should be a MAY.
>
>Label mapping, label withdraw and the use of PW Status are all functions that are implemented in software. Therefore, it may be true that there are legacy devices today that only support label withdraw, but there is no reason why vendors would not be able to support PW Status in future software releases. PW Status is mandatory and future software releases must support it to be standards-compliant.
>
>Considering the fact that PWE is a relatively new and rapidly expanding technology, does anybody believe that five years from now there will be products in the field that were installed pre 2003 and that still run their original R1 software load?
>
>
>
>  
>
Yes , I can agree with a MAY. This would allow backward compatibility 
until it is no longer needed for migration.
However I still would like to hear fro the rest f the WG.

Luca

>
>
>
>  
>
>>   supported as a legacy means of signaling PW status. When 
>>the PW status
>>   negotiation procedures are completed and if they result in 
>>not using the
>>   PW Status TVL, the label withdraw PW status method MUST be 
>>used. This
>>   will result in the PW label mapping message being 
>>advertised only if
>>   the attachment circuit becomes active. The PW status signaling
>>   procedures described in this section MUST be fully implemented.
>>
>>/Benny
>>
>>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>>Luca Martini
>>Sent: 22. februar 2005 20:35
>>To: [email-masked]
>>Cc: [email-masked]; [email-masked]
>>Subject: Re: [PWE3] Control protocol draft - section 5.3.1 
>>change to PW
>>status.
>>
>>
>>[email-masked] wrote:
>>
>>    
>>
>>>Mustapha,
>>>
>>>This is precisely why I raised this point.....but please do 
>>>      
>>>
>>not overlook
>>    
>>
>>>the more fundamantal point that 'defect events' in any client layer
>>>should never result in 'events' in any server layer.  One should not
>>>violate principles like these just because its expedient.  
>>>      
>>>
>>If everyone
>>    
>>
>>>had taken this attitude we could, in theory, cause 'events' at the
>>>optics layer (maybe in someone else's network even) for 
>>>      
>>>
>>'defect events'
>>    
>>
>>>in some client perhaps several layers removed (upwards).  
>>>      
>>>
>>Clearly this
>>    
>>
>>>is a nonsense.
>>>
>>>regards, Neil
>>>
>>>
>>>
>>>      
>>>
>>Neil, I agree, however the PW is not a client of the PW control
>>protocol. I see the PW an adaptation of the 
>>atm/frame/ethernet etc. to MPLS.
>>So we are not causing an alarm in the RSVP LSP , or in the 
>>IGP protocol.....
>>
>>Luca
>>
>>    
>>
>>>>-----Original Message-----
>>>>From: Mustapha Aissaoui [mailto:[email-masked]]
>>>>Sent: 22 February 2005 15:05
>>>>To: 'Luca Martini'; Harrison,N,Neil,IKM1 R
>>>>Cc: [email-masked]
>>>>Subject: RE: [PWE3] Control protocol draft - section 5.3.1
>>>>change to PW status.
>>>>
>>>>
>>>>Luca,
>>>>However, it all appears that if the label withdraw PW status
>>>>method is used, then a label is withdrawn if say a AIS cell
>>>>is received from the local ATM network or LMI indicated a
>>>>fault. Am I wrong?
>>>>
>>>>Also, how should we interpret the new text? Initially, you
>>>>advertize the label regardless of the state of AC. Then, if
>>>>the PW status negotiation results in the use of the label
>>>>withdraw PW status method, would you immediately withdraw the
>>>>label because the AC is not active?
>>>>
>>>>I would like to see a simplification to the procedures. The
>>>>reason why label withdrawal is to be avoided as much as
>>>>possible is because it confuses a fault condition with an
>>>>adiministrative operation. We do not want to have the network
>>>>react to some unstable CPE or L2 network condition.
>>>>
>>>>I suggest that regardless of the PW status method used, a
>>>>label is withdrawan only if the user configures the AC
>>>>administrative state to DOWN. Any other fault condition
>>>>should raise an alarm to the management system but should not
>>>>cause a label withdrawal.
>>>>
>>>>Mustapha.
>>>>
>>>>-----Original Message-----
>>>>From: [email-masked] [mailto:[email-masked]] On
>>>>Behalf Of Luca Martini
>>>>Sent: Friday, February 18, 2005 10:45 AM
>>>>To: [email-masked]
>>>>Cc: [email-masked]
>>>>Subject: Re: [PWE3] Control protocol draft - section 5.3.1
>>>>change to PW status.
>>>>
>>>>[email-masked] wrote:
>>>>
>>>>
>>>>
>>>>        
>>>>
>>>>>Luca asked:  Please let me know if you have any comments about this
>>>>>text.
>>>>>
>>>>>Question:  Is there is any inference in this text (or other text in
>>>>>this draft, or in any other draft for that matter) that a 
>>>>>          
>>>>>
>>PW must be
>>    
>>
>>>>>taken down in response to a failure on an AC?  If there is
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>then its wrong.
>>>>
>>>>
>>>>        
>>>>
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>In the new PW status design, described here , the  PW is not
>>>>"taken down ", but instead attachment circuit status is
>>>>communicated to the remote end of the PW. So the answer is
>>>>no. Example ATM AIS alarm. The AIS OAM cells will be passed
>>>>along the PW , additionally a PW status TLV "interface
>>>>Receive Fault" will also be transmitted in the control protocol.
>>>>
>>>>Luca
>>>>
>>>>
>>>>
>>>>        
>>>>
>>>>>One should NEVER take down a server layer trail in response
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>to a defect
>>>>
>>>>
>>>>        
>>>>
>>>>>in some client layer link connection.  Just think if we 
>>>>>          
>>>>>
>>did this for
>>    
>>
>>>>>all nested layer networks right down to optics!
>>>>>
>>>>>regards, Neil
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>>>-----Original Message-----
>>>>>>From: [email-masked] 
>>>>>>            
>>>>>>
>>[mailto:[email-masked]] On Behalf
>>    
>>
>>>>>>Of Luca Martini
>>>>>>Sent: 17 February 2005 23:35
>>>>>>To: PWE3 WG (E-mail)
>>>>>>Subject: [PWE3] Control protocol draft - section 5.3.1 
>>>>>>            
>>>>>>
>>change to PW
>>    
>>
>>>>>>status.
>>>>>>
>>>>>>
>>>>>>In this section , we were asked to make the 
>>>>>>            
>>>>>>
>>implementation of the PW
>>    
>>
>>>>>>status messages/TLV mandatory.
>>>>>>Also all "CE-facing port" terminology will be changed to
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>"attachment
>>>>
>>>>
>>>>        
>>>>
>>>>>>circuit".
>>>>>>
>>>>>>5.3.1. Use of Label Mappings.
>>>>>>
>>>>>> The PEs MUST send PW label mapping messages to their
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>peers as soon
>>>>
>>>>
>>>>        
>>>>
>>>>>>as
>>>>>> the PW is configured and administratively enabled, regardless of
>>>>>>the
>>>>>> CE-facing interface state. The PW label should not be withdrawn
>>>>>> unless the user administratively configures the
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>CE-facing interface
>>>>
>>>>
>>>>        
>>>>
>>>>>> down (or the PW configuration is deleted entirely). Using the
>>>>>> procedures outlined in this section a simple label
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>withdraw method
>>>>
>>>>
>>>>        
>>>>
>>>>>> MAY also be supported as a primitive means of signaling
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>PW status.
>>>>
>>>>
>>>>        
>>>>
>>>>>>It
>>>>>> is strongly RECOMMENDED that the PW status signaling procedures
>>>>>>below
>>>>>> be fully implemented. In any case if the Label mapping is not
>>>>>> available the PW MUST be considered in the down state.
>>>>>>
>>>>>>will change to:
>>>>>>
>>>>>>5.3.1. Use of Label Mappings.
>>>>>>The PEs MUST send PW label mapping messages to their peers
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>as soon as
>>>>
>>>>
>>>>        
>>>>
>>>>>>the PW is configured and administratively enabled,
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>regardless of the
>>>>
>>>>
>>>>        
>>>>
>>>>>>attachment circuit state. The PW label should not be
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>withdrawn unless
>>>>
>>>>
>>>>        
>>>>
>>>>>>the user administratively configures the CE-facing
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>interface down (or
>>>>
>>>>
>>>>        
>>>>
>>>>>>the PW configuration is deleted entirely). Using the procedures
>>>>>>outlined in this section a simple label withdraw method
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>MUST also be
>>>>
>>>>
>>>>        
>>>>
>>>>>>supported as a primitive means of signaling PW status. In
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>any case if
>>>>
>>>>
>>>>        
>>>>
>>>>>>the Label mapping is not available the PW MUST be 
>>>>>>            
>>>>>>
>>considered in the
>>    
>>
>>>>>>down state.
>>>>>>
>>>>>>Once, the PW status negotiation procedures are completed 
>>>>>>            
>>>>>>
>>and if they
>>    
>>
>>>>>>result in the use of the label withdraw method for PW status
>>>>>>communication, the label withdraw PW status method MUST be
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>used. This
>>>>
>>>>
>>>>        
>>>>
>>>>>>will result in the PW label mapping message being
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>advertised only if
>>>>
>>>>
>>>>        
>>>>
>>>>>>the attachment circuit becomes active. The PW status signaling
>>>>>>procedures described in this section MUST be fully implemented.
>>>>>>
>>>>>>
>>>>>>Please let me know if you have any comments about this text. Luca
>>>>>>
>>>>>>_______________________________________________
>>>>>>pwe3 mailing list
>>>>>>[email-masked]
>>>>>>https://www1.ietf.org/mailman/listinfo/pwe3
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>            
>>>>>>
>>>>>_______________________________________________
>>>>>pwe3 mailing list
>>>>>[email-masked]
>>>>>https://www1.ietf.org/mailman/listinfo/pwe3
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>          
>>>>>
>>>>_______________________________________________
>>>>pwe3 mailing list
>>>>[email-masked]
>>>>https://www1.ietf.org/mailman/listinfo/pwe3
>>>>
>>>>
>>>>
>>>>
>>>>        
>>>>
>>>
>>>      
>>>
>>_______________________________________________
>>pwe3 mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/pwe3
>>
>>
>>
>>_______________________________________________
>>pwe3 mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/pwe3
>>
>>    
>>
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>
>  
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 24 Feb 2005 13:21:39 -0500

On Feb 24, 2005, at 12:16 PM, Busschbach, Peter B (Peter) wrote:

> I have made this point in an earlier email, but I think it is worth 
> repeating. I believe that this MUST should be a MAY.

	Peter,

	This seems reasonable (and flexible) to me.  In fact,
I thought we all agreed to a MAY a while back.

	--Tom

>
> Label mapping, label withdraw and the use of PW Status are all 
> functions that are implemented in software. Therefore, it may be true 
> that there are legacy devices today that only support label withdraw, 
> but there is no reason why vendors would not be able to support PW 
> Status in future software releases. PW Status is mandatory and future 
> software releases must support it to be standards-compliant.
>
> Considering the fact that PWE is a relatively new and rapidly 
> expanding technology, does anybody believe that five years from now 
> there will be products in the field that were installed pre 2003 and 
> that still run their original R1 software load?
>
>
>
>
>
>
>