Subject: Re: Control protocol draft - section 5.3.1 change to PW st atus.

From: Luca Martini <[email-masked]>
Date: Thu, 24 Feb 2005 12:06:41 -0700

Excellent , it sound like we are converging.
However we need to agree on the logic of this PW status procedure.
If the PW status negotiation results in Label Withdraw method then :

1) we use label withdraw method ( MAY option )
2) if label withdraw is not implemented , we disable the PW with a label 
release error message.
3) we do nothing. however in this case PW messaging would be broken.

I think that we need #1 and #2 in the text with the corresponding error 
for #2

Do you agree ?

Luca

Shahram Davari wrote:

>This is a reasonable suggestion.
>
>-Shahram
>
>
>  
>
>>>I have made this point in an earlier email, but I think it is worth 
>>>repeating. I believe that this MUST should be a MAY.
>>>      
>>>
>>	Peter,
>>
>>	This seems reasonable (and flexible) to me.  In fact,
>>I thought we all agreed to a MAY a while back.
>>
>>	--Tom
>>
>>
>>    
>>
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>  
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 24 Feb 2005 14:51:34 -0500

Cool with me.  So I think it should be worded
like:

If the PW status negotiation results in Label Withdraw method then
you SHOULD use either 1) label withdraw method, or 2) if
label withdraw is not implemented, we disable the PW with a label
release error message.

	--tom

> 2) if label withdraw is not implemented , we disable the PW with a 
> label release error message.
> I think that we need #1 and #2 in the text with the corresponding 
> error for #2
>
> Do you agree ?
>
> Luca
>
>
>
>
> Shahram Davari wrote:
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 24 Feb 2005 15:50:04 -0500

The SHOULD in Tom's text below needs to be a MUST, since if the negotiation 
results in using the Withdraw method, then you MUST follow Tom's algorithm.

I would also prefer that implementations SHOULD implement Withdraw for 
backwards compatibility, rather than MAY, to encourage backwards 
compatibility without actually requiring it.  When the Proposed Standard 
goes for Draft Standard, we can think about lessening the SHOULD to a MAY 
(or even removing it), since hopefully at that point the installed base 
would have migrated to the RFC.

Cheers,
Andy

------------