Subject: Re: Control protocol draft - section 5.3.1 change to PW st atus.

From: Luca Martini <[email-masked]>
Date: Thu, 24 Feb 2005 19:09:58 -0700

Ok,
here is the section in question :
---------------------------------------------
.Pc "Use of Label Mappings."
The PEs MUST send PW label mapping messages to their peers as soon as the PW
is configured and administratively enabled, regardless of the attachment
circuit state. The PW label should not be withdrawn unless the user
administratively configures the attachment circuit down (or the PW
configuration is deleted entirely). Using the procedures outlined in this
section a simple label withdraw method SHOULD also be supported as a legacy
means of signaling PW status. In any case if the Label mapping is not
available the PW MUST be considered in the down state.

Once, the PW status negotiation procedures are completed and if they result
in the use of the label withdraw method for PW status communication, and
this method is not supported by the PE, then the PW MUST be disabled and a
label release message MUST be sent to he remote PE with the following error:

"Label Withdraw PW Status Method Not Supported"

If the label withdraw method for PW status communication is selected for the
PW, it  will result in the PW label mapping message being advertised only if
the attachment circuit becomes active.
The PW status signaling procedures described in this section MUST be fully
implemented.
----------------------------------------------------------

Is this ok ?

I am in favor of the SHOULD myself , but it might not make the AD/IESG 
review. They will probably ask in what situation is this part not going 
to be implemented ?

Luca

Busschbach, Peter B (Peter) wrote:

>I agree with Andy's proposal.
>
>Peter
>
>  
>
>>-----Original Message-----
>>From: Andrew G. Malis [mailto:[email-masked]]
>>Sent: Thursday, February 24, 2005 3:50 PM
>>To: Thomas D. Nadeau
>>Cc: Luca Martini; Shahram Davari; [email-masked]; 'Benny Ammitzboll';
>>Busschbach, Peter B (Peter); [email-masked];
>>[email-masked]
>>Subject: Re: [PWE3] Control protocol draft - section 5.3.1 
>>change to PW
>>st atus.
>>
>>
>>The SHOULD in Tom's text below needs to be a MUST, since if 
>>the negotiation 
>>results in using the Withdraw method, then you MUST follow 
>>Tom's algorithm.
>>
>>I would also prefer that implementations SHOULD implement 
>>Withdraw for 
>>backwards compatibility, rather than MAY, to encourage backwards 
>>compatibility without actually requiring it.  When the 
>>Proposed Standard 
>>goes for Draft Standard, we can think about lessening the 
>>SHOULD to a MAY 
>>(or even removing it), since hopefully at that point the 
>>installed base 
>>would have migrated to the RFC.
>>
>>Cheers,
>>Andy
>>
>>------------
>>
>>At 2/24/2005 02:51 PM -0500, Thomas D. Nadeau wrote:
>>
>>    
>>
>>>        Cool with me.  So I think it should be worded
>>>like:
>>>
>>>If the PW status negotiation results in Label Withdraw method then
>>>you SHOULD use either 1) label withdraw method, or 2) if
>>>label withdraw is not implemented, we disable the PW with a label
>>>release error message.
>>>
>>>        --tom
>>>
>>>
>>>      
>>>
>>>>Excellent , it sound like we are converging.
>>>>However we need to agree on the logic of this PW status procedure.
>>>>If the PW status negotiation results in Label Withdraw method then :
>>>>
>>>>1) we use label withdraw method ( MAY option )
>>>>2) if label withdraw is not implemented , we disable the PW 
>>>>        
>>>>
>>with a label 
>>    
>>
>>>>release error message.
>>>>3) we do nothing. however in this case PW messaging would be broken.
>>>>
>>>>I think that we need #1 and #2 in the text with the 
>>>>        
>>>>
>>corresponding error 
>>    
>>
>>>>for #2
>>>>
>>>>Do you agree ?
>>>>
>>>>Luca
>>>>        
>>>>
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3
>  
>

---

From: Benny Ammitzbøll <[email-masked]>
Date: Fri, 25 Feb 2005 10:34:39 +0100

The sentence "The PW label should not be withdrawn unless the user
administratively configures the attachment circuit down" stands on its own
early on. It is confusing me - am I right in assuming that a PE that
supports the Status message (and has negotiated to use the Status message)
should *only* send a label withdraw if the PW itself is deleted or set to
admin down? This sentence makes it sound like it is ok to send a label
withdraw when the user sets the AC admin state down - even if the Status
message is in use!

I think we have to spell out very clearly that the label withdraw is not the
way to signal AC state to the remote PE. For this reason I also think the
SHOULD should just be a MAY.

/Benny

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Luca Martini
Sent: 25. februar 2005 03:10
To: Busschbach, Peter B (Peter)
Cc: Thomas D. Nadeau; Shahram Davari; [email-masked]; 'Benny Ammitzboll';
[email-masked]; [email-masked]
Subject: Re: [PWE3] Control protocol draft - section 5.3.1 change to PW
status.

Ok,

Is this ok ?

Luca

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 25 Feb 2005 09:44:22 -0500

> here is the section in question :
                                        ^^
                                        the

> review. They will probably ask in what situation is this part not 
> going to be implemented ?
>
> Luca
>
>
>
>>> The SHOULD in Tom's text below needs to be a MUST, since if the 
>>> negotiation results in using the Withdraw method, then you MUST 
>>> follow Tom's algorithm.
>>>
>>> I would also prefer that implementations SHOULD implement Withdraw 
>>> for backwards compatibility, rather than MAY, to encourage backwards 
>>> compatibility without actually requiring it.  When the Proposed 
>>> Standard goes for Draft Standard, we can think about lessening the 
>>> SHOULD to a MAY (or even removing it), since hopefully at that point 
>>> the installed base would have migrated to the RFC.
>>>
>>> Cheers,
>>> Andy
>>>
>>> ------------
>>>
>>>>> :