Subject: Padding REQUIREMENT removed from Frame relay draft

From: Luca Martini <[email-masked]>
Date: Fri, 18 Feb 2005 18:49:18 -0700

WG,

For some reason the frame relay drafts specified that packet MUST be 
padded if the length is less then 64 bytes. This is not necessary , nor 
is it part of the architecture.
I have changed the draft to be similar to the ethernet/ATM/PPP/HDLC ones.
The length field is used to remove any padding that may be added in the 
PSN. ( but no padding is added at the ingress PE, unless the PSN 
requires it )

Luca

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 20 Feb 2005 17:43:39 +0200

> For some reason the frame relay drafts specified that packet 
> MUST be padded if the length is less then 64 bytes. This is 
> not necessary , nor is it part of the architecture.
> The length field is used to remove any padding that may be 
> added in the PSN. ( but no padding is added at the ingress 
> PE, unless the PSN requires it )

I completely agree.

The ITU version (X.84) also goes into the padding at great length
(although it gives the caveat that padding is only done if
the link-layer protocol requires it).

This padding is not architecturally part of the PW specification,
and should not be added or processed by the PW interworking function.

Can we send a liaison to ITU asking for this to be removed?

More generally, after the FR draft is finalized here,
I think we will have to ask the ITU to realign X.84.

Y(J)S

---

From: [email-masked]
Date: Mon, 21 Feb 2005 08:46:05 -0000

> > padded if the length is less then 64 bytes. This is not necessary , 
> > nor is it part of the architecture. I have changed the draft to be 
> > similar to the ethernet/ATM/PPP/HDLC ones.
> (although it gives the caveat that padding is only done if the 
> link-layer protocol requires it).
> 
> This padding is not architecturally part of the PW specification, and 
> should not be added or processed by the PW interworking function.
> 

Yaakov,  You raise an important point here.....

IMO it makes no sense to have ITU (or any other SDO for that matter)
creating stds based on IETF drafts which are not even stable rfcs and
subject to change.   Further, wrt to my remark yesterday I do not
believe one can leave the handling of persistent Seq No. aberrations an
open issue. Then there is all the stuff on MH PWs which is also far from
complete.  So how many subsequent 'update' liaisons will there be?

Note - This is not simply a 'formal SDO issue' IMO, as I believe there
is a professional/ethical responsibility here on those folks who are
active in such work in both IETF and ITU.

But even with stable rfcs one then has the ongoing problem of keeping
the stds in the 2 bodies in sync.  Unless there is a good reason to have
different SDO producing stds on the same topic (which may in practice be
simply an issue of more completeness and/or reducing options) then a
non-lead SDO should simply reference the stds work of the lead SDO IMO.

regards, Neil

---

From: "Walsh, Thomas D (Tom)" <[email-masked]>
Date: Tue, 22 Feb 2005 11:46:24 -0500

Neil, 

I am a bit surprised by your comments given your active involvement in X.84.  Also, I believe the IETF has made it clear on many occassions they address a different segment of the industry than ITU-T.  

Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, February 21, 2005 3:46 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [PWE3] Padding REQUIREMENT removed from Frame relay draft

regards, Neil

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: [email-masked]
Date: Tue, 22 Feb 2005 17:24:57 -0000

Tom,

> Neil, 
> 
> I am a bit surprised by your comments given your active 
> involvement in X.84.
NH=> My 'active involvement' on X.84 was to point out some of the issues
with it when I noticed SG17 (now disbanded) working on it.

>   Also, I believe the IETF has made it 
> clear on many occassions they address a different segment of 
> the industry than ITU-T. 
NH=> IMO most of CCAMPs stuff is not aimed at the public Internet.  But
are you saying that none of the IETF work is targeted at operators, and
this has been made clear?  Can you point me to the right references
please?

regards, Neil
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of [email-masked]
> > > similar to the ethernet/ATM/PPP/HDLC ones. The length 
> field is used 
> > > to remove any padding that may be added in the PSN. ( but 
> no padding 
> > > is added at the ingress PE, unless the PSN requires it )
> > 
> > I completely agree.
> > 
> IMO it makes no sense to have ITU (or any other SDO for that 
> matter) creating stds based on IETF drafts which are not even 
> stable rfcs and
> believe one can leave the handling of persistent Seq No. 
> aberrations an open issue. Then there is all the stuff on MH 
> PWs which is also far from complete.  So how many subsequent 
> 'update' liaisons will there be?
> 
> Note - This is not simply a 'formal SDO issue' IMO, as I 
> believe there is a professional/ethical responsibility here 
> on those folks who are active in such work in both IETF and ITU.
> 
> But even with stable rfcs one then has the ongoing problem of 
> keeping the stds in the 2 bodies in sync.  Unless there is a 
> good reason to have different SDO producing stds on the same 
> topic (which may in practice be simply an issue of more 
> completeness and/or reducing options) then a non-lead SDO 
> should simply reference the stds work of the lead SDO IMO.
> 
> regards, Neil
>

---

From: "Walsh, Thomas D (Tom)" <[email-masked]>
Date: Tue, 22 Feb 2005 12:37:24 -0500

Neil,

SG 17 was not disbanded - nor was the work terminated.  Its now in SG 13 Q/12.  If IETF finds a technical problem with X.84, ITU-T will address it.

Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 22, 2005 12:25 PM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]

Tom,

regards, Neil

---

From: [email-masked]
Date: Mon, 28 Feb 2005 17:45:47 -0000

Tom, Folks,

> involvement in X.84.  Also, I believe the IETF has made it 

Indeed ITU address a different segment of the industry to IETF.  However I believe Neil's main point (which I support) is that two different SDOs shouldn't produce a standard on the same thing.  I appreciate that X.84 contains lots of stuff that may not be in the IETF draft, but it also contains lots of stuff that is already in the draft and that is likely (definitely?) to cause headaches trying to keep the docs in sync.

I am lead to believe that ETSI take a 'common sense' approach to this sort of thing and reference the necessary sections of standards from other SDOs and only include original text in ETSI's outputs.  That seems to me to be a good approach for all SDOs to take.

I believe Neil's other point (which unsurprisingly I also support) is to question whether ITU should ratify a standard when the document it is based on (from IETF) is still a draft and not a standard.

Anyway, I believe this is all out of scope for this list...

Ben

---

From: "Walsh, Thomas D (Tom)" <[email-masked]>
Date: Mon, 28 Feb 2005 12:57:25 -0500

Ben

Yes, Neil and I took it off list long ago. As far as what ITU should standardize, that is based on what contributions they get.  ITU was doing Frame Relay long before IETF started pwe3.  And FRF was doing FRF interworking long before IETF pwe3. At one point, about 3 plus years ago, there were one common draft between ITU-T, FRF, MPLS Forum and IETF with the same author.  So the material was not exclusive to IETF.  The other groups have long sinced finished their work.  It will be  nice when IETF finishes theirs.

Any more comments will be off-line.

Tom    

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Monday, February 28, 2005 12:46 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [PWE3] Padding REQUIREMENT removed from Frame relay draft

Tom, Folks,

Ben