Subject: Re: Control protocol draft - section 5.3.1 change to PW status.

From: Stewart Bryant <[email-masked]>
Date: Fri, 18 Feb 2005 09:27:47 +0000

[email-masked] wrote:

> Luca asked:  Please let me know if you have any comments about this
> text.
> 
> Question:  Is there is any inference in this text (or other text in this
> draft, or in any other draft for that matter) that a PW must be taken
> down in response to a failure on an AC?  

I do not read that into Luca's new text, and I am not aware of such
text in the drafts

> If there is then its wrong.

Indeed

> One should NEVER take down a server layer trail in response to a defect
> in some client layer link connection.  Just think if we did this for all
> nested layer networks right down to optics!
> 

I agree.

- Stewart

> regards, Neil
> 
> 
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]] On 
>>Behalf Of Luca Martini
>>Sent: 17 February 2005 23:35
>>To: PWE3 WG (E-mail)
>>Subject: [PWE3] Control protocol draft - section 5.3.1 change 
>>to PW status.
>>
>>
>>In this section , we were asked to make the implementation of the PW 
>>status messages/TLV mandatory.
>>Also all "CE-facing port" terminology will be changed to "attachment 
>>circuit".
>>
>>5.3.1. Use of Label Mappings.
>>
>>   The PEs MUST send PW label mapping messages to their peers 
>>as soon as
>>   the PW is configured and administratively enabled, 
>>regardless of the
>>   CE-facing interface state. The PW label should not be withdrawn
>>   unless the user administratively configures the CE-facing interface
>>   down (or the PW configuration is deleted entirely). Using the
>>   procedures outlined in this section a simple label withdraw method
>>   MAY also be supported as a primitive means of signaling PW 
>>status. It
>>   is strongly RECOMMENDED that the PW status signaling 
>>procedures below
>>   be fully implemented. In any case if the Label mapping is not
>>   available the PW MUST be considered in the down state.
>>
>>will change to:
>>
>>5.3.1. Use of Label Mappings.
>>The PEs MUST send PW label mapping messages to their peers as 
>>soon as the PW is configured and administratively enabled, 
>>regardless of the attachment circuit state. The PW label 
>>should not be withdrawn unless the user administratively 
>>configures the CE-facing interface down (or the PW 
>>configuration is deleted entirely). Using the procedures 
>>outlined in this section a simple label withdraw method MUST 
>>also be supported as a primitive means of signaling PW 
>>status. In any case if the Label mapping is not available the 
>>PW MUST be considered in the down state.
>>
>>Once, the PW status negotiation procedures are completed and 
>>if they result in the use of the label withdraw method for PW 
>>status communication, the label withdraw PW status method 
>>MUST be used. This will result in the PW label mapping 
>>message being advertised only if the attachment circuit 
>>becomes active. The PW status signaling procedures described 
>>in this section MUST be fully implemented.
>>
>>
>>Please let me know if you have any comments about this text. Luca
>>
>>_______________________________________________
>>pwe3 mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/pwe3
>>
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
>

---

From: Luca Martini <[email-masked]>
Date: Fri, 18 Feb 2005 08:45:28 -0700

[email-masked] wrote:

>down in response to a failure on an AC?  If there is then its wrong.
>  
>
In the new PW status design, described here , the  PW is not "taken down 
", but instead attachment circuit status is communicated to the remote 
end of the PW.
So the answer is no. Example ATM AIS alarm. The AIS OAM cells will be 
passed along the PW , additionally a PW status TLV "interface Receive 
Fault" will also be transmitted in the control protocol.

Luca