Subject: Re: I-D ACTION:draft-ietf-pwe3-fragmentation-08.txt

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 16 Feb 2005 03:03:21 -0500

Seung Yeop,

Fragmentation is an additional optional function added to the encapsulation 
layer, rather than a separate layer.  It uses two bits reserved for the 
function in the CW, and re-uses the same sequence number field in the 
CW.  The reason that it's in a separate draft is that it's a common 
function across a number of encapsulations, and this way we don't have to 
repeat that same text in every encapsulation draft.  As Mark said, the only 
purpose for the fragmentation is to allow PWE3 to function in environments 
where the encapsulated packets would be larger than the path MTU, and 
dropped by the network as a result.

Cheers,
Andy

----------

At 2/15/2005 11:02 AM -0800, Seung Yeop Yang wrote:
>Thank you, Mark and Andy.
>
>Please, let me ask you another question.
>
>As this fragmentation document is related only MTU-issue, then it's the 
>function of PWE3 demultiplexer layer as described in PWE3 architecture 
>I-D, and multilink PW should be carried on PW encapsulation layer.
>Is my understanding correct?
>
>Then PW-CW is used for reassembly in demux layer, is it still valid to be 
>used for PW encapsulation layer?
>Then where is the PW-CW termination layer, is it demultiplexer layer or 
>encapsulation or both?
>
>Regards,
>Seung Yeop.

---

From: Seung Yeop Yang <[email-masked]>
Date: Tue, 15 Feb 2005 11:02:53 -0800 (PST)

As this fragmentation document is related only MTU-issue, then it's the function of PWE3 demultiplexer layer as described in PWE3 architecture I-D, and multilink PW should be carried on PW encapsulation layer. 
Is my understanding correct?
 
Then PW-CW is used for reassembly in demux layer, is it still valid to be used for PW encapsulation layer?
Then where is the PW-CW termination layer, is it demultiplexer layer or encapsulation or both?
 
Regards,
Seung Yeop.

"Andrew G. Malis" <[email-masked]> wrote:
Seung Yeop,

If the PW control word sequence number is used, then you have the same capabilities that are found in RFC 1990 and you can effectively have multilink PWs.  Typically that would be implemented through the use of multilink traffic tunnels, rather than any additional mechanisms in the pseudowire encapsulation or signaling.

Cheers,
Andy

-----------

At 2/15/2005 07:04 AM -0800, Seung Yeop Yang wrote:

   Hi all, 

   I have a quick question for below (from Appendix A).

   ============================================================

   RFC 1990 was designed for use in environments where packet 

       fragments may arrive out of order due to their transmission on 

       multiple parallel links, specifying that buffering be used to place 

       the fragments in correct order.  For PWE3, the ability to reorder 

       fragments prior to reassembly is OPTIONAL; receivers MAY choose to 

       drop frames when a lost fragment is detected.

   ============================================================

   It looks like that the pwe3 fragmentation I-D excluded any fragment reordering case. Does it mean that it needs another I-D for Multilink Pseudo-Wire?, or it mean that Multilink PW is not necessary in PWE3?

   Regards,

   Seung Yeop.

[email-masked] wrote: 

   A New Internet-Draft is available from the on-line Internet-Drafts directories.

   This draft is a work item of the Pseudo Wire Emulation Edge to Edge Working Group of the IETF.

   Title : PWE3 Fragmentation and Reassembly

   Author(s) : A. Malis, M. Townsley

   Filename : draft-ietf-pwe3-fragmentation-08.txt

   Pages : 14

   Date : 2005-2-11

   This document defines a generalized method of performing 

   fragmentation for use by Pseudo Wire Emulation Edge to Edge (PWE3) 

   protocols and services.

   A URL for this Internet-Draft is:

   http://www.ietf.org/internet-drafts/draft-ietf-pwe3-fragmentation-08.txt 

   To remove yourself from the I-D Announcement list, send a message to 

   [email-masked] with the word unsubscribe in the body of the message. 

   You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 

   to change your subscription settings.

   Internet-Drafts are also available by anonymous FTP. Login with the username

   "anonymous" and a password of your e-mail address. After logging in,

   type "cd internet-drafts" and then

   "get draft-ietf-pwe3-fragmentation-08.txt".

   A list of Internet-Drafts directories can be found in

   http://www.ietf.org/shadow.html 

   or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

   Internet-Drafts can also be obtained by e-mail.

   Send a message to:

   [email-masked].

   In the body type:

   "FILE /internet-drafts/draft-ietf-pwe3-fragmentation-08.txt".

   NOTE: The mail server at ietf.org can return the document in

   MIME-encoded form by using the "mpack" utility. To use this

   feature, insert the command "ENCODING mime" before the "FILE"

   command. To decode the response(s), you will need "munpack" or

   a MIME-compliant mail reader. Different MIME-compliant mail readers

   exhibit different behavior, especially when de! aling with

   "multipart" MIME messages (i.e. documents which have been split

   up into multiple messages), so check your local documentation on

   how to manipulate these messages.

   Below is the data which will enable a MIME compliant mail reader

   implementation to automatically retrieve the ASCII version of the

   Internet-Draft.

   _______________________________________________

   pwe3 mailing list

   [email-masked]

   https://www1.ietf.org/mailman/listinfo/pwe3

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3
__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3