Subject: RE: [PWE3] VCCV on disabled PW

From: Sasha Vainshtein <[email-masked]>
Date: Sat, 18 Mar 2006 22:56:26 +0200

Tom, Ron and all,
IMHO administrative disabling of a signaled PW
should result in withdrawal of the labels.

The control protocol draft does not mention that
probably because it does not consider PWs as interfaces
having administrative state.

My 2 c.

Regards,
               Sasha

-----Original Message-----
From: Thomas D. Nadeau
To: Ron Cohen
Cc: Zohar Peleg; pwe3
Sent: 3/18/2006 12:58 AM
Subject: Re: [PWE3] VCCV on disabled PW

On Mar 17, 2006, at 3:24 AM, Ron Cohen wrote:

> Hi,
>
> I appreciate a clarification on the following issue that relates to  
> inband VCCV.
>
> Should a PE process a incoming VCCV message which arrives with a vc- 
> label of a pw which is administratively disabled? Can it safely  
> discard such messages?

	I believe you *should* discard the messages, but
there might not be any harm in continuing to send them,
especially for the cases where you want to make sure that
the LSP for the PW is working. You might want to back off on the
frequency, but still send them periodically. The draft however,
does not discuss this corner case explicitly.

> Same question relates to inband VCCV arriving with a vc-label for  
> which no pw is configured.

	Yes. In fact, the draft explicitly states that
PEs MUST NOT send VCCV messages on PWs that have not a) been
signaled, and b) had that capability advertised for.

	--Tom

>
> Thanks
> Ron
>
> Ron Cohen
> CTO
> Resolute Networks
> Redux and Lycium Unite
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Ron Cohen" <[email-masked]>
Date: Sun, 19 Mar 2006 09:01:29 +0200

Sasha, Tom,

Thanks for the answers.

Best,
Ron

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Saturday, March 18, 2006 10:56 PM
To: 'Thomas D. Nadeau '; Ron Cohen
Cc: Zohar Peleg; 'pwe3 '
Subject: RE: [PWE3] VCCV on disabled PW

Tom, Ron and all,
IMHO administrative disabling of a signaled PW should result in withdrawal of the labels.

The control protocol draft does not mention that probably because it does not consider PWs as interfaces having administrative state.

My 2 c.

Regards,
               Sasha

-----Original Message-----
From: Thomas D. Nadeau
To: Ron Cohen
Cc: Zohar Peleg; pwe3
Sent: 3/18/2006 12:58 AM
Subject: Re: [PWE3] VCCV on disabled PW

> label of a pw which is administratively disabled? Can it safely 

	I believe you *should* discard the messages, but there might not be any harm in continuing to send them, especially for the cases where you want to make sure that the LSP for the PW is working. You might want to back off on the frequency, but still send them periodically. The draft however, does not discuss this corner case explicitly.

> which no pw is configured.

	Yes. In fact, the draft explicitly states that PEs MUST NOT send VCCV messages on PWs that have not a) been signaled, and b) had that capability advertised for.

	--Tom

--
This message has been scanned for viruses and dangerous content by OpenProtect(http://www.openprotect.com), and is believed to be clean.