Subject: [PWE3] VCCV on disabled PW

From: "Ron Cohen" <[email-masked]>
Date: Fri, 17 Mar 2006 11:24:47 +0200

Hi,

I appreciate a clarification on the following issue that relates to inband VCCV.

Should a PE process a incoming VCCV message which arrives with a vc-label of a pw which is administratively disabled? Can it safely discard such messages? 

Same question relates to inband VCCV arriving with a vc-label for which no pw is configured.

Thanks
Ron

Ron Cohen
CTO
Resolute Networks
Redux and Lycium Unite 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 17 Mar 2006 16:58:27 -0600

On Mar 17, 2006, at 3:24 AM, Ron Cohen wrote:

> Should a PE process a incoming VCCV message which arrives with a vc- 
> label of a pw which is administratively disabled? Can it safely  
> discard such messages?

	I believe you *should* discard the messages, but
there might not be any harm in continuing to send them,
especially for the cases where you want to make sure that
the LSP for the PW is working. You might want to back off on the
frequency, but still send them periodically. The draft however,
does not discuss this corner case explicitly.

> which no pw is configured.

	Yes. In fact, the draft explicitly states that
PEs MUST NOT send VCCV messages on PWs that have not a) been
signaled, and b) had that capability advertised for.

	--Tom