Subject: [PWE3] Question on PW MIB

From: "Bala S. Venkata" <[email-masked]>
Date: Wed, 15 Mar 2006 02:35:57 -0800

David/Tom-

I was going thru the PW MIB (draft-ietf-pwe3-pw-mib-07.txt). Can you 
tell me the reason to have "pwPeerMappingTable" ? Shouldn't the info in 
pwTable be enough to query for all existing PWs ? (what is the 'order' 
used by the pwPeerMappingTable" when I query for all PWs ?)

Btw, I saw references to a "pwVcTable" which seem to be for "pwTable". 
Both the PW-STD-MIB and  PW-MPLS-STD-MIB IDs contain this incorrect 
reference.

Thanks !

/bala

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 15 Mar 2006 11:21:32 -0500

> David/Tom-
>
> I was going thru the PW MIB (draft-ietf-pwe3-pw-mib-07.txt). Can  
> you tell me the reason to have "pwPeerMappingTable" ? Shouldn't the  
> info in pwTable be enough to query for all existing PWs ? (what is  
> the 'order' used by the pwPeerMappingTable" when I query for all  
> PWs ?)

	The reason is simple. We created a simple, single index
for the main table which allows for quick access to entries once
they are provisioned. It also allows us to simplify the notifications.
The mapping tables were added to allow access to the same
entries using the long-hand form (using the signaled values), as
well as to allow for SNMP-based provisioning, which at least 2
vendors I know of are using.

> Btw, I saw references to a "pwVcTable" which seem to be for  
> "pwTable". Both the PW-STD-MIB and  PW-MPLS-STD-MIB IDs contain  
> this incorrect reference.

	Yep. That will be fixed in the next version.

	--Tom