Subject: [PWE3] Question on draft-ietf-pwe3-enet-mib-07.txt

From: "Zheng Wang" <[email-masked]>
Date: Fri, 24 Mar 2006 12:26:33 -0800

I have a question for the following counter.  
 
pwEnetStatsIllegalVlan  OBJECT-TYPE  
      SYNTAX     ZeroBasedCounter32  
      MAX-ACCESS  read-only  
      STATUS     current  
      DESCRIPTION   
          "The number of packets received (from the PSN) on this PW   
           with an illegal VLAN field, missing VLAN field that was   
           expected, or A VLAN field when it was not expected. This   
           counter may not be applicable in some case,  and MUST  
           return the value of zero in this case."  
      ::= { pwEnetStatsEntry 1 }

1) Are you talking about the VLAN in the customer Ethernet (payload of
PW)? Assuming this is the case, when an Ethernet PW packet is received
from PSN, how do you determine whether a VLAN is illegal?  

2) Do you need a counter on the customer facing side (CE-PE) to counter
the illegal VLAN (e.g., service-delimiting tag in a raw mode)
 
Cheers
Zheng

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "David Zelig" <[email-masked]>
Date: Sun, 26 Mar 2006 08:54:21 +0200

Zheng,

See inline.

>  -----Original Message-----
>  From: Zheng Wang [mailto:[email-masked]] 
>  Sent: Friday, March 24, 2006 10:27 PM
>  To: David Zelig; Thomas D. Nadeau
>  Cc: pwe3
>  Subject: Question on draft-ietf-pwe3-enet-mib-07.txt
>  
>  
>  1) Are you talking about the VLAN in the customer Ethernet 
>  (payload of PW)? Assuming this is the case, when an Ethernet 
>  PW packet is received from PSN, how do you determine whether 
>  a VLAN is illegal?  

Yes, This counter applies only for PWs that are known to carry VLAN
field (for example EthernetTagged mode) and when the PE knows in advance
the expected value.

>  2) Do you need a counter on the customer facing side (CE-PE) 
>  to counter the illegal VLAN (e.g., service-delimiting tag in 
>  a raw mode)
>   
Errors on the CE-PE side regarding a VLAN cannot be handled in this
table because they cannot be associated to a specific PW.

David