Subject: [PWE3] [Fwd: I-D ACTION:draft-muley-pwe3-redundancy-00.txt]

From: Stewart Bryant <[email-masked]>
Date: Wed, 27 Sep 2006 14:57:57 +0100

-------- Original Message --------
Subject: 	I-D ACTION:draft-muley-pwe3-redundancy-00.txt
Date: 	Tue, 26 Sep 2006 10:50:01 -0400
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title		: Pseudowire (PW) Redundancy 
	Author(s)	: P. Muley, et al.
	Filename	: draft-muley-pwe3-redundancy-00.txt
	Pages		: 11
	Date		: 2006-9-26
	
This document describes a few scenarios where PW redundancy is   
needed. A set of redundant PWs is configured between PE nodes in SS-   
PW applications, or between T-PE nodes in MS-PW applications. In   
order for the PE/T-PE nodes to indicate the preferred PW path to   
forward to one another, a new status bit is needed to indicate the  
preferential forwarding status of active or standby for each PW in   
the redundancy set. This draft specifies a new PW status bit for this 
purpose.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-muley-pwe3-redundancy-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-muley-pwe3-redundancy-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-muley-pwe3-redundancy-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Danny McPherson <[email-masked]>
Date: Wed, 27 Sep 2006 14:47:48 -0600

Folks,
We'd like to considering moving this document towards
WG adoption and progression towards the chartered
PW redundancy work.

Comments to chairs/list within next two weeks (by
10/13/2006).

Thanks!

-danny

On Sep 27, 2006, at 7:57 AM, Stewart Bryant wrote:

> 	Title		: Pseudowire (PW) Redundancy 	Author(s)	: P. Muley, et al.
> needed. A set of redundant PWs is configured between PE nodes in  
> SS-   PW applications, or between T-PE nodes in MS-PW applications.  
> In   order for the PE/T-PE nodes to indicate the preferred PW path  
> to   forward to one another, a new status bit is needed to indicate  
> the  preferential forwarding status of active or standby for each  
> PW in   the redundancy set. This draft specifies a new PW status  
> bit for this purpose.
>
> To remove yourself from the I-D Announcement list, send a message  
> to [email-masked] with the word unsubscribe in the  
> body of the message. You can also visit https://www1.ietf.org/ 
> mailman/listinfo/I-D-announce to change your subscription settings.
>
> logging in, type "cd internet-drafts" and then "get draft-muley- 
> pwe3-redundancy-00.txt".
>
> http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow- 
> sites.txt
>
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
>

---

From: <[email-masked]>
Date: Thu, 28 Sep 2006 12:54:21 +0100

Colleagues,

Some comments/questions on draft-muley-pwe3-redundancy.

How is the PW Preferential Forwarding Status Code communicated (via
T-LDP?)?

What error messages and consequent actions are performed if one end of a
PW signals "standby" and the other end signals "active"?

How is the priority mentioned in section 4.2 communicated?  Is it
configured or signalled?

The text describing how to decide which PW to use based on operational
status and standby/active status is OK but 'heavy' to read.  Maybe worth
including a few simple tables that clearly show what is expected based
on the states of the PWs in the examples.

Ben

-- 
Ben Niven-Jenkins
Network Architect, BT Exact
  
E-mail: [email-masked] 
Office: +44 (0)1473 648225
Mobile: +44 (0)7918 077205
   Fax: +44 (0)1332 578827

---

From: Lucy Yong <[email-masked]>
Date: Thu, 28 Sep 2006 09:32:28 -0500

Hello Muley,

The draft proposes some redundancy configurations for PW. Here are some
questions about applications for these configurations.
1) The first scenario in figure 1 shows an asymmetrical protection. The
protection is done at CE on one side and at PE at another side.  The
redundancy is achieved at duel PEs on one side. What application needs this
kind of asymmetrical protection?
In most of cases, PW protection can be configured from either CE or PE
symmetrically. Dual homing can be achieved by 1+1 or 1:1 protection at CE
directly.
2) The second scenario in figure 2 shows double protection at both CE and
PE. This is more expensive configuration and PW availability is close to
dual homing protection from CE directly. In addition, double protection
could raise the competition situation.
Again, what application requires this configuration?
3) The third scenario in figure 3 has the same issue as the first. 
4) The fourth scenario is valuable. PW protection needs to consider how to
do in multi-segment environment.

Best Regards,
Lucy Yong

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Wednesday, September 27, 2006 8:58 AM
To: pwe3
Subject: [PWE3] [Fwd: I-D ACTION:draft-muley-pwe3-redundancy-00.txt]

-------- Original Message --------
Subject: 	I-D ACTION:draft-muley-pwe3-redundancy-00.txt
Date: 	Tue, 26 Sep 2006 10:50:01 -0400
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

	

Send a message to:
	[email-masked].
In the body type: