Subject: RE: [PWE3] ATM encapsulation draft - Deletion of section 7.4

From: Shahram Davari <[email-masked]>
Date: Fri, 6 Oct 2006 07:30:35 -0700

Thanks Tom,

How come it is removed from PWE3 Webpage?
By the way is the intention for the ATM encap draft to
refer to this draft? or just not mention anything about defect handling? 

Thanks,
Shahram

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Friday, October 06, 2006 10:12 AM
> To: Shahram Davari
> Cc: 'Luca Martini'; PWE3 WG (E-mail)
> Subject: Re: [PWE3] ATM encapsulation draft - Deletion of section 7.4
> 
> 
> 
> http://tools.ietf.org/wg/pwe3/
> 
> 
> > Hi Luca,
> >
> > Could you please provide the link to the "OAM message mapping"?
> > Is it a WG document?
> >
> > Thanks,
> > Shahram
> >
> >> -----Original Message-----
> >> From: Luca Martini [mailto:[email-masked]]
> >> Sent: Thursday, October 05, 2006 1:33 PM
> >> To: PWE3 WG (E-mail)
> >> Subject: [PWE3] ATM encapsulation draft - Deletion of section 7.4
> >>
> >>
> >> WG,
> >>
> >> The authors of the ATM  encapsulation draft have agreed that
> >> we should
> >> delete section 7.4 "Defect Handling" to defer this topic 
> to the more
> >> extensive treatment in the oam-message-mapping draft.
> >>
> >> Please note that the ATM encapsulation draft is being edited
> >> by the rfc
> >> editor, so it will become rfc very shortly.
> >> Please let me know if there is any strong objection to
> >> proceed with the
> >> deletion of section 7.4.
> >>
> >> Thanks.
> >> Luca
> >>
> >>
> >> _______________________________________________
> >> pwe3 mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/pwe3
> >>
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 6 Oct 2006 10:34:19 -0400

> How come it is removed from PWE3 Webpage?

	It expired; we are refreshing now.

> refer to this draft?

	Yes.

	--Tom

> or just not mention anything about defect handling?
>
> Thanks,
> Shahram
>

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 06 Oct 2006 15:40:35 +0100

>How come it is removed from PWE3 Webpage?
This happens automatically when authors fail to refresh before
the draft dies of old age.

It's still a WG draft and should be refreshed in the next few days.

- Stewart

---

From: Luca Martini <[email-masked]>
Date: Fri, 06 Oct 2006 09:56:56 -0600

To answer the only question that I did not see answered on this thread :

The reason we think that it would be better to remove section 7.4 is the 
fact that this section is a sort of mini summary of the 
oam-message-mapping WG draft. We want to avoid creating any 
contradictions because of summarizations between this RFC and the 
upcoming oam-message-mapping rfc.

If we remove section 7.4 , there would NOT be a normative reference to 
the oam-message-mapping draft.

It is my opinion that this section is a remnant of the document 
organization we had about 6 years ago. Since then we have re-organized 
the text to be separate documents , and it does not make much sense to 
have this summary text here.

I'm very open to re-consider this decision, however , I really want to 
avoid any contradictions between the ATM encapsulation RFC, and the 
oam-message-mapping rfc in the future.

Thanks.
Luca

---

From: [email-masked]
Date: Fri, 6 Oct 2006 17:45:35 +0100

Luca, all,

> the oam-message-mapping draft.

If we did refer to the message mapping draft presumably this would hold up
publication of the ATM draft until the message mapping draft is an RFC.

> have this summary text here.

I agree with this. The message mapping draft has not gone through last call
yet, and if we had to make any changes to the ATM OAM text these could not
be reflected in the ATM RFC.

Is there anything that will be missing in the specification of defect
handling for ATM PWs if we remove section 7.4 and rely on the message
mapping draft?

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 6 Oct 2006 12:53:42 -0400

> publication of the ATM draft until the message mapping draft is an  

	Does the reference have to be normative? If we could
make it informative, then it would not hold things up. In
the least, you could leave the OAM stuff out as "for further
study" perhaps.

	--Tom

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 06 Oct 2006 14:02:41 -0400

Removing a lot of forwarded text:

If we remove section 7.4 , there would NOT be a normative
>>>reference to

Section 7.4 is important in implementations because it provides the 
operator with fault notifications.  If we remove it and don't have 
any references to the OAM message map draft, then important 
functionality is lost. If we replace section 7.4 with either a 
normative or informative reference to the message map draft, then the 
ATM draft is going to have to wait for the message map draft, because 
RFCs can't have any references to drafts, even if informative.  And 
IMHO, this would need to be a normative reference, since your'e 
moving necessary functionality from one document to another.  It's 
still just as necessary as before.

If we keep section 7.4 and publish the ATM encaps draft, and we later 
find during the further development of the message map draft that we 
need to change or augment the existing functionality in section 7.4, 
then  we don't need to revise the ATM encaps RFC - we note the change 
to section 7.4 in the OAM message map RFC, and note for the RFC index 
that the OAM message map RFC updates the ATM encaps RFC.  If you look 
at http://www.ietf.org/rfc/rfc-index.txt you'll see that this is a 
common practice.  Anyway, that's the path that I would prefer.

Cheers,
Andy

---

From: [email-masked]
Date: Mon, 9 Oct 2006 12:59:21 +0100

Andy,

I agree that the OAM functionality is a very important part of the
specification for ATM PWs. If it is not clear that this is described in the
OAM message mapping draft, then I am happy to keep 7.4 in the ATM draft and
note any updates n the RFC index, as you describe below.

Best regards,

Matthew