Subject: RE: [PWE3] Secure MPLS based TDM PW

From: "Gray, Eric" <[email-masked]>
Date: Mon, 2 Oct 2006 14:05:48 -0400

Stewart,

	Strictly speaking, it's more complicated than eavesdropping
and/or a compromised router.  It is sufficient for there to be a
compromise in physical access to the label switching portion of a
network, since the only thing that guarantees "labels have to be
put there by the network" is physical access.

--
Eric

--> -----Original Message-----
--> From: Stewart Bryant [mailto:[email-masked]] 
--> Sent: Monday, October 02, 2006 10:15 AM
--> To: Bapat, Swapna (Swapna)
--> Cc: [email-masked]
--> Subject: Re: [PWE3] Secure MPLS based TDM PW
--> 
--> Bapat, Swapna (Swapna) wrote:
--> 
--> >I would like to understand if there is a consensus on 
--> securing payload of MPLS based TDM PW.
--> >One could argue that the PW is emulating a point to point 
--> circuit, so why do we need encryption? but since the data 
--> traverses a packet network, some providers have expressed a 
--> need for securing the PW traffic.
--> >  
--> >
--> What do you mean by secure?
--> 
--> An MPLS network is intrinsicly more secure than an IP 
--> network, because
--> the labels have to be put there by the network rather than the user.
--> 
--> If you mean secure against evesdropping, or secure against 
--> a compromised
--> router, then we have no protection.
--> 
--> >Alternate suggestions are to use IP/UDP encapsulation so 
--> that IPSec can be used. This approach makes us lose the 
--> benefits of MPLS traffic engineering.
--> >  
--> >
--> Well no, you can encap in UDP/IP, secure, then encap in MPLS, then
--> run TE, so you don't loose the benefits of TE, but it's not 
--> very ellegant.
--> 
--> >Thoughts or suggestions?
--> >  
--> >
--> 
--> Yaakov did have some other ideas, which I am sure he will 
--> explain, and
--> yes this is an area that I think the WG needs to give 
--> greater attention to.
--> 
--> - Stewart
--> 
--> >Regards,
--> >Swapna
--> >
--> >
--> >_______________________________________________
--> >pwe3 mailing list
--> >[email-masked]
--> >https://www1.ietf.org/mailman/listinfo/pwe3
--> >
--> >  
--> >
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Gray, Eric" <[email-masked]>
Date: Wed, 4 Oct 2006 13:39:13 -0400

Yaakov,

	IMO, when you're in an environment where you might need
to "secure" an MPLS payload, you're also in an environment in
which you need to authenticate labels.  This seems to be a 
much bigger problem...

--
Eric

--> -----Original Message-----
--> From: Yaakov Stein [mailto:[email-masked]] 
--> Sent: Wednesday, October 04, 2006 4:15 AM
--> To: Bapat, Swapna (Swapna); [email-masked]
--> Subject: RE: [PWE3] Secure MPLS based TDM PW
--> 
-->  
--> 
--> I would like to understand if there is a consensus on 
--> securing payload
--> of MPLS based TDM PW.
--> One could argue that the PW is emulating a point to point 
--> circuit, so
--> why do we need encryption? but since the data traverses a packet
--> network, some providers have expressed a need for securing the PW
--> traffic.
--> 
--> Alternate suggestions are to use IP/UDP encapsulation so 
--> that IPSec can
--> be used. This approach makes us lose the benefits of MPLS traffic
--> engineering. 
--> 
--> Thoughts or suggestions?
--> 
--> 
--> [YJS] I intend presenting in San Diego an approach for accomplishing
--> this 
--> (hint: based on MACsec idea).  Also - see draft-stein-pwe3-sec-req.
--> 
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
-->