Subject: RE: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt

From: "Suberri, Moshe" <[email-masked]>
Date: Sun, 1 Apr 2007 20:38:16 -0400

If the semantic refers to an active row, the wording should be changed
from:

"1) Objects that MUST NOT be changed after row creation." 

to

"1) Objects that MUST NOT be changed after row activation."

________________________________

From: Orly Nicklass [mailto:[email-masked]] 
Sent: Saturday, March 31, 2007 5:09 AM
To: Suberri, Moshe; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

the semantic refers to active row.

________________________________

From: Suberri, Moshe [mailto:[email-masked]] 
Sent: Friday, March 30, 2007 23:53
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

"The read-create objects in this tables are divided into

           three categories:

           1) Objects that MUST NOT be changed after row creation.

           These are objects that define basic properties of the

           PW (for example type, destination, etc.)."

Why "basic properties" (with exception to pwIndex) may not be changed if
the object is in Not-Ready state? 

After all the Not-Ready state supposes to provide a scratch pad
configuration which is incomplete. 

[SNMP-v2-TC]   "- `notReady', which indicates that the conceptual row

                 exists in the agent, but is missing information

                 necessary in order to be available for use by the

                 managed device (i.e., one or more required columns in

                 the conceptual row have not been instanciated); "   

Regards

Moshe

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 07, 2007 3:50 PM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

A New Internet-Draft is available from the on-line Internet-Drafts 

directories.

This draft is a work item of the Pseudowire Emulation Edge to Edge
Working Group of the IETF.

      Title       : Pseudo Wire (PW) Management Information Base

      Author(s)   : D. Zelig, et al.

      Filename    : draft-ietf-pwe3-pw-mib-10.txt

      Pages       : 63

      Date        : 2007-2-7

This memo defines an experimental portion of the Management

   Information Base for use with network management protocols in the

   Internet community.  In particular, it describes managed objects for

   modeling of Pseudo Wire Edge-to-Edge services carried over a general

   Packet Switched Network.

A URL for this Internet-Draft is:

http://www.ietf.org/internet-drafts/draft-ietf-pwe3-pw-mib-10.txt

To remove yourself from the I-D Announcement list, send a message to 

[email-masked] with the word unsubscribe in the body of 

the message. 

You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 

to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 

username "anonymous" and a password of your e-mail address. After 

logging in, type "cd internet-drafts" and then 

"get draft-ietf-pwe3-pw-mib-10.txt".

A list of Internet-Drafts directories can be found in

http://www.ietf.org/shadow.html 

or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:

      [email-masked].

In the body type:

      "FILE /internet-drafts/draft-ietf-pwe3-pw-mib-10.txt".

NOTE: The mail server at ietf.org can return the document in

      MIME-encoded form by using the "mpack" utility.  To use this

      feature, insert the command "ENCODING mime" before the "FILE"

      command.  To decode the response(s), you will need "munpack" or

      a MIME-compliant mail reader.  Different MIME-compliant mail
readers

      exhibit different behavior, especially when dealing with

      "multipart" MIME messages (i.e. documents which have been split

      up into multiple messages), so check your local documentation on

      how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader

implementation to automatically retrieve the ASCII version of the

Internet-Draft.

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Orly Nicklass" <[email-masked]>
Date: Mon, 2 Apr 2007 13:07:48 +0300

will do.

From: Suberri, Moshe [mailto:[email-masked]]
Sent: Mon 4/2/2007 03:38
To: Orly Nicklass; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

If the semantic refers to an active row, the wording should be changed from:

to

 

           three categories:

 

Why "basic properties" (with exception to pwIndex) may not be changed if the object is in Not-Ready state? 

After all the Not-Ready state supposes to provide a scratch pad configuration which is incomplete. 

Regards

Moshe

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 07, 2007 3:50 PM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

directories.

This draft is a work item of the Pseudowire Emulation Edge to Edge Working Group of the IETF.

      Pages       : 63

      Date        : 2007-2-7

   Packet Switched Network.

the message. 

Send a message to:

      [email-masked].

In the body type:

      a MIME-compliant mail reader.  Different MIME-compliant mail readers

Internet-Draft.

---

From: "Suberri, Moshe" <[email-masked]>
Date: Mon, 9 Apr 2007 13:27:03 -0400

"

7.  Relations to Other PWE3 MIB Modules

.

.

.

-  Unless all the necessary entries in the applicable tables have been

   created and all the parameters have been consistently configured in

   those tables, signaling cannot be performed from the local node, and

   the pwVcOperStatus should report 'notPresent'."

"

If you want to expand the definition of the Operational Status to
include configuration anomalies, it could be operationally helpful to
uniquely qualify this class of errors. For example, adding a value of
'inconsistentConfiguration' or 'configurationError' will unambiguously
identify the problem to the operator. 

Regards

Moshe   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 07, 2007 3:50 PM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

directories.

      Pages       : 63

      Date        : 2007-2-7

   Packet Switched Network.

the message. 

Send a message to:

      [email-masked].

In the body type:

Internet-Draft.

---

From: "David Zelig" <[email-masked]>
Date: Thu, 12 Apr 2007 19:07:26 +0300

Moshe,
The definition of the operstatus states are de-facto standard, therefore
I believe that adding a new state is not feasible. The 'notPresent'
state is rarely used otherwise so it is a good hint to look for
configuration inconsistency.
Note also that most of configuration inconsistencies/errors are already
covered extensively in the service specific MIBs with detailed error
coding.
 
Thanks
David

From: Suberri, Moshe [mailto:[email-masked]] 
Sent: Monday, April 09, 2007 8:27 PM
To: David Zelig; [email-masked]
Cc: [email-masked]
Subject: RE: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

"

.

.

.

"

 

Regards

Moshe   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 07, 2007 3:50 PM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

directories.

      Pages       : 63

      Date        : 2007-2-7

   Packet Switched Network.

the message. 

Send a message to:

      [email-masked].

In the body type:

Internet-Draft.

---

From: "Suberri, Moshe" <[email-masked]>
Date: Thu, 12 Apr 2007 13:49:01 -0400

David,

It is my understanding that the "Textual Conventions and for Managing
Pseudo-Wires" is still a draft document. 

To be more specific, my concern is with the PW "payload size" and the
"TDM rate". Since the "TDM Rate" is in one table and the "Payload size"
is in another table, the proposed way to expose an inconsistency between
the two objects is through the operational status.

If the operational status is cast in stone, the above inconsistency can
be exposed with a new bit (payloadSizeInconsistent) in the
pwTDMConfigError object

Moshe   

From: David Zelig [mailto:[email-masked]] 
Sent: Thursday, April 12, 2007 12:07 PM
To: Suberri, Moshe
Cc: [email-masked]; [email-masked]
Subject: RE: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

Moshe,

Thanks

David

"

.

.

.

"

 

Regards

Moshe   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 07, 2007 3:50 PM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

directories.

      Pages       : 63

      Date        : 2007-2-7

   Packet Switched Network.

the message. 

Send a message to:

      [email-masked].

In the body type:

Internet-Draft.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 12 Apr 2007 14:13:54 -0400

> David,
>
>
>
> It is my understanding that the “Textual Conventions and for  
> Managing Pseudo-Wires” is still a draft document.

	Yes, but there are a number of implementations of this draft, so we  
need to be careful about
how we alter it. With that said, if something is totally broken we  
need to fix it, but in this case,
but I do not think that is the case here.
> To be more specific, my concern is with the PW “payload size” and  
> the “TDM rate”. Since the “TDM Rate” is in one table and the  
> “Payload size” is in another table, the proposed way to expose an  
> inconsistency between the two objects is through the operational  
> status.
>
>
>
> If the operational status is cast in stone, the above inconsistency  
> can be exposed with a new bit (payloadSizeInconsistent) in the  
> pwTDMConfigError object
	What it sounds like to me is that you are trying to uncover a  
provisioning inconsistency.
In this case, the agent can refuse to create the entry based on the  
state of the other table.

	--Tom

> The definition of the operstatus states are de-facto standard,  
> therefore I believe that adding a new state is not feasible. The  
> 'notPresent' state is rarely used otherwise so it is a good hint to  
> look for configuration inconsistency.
>
> Note also that most of configuration inconsistencies/errors are  
> already covered extensively in the service specific MIBs with  
> detailed error coding.
>
>
>
> Thanks
>
> David
>
>
>
> “
>    the pwVcOperStatus should report 'notPresent'.”
>
> “
>
>
>
> include configuration anomalies, it could be operationally helpful  
> to uniquely qualify this class of errors. For example, adding a  
> value of ‘inconsistentConfiguration’ or ‘configurationError’ will  
> unambiguously identify the problem to the operator.
>
>
>
>
>
> Regards
>
> Moshe
>
>
>
>
>
>
>

---

From: "Orly Nicklass" <[email-masked]>
Date: Fri, 13 Apr 2007 08:25:30 +0300

The inconsistency can be a result of single set operation where the
agent has the complete set of values to verify integrity among them. As
such, the set operation should fail with an error of
'inconsistentValue'.

From: Thomas D. Nadeau [mailto:[email-masked]] 
Sent: Thursday, April 12, 2007 21:14
To: Suberri, Moshe
Cc: [email-masked]; David Zelig
Subject: Re: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

	David,

	It is my understanding that the "Textual Conventions and for
Managing Pseudo-Wires" is still a draft document.

Yes, but there are a number of implementations of this draft, so we need
to be careful about
how we alter it. With that said, if something is totally broken we need
to fix it, but in this case,
but I do not think that is the case here.

	To be more specific, my concern is with the PW "payload size"
and the "TDM rate". Since the "TDM Rate" is in one table and the
"Payload size" is in another table, the proposed way to expose an
inconsistency between the two objects is through the operational status.

	If the operational status is cast in stone, the above
inconsistency can be exposed with a new bit (payloadSizeInconsistent) in
the pwTDMConfigError object

--Tom

	Moshe  

	Moshe,

	The definition of the operstatus states are de-facto standard,
therefore I believe that adding a new state is not feasible. The
'notPresent' state is rarely used otherwise so it is a good hint to look
for configuration inconsistency.

	Note also that most of configuration inconsistencies/errors are
already covered extensively in the service specific MIBs with detailed
error coding.

	Thanks

	David

	"

	.

	.

	.

	-  Unless all the necessary entries in the applicable tables
have been

	   created and all the parameters have been consistently
configured in

	   those tables, signaling cannot be performed from the local
node, and

	"

	If you want to expand the definition of the Operational Status
to include configuration anomalies, it could be operationally helpful to
uniquely qualify this class of errors. For example, adding a value of
'inconsistentConfiguration' or 'configurationError' will unambiguously
identify the problem to the operator.

	Regards

	Moshe   

	-----Original Message-----

	A New Internet-Draft is available from the on-line
Internet-Drafts

	directories.

	This draft is a work item of the Pseudowire Emulation Edge to
Edge Working Group of the IETF.

	      Pages       : 63

	      Date        : 2007-2-7

	   Information Base for use with network management protocols in
the

	   Internet community.  In particular, it describes managed
objects for

	   modeling of Pseudo Wire Edge-to-Edge services carried over a
general

	   Packet Switched Network.

	To remove yourself from the I-D Announcement list, send a
message to

	[email-masked] with the word unsubscribe in the
body of

	the message.

	You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce

	Internet-Drafts are also available by anonymous FTP. Login with
the

	username "anonymous" and a password of your e-mail address.
After

	Send a message to:

	      [email-masked].

	In the body type:

	      MIME-encoded form by using the "mpack" utility.  To use
this

	      feature, insert the command "ENCODING mime" before the
"FILE"

	      command.  To decode the response(s), you will need
"munpack" or

	      a MIME-compliant mail reader.  Different MIME-compliant
mail readers

	      "multipart" MIME messages (i.e. documents which have been
split

	      up into multiple messages), so check your local
documentation on

	implementation to automatically retrieve the ASCII version of
the

	Internet-Draft.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 13 Apr 2007 10:48:29 -0400

Precisely my point.

	--Tom

> agent has the complete set of values to verify integrity among  
> them. As such, the set operation should fail with an error of  
> 'inconsistentValue'.
>
>> inconsistency can be exposed with a new bit  
>> (payloadSizeInconsistent) in the pwTDMConfigError object
>> 'notPresent' state is rarely used otherwise so it is a good hint  
>> to look for configuration inconsistency.
>>

---

From: "Suberri, Moshe" <[email-masked]>
Date: Mon, 16 Apr 2007 11:53:57 -0400

I still feel that the reporting of 'inconsistent configuration' through
'notPresent' in the pwVcOperStatus, is not at all intuitive. 

A bit in the pwTDMConfigError will do the same job and will be much more
self explanatory and intuitive. After all, the pwTDMConfigError object
supposes to report configuration related errors and the 'inconsistent
configuration' is such an issue. 

Moshe

. .  

From: Orly Nicklass [mailto:[email-masked]] 
Sent: Friday, April 13, 2007 1:26 AM
To: Thomas D. Nadeau; Suberri, Moshe
Cc: [email-masked]; David Zelig
Subject: RE: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt 

	David,

--Tom

Moshe  

size=2 width="100%" align=center tabIndex=-1> 

Moshe,

Thanks

David

"

.

.

.

"

Regards

Moshe   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, February 07, 2007 3:50 PM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] I-D ACTION:draft-ietf-pwe3-pw-mib-10.txt

directories.

      Pages       : 63

      Date        : 2007-2-7

   Packet Switched Network.

the message.

Send a message to:

      [email-masked].

In the body type:

Internet-Draft.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 16 Apr 2007 13:17:07 -0400

If you think if the operStatus is insufficient, that you should take  
that up with the
WGs that are working on SNMP so that it can be addressed in a common  
place.
Hacking up all of the PWE3 MIBs (and then who knows how many others) to
be more explicit about configuration errors seems to be going in the  
wrong
direction IMHO.

	--Tom

> I still feel that the reporting of ‘inconsistent configuration’  
> through ‘notPresent' in the pwVcOperStatus, is not at all intuitive.
>
> A bit in the pwTDMConfigError will do the same job and will be much  
> more self explanatory and intuitive. After all, the  
> pwTDMConfigError object supposes to report configuration related  
> errors and the ‘inconsistent configuration’ is such an issue.
>
>
>
>
>
> Moshe
>
> . .
>
>
>