Subject: RE: [PWE3] WG LC: I-D ACTION:draft-ietf-pwe3-tdm-mib-07.txt

From: "Suberri, Moshe" <[email-masked]>
Date: Sun, 1 Apr 2007 20:23:49 -0400

In the current data model the validation of the payload size is
one-to-many (assuming multiple TDM circuits are using the TDMCfg row).
None of the other objects need any validation with respect to the TDM`
circuit. 

When you move the payload size to the pwTDMTable the validation is one
to one. That is, payload size to TDM rate.
 
Pesach Samech!

-----Original Message-----
From: Orly Nicklass [mailto:[email-masked]] 
Sent: Saturday, March 31, 2007 5:15 AM
To: Suberri, Moshe
Cc: pwe3 ((((((((E-mail)))))))) WG
Subject: RE: [PWE3] WG LC: I-D ACTION:draft-ietf-pwe3-tdm-mib-07.txt 

 pwTDMCfgTable is for all configurable objects while pwTDMTable is for
the framework. pwTDMTable holds the rate to distinguish among the
various TDM types in a smaller resolution than the one  exist in the
generic PW table. The validation is needed regardless of the object's
position and feasible in both cases.

-----Original Message-----
From: Suberri, Moshe [mailto:[email-masked]] 
Sent: Friday, March 30, 2007 21:47
To: Orly Nicklass
Cc: pwe3 ((((((((E-mail)))))))) WG
Subject: RE: [PWE3] WG LC: I-D ACTION:draft-ietf-pwe3-tdm-mib-07.txt 

Dear Orly,

Regarding "pwTDMCfgPayloadSize" in the "pwTDMCfgTable" table 

With exception to the payload size all the objects that in the
"pwTDMCfgTable" are generic in nature and do not need to be crossed
checked with any other tables or objects.

The payload size is rather more complex object. In the case of
Structure-Aware PW or T1 Structure-Agnostic octet aligned PW, the
payload size is closely related to the TDM Rate. That is the payload
size must be an integer multiplication of the TDM rate. 

Having the payload size in the pwTDMCfgTable forces the NMS (or SNMP
agent) to validate that the payload size is correct with respect to all
the Structure-Aware circuits that are using this payload size.   

Therefore, I would like you to consider moving the "pwTDMCfgPayloadSize"
from the "pwTDMCfgTable" to the "pwTDMTable".

Best Regards
Moshe

 _______________________________________________
 I-D-Announce mailing list
 [email-masked]
 https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Orly Nicklass" <[email-masked]>
Date: Mon, 2 Apr 2007 13:09:07 +0300

Validation is done at assignment time, which is one time, regardless of where we place the object.

________________________________

Sent: Mon 4/2/2007 03:23

Pesach Samech!

-----Original Message-----
From: Suberri, Moshe [mailto:[email-masked]]
Sent: Friday, March 30, 2007 21:47
To: Orly Nicklass
Cc: pwe3 ((((((((E-mail)))))))) WG
Subject: RE: [PWE3] WG LC: I-D ACTION:draft-ietf-pwe3-tdm-mib-07.txt

Dear Orly,

Best Regards
Moshe