Subject: [PWE3] PW Redundancy to WG drafts?

From: "BOCCI Matthew" <[email-masked]>
Date: Fri, 7 Dec 2007 00:07:13 +0100

In the PWE3 meeting in Vancouver, I asked if we could progress the
following drafts to WG Status:

- draft-muley-pwe3-redundancy-02.txt : This contains the PW redundancy
scenarios
- draft-muley-dutta-pwe3-redundancy-bit-02.txt : Definition of the PW
status bits  to support these PW redundancy scenarios.

We received a couple of comments in the meeting, but I would also
appreciate some feedback on the list.

Best regards,

Matthew
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Danny McPherson <[email-masked]>
Date: Fri, 7 Dec 2007 09:07:50 -0700

On Dec 6, 2007, at 4:07 PM, BOCCI Matthew wrote:

> - draft-muley-pwe3-redundancy-02.txt : This contains the PW  
> redundancy scenarios
> - draft-muley-dutta-pwe3-redundancy-bit-02.txt : Definition of the  
> PW status bits  to support these PW redundancy scenarios.
>

Yes, I was planning to send an email on this.  Folks, we
either need to move forward with these documents (or
competing ones) or remove these related items from the
WG Goals & Milestones.

I.e., Now is the time to comment or contribute if you're
interested with this work.

-danny

---

From: "HENDERICKX Wim" <[email-masked]>
Date: Fri, 7 Dec 2007 18:33:28 +0100

I support these drafts to move to working group draft status

________________________________

From: BOCCI Matthew 
Sent: vrijdag 7 december 2007 0:07
To: [email-masked]
Subject: [PWE3] PW Redundancy to WG drafts?

Best regards, 

Matthew

---

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Fri, 7 Dec 2007 11:47:55 -0600

Yes to both of them.
 
Mustapha.

	From: BOCCI Matthew [mailto:[email-masked]] 
	Sent: Thursday, December 06, 2007 6:07 PM
	To: [email-masked]
	Subject: [PWE3] PW Redundancy to WG drafts?

	In the PWE3 meeting in Vancouver, I asked if we could progress
the following drafts to WG Status: 

	- draft-muley-pwe3-redundancy-02.txt : This contains the PW
redundancy scenarios 
	- draft-muley-dutta-pwe3-redundancy-bit-02.txt : Definition of
the PW status bits  to support these PW redundancy scenarios.

	We received a couple of comments in the meeting, but I would
also appreciate some feedback on the list. 

	Best regards, 

	Matthew

---

From: "Dutta, Pranjal Kumar \(Pranjal\)" <[email-masked]>
Date: Fri, 7 Dec 2007 23:26:29 +0530

Support for both the drafts.
 
Thanks,
Pranjal

From: BOCCI Matthew [mailto:[email-masked]]
Sent: Fri 12/7/2007 4:37 AM
To: [email-masked]
Subject: [PWE3] PW Redundancy to WG drafts?

In the PWE3 meeting in Vancouver, I asked if we could progress the following drafts to WG Status: 

- draft-muley-pwe3-redundancy-02.txt : This contains the PW redundancy scenarios 
- draft-muley-dutta-pwe3-redundancy-bit-02.txt : Definition of the PW status bits  to support these PW redundancy scenarios.

We received a couple of comments in the meeting, but I would also appreciate some feedback on the list. 

Best regards, 

Matthew

---

From: "KOMPELLA Vach" <[email-masked]>
Date: Fri, 7 Dec 2007 12:56:08 -0600

Yes to both.

-Vach  

> -----Original Message-----
> From: Danny McPherson [mailto:[email-masked]] 
> Sent: Friday, December 07, 2007 8:08 AM
> To: pwe3; BOCCI Matthew
> Subject: Re: [PWE3] PW Redundancy to WG drafts?
> 
> 
> redundancy

---

From: Thomas Nadeau <[email-masked]>
Date: Fri, 7 Dec 2007 15:09:38 -0500

Yes to both from my end.

	--Tom

---

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 07 Dec 2007 22:41:10 +0100

yes to both.

-d.

BOCCI Matthew wrote:
> ------------------------------------------------------------------------
>

---

From: "JOUNAY Frederic RD-RESA-LAN" <[email-masked]>
Date: Sat, 8 Dec 2007 18:38:26 +0100

support for both drafts
 
Fred

From: BOCCI Matthew 

Best regards, 

Matthew

---

From: "NIGER Philippe RD-RESA-LAN" <[email-masked]>
Date: Mon, 10 Dec 2007 11:42:45 +0100

Yes for both drafts.

Philippe. 

-----Message d'origine-----
De : Danny McPherson [mailto:[email-masked]] 
Envoyé : vendredi 7 décembre 2007 17:08
À : pwe3; BOCCI Matthew
Objet : Re: [PWE3] PW Redundancy to WG drafts?

-danny

---

From: "Newton, Jonathan" <[email-masked]>
Date: Tue, 11 Dec 2007 11:45:49 -0000

Support for both drafts here.
Cheers,
~Jon.

	From: BOCCI Matthew [mailto:[email-masked]] 
	Sent: 06 December 2007 23:07
	To: [email-masked]
	Subject: [PWE3] PW Redundancy to WG drafts?

	Best regards, 

	Matthew 

This e-mail has been scanned for viruses by the Cable & Wireless e-mail security system - powered by MessageLabs. For more information on a proactive managed e-mail security service, visit http://www.cw.com/uk/emailprotection/ 

The information contained in this e-mail is confidential and may also be subject to legal privilege. It is intended only for the recipient(s) named above. If you are not named above as a recipient, you must not read, copy, disclose, forward or otherwise use the information contained in this email. If you have received this e-mail in error, please notify the sender (whose contact details are above) immediately by reply e-mail and delete the message and any attachments without retaining any copies.
 
Cable and Wireless plc 
Registered in England and Wales.Company Number 238525 
Registered office: 7th Floor, The Point, 37 North Wharf Road, London W2 1LA

---

From: "Kulmala, Marko" <[email-masked]>
Date: Tue, 11 Dec 2007 14:01:30 +0200

Support for both drafts.

Regards,

Marko Kulmala

From: BOCCI Matthew [mailto:[email-masked]] 
Sent: 7. joulukuuta 2007 1:07
To: [email-masked]
Subject: [PWE3] PW Redundancy to WG drafts?

Best regards, 

Matthew 

============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "LASSERRE, Marc \(Marc\)" <[email-masked]>
Date: Tue, 11 Dec 2007 13:35:29 +0100

Support for both drafts.

Cheers,

Marc

.

	Best regards, 

	Matthew

---

From: Ville Hallivuori <[email-masked]>
Date: Tue, 11 Dec 2007 20:56:53 +0200

Support for both drafts.

However I have some reservations concerning reliance to proprietary
(and Ethernet specific?) MC-LAG in draft-muley-pwe3-redundancy-02.txt --
perhaps some of the scenarios could be accomplished without it
(e.g. in figure 1 make PE2 master (PE1/PE3 slave) and let PE1/PE3 signal AC
status toward CE1 using native OAM (ATM AIS, TDM AIS, etc). Obviously
in some cases MC-LAG or equivalent might be needed, but I would like to
see cases where it is not needed presented as well (especially, as
defining these cases allows interoperability).

-- 
[Ville Hallivuori][[email-masked]][http://www.iki.fi/vph/]
[ID 8E1AD461][FP16=C9 50 E2 DF 48 F6 33 62  5D 87 47 9D 3F 2B 07 5D]
[ID 58543419][FP20=8731 941D 15AB D4A0 88A0  FC8F B55C F4C4 5854 3419]
[ID 8061C24E][FP20=C722 12DA 841E D811 DBFE  2FB3 174C E291 8061 C24E]

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Tue, 11 Dec 2007 14:33:04 -0500

Yes to both.
 
Hamid.

	Best regards, 

	Matthew

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 12 Dec 2007 20:14:07 +0200

I support both drafts becoming WG drafts.

I also suggest coordination of efforts on redundancy and load balancing
architecture
(as promised, I will write a draft ASAP).

Y(J)S

-----Original Message-----
From: Danny McPherson [mailto:[email-masked]] 
Sent: Friday, December 07, 2007 6:08 PM
To: pwe3; BOCCI Matthew
Subject: Re: [PWE3] PW Redundancy to WG drafts?

-danny

---

From: "MULEY Praveen" <[email-masked]>
Date: Wed, 12 Dec 2007 12:27:21 -0600

Yes to both.
 
 -Praveen .

	Best regards, 

	Matthew

---

From: "Yuji KAMITE" <[email-masked]>
Date: Thu, 13 Dec 2007 11:05:58 +0900

I support both being adopted.

-Yuji

	From: BOCCI Matthew [mailto:[email-masked]] 
	Sent: Friday, December 07, 2007 8:07 AM
	To: [email-masked]
	Subject: [PWE3] PW Redundancy to WG drafts?

	Best regards, 

	Matthew

---

From: "MULEY Praveen" <[email-masked]>
Date: Sun, 9 Dec 2007 19:01:08 -0600

Yes to both of them.
 
 -Praveen 

	Best regards, 

	Matthew 

Yes to both of them.
 
 -Praveen 

	Best regards, 

	Matthew

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 17 Dec 2007 11:59:48 +0000

A considerable number of people have said that they support adoption of 
these
drafts, but the minutes of the PWE3 meetings say:

 >Authors requesting to move to WG status
 >Dave McDyson: Proposes requirements be settled first.
 >Also requests cross-referencing other drafts, and
 >explaining terminology.
 >
 >Stewart: asks what alignment is required
 >
 >Dave McDyson: IEEE protection, and possibly ITU
 >
 >Matthew: That is part of requirements draft
 >
 >Dave McDyson: The solution seems to rely on correct configuration.
 >
 >Automatic identification of master and slave would be nice.
 >
 >Danny: Are you volunteering to help ?
 >
 >Dave McDyson: yes
 >
 >Dave says he is happy that Luca is now working on this draft as well
 >
 >Luca Martini (via Jabber): Hey ! , this is a very different document
 >since the time I made that statement !
 >
 >Danny: will ask on the list.

I therefore have two questions?

1) Do we need a requirements draft?

2) If we need a requirements draft,
2a) Do we proceed with these proposals and sync up the
requirements and solutions drafts on the fly?

or

2b) Do we get traction on the requirements draft and then verify
that these drafts are suitable solutions?

Stewart

---

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 17 Dec 2007 17:21:05 +0200

Stewart, 

I think that by saying that they approve the draft(s),
people are saying that they do not believe that a separate requirements
draft is needed.

Y(J)S 

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Monday, December 17, 2007 2:00 PM
To: [email-masked]
Subject: Re: [PWE3] PW Redundancy to WG drafts?

or

Stewart

---

From: Dave McDysan <[email-masked]>
Date: Mon, 17 Dec 2007 10:54:01 -0500

I think that we need the requirements draft.

I am OK with the requirements and solution drafts proceeding in parallel.

Dave 

> Sent: Monday, December 17, 2007 7:00 AM
> To: [email-masked]
> A considerable number of people have said that they support 
> adoption of these drafts, but the minutes of the PWE3 meetings say:
> 
>

---

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Mon, 17 Dec 2007 09:55:39 -0600

Stewart,
I believe all of the requirements we received from service providers and
vendors were incorporated into the scenarios described in the framework
draft and addressed by the solution draft. In my opinion, this reflects
the level of support for moving these two documents to WG status.  

Having said that, if the WG requires a separate requirements document,
we can work on separating them from the framework draft but this should
not delay these drafts from progressing as WG documents. 

Regards,
Mustapha.

---

From: "LASSERRE, Marc \(Marc\)" <[email-masked]>
Date: Mon, 17 Dec 2007 16:58:56 +0100

I share the same view.

Marc

-----Original Message-----
From: AISSAOUI Mustapha [mailto:[email-masked]] 
Sent: lundi 17 décembre 2007 16:56
To: [email-masked]; [email-masked]
Subject: RE: [PWE3] PW Redundancy to WG drafts?

Stewart,

Regards,
Mustapha.

---

From: Dave McDysan <[email-masked]>
Date: Mon, 17 Dec 2007 11:11:49 -0500

The charter states the following:

"Define requirements for and mechanisms to provide protection and
restoration of PWs."

I view draft-muley-pwe3-redundancy-02.txt that describes scenarios as a good
starting point to document requirements, which can be combined with a
framework (if the wg wants to undertake that increased charter scope). 

I support these documents becoming WG drafts so that they can be open to
inputs from the working group. 

As I mentioned in the meeting, I have additional requirements and scenarios
that I would like for the wg to consider.

Thanks,

Dsve
> Sent: Monday, December 17, 2007 10:56 AM
> I believe all of the requirements we received from service 
> providers and vendors were incorporated into the scenarios 
> described in the framework draft and addressed by the 
> solution draft. In my opinion, this reflects the level of 
> support for moving these two documents to WG status.  
> 
> Having said that, if the WG requires a separate requirements 
> document, we can work on separating them from the framework 
> draft but this should not delay these drafts from progressing 
> as WG documents. 
> 
> Regards,
> Mustapha.
> 
> adoption 
> > of these drafts, but the minutes of the PWE3 meetings say:
> > 
> > 
> >  >Authors requesting to move to WG status  >Dave McDyson: Proposes 
> > requirements be settled first.
> >  >Also requests cross-referencing other drafts, and  >explaining 
> > terminology.
> >  >
> >  >Stewart: asks what alignment is required  >  >Dave McDyson: IEEE 
> > protection, and possibly ITU  >
> >  >Matthew: That is part of requirements draft  >  >Dave 
> McDyson: The 
> > solution seems to rely on correct configuration.
> >  >
> > >  >Luca Martini (via Jabber): Hey ! , this is a very different 
> > document  >since the time I made that statement !
> >  >
> > 2a) Do we proceed with these proposals and sync up the requirements 
> > and solutions drafts on the fly?
> > 
> > or
> > 
> > 2b) Do we get traction on the requirements draft and then 
> verify that 
> > these drafts are suitable solutions?
> > 
> > Stewart
> > 
> > 
> >

---

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Mon, 17 Dec 2007 10:26:43 -0600

Dave,
sure, let us incorporate your scenarios into the framework document. We
can then evaluate if these can be addressed by capabilities currently
defined the solution draft or not.

Mustapha.

> From: Dave McDysan [mailto:[email-masked]] 
> Sent: Monday, December 17, 2007 11:12 AM
> To: AISSAOUI Mustapha; [email-masked]; [email-masked]
> "Define requirements for and mechanisms to provide protection 
> and restoration of PWs."
> 
> I view draft-muley-pwe3-redundancy-02.txt that describes 
> scenarios as a good starting point to document requirements, 
> which can be combined with a framework (if the wg wants to 
> undertake that increased charter scope). 
> 
> I support these documents becoming WG drafts so that they can 
> be open to inputs from the working group. 
> 
> As I mentioned in the meeting, I have additional requirements 
> and scenarios that I would like for the wg to consider.
> 
> Thanks,
> 
> Dsve
> > From: AISSAOUI Mustapha 
> [mailto:[email-masked]]
> providers 
> > and vendors were incorporated into the scenarios described in the 
> > framework draft and addressed by the solution draft. In my opinion, 
> > this reflects the level of support for moving these two 
> documents to 
> > WG status.
> > 
> > we can work on separating them from the framework draft but this 
> > should not delay these drafts from progressing as WG documents.
> > 
> > Regards,
> > Mustapha.
> >

---

From: "KOMPELLA Vach" <[email-masked]>
Date: Mon, 17 Dec 2007 10:40:49 -0600

Let me suggest a direction that is in line with what Dave is suggesting
- the drafts move to WG status, but  we will further amplify
draft-muley-pwe3-redundancy as the framework, with additional scenarios
that Dave has in mind.

I have no problem with that.

-Vach  

> Sent: Monday, December 17, 2007 8:12 AM

---

From: Dave McDysan <[email-masked]>
Date: Mon, 17 Dec 2007 12:06:42 -0500

This approach works for me. Just to be clear, the
draft-muley-pwe3-redundancy-02.txt is the framework that contains scenarios
(and "requirements" to meet the PWE3 charter objective).

A separate requirements document is not necessary.

Dave

> From: KOMPELLA Vach [mailto:[email-masked]] 
> Sent: Monday, December 17, 2007 11:41 AM
> To: Dave McDysan; AISSAOUI Mustapha; [email-masked]; [email-masked]
> draft-muley-pwe3-redundancy as the framework, with additional 
> scenarios that Dave has in mind.
> 
> scenarios as 
> > a good starting point to document requirements, which can 
> be combined 
> > with a framework (if the wg wants to undertake that 
> increased charter 
> > scope).
> > 
> > I support these documents becoming WG drafts so that they 
> can be open 
> > to inputs from the working group.
> > 
> > As I mentioned in the meeting, I have additional requirements and 
> > scenarios that I would like for the wg to consider.
> > 
> > Thanks,
> > 
> > Dsve
> >explaining

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 17 Dec 2007 12:12:52 -0500

> the level of support for moving these two documents to WG status.

	If that is the case, I would agree that a separate document is
unnecessary; however, I would like to see said requirements listed on
the mailing list for debate/discussion here.

	--Tom

> should

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 17 Dec 2007 17:30:57 +0000

> A separate requirements document is not necessary.
Works for me as well, and squares with the decision on
requirements at the WG meeting.

Stewart