Subject: [PWE3] PW Update and PW Redundancy

From: Mark Townsley <[email-masked]>
Date: Mon, 03 Dec 2007 16:46:06 -0800

If PW Update is a "make before break" model, why not just setup a 
redundant PW ala                     draft-muley-pwe3-redundancy-00.txt 
and then kill the old PW after?

- Mark

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Nitin Bahadur" <[email-masked]>
Date: Mon, 3 Dec 2007 16:59:56 -0800

Not sure if you even need that (since both PWs start from the same PE).
The 2nd PW can be setup in the control plane and the control-plane can
do a make-before-break in the forwarding plane.

Nitin

> -----Original Message-----
> From: Mark Townsley [mailto:[email-masked]]
> Sent: Monday, December 03, 2007 4:46 PM
> To: pwe3
> Subject: [PWE3] PW Update and PW Redundancy
> 
>

---

From: "JOUNAY Frederic RD-RESA-LAN" <[email-masked]>
Date: Tue, 4 Dec 2007 03:52:33 +0100

Using another PW would imply to configure a new AII or a new Pwid, and this is actually what we want to avoid for manageability considerations.

Fred 

-----Message d'origine-----
De : Nitin Bahadur [mailto:[email-masked]] 
Envoyé : mardi 4 décembre 2007 02:00
À : Mark Townsley; pwe3
Objet : RE: [PWE3] PW Update and PW Redundancy

Not sure if you even need that (since both PWs start from the same PE).
The 2nd PW can be setup in the control plane and the control-plane can do a make-before-break in the forwarding plane.

Nitin

---

From: "HENDERICKX Wim" <[email-masked]>
Date: Tue, 4 Dec 2007 01:53:14 +0100

Mark, I think this indeed a good alternative according to me. 

-----Original Message-----
From: Mark Townsley [mailto:[email-masked]] 
Sent: dinsdag 4 december 2007 1:46
To: pwe3
Subject: [PWE3] PW Update and PW Redundancy

- Mark

---

From: "Yang Yang" <[email-masked]>
Date: Thu, 6 Dec 2007 03:02:34 +0800

Hello all,
   The bandwidth of the underlying tunnel may not be bigger enough to set up
a redundant PW.  In this case, it may be good to only update the traffic
profile of the PW.

    Best Regards!
       Yang

---

From: "Italo Busi" <[email-masked]>
Date: Wed, 5 Dec 2007 12:39:17 -0800

Hi all,

It's my understanding that some concerns have been raised after Monday PWE3 WG
meeting, based upon some comments I made at the microphone.  In particular, my
comment using the phrase "separate domains", which is being interpreted as
meaning "disjoint networks" as described in Stewart's presentation.

I would like to clarify that this was not my intended meaning and that I fully
support the agreements reached during the Stuttgart meeting.

I am available for offline discussion on this topic with anybody interested

Italo

---

From: Loa Andersson <[email-masked]>
Date: Wed, 05 Dec 2007 22:09:23 +0100

Italo,

> support the agreements reached during the Stuttgart meeting.

this pretty much explains what you did not mean to say, not so much what
you wanted to say :) , if "separate domains" is not the same thing as
"disjoint networks" what are they? If you weren't commenting on the on
the slide in Stewarts presentation I've to assume that you agree with
it; so what was your comment about??

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                           [email-masked]

This email was Anti Virus checked by Astaro Security Gateway. http://www.astaro.com

---

From: Mark Townsley <[email-masked]>
Date: Wed, 05 Dec 2007 14:20:26 -0800

Yang Yang wrote:
>  Hello all,
>    The bandwidth of the underlying tunnel may not be bigger enough to 
> set up a redundant PW.  In this case, it may be good to only update 
> the traffic profile of the PW.
This doesn't make much sense - A redundant PW doesn't use any bandwidth 
until the old PW is torn down.

- Mark
>  
>     Best Regards!
>        Yang
>
> On Dec 4, 2007 8:53 AM, HENDERICKX Wim 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     From: Mark Townsley [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     [email-masked] <mailto:[email-masked]>
>     <https://www1.ietf.org/mailman/listinfo/pwe3>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www1.ietf.org/mailman/listinfo/pwe3>
>
>

---

From: "JOUNAY Frederic RD-RESA-LAN" <[email-masked]>
Date: Thu, 6 Dec 2007 22:12:22 +0100

Hi Mark, Wim,

A "make before break" based on the pwe3-redundancy draft for CESoPSN would imply the following configurations at both endpoints:
- New AII or PWid (must be defined so as to get the highest priority)
- AC/"new PW" binding
- New int. Paramters to the "new PW"
The cumbersome configuration could be prone to mis-configuration and so possible service disruption.
Upon the switchover step as defined in pwe3-redundancy draft, the initial PW must be teared down. This is not required, so not specified in the PW redundancy procedure. 
Hence the initial PW removal must be achieved via CLI/knob (to be supported at the both endpoints).
Extending the PW redundancy for a dynamic update for CESoPSN on the fly without service interruption would lead to define also some specific extensions.
So,let's figure out the pros and cons of both approaches.
The PW Update draft proposes a real PW dynamic update since it allows to maintain the PW FEC and so alleviates the operational concerns.

Best regards,

Frederic

-----Original Message-----
From: Mark Townsley [mailto:[email-masked]]
Sent: dinsdag 4 december 2007 1:46
To: pwe3
Subject: [PWE3] PW Update and PW Redundancy

- Mark