Subject: [PWE3] Fat PW - a couple of points I was asked about.

From: Stewart Bryant <[email-masked]>
Date: Wed, 05 Dec 2007 18:13:33 +0000

Following a couple of hallway conversations I would
like to clear up two issues regarding the load
balance label fat-pw method.

The presence of the LB label is signaled but
the value used are not signaled.

How the LB value is chosen is a private matter for
the ingress PE. An obvious  value to use is the
result of the classification hash.

The order of pushing the labels etc at the ingress PE
is control word, then  LB label (S-bit set), then
PW label, then PSN label.

At egress, the PSN label is popped (or PHPed),
then the PW label is popped, then the next
four bytes are unconditionally discarded - they
have no information of value to the egress PE.
Then the CW is processed as normal.

I will make sure this is clearer in the next version of
the text.

- Stewart

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 05 Dec 2007 21:10:17 +0000

Yang Yang wrote:
> Hello Stewart,
>     I'm wondering how to use the LB label inside PSN. If LB label is 
> only used by the ingress T-PE for load-balancing, maybe it's no 
> necessary to carry the LB label across the PSN.
>  
>     Best Regards!
>         Yang

It is carried across the PSN.

Any P router that includes the bottom label in its ECMP calculation takes
advantage of it.

Stewart

---

From: "Yang Yang" <[email-masked]>
Date: Thu, 6 Dec 2007 05:45:33 +0800

Hello Stewart,

   Please see the comments inline.

   Best Regards!
        Yang

> Any P router that includes the bottom label in its ECMP calculation takes

So, the ingess T-PE adds load-balancing label, and the Ps use the LB label
for ECMP calculation.  How does the P notice the existing of the LB label?
And is it PW load-balancing? I'm a little confused. It's like that the P
couldn't get the right information for ECMP calculation and then the T-PE
should add some information.

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 06 Dec 2007 14:03:20 +0000

Yang Yang wrote:
> On Dec 6, 2007 5:10 AM, Stewart Bryant <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Yang Yang wrote:
>     > Hello Stewart,
> So, the ingess T-PE adds load-balancing label, and the Ps use the LB 
> label for ECMP calculation.  How does the P notice the existing of the 
> LB label? 
> And is it PW load-balancing? I'm a little confused. It's like that the 
> P couldn't get the right information for ECMP calculation and then the 
> T-PE should add some information.
>  
The P router hashes the label stack.

However you need to make sure that different flows have different
hash outputs to spread the flows over the ECMP set.

Since the egress PE label and the PW label for this high
bandwidth PW are the same for every packet all flows
within the PW go the same way (we designed
the PW to make that happen). However since acesss
speed is now high compared to core speed this can
be a problem with some PWs.

So you need to add some flow info into the labels stack and
you can either do this by using a number of signalled PW
labels and mapping some flows to each, or you can add
an additional label (that you hope the P routers will
include in their hash) and put some form of flow identifier
in  that additional label.

- Stewart

---

From: "Yang Yang" <[email-masked]>
Date: Thu, 6 Dec 2007 02:34:46 +0800

Hello Stewart,
    I'm wondering how to use the LB label inside PSN. If LB label is only
used by the ingress T-PE for load-balancing, maybe it's no necessary to
carry the LB label across the PSN.

    Best Regards!
        Yang