Subject: [PWE3] What PW type shall be used in pw.mib for MS-PW provisioned on S-PE devices

From: "Amir Halperin" <[email-masked]>
Date: Mon, 10 May 2010 11:58:06 +0300

Hi.

The following question is directed to authors of
draft-ietf-pwe3-segmented-pw.

I'm wondering what should be the pw-type in pw.mib for PW on S-PE
devices where the PW switching is between PWs and (not ACs)?

>From http://tools.ietf.org/html/draft-ietf-pwe3-segmented-pw-14 and also
from ms-pw architecture RFC, it says that all PW segments must share the
same PW type.

But on the other hand from
http://tools.ietf.org/html/rfc5659#section-5.1.2, there shall not be any
native service processing in S-PEs.

Please also note that according to the PW MIB description, native PW
entries are created automatically by the SNMP agenet according to the PW
type as defined in pw.mib e.g. pasted from pw-enet.mib "An entry is
created in this table by the agent for every entry in the pwTable with a
pwType of 'ethernetTagged' or 'ethernet'."

Thanks in advance,

Amir

Amir Halperin
System Architect

ORCKIT Corrigent

Office: +972-3-694-5379

Fax:    +972-3-695-3222
Mobile:+972-54-4323-815
mailto:[email-masked]

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 11 May 2010 18:12:29 +0300

Amir, and all,
IMHO the PW type for MS-PWs must be exactly the same as for SS-PWs.
One of the reasons for that is that PW Type is associated with specific interface parameters that must be passed between the T-PEs (e.g., in the case of a TDM PW). In the case of MS-PWs these parameters have to be passed by S-PEs (even if they do not affect the data path processing).

Regards,
     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of Amir Halperin
Sent: Monday, May 10, 2010 11:58 AM
To: [email-masked]
Cc: Amir Halperin
Subject: [PWE3] What PW type shall be used in pw.mib for MS-PW provisioned on S-PE devices

Hi.

The following question is directed to authors of draft-ietf-pwe3-segmented-pw.

I'm wondering what should be the pw-type in pw.mib for PW on S-PE devices where the PW switching is between PWs and (not ACs)?
>From http://tools.ietf.org/html/draft-ietf-pwe3-segmented-pw-14 and also from ms-pw architecture RFC, it says that all PW segments must share the same PW type.
But on the other hand from http://tools.ietf.org/html/rfc5659#section-5.1.2, there shall not be any native service processing in S-PEs.

Please also note that according to the PW MIB description, native PW entries are created automatically by the SNMP agenet according to the PW type as defined in pw.mib e.g. pasted from pw-enet.mib "An entry is created in this table by the agent for every entry in the pwTable with a pwType of 'ethernetTagged' or 'ethernet'."

Thanks in advance,
Amir

Amir Halperin
System Architect
ORCKIT Corrigent
Office: +972-3-694-5379
Fax:    +972-3-695-3222
Mobile:+972-54-4323-815
mailto:[email-masked]

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 11 May 2010 19:15:40 +0300

Amir,
I understand the context for your question now.

I think that the existing PW MIB (RFC 5061) and MPLS PW MIB (RFC 5062) have not been designed to support MS-PWs.
E.g., even if you are speaking about a T-PE, you probably need to specify the adjacent S-PE in addition to the actual PW peer - but there is just "peer" element.

And two segments of an S-PE can be set using different techniques - e..g., a static segment can be stitched to a signaled one. And of course, in the case of an S-PE you need the information about two adjacent S-PEs and two T-PEs...

In short, it looks as if a major rework of the PW MIB is required in order to support MS-PWs.  The WG Charter explicitly refers to this item, and should have been completed by July 2009:) .. but I did not find any active WG drafts dealing with this.

Andy/Matthew,
Did I miss something? (And no, I do not volunteer for this task!)

And, BTW,  PW Type seems to be one of the elements of the current PW MIB that should be inherited without any changes by the MIB supporting MS-PWs.

Regards,
     Sasha

From: Amir Halperin [mailto:[email-masked]]
Sent: Tuesday, May 11, 2010 6:22 PM
To: Alexander Vainshtein
Cc: [email-masked]
Subject: RE: [PWE3] What PW type shall be used in pw.mib for MS-PW provisioned on S-PE devices

Hi Sasha,

I understand and agreed that native service properties, in some cases, should be singled to the far end tail-end.
However, I'm asking what shall be the MIB reflection in the S-PE?
1. What PW-type on the PW entry in the S-PE?
2. Which MIB entries to create on S-PE, PW general or also native PW entries?
3. If only PW general entries are required on S-PE, then how the agent in S-PE differ between T-PE to S-PE cases?

Cheers,

Amir Halperin
mailto:[email-masked]
________________________________
From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Tuesday, May 11, 2010 6:12 PM
To: Amir Halperin
Cc: [email-masked]
Subject: RE: [PWE3] What PW type shall be used in pw.mib for MS-PW provisioned on S-PE devices

Amir, and all,

Regards,
     Sasha

Hi.

Thanks in advance,
Amir

Amir Halperin
System Architect
ORCKIT Corrigent
Office: +972-3-694-5379
Fax:    +972-3-695-3222
Mobile:+972-54-4323-815
mailto:[email-masked]

---

From: "Amir Halperin" <[email-masked]>
Date: Tue, 11 May 2010 18:21:45 +0300

Hi Sasha,

I understand and agreed that native service properties, in some cases,
should be singled to the far end tail-end.

2. Which MIB entries to create on S-PE, PW general or also native PW
entries? 

3. If only PW general entries are required on S-PE, then how the agent
in S-PE differ between T-PE to S-PE cases?

Cheers,

Amir Halperin
mailto:[email-masked]

From: Alexander Vainshtein [mailto:[email-masked]] 
Sent: Tuesday, May 11, 2010 6:12 PM
To: Amir Halperin
Cc: [email-masked]
Subject: RE: [PWE3] What PW type shall be used in pw.mib for MS-PW
provisioned on S-PE devices

Amir, and all,

One of the reasons for that is that PW Type is associated with specific
interface parameters that must be passed between the T-PEs (e.g., in the
case of a TDM PW). In the case of MS-PWs these parameters have to be
passed by S-PEs (even if they do not affect the data path processing).

Regards,

     Sasha

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Amir Halperin
Sent: Monday, May 10, 2010 11:58 AM
To: [email-masked]
Cc: Amir Halperin
Subject: [PWE3] What PW type shall be used in pw.mib for MS-PW
provisioned on S-PE devices

Hi.

Thanks in advance,

Amir

Amir Halperin
System Architect

ORCKIT Corrigent

Office: +972-3-694-5379

Fax:    +972-3-695-3222
Mobile:+972-54-4323-815
mailto:[email-masked]