Subject: [PWE3] Clarification request on pwID mib object usage for manual and genFecSignaling PWs

From: venkatesan mahalingam <[email-masked]>
Date: Fri, 6 Aug 2010 13:21:01 +0530

Hi,
As per RFC-5601, it seems that the pwID can also be used for manual and
genFecSignaling apart from pwIdFecSignaling configurations.

Is this understaning correct?

If the answer is Yes, can you please describe the need of pwID usage for
manual and genFecSignaling configurations?

*RFC-5601 mib object and its descriptions:*
pwID OBJECT-TYPE
     SYNTAX        PwIDType
     MAX-ACCESS    read-create
     STATUS        current
     DESCRIPTION
         "Pseudowire identifier.

          If the pwOwner object is 'pwIdFecSignaling' or
          'l2tpControlProtocol', then this object is signaled in the
          outgoing PW ID field within the 'Virtual Circuit FEC
          Element'.  *For other values of pwOwner, this object is not
          signaled and it MAY be set to zero.
*
          For implementations that support the pwIndexMappingTable,
          a non-zero value is RECOMMENDED, even if this
          identifier is not signaled.  This is so that reverse
          mappings can be provided by pwIndexMappingTable and
          pwPeerMappingTable.  It is therefore RECOMMENDED that the
          value of this pwID be unique (or if pwPeerAddrType is not
          'unknown', at least [pwType, pwID, pwPeerAddrType, pwPeerAddr]
          is unique.)"
      REFERENCE
         "Martini, et al, 'Pseudowire Setup and Maintenance using
          the Label Distribution Protocol', RFC
4447<http://tools.ietf.org/html/rfc4447>
."

-- 
Best Regards,
Venkatesan Mahalingam.

---

From: Sriram K <[email-masked]>
Date: Fri, 6 Aug 2010 21:00:06 +0530

Hi,
Following is my interpretation. 
> For other values of pwOwner, this object is not

The RFC doesn't mandate the pwID object to be set to 0, when manual/genFecSignaling is used. But the actual values used in the Gen. FEC element will be of the below objects when genFecSignaling is used. The value of the pwID object doesn't matter when genFecSignaling/manual is in use.

pwGroupAttachmentID OBJECT-TYPE
     SYNTAX        PwAttachmentIdentifierType
     MAX-ACCESS    read-create
     STATUS        current
     DESCRIPTION
         "This object is an octet string representing the attachment
          group identifier (AGI) that this PW belongs to, which
          typically identifies the VPN ID.
          Applicable if pwOwner equals 'genFecSignaling'."
     REFERENCE
         "Martini, et al, 'Pseudowire Setup and Maintenance using
          the Label Distribution Protocol', RFC 4447."
     ::= { pwEntry 14 }

  pwLocalAttachmentID   OBJECT-TYPE
     SYNTAX        PwAttachmentIdentifierType
     MAX-ACCESS    read-create
     STATUS        current
     DESCRIPTION
         "This object is an octet string representing the local
          forwarder attachment individual identifier (AII) to be
          used by this PW.  It is used as the Source AII (SAII) for
          outgoing signaling messages and the Target AII (TAII) in
          the incoming messages from the peer.  Applicable if
          pwOwner equal 'genFecSignaling'."
      REFERENCE
         "Martini, et al, 'Pseudowire Setup and Maintenance using
          the Label Distribution Protocol', RFC 4447."
     ::= { pwEntry 15 }

  pwRemoteAttachmentID   OBJECT-TYPE
     SYNTAX        PwAttachmentIdentifierType
     MAX-ACCESS    read-create
     STATUS        current
     DESCRIPTION
         "This object is an octet string representing the remote
          forwarder attachment individual identifier (AII) to be
          used by this PW.  It is used as the TAII for outgoing
          signaling messages and the SAII in the incoming messages
          from the peer.
          Applicable if pwOwner equals 'genFecSignaling'."
      REFERENCE
         "Martini, et al, 'Pseudowire Setup and Maintenance using
          the Label Distribution Protocol', RFC 4447."
     ::= { pwEntry 16 }

Best Regards,
Sriram

On 06-Aug-2010, at 1:21 PM, venkatesan mahalingam wrote:

> Hi,
> As per RFC-5601, it seems that the pwID can also be used for manual and genFecSignaling apart from pwIdFecSignaling configurations.
>  
> If the answer is Yes, can you please describe the need of pwID usage for manual and genFecSignaling configurations?
>  
> RFC-5601 mib object and its descriptions:
> pwID OBJECT-TYPE
>      SYNTAX        PwIDType
>      MAX-ACCESS    read-create
>      STATUS        current
>      DESCRIPTION
>          "Pseudowire identifier.
> 
>           Element'.  For other values of pwOwner, this object is not
>           the Label Distribution Protocol', RFC 4447."
> 
> -- 
> Best Regards,
> Venkatesan Mahalingam.
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 25 Aug 2010 14:46:04 -0400

Hi,

	Yes, you are correct in that the pwID can be used for other configurations. The pwID is used as a unique identifier for the PW.

	--Tom