Subject: Re: [PWE3] A question regarding RFC 3985

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 5 Jan 2011 08:03:24 +0200

Resending to include the PWE3 list

________________________________
From: Alexander Vainshtein
Sent: Wednesday, January 05, 2011 8:00 AM
To: Stewart Bryant ([email-masked]); [email-masked]
Cc: [email-masked]
Subject: A question regarding RFC 3985

Stewart, Prayson and all,
I have a question regarding the following statement in RFC 3985:

   When a MPLS label is used as a PW Demultiplexer, setting of the TTL
   value [RFC3032] in the PW label is application specific.

This statement seems to assume that the tunnel in which the PW crosses the PSN MUST use

either Pipe or Short Pipe TTL processing model, because with Uniform model the TTL value

would change when the PW label is exposed.

Is this interpretation correct?

Regards, and lots of thanks in advance,

     Sasha

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 05 Jan 2011 09:44:59 +0000

The context at the time the RFC was written was a discussion on whether 
to set the TTL such that the packet could not wander off in the network 
if the PSN label got popped incorrectly. However it turned out be be 
difficult to pick a value that everyone agreed on, hence the text below.

You could run the Uniform model if that is what you needed, but then you 
could not use TTL as an OAM exception mechanism for that PW.

Stewart

On 05/01/2011 06:03, Alexander Vainshtein wrote:
> ------------------------------------------------------------------------
> *From:* Alexander Vainshtein
> *Sent:* Wednesday, January 05, 2011 8:00 AM
> *To:* Stewart Bryant ([email-masked]); 
> [email-masked]
> *Cc:* [email-masked]
> *Subject:* A question regarding RFC 3985
>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 5 Jan 2011 17:59:22 +0200

Stewart,
Lots of thanks for a prompt response. It matches my recollection from the early PWE3 days long  ago, namely that at that time we did not think about this  detail of PWE3 architecture vs. MPLS one.

This is probably not the only such missing detail, but, somehow, PWs work quite well today:).

Regards,
     Sasha

From: Stewart Bryant [mailto:[email-masked]]
Sent: Wednesday, January 05, 2011 11:45 AM
To: Alexander Vainshtein
Cc: [email-masked]; [email-masked]
Subject: Re: A question regarding RFC 3985

The context at the time the RFC was written was a discussion on whether to set the TTL such that the packet could not wander off in the network if the PSN label got popped incorrectly. However it turned out be be difficult to pick a value that everyone agreed on, hence the text below.

You could run the Uniform model if that is what you needed, but then you could not use TTL as an OAM exception mechanism for that PW.

Stewart

________________________________
From: Alexander Vainshtein
Sent: Wednesday, January 05, 2011 8:00 AM
To: Stewart Bryant ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: A question regarding RFC 3985
Stewart, Prayson and all,
I have a question regarding the following statement in RFC 3985:

     Sasha

--