Subject: Re: [PWE3] GAL above and below the PW label

From: Luca Martini <[email-masked]>
Date: Wed, 13 Apr 2011 23:31:37 -0600

On 03/30/11 02:51, Sam Aldrin wrote:
> When ms-pw ping is performed, the packet should not be processed at S-PE, unless the PW label ttl is expired. With the proposed GAL label above PW label, how do you ensure the OAM packet take the same data path to reach far-end T-PE, without getting processed/punted at S-PE? Or for that matter go beyond first S-PE?
>
You do not.
Either there is no ECMP deployed on the network , or you must use the CW.

Luca

> -sam
>
> Sent from my iPad
>
> On Mar 30, 2011, at 1:44 AM, Loa Andersson <[email-masked]> wrote:
>
>> Sasha,
>>
>> what do you mean with "exposed" I thought that what is gpoing on
>> in an S-PE is normal MPLS label switching.
>>
>> /Loa
>>
>> On 2011-03-30 10:36, Alexander Vainshtein wrote:
>>> Tom, Luca and all,
>>>
>>> I would like to clarify – again – my position regarding GAL above the PW
>>> label.
>>>
>>> I think that, other issues notwithstanding, it would create an issue if
>>> used with MS-PWs:
>>>
>>> ·GAL would be exposed at each S-PE (making a presumably end-to-end OAM
>>> message to be intercepted)
>>>
>>> ·What is even worse, there is no rule for forwarding the packet that has
>>> been intercepted due to an exposed GAL (until you count the statement in
>>> 5586 requesting that a packet MUST NOT be ever forwarded based on GALJ).
>>> Hence it would be perfectly valid just to drop such a packet at the
>>> first S-PE it crosses…
>>>
>>> This said, I still do not think using GAL below the PW label is a good
>>> idea either. But this is a different story…
>>>
>>> Regards,
>>>
>>> Sasha
>>>
>>>
>>>
>>> _______________________________________________
>>> pwe3 mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/pwe3
>> -- 
>>
>>
>> Loa Andersson                         email: [email-masked]
>> Sr Strategy and Standards Manager            [email-masked]
>> Ericsson Inc                          phone: +46 10 717 52 13
>>                                             +46 767 72 92 13
>> _______________________________________________
>> pwe3 mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pwe3
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 14 Apr 2011 07:43:23 -0700

Luca,

This is not regarding the ecmp in the networks, rather the impact of GAL label being present above PW label in ms-PW networks. With the proposed model of GAL label above PW label, the Ttl setting of PW label has no bearing, as it will get punted at the very next S-PE, due to GAL.

Sam

Sent from my iPad

On Apr 13, 2011, at 10:31 PM, Luca Martini <[email-masked]> wrote:

>>>> I would like to clarify â€“ again â€“ my position regarding GAL above the PW
>>>> label.
>>>> 
>>>> Â·GAL would be exposed at each S-PE (making a presumably end-to-end OAM
>>>> Â·What is even worse, there is no rule for forwarding the packet that has
>>>> first S-PE it crossesâ€¦
>>>> idea either. But this is a different storyâ€¦
>>>> 
>>>> Regards,
>>>> 
>>>> Sasha
>>>> 
>>>> 
>>>>

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 15 Apr 2011 20:01:18 -0400

In message <[email-masked]>
Luca Martini writes:
> > When ms-pw ping is performed, the packet should not be processed at
> > S-PE, unless the PW label ttl is expired. With the proposed GAL label
> > above PW label, how do you ensure the OAM packet take the same data
> > path to reach far-end T-PE, without getting processed/punted at S-PE?
> > Or for that matter go beyond first S-PE? 
> >
> You do not.

Luca,

This may be a valid concern.  If there is multipath and there is CW,
many existing implementations use the entire label stack, including
reserved labels (GAL) in the hash.  If so, the payload with a fixed
label stack and the OAM, also with a fixed label stack but with GAL
added, are very likely to take different paths (different multipath
components, for example different LAG members).

When using of GAL with multipath it is best to confirm that the LSR
along the path do not use reserved labels in their hash.  If they do,
then the above condition can occur.  While it is a valid concern, it
should be fine to put a small warning in the document and move on.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 15 Apr 2011 20:23:27 -0400

In message <[email-masked]>
Sam Aldrin writes:
>  
> Luca,
>  
> This is not regarding the ecmp in the networks, rather the impact of
> GAL label being present above PW label in ms-PW networks. With the
> proposed model of GAL label above PW label, the Ttl setting of PW
> label has no bearing, as it will get punted at the very next S-PE, due
> to GAL.
>  
> Sam

Sam,

I think the authors agreed that GAL would be below the PW label
(closer to the BOS aka S=1 bit).

Curtis

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 15 Apr 2011 17:37:55 -0700

Thanks, Curtis.
Much appreciated.

Cheers
Sam

Sent from my iPad