Subject: [PWE3] LDP DoD and PW Signalling ...

From: <[email-masked]>
Date: Mon, 27 Jun 2011 09:41:13 +0200

Hi,

We came across an issue related to the Seamless MPLS Architecture when running LDP DoD between two nodes if we are trying to set up an PW between the same nodes.

Assume we have an Access Node (AN) and an Aggregation Mode (AG). The AN establishes a LDP DoD with the AG. When we are going to establish a PW between the AN and the AG as well we run into the problem that RFC4447 specifies only the DU mode for the targeted LDP session (section 3):

   "An LDP session must be set up between the pseudowire endpoints.
    LDP MUST be used in its 'downstream unsolicited' mode.  LDP's
    'liberal label retention' mode SHOULD be used."

>From our point of view we should reuse the existing LDP session and go with only a single LDP session between AN and AG. That has the advantage that we do not change the behaviour of PW FECs 128/129 (there are other options like using two LDP sessions with additonal lookbacks or two sessions with single loopback and LDP DoD for IP FECs, but those have an heavy -  negative impact - on the existing implementations and/or standards).

For a more long term approach we are in favour of a change to RFC5036 by defining a new TLV which denotes the DU/DoD mode per FEC type.

Any comments on that?

  Regards

     Nic

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Mon, 27 Jun 2011 18:10:06 -0500

Hi Nic,

> For a more long term approach we are in favour of a change to RFC5036
by
> defining a new TLV which denotes the DU/DoD mode per FEC type.

You mean, define a new 'Common Session Parameters TLV' (in the
initialization message) to denote the DU/DoD mode per FEC type? Or a new
'optional parameter' TLV (in the initialization message) to denote the
same? Or simply a new capability?

I hope that it is not the former.

>     LDP MUST be used in its 'downstream unsolicited' mode.  LDP's

Have we concluded that the above restriction in RFC4447 can not be
relaxed?
 
Cheers,
Rajiv

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> [email-masked]
> Sent: Monday, June 27, 2011 3:41 AM
> To: [email-masked]; [email-masked]
> Subject: [PWE3] LDP DoD and PW Signalling ...
> 
> Hi,
> 
> We came across an issue related to the Seamless MPLS Architecture when
running
> LDP DoD between two nodes if we are trying to set up an PW between the
same
> nodes.
> 
> Assume we have an Access Node (AN) and an Aggregation Mode (AG). The
AN
> establishes a LDP DoD with the AG. When we are going to establish a PW
between
> the AN and the AG as well we run into the problem that RFC4447
specifies only
> the DU mode for the targeted LDP session (section 3):
> 
> From our point of view we should reuse the existing LDP session and go
with
> only a single LDP session between AN and AG. That has the advantage
that we do
> not change the behaviour of PW FECs 128/129 (there are other options
like
> using two LDP sessions with additonal lookbacks or two sessions with
single
> loopback and LDP DoD for IP FECs, but those have an heavy -  negative
impact -
> on the existing implementations and/or standards).
> 
> For a more long term approach we are in favour of a change to RFC5036
by
> defining a new TLV which denotes the DU/DoD mode per FEC type.
> 
> Any comments on that?
> 
>   Regards
> 
>      Nic
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

---

From: Mach Chen <[email-masked]>
Date: Tue, 28 Jun 2011 08:51:10 +0000

Hi Nic,

IMHO, if we could category the existing FECs into two types: 1) Controlled by the LDP Session mode( e.g., IPv4/IPv6 FEC, P2MP/MP2MP FEC); 2). Independent of the LDP Session mode (e.g., FEC 128/129); then it just need to relax the restriction of FECs 128/129(the specific mode is determined by the FEC type and does not controlled by the session mode), and the issue in question could be solved easily. And from the view of implementation, it's easy to change the L2VPN module to relax the restriction.

BTW, I know some implementations that have already done like this.

Best regards,
Mach

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, June 27, 2011 3:41 PM
> running LDP DoD between two nodes if we are trying to set up an PW between
> the same nodes.
> 
> Assume we have an Access Node (AN) and an Aggregation Mode (AG). The AN
> between the AN and the AG as well we run into the problem that RFC4447
> specifies only the DU mode for the targeted LDP session (section 3):
> 
> From our point of view we should reuse the existing LDP session and go with
> only a single LDP session between AN and AG. That has the advantage that we
> do not change the behaviour of PW FECs 128/129 (there are other options like
> using two LDP sessions with additonal lookbacks or two sessions with single
> loopback and LDP DoD for IP FECs, but those have an heavy -  negative impact
> - on the existing implementations and/or standards).
> 
> For a more long term approach we are in favour of a change to RFC5036 by

---

From: Maciek Konstantynowicz <[email-masked]>
Date: Wed, 29 Jun 2011 08:48:20 +0100

Nic,

I don't believe this is a major issue.

Proposed short term approach of using DoD mode (negotiated during LDP session establishment per 'Common Session Parameters' TLV) for IP FECs and fixed DU mode for PW FECs makes sense to me.

I also agree that going forward we should consider introducing per FEC type indication of label advertisement discipline.
The least disruptive approach seems to be to amend rfc5036 and define a new 'Optional Parameter' TLV in the LDP Initialization message to indicate label advertisement discipline per FEC type, if different from the one advertised in 'Common Session Parameters' TLV.

Cheers,
Maciek.