Subject: [PWE3] WG LC on draft-ietf-pwe3-mpls-tp-gal-in-pw-01.txt

From: David Allan I <[email-masked]>
Date: Thu, 9 Jun 2011 18:43:55 -0400

I'm opposed to this draft progressing at this time.

At the moment the PW with a CW is a unifying agent that will work in both TP domains and those that employ ECMP and LAG. The GAL/ACh version cannot make this claim.

What would be required to make this acceptable IMO would be agreement with the MPLS WG to produce an RFC that documented excluding reserved labels from ECMP consideration such that GAL/GACh encapsulated PW OAM had "feature parity" with ACh encapsulated PW-OAM...

Then we could reasonably consider taking steps to move to a common OAM encapsulation mechanism common to LSPs and PWs.

My 2 cents
Dave

---

From: Alexander Vainshtein <[email-masked]>
Date: Fri, 10 Jun 2011 16:46:14 +0300

Hi all,
I concur with Dave.
Regards,
Sasha
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of David Allan I [[email-masked]]
Sent: Friday, June 10, 2011 1:43 AM
To: [email-masked]
Subject: [PWE3]  WG LC on draft-ietf-pwe3-mpls-tp-gal-in-pw-01.txt

What would be required to make this acceptable IMO would be agreement with the MPLS WG to produce an RFC that documented excluding reserved labels from ECMP consideration such that GAL/GACh encapsulated PW OAM had "feature parity" with ACh encapsulated PW-OAM…

My 2 cents
Dave

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Hejia <[email-masked]>
Date: Wed, 15 Jun 2011 20:30:02 +0000

Hi Dave and Sasha,

In fact, RFC5586 places no restrictions on the usage of GAL with PWs in MPLS environment but states that GAL MUST NOT be used with PWs in MPLS-TP environment. 

draft-ietf-pwe3-mpls-tp-gal-in-pw is created to remove the restrictions placed on GAL usage with PWs in MPLS-TP environment.

B.R.
Jia

________________________________________
From: [email-masked] [[email-masked]] on behalf of Alexander Vainshtein [[email-masked]]
Sent: Friday, June 10, 2011 9:46 PM
To: David Allan I; [email-masked]
Subject: Re: [PWE3] WG LC on draft-ietf-pwe3-mpls-tp-gal-in-pw-01.txt

Hi all,
I concur with Dave.
Regards,
Sasha

My 2 cents
Dave

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Luca Martini <[email-masked]>
Date: Fri, 17 Jun 2011 15:38:19 -0600

Dave,
And everybody else.

Thanks you for your support!
Since this document does not describe anything of what you mentioned below,
you must be a supporter !

Please read the document .

Thank you.
Luca

---

From: David Allan I <[email-masked]>
Date: Fri, 17 Jun 2011 17:45:26 -0400

I did read it and given this extract from the document am wondering what part I missed?

   Therefore, this document specifies that the GAL can be used with
   packets on a G-ACh on LSPs, Concatenated Segments of LSPs, Sections,
   and PWs in both MPLS and MPLS-TP environments without discrimination.

I would argue that using the GAL for PWs in any environment is a mistake, and this is not the only symptom of the problem... The fix to 5586 should be to PLACE a restiction on the use of the GAL on PWs in MPLS environments...not eliminate the restriction in TP environments.

I hope that is clearer.

cheers
Dave
________________________________
From: Luca Martini [mailto:[email-masked]]
Sent: Friday, June 17, 2011 2:38 PM
To: David Allan I
Cc: [email-masked]
Subject: Re: [PWE3] WG LC on draft-ietf-pwe3-mpls-tp-gal-in-pw-01.txt

Dave,
And everybody else.

Thank you.
Luca

My 2 cents
Dave

_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Alexander Vainshtein <[email-masked]>
Date: Sat, 18 Jun 2011 18:07:59 +0300

Dave,
Lots of thanks - I could not say it any better even if I have tried.

Regards,
     Sasha

________________________________
From: [email-masked] [[email-masked]] On Behalf Of David Allan I [[email-masked]]
Sent: Saturday, June 18, 2011 12:45 AM
To: Luca Martini
Cc: [email-masked]
Subject: Re: [PWE3] WG LC on draft-ietf-pwe3-mpls-tp-gal-in-pw-01.txt

I hope that is clearer.

cheers
Dave

Dave,
And everybody else.

Thank you.
Luca

My 2 cents
Dave

---

From: Luca Martini <[email-masked]>
Date: Sat, 18 Jun 2011 12:08:59 -0600

Alan,
Thanks for the clarification.
Indeed we have totally opposite views.

Luca