Subject: Re: [PWE3] Changes to draft-ietf-pwe3-dynamic-ms-pw

From: [email-masked]
Date: Thu, 30 Jun 2011 11:29:12 +0800

Hi Matthew,
I agree with to be WG draft. But I would like to know what kind of 
Explicit Route TLV that would be defined in the new draft. In 
draft-ietf-pwe3-dynamic-ms-pw, the defined format is from RFC3212 which 
has been deprecated by RFC 3468. Such kind of normative reference may be 
not appropriate.

Thanks
Lizhong

> 
> ------------------------------
> 
> Message: 3
> Date: Wed, 29 Jun 2011 16:42:23 +0200
> From: "Bocci, Matthew (Matthew)" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: [PWE3] Changes to draft-ietf-pwe3-dynamic-ms-pw
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
> 
> While making some updates to the Dynamic Multi-Segment Pseudowire 
> draft (draft-ietf-pwe3-dynamic-ms-pw) to prepare it for WG last 
> call, Luca and I have come to the conclusion that we need to add a 
> significant amount of text describing the procedures for handling 
> explicit routes and the applicability of different ER techniques. 
> The current draft defines the ER TLV, but not how it is processed.
> 
> In order to progress the current draft expeditiously, we think that 
> it would be better to split the ER TLV definition and procedures 
> into a separate draft.
> 
> We have discussed this with the chairs, and since this is being 
> split out from an existing working group draft, we would like to 
> create a new working group document from it rather than starting an 
> individual draft and asking for adoption.
> 
> We would like to know if there are any concerns from the working 
> group with moving straight to a WG draft for the explicit route TLV 
> definition and procedures.
> 
> If you have any concerns, please let us and the chairs know.
> 
> Regards,
> 
> Matthew
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://www.ietf.org/mail-
> archive/web/pwe3/attachments/20110629/076522f4/attachment.htm>
> 
> ------------------------------
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Bocci, Matthew (Matthew)" <[email-masked]>
Date: Thu, 30 Jun 2011 12:47:08 +0200

Hi Lizhong,

Yes, I agree with you. We did copy the format of the ER TLV across from the RFC and remove the reference, but somehow that version of the draft did not get posted yet.

I think we need to do the following in the new draft:

 *   Include a fully specified ER TLV based on the existing TLV and code points, and remove any reference to RFC3212.
 *   Add a sub-TLV to enable S-PE L2 addresses to be carried.
 *   Explicitly specify the procedures for using the TLV.

Best regards,

Matthew

On 30/06/2011 04:29, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Matthew,
I agree with to be WG draft. But I would like to know what kind of Explicit Route TLV that would be defined in the new draft. In draft-ietf-pwe3-dynamic-ms-pw, the defined format is from RFC3212 which has been deprecated by RFC 3468. Such kind of normative reference may be not appropriate.

Thanks
Lizhong

> From: "Bocci, Matthew (Matthew)" <[email-masked]<mailto:[email-masked]>>
> To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> Message-ID: <[email-masked]<mailto:[email-masked]>>

---

From: [email-masked]
Date: Thu, 30 Jun 2011 20:13:26 +0800

Hi Matthew,
That would be good. Thank you for the clarification.

Regards
Lizhong

"Bocci, Matthew (Matthew)" <[email-masked]> wrote on 
2011-06-30 18:47:08:

> Hi Lizhong,
> 
> Yes, I agree with you. We did copy the format of the ER TLV across 
> from the RFC and remove the reference, but somehow that version of 
> the draft did not get posted yet. 
> 
> Include a fully specified ER TLV based on the existing TLV and code 
> points, and remove any reference to RFC3212. 
> Add a sub-TLV to enable S-PE L2 addresses to be carried.
> Explicitly specify the procedures for using the TLV.
> Best regards,
> 
> Matthew
> 
> On 30/06/2011 04:29, "[email-masked]" <[email-masked]> 
wrote:
> Explicit Route TLV that would be defined in the new draft. In draft-
> ietf-pwe3-dynamic-ms-pw, the defined format is from RFC3212 which 
> has been deprecated by RFC 3468. Such kind of normative reference 
> may be not appropriate.
> 
> Thanks
> Lizhong
> 
> 
> >