Subject: [PWE3] Comments to draft-ietf-pwe3-mpls-tp-pw-over-bidir-lsp-01

From: Gregory Mirsky <[email-masked]>
Date: Fri, 7 Jun 2013 22:18:52 +0000

Dear Authors, et al.,
I've prepared some questions and comments that I hope you'll kindly consider:
*       I've got confused by definition of C bit in section 2.1. That might be in part because congruency in geometry has very certain definition and I'm projecting that to term congruent path introduced in the document. In addition I think that "same route" in the second sentence is vague. Does that imply that active PE requests far-end PE to use co-routed LSP? If that is the case, should C bit explained as request to use Co-routed path?
   *    Last sentence of section 2.1 defines that detection of C and S bits being simultaneously set as error. How that error being signaled in LDP Status Codes?

        Regards,
                Greg

---

From: Mach Chen <[email-masked]>
Date: Sun, 9 Jun 2013 03:03:01 +0000

Hi Greg,

Thanks for your comments!

Yes, it intends to mean co-routed here. Not use the "co-routed" because there is definition of  co-routed bidirectional LSP, where the "co-routed" means not only co-routed but signaled by a single path/resv exchange. If the WG think co-routed is better, I am fine to change to it.

For example, change the C (Congruent Path) bit to C (Co-routed path) bit, and then it's definition would like this:

"C (Co-routed path) bit: This informs the remote T-PE/S-PEs about the properties of the underlying LSPs. When set, the remote T-PE/S-PEs need to select co-routed LSP as the PSN tunnel. If there is no such tunnel available, the node may trigger the remote T-PE/S-PEs to establish a new LSP."

How do you think?

Best regards,
Mach

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Saturday, June 08, 2013 6:19 AM
To: Mach Chen; Caowei (Wayne); Attila Takacs; [email-masked]; [email-masked]; [email-masked]
Subject: Comments to draft-ietf-pwe3-mpls-tp-pw-over-bidir-lsp-01

Dear Authors, et al.,

        Regards,
                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 11 Jun 2013 18:32:09 +0000

Hi Mach,
yes, I think I see what caused your hesitation "the remote T-PE/S-PEs to establish a new (co-routed) LSP". Frankly, I need to go back to authoritive sources, but I think that signaling of a co-routed LSP is not mandated to be in single Path/Resv pass. I think that if intention is to map PW onto co-routed LSP, then C in C-bit should stand for "co-routed".

    Regards,
        Greg

________________________________
From: Mach Chen [mailto:[email-masked]]
Sent: Saturday, June 08, 2013 8:03 PM
To: Gregory Mirsky; Caowei (Wayne); Attila Takacs; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Comments to draft-ietf-pwe3-mpls-tp-pw-over-bidir-lsp-01

Hi Greg,

How do you think?

Best regards,
Mach

Dear Authors, et al.,

        Regards,
                Greg

---

From: Mach Chen <[email-masked]>
Date: Thu, 13 Jun 2013 07:56:20 +0000

Hi Greg,

OK, I am fine with "co-routed".

In addition, regarding to "the C and S bits being simultaneously set", there should be an error code should be signaled, a new status code("The C-bit and S-bit cannot be both set") will be added in the next revision.

Best regards,
Mach

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Wednesday, June 12, 2013 2:32 AM
To: Mach Chen; Caowei (Wayne); Attila Takacs; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Comments to draft-ietf-pwe3-mpls-tp-pw-over-bidir-lsp-01

Hi Mach,

    Regards,
        Greg

How do you think?

Best regards,
Mach

Dear Authors, et al.,

        Regards,
                Greg