Subject: Re: [PWE3] New Version Notification for draft-jiang-pwe3-mc-pon-02.txt

From: "JOSHI, SHRINIVAS ASHOK (SHRINIVAS ASHOK)" <[email-masked]>
Date: Thu, 24 Jul 2014 04:08:39 +0000

Hi Yuanlong,

Thanks for including DSL and P2P in use cases in Introduction. However the TLV's and procedures are still PON specific.
I would suggest to make the TLV and procedures generic so they are applicable to DSL and P2P Ethernet as well.

Also in access network i.e. PON and P2P ethernet there is significant amount of dynamic information e.g. DHCP leases, PPP sessions etc which are maintained by OLT for each subscriber, the draft should cover the procedure for synchronization of this dynamic information between the two OLT's.

One additional point current draft does not cover the procedure for PON configuration TLV when & how it would be used.

Also it would be good to have some discussion/feedback on mailing list on the expanded draft to see if it covers all scenario's.

Thanks
--
Shrinivas Joshi

-----Original Message-----

Hi colleagues,
 
We had updated the draft to a new revision. The main updates include:
1.	Add more application scenarios, such as MSO and DSL;
2.	Add support to a deployment scenario of partly protection raised by some service providers;
3.	Add Chenbin and Yimin to our co-authors;
4.  Substantial editorial changes. 

Please feedback you opinions on this version. Thanks!

Regards,
Yuanlong

-----Original Message-----
From: internet-drafts at ietf.org [mailto:internet-drafts at ietf.org] 
Sent: Wednesday, April 02, 2014 11:19 AM
To: Yimin Shen; Luoyong (Dennis); Chengbin Shen; Chengbin Shen; Edwin Mallette; Yimin Shen; Edwin Mallette; Jiangyuanlong; Jiangyuanlong; Luoyong (Dennis)
Subject: New Version Notification for draft-jiang-pwe3-mc-pon-02.txt

A new version of I-D, draft-jiang-pwe3-mc-pon-02.txt
has been successfully submitted by Yuanlong Jiang and posted to the
IETF repository.

Name:		draft-jiang-pwe3-mc-pon
Revision:	02
Title:		Multi-chassis PON Protection in MPLS
Document date:	2014-04-02
Group:		Individual Submission
Pages:		15
URL:            http://www.ietf.org/internet-drafts/draft-jiang-pwe3-mc-pon-02.txt
Status:         https://datatracker.ietf.org/doc/draft-jiang-pwe3-mc-pon/
Htmlized:       http://tools.ietf.org/html/draft-jiang-pwe3-mc-pon-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-jiang-pwe3-mc-pon-02

Abstract:
   MPLS is being deployed deeper into operator networks, often to or
   past the access network node. Separately network access nodes such as
   PON OLTs have evolved to support first-mile access protection, where
   one or more physical OLTs provide first-mile diversity to the
   customer edge. Multi-homing support is needed on the MPLS-enabled PON
   OLT to provide resiliency for provided services.  This document
   describes the multi-chassis PON protection architecture in MPLS and
   also proposes the ICCP extension to support it.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jiangyuanlong <[email-masked]>
Date: Thu, 24 Jul 2014 19:04:22 +0000

Hi Joshi,

Thank you for the detailed comments, please see my comments inline.

Best regards,
Yuanlong

-----Original Message-----
From: JOSHI, SHRINIVAS ASHOK (SHRINIVAS ASHOK) [mailto:[email-masked]] 
Sent: Thursday, July 24, 2014 12:09 PM
To: [email-masked]; Jiangyuanlong
Subject: Re: New Version Notification for draft-jiang-pwe3-mc-pon-02.txt

Hi Yuanlong,

Thanks for including DSL and P2P in use cases in Introduction. However the TLV's and procedures are still PON specific.
I would suggest to make the TLV and procedures generic so they are applicable to DSL and P2P Ethernet as well.
[YJ] I agree that most TLVs and procedures may be similar, but have some doubts that TLVs of PON and the others may use the same format, such as per Sec. 4.1.5. "PON ONU Database Sync TLV", it seems they do have their special parameters. But what concerns me most is the scalability and economics of DSL dual-homing, unlike PON trunk protection where a tree of ONUs can be protected by merely two trunk links, DSL needs two subscriber line for each user. However, opinions from service providers are needed. 

Also in access network i.e. PON and P2P ethernet there is significant amount of dynamic information e.g. DHCP leases, PPP sessions etc which are maintained by OLT for each subscriber, the draft should cover the procedure for synchronization of this dynamic information between the two OLT's.
[YJ] This is a good problem space, we can add these materials definitely if the WG have a consensus, and your inputs will be greatly appreciated.

One additional point current draft does not cover the procedure for PON configuration TLV when & how it would be used.
[YL] it is used in configuration phase, and a device (OLT or router with PON interfaces) notifies its peer what its local configuration is. We will add some texts into the next revision to make it clear. 

Also it would be good to have some discussion/feedback on mailing list on the expanded draft to see if it covers all scenario's.
[YL] Yes, more discussions are greatly welcome and helpful to drive this work.

Thanks
--
Shrinivas Joshi

-----Original Message-----

Hi colleagues,

Regards,
Yuanlong

-----Original Message-----
From: internet-drafts at ietf.org [mailto:internet-drafts at ietf.org] 
Sent: Wednesday, April 02, 2014 11:19 AM
To: Yimin Shen; Luoyong (Dennis); Chengbin Shen; Chengbin Shen; Edwin Mallette; Yimin Shen; Edwin Mallette; Jiangyuanlong; Jiangyuanlong; Luoyong (Dennis)
Subject: New Version Notification for draft-jiang-pwe3-mc-pon-02.txt

Abstract:

The IETF Secretariat