Subject: Re: [PWE3] I-D Action: draft-shawam-pwe3-ms-pw-protection-00.txt

From: Huub van Helvoort <[email-masked]>
Date: Fri, 11 Jul 2014 11:09:39 +0200

All,

After publication of RFC6378 and RFC7271 The ITU-T has approved
recommendation G.8131 based on these RFCs.

However, during the drafting of this recommendation operators
expressed their concern that this recommendation only applies
to LSPs, and not to PWs, in particular MS-PWs.

To address their concern we started working on this draft.
When it becomes an RFC it will be used to extend G.8131 to
include PWs.

Cheers, Huub.

=============

On 01-07-14 19:03, [email-masked] wrote:
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>          Title           : Encapsulation for PSC for Multi-Segment Pseudowires
>          Authors         : Huub van Helvoort
>                            Loa Andersson
>                            Andrew G. Malis
>                            Jongyoon Shin
>                            Lei Wang
>                            Alessandro D'Alessandro
> 	Filename        : draft-shawam-pwe3-ms-pw-protection-00.txt
> 	Pages           : 4
> 	Date            : 2014-07-01
>
> Abstract:
>     In RFC 6378 'MPLS Transport Profile (MPLS-TP) Linear Protection', as
>     well as in the later updates of this RFC, the Protection State
>     Coordiantion (PSC) protocol was defined for MPLS LSPs only.  This
>     draft extends RFC 6378 to be applicable for pseudowires as well.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-shawam-pwe3-ms-pw-protection/
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-shawam-pwe3-ms-pw-protection-00
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 14 Jul 2014 11:19:59 +0100

Huub,

This is going to need quite a lot more detail, both
in terms of specific updates to RFC6378/7271 and in terms
of operation in the PW context.

Stewart

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 14 Jul 2014 10:49:45 -0400

Stewart,

Thanks for the comment. This is obviously just an initial draft, we would
appreciate any further comments from you and the list on where we can add
detail in future revisions. The overall intention is that operation will be
basically identical to that for statically provisioned MPLS-TP LSPs in RFC
6378.

Cheers,
Andy

On Mon, Jul 14, 2014 at 6:19 AM, Stewart Bryant <[email-masked]> wrote:

> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 14 Jul 2014 16:25:14 +0100

Andy,

An overarching question - SS-PW and/or MS-PW?

MPLS-TP does not say much about MS-PW and I am not sure whether or not 
they are needed.

In the case of SS-PW  the LSP are entirely congruent, so presumably your 
concern is bandwidth of the underlying LSP causing you to need to spread 
your repair across a number of LSPs and thus the LSP and PW repair are 
mutually exclusive - correct?

Stewart

On 14/07/2014 15:49, Andrew G. Malis wrote:
> Stewart,
>
> Thanks for the comment. This is obviously just an initial draft, we 
> would appreciate any further comments from you and the list on where 
> we can add detail in future revisions. The overall intention is that 
> operation will be basically identical to that for statically 
> provisioned MPLS-TP LSPs in RFC 6378.
>
> Cheers,
> Andy
>
>
> On Mon, Jul 14, 2014 at 6:19 AM, Stewart Bryant <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Huub,
>
>         On 01-07-14 19:03, [email-masked]
>         <mailto:[email-masked]> wrote:
>
>
>                 Filename        :
>             draft-shawam-pwe3-ms-pw-protection-00.txt
>                 Pages           : 4
>                 Date            : 2014-07-01
>
>             Abstract:
>             until the htmlized version and diff are available at
>             tools.ietf.org <http://tools.ietf.org>.
>
>             [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 14 Jul 2014 11:42:32 -0400

Stewart,

This draft is explicitly meant for statically provisioned MS-PWs running
over MPLS-TP LSPs, in order to protect for S-PE failure. Each of the
component SS-PWs are automatically protected by the underlying LSP
protection, so for SS-PWs, there will only be one level of repair, at the
LSP level. We tried to make this clear in the draft. We can try to make
that more clear in the next revision.

Generally, MS-PWs are needed over MPLS-TP for the same reasons that they're
needed over MPLS.

Cheers,
Andy

On Mon, Jul 14, 2014 at 11:25 AM, Stewart Bryant <[email-masked]> wrote:

> would appreciate any further comments from you and the list on where we can
> add detail in future revisions. The overall intention is that operation
> will be basically identical to that for statically provisioned MPLS-TP LSPs
> in RFC 6378.
>
>  Cheers,
> Andy
>
>
> pwe3 mailing [email-masked]://www.ietf.org/mailman/listinfo/pwe3
>
>
>
> --