Subject: Re: [PWE3] how to distinguish VCC and VPC connection in ATM

From: manomugdha biswas <[email-masked]>
Date: Sat, 14 May 2005 07:57:55 +0100 (BST)

Hi Xixiang,

Thanks for the reply. So after receiving encapsulated
packet I can determine the type of connection that the
payload belongs to. It is fine.

Now I want to know one more thing in this context. I
want to send some payload over a VCC connection. So
how to establish this VCC connection? Similarly if I
want to send packet over VPC connection then how to
establish that VPC connection? 

Here my intention is to know how to establish a
particular type of atm connection (VCC or VPC)?

I can establish PVC where I have to specify both VPI
adnd VCI. 
---------
* V (VCI present) bit
> 
>        Bit (V) of the control byte indicates whether
> the VCI field is
>        present in the packet. If set to 1, the VCI
> field is present for
>        the cell. If set to 0, no VCI field is
> present. In the case of a
>        VCC, the VCI field is not required. For VPC,
> the VCI field is
>        required and is transmitted with each cell.
---------

ATM Cell has header of 5 bytes, where VPI field is of
8 bits and VCI field is of 16 bits. 

According to the above statement V bit is used to
indicate whether VCI field is present for the cell. If
set to 0 then no VCI field is present. So how to
establish this particular connection (VCC) and what
will be the value of the 16 bits VCI field of atm cell
when I will send an atm cell over this VCC connection?

How a PE (provider Edge) distinguishes between VCC and
VPC?

Please let me know?

Regards,
Manomugdha

--- Xixiang Li <[email-masked]> wrote:
> Hi Manomugdha,
> 
> According to clause 9.3. ATM VCC Cell Transport
> Service, draft-ietf-pwe3-atm-encap-08.txt, 
> there's a 'V' bit used to distinguish VPC and VCC
> cells. If 'V' is set to 1, it should be a VPC cell
> encapsulation, otherwise, a VCC cell.
> So you must check the V bit of the control word to
> find which type of connection that the payload
> belongs to.
> 
> Please review the following text that copy-pasted
> from the draft.
> 
>      0                                    1         
>                          2                          
>         3
>      0  1  2  3  4  5 6  7 8  9  0  1 2  3  4  5 6 
> 7  8 9  0  1  2 3  4  5  6  7 8  9  0 1
>   
>
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |                           PSN Transport Header
> (As Required)                                   |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |                                       Pseudo
> Wire Header                                         
>        |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    | 0  0  0  0|  Resvd   |      Optional Sequence
> Number           |M|V|Res | PTI   |C|
>   
>
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |                                                
>                                                     
>                   |
>    |                                         ATM
> Cell Payload ( 48 bytes )                           
>     |
>    |                                                
>                                                     
>                   |
>   
>
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> 
>                 Figure 7: Single ATM VCC Cell
> Encapsulation
> 
>      * V (VCI present) bit
> 
>        Bit (V) of the control byte indicates whether
> the VCI field is
>        present in the packet. If set to 1, the VCI
> field is present for
>        the cell. If set to 0, no VCI field is
> present. In the case of a
>        VCC, the VCI field is not required. For VPC,
> the VCI field is
>        required and is transmitted with each cell.
> 
> rgds,
> Xixiang Li
> 
> 
> 
> ----- Original Message ----- 
> From: "manomugdha biswas" <[email-masked]>
> To: <[email-masked]>
> Sent: Saturday, May 14, 2005 12:35 AM
> Subject: [PWE3] how to distinguish VCC and VPC
> connection in ATM
> 
> 
> > Hi,
> > I want to establish an atm VCC connection between
> two
> > atm nodes and an atm vpc connection between two
> atm
> > nodes. How to do that? Now having a single atm
> > connection how can I identify this connection
> whether
> > it is a VCC or VPC connection? It will be a great
> help
> > if any one can give some light on this.
> > 
> > Regards,
> > Manomugdha
> > 
> > Manomugdha Biswas
> > 
> >
>
________________________________________________________________________
> > Yahoo! India Matrimony: Find your life partner
> online
> > Go to: http://yahoo.shaadi.com/india-matrimony
> > 
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> 

Manomugdha Biswas

________________________________________________________________________
Yahoo! India Matrimony: Find your life partner online
Go to: http://yahoo.shaadi.com/india-matrimony

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Mon, 16 May 2005 11:24:01 -0400

Hi Manomugdha,
In fact, the PE knows if the connection is a VPC or VCC through the local
configuration of the ATM PW. Also, the label mapping message it receives
from the remote PE for the Pwid associated with that configuration will also
indicate a different code point for VPC or VCC PW types in both one-to-one
and many-to-one cell mode encapsulations (see
draft-ietf-pwe3-iana-allocation-09.txt). Therefore, a PE will infer from the
PW label in a received packet whether it is a VPC or VCC.

The V bit described below is only applicable to the one-to-one cell mode
encapsulation. It is not strictly required for the proper operation of the
ATM PW as the . It is there for backward compatiblity reason. The ATM Forum
specification for ATM-MPLS network interworking allowed for a VCI
optimization mode in the case of VPs with concatenation (see Section 6.3.1
of str-aic-mpls-niwf-02.02, "ATM-MPLS Network Interworking Version 2.0").

Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
manomugdha biswas
Sent: Saturday, May 14, 2005 2:58 AM
To: Xixiang Li
Cc: [email-masked]
Subject: Re: [PWE3] how to distinguish VCC and VPC connection in ATM

Hi Xixiang,

Thanks for the reply. So after receiving encapsulated packet I can determine
the type of connection that the payload belongs to. It is fine.

Now I want to know one more thing in this context. I want to send some
payload over a VCC connection. So how to establish this VCC connection?
Similarly if I want to send packet over VPC connection then how to establish
that VPC connection?

Here my intention is to know how to establish a particular type of atm
connection (VCC or VPC)?

I can establish PVC where I have to specify both VPI adnd VCI.
---------
* V (VCI present) bit
>
>        Bit (V) of the control byte indicates whether the VCI field is
>        present in the packet. If set to 1, the VCI field is present
> for
>        the cell. If set to 0, no VCI field is present. In the case of
> a
>        VCC, the VCI field is not required. For VPC, the VCI field is
---------

According to the above statement V bit is used to indicate whether VCI field
is present for the cell. If set to 0 then no VCI field is present. So how to
establish this particular connection (VCC) and what will be the value of the
16 bits VCI field of atm cell when I will send an atm cell over this VCC
connection?

How a PE (provider Edge) distinguishes between VCC and VPC?

Please let me know?

Regards,
Manomugdha

--- Xixiang Li <[email-masked]> wrote:
> Hi Manomugdha,
>
> According to clause 9.3. ATM VCC Cell Transport Service,
> draft-ietf-pwe3-atm-encap-08.txt, there's a 'V' bit used to
> distinguish VPC and VCC cells. If 'V' is set to 1, it should be a VPC
> cell encapsulation, otherwise, a VCC cell.
> So you must check the V bit of the control word to find which type of
> connection that the payload belongs to.
>
> Please review the following text that copy-pasted from the draft.
>
>      0                                    1
>                          2
>         3
>
>                 Figure 7: Single ATM VCC Cell Encapsulation
>
>      * V (VCI present) bit
>
>        Bit (V) of the control byte indicates whether the VCI field is
>        present in the packet. If set to 1, the VCI field is present
> for
>        the cell. If set to 0, no VCI field is present. In the case of
> a
>        VCC, the VCI field is not required. For VPC, the VCI field is
> Subject: [PWE3] how to distinguish VCC and VPC connection in ATM
>
>
> > Hi,

Manomugdha Biswas