Subject: RE: [PWE3] Generic vs Preferred CW

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 5 May 2005 14:14:37 +0200

Mustapha, 

If the ONLY intention of the CW draft is to avoid
IP packet aliasing, then it should not have specified
a 4 byte CW at all. 

It should have defined a 1 nibble preamble
(OK, perhaps we could allow it to splurge 
and throw away an entire byte)
and left the rest to the encap documents.

In particular, some encap might want to use 
only one or 2 bytes of CW overhead.
If we are interested in minimizing header overhead 
why use 4 bytes and then worry about compression?

The CW draft proposes more than that -
it standardizes the PWE CW
(already grounded in the architecture RFC).
Almost all the encap drafts use the same CW anyway,
with the noncompliant ones slowly adopting it as well
(first CESoPSN and now CEP).

We should welcome the simplification proposed here,
even if it means that some old pre-standard
implementations have to be updated,
and some new suggestions have to take the
standard into account.

Y(J)S

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Thu, 5 May 2005 13:39:15 -0400

Yakov,
You are right that the CW BCP is not just about the ECMP issue. I obviously
have not re-read the introduction for some time :-)

I however do not agree with the idea of a single CW for all applications. I
know you have already proposed this, but in practice, each technology has
its own specifics. I guess we (or some other people) will have to make a
decision for each new application when it comes up.

Regards,
Mustapha.

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Thursday, May 05, 2005 8:15 AM
To: Mustapha Aissaoui; pwe3; Stewart Bryant
Subject: RE: [PWE3] Generic vs Preferred CW

Mustapha,

If the ONLY intention of the CW draft is to avoid IP packet aliasing, then
it should not have specified a 4 byte CW at all.

It should have defined a 1 nibble preamble (OK, perhaps we could allow it to
splurge and throw away an entire byte) and left the rest to the encap
documents.

In particular, some encap might want to use only one or 2 bytes of CW
overhead.
If we are interested in minimizing header overhead why use 4 bytes and then
worry about compression?

The CW draft proposes more than that -
it standardizes the PWE CW
(already grounded in the architecture RFC).
Almost all the encap drafts use the same CW anyway, with the noncompliant
ones slowly adopting it as well (first CESoPSN and now CEP).

We should welcome the simplification proposed here, even if it means that
some old pre-standard implementations have to be updated, and some new
suggestions have to take the standard into account.

Y(J)S