Subject: Re: [PWE3] Generic vs Preferred CW

From: [email-masked]
Date: Wed, 4 May 2005 14:04:44 +0100

Stewart,

I also agree that option (a) is preferable. (b) appears to mandate a
specific control word format for all furture PW types.

Matthew

|---------+--------------------------->
|         |           "Andrew G.      |
|         |           Malis"          |
|         |           <andymalis@comca|
|         |           st.net>         |
|         |           Sent by:        |
|         |           pwe3-bounces@iet|
|         |           f.org           |
|         |                           |
|         |                           |
|         |           25/04/2005 15:02|
|         |                           |
|---------+--------------------------->
  >--------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                                |
  |        To:      Stewart Bryant <[email-masked]>                                                                            |
  |        cc:      "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>, pwe3 <[email-masked]>                                          |
  |        Subject: Re: [PWE3] Generic vs Preferred CW                                                                             |
  >--------------------------------------------------------------------------------------------------------------------------------|

Stewart,

I prefer option a.  There is now another draft,
http://www.ietf.org/internet-drafts/draft-ash-avt-hc-over-mpls-protocol-00.txt

, that follows the generic control word (the first four bits are 0000) but
diverges from the preferred CW.  This draft defines a new pseudowire type,
header-compressed VoIP over MPLS (voice/RTP/UDP/IP/MPLS labels).  The CW is

only one octet in length, because for this application every octet counts
and packet reordering is allowed.

Thanks,
Andy

---------

At 4/25/2005 11:56 +0100, Stewart Bryant wrote:
>I am working on -04 of the CW draft that takes into a/c
>the feedback that I have received from the list and
>AD on -03.
>
>Before I complete this I need to ask the list to
>consider the following proposed text:
>
>---------------------------------------------------------------
>
>
>3.   Generic PW MPLS Control Word
>
>    The Generic PW MPLS Control Word is shown in Figure 1.
>
>
>     0                   1                   2                   3
>     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |0 0 0 0|          Specified by PW Encapsulation                |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>          Figure 1: Generic PW MPLS Control Word
>
>
>    The PW set-up protocol or configuration mechanism determines whether
>    a PW uses a PW MPLS Control Word (PWMCW). Bits 0..3 differ from the
>    first four bits of an IP packet [BCP] and hence provide the
>    necessary MPLS payload discrimination.
>
>    When a PWMCW is used, it MUST adhere to the Generic MPLS Control
>    Word format as illustrated in Figure 1 above. It SHOULD also follow
>    the following format:
>
>
>     0                   1                   2                   3
>     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |0 0 0 0| Flags |FRG|  Length   | Sequence Number               |
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>         Figure 2: PW Preferred MPLS Control Word
>
>    The meaning of the fields of the PW Preferred MPLS Control Word
>    (Figure 2) is as follows:
>
>--------------------------------------------------------------------
>
>With the proposed changes to the CEP draft, the only encaps that do not
>use the preferred CW is ATM 1 to 1 Cell Mode AAL5 PDU Frame Mode.
>
>We therefore have two choices:
>
>a) Leave the text above and thereby leave the ambiguity as to how
>important it is to use preferred vs generic CW.
>
>b) Change the text to say that the encap MUST use the Preferred
>CW, and add exception text to the ATM draft.
>
>I think that option (b) is better, because it requires
>future encapsulations that do not adhere to the Preferred CW
>to draw attention to the technical reasons why.
>
>Views?
>
>- Stewart
>
>_______________________________________________
>pwe3 mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Wed, 4 May 2005 13:23:08 -0400

Stewart,
The CW text in the BCP seems to be causing much trouble to IESG and to some
of us. I recall the intent of this BCP was to make sure that PW packets do
not get mistaken for IPv4 and IPv6 packets by routers performing ECMP or
some other load-balancing. The proposed rule is to add a CW with a "0000" or
"0001" in the first nibble. This is all covered by the Generic control word
and all PW applications should adhere to this. The BCP should care less how
to code the remaining fields in the CW.

What is referred to as the "preferred" control word is an example of a CW
which adheres to the BCP and which is also used by most PW encapsulations
today. We do not know it will be a good fit in the future and the BCP has no
business into specifying what bits a specific PW application should be
using. As an example, the MPLS BCP, i.e., draft-ietf-mpls-ecmp-bcp-00.txt,
only mandates what values the first nibble of the payload should use (or not
use). Nothing more, nothing less.

I am thus proposing the following text to go into Section 3. Comments are
welcome.

    0                   1                   2                   3

   When a PWMCW is used, it MUST adhere to the Generic MPLS Control
   Word format as illustrated in Figure 1 above. An example of a compliant
   CW is shown in Figure 2. This CW is used by most PW encpasulations today.

    0                   1                   2                   3

Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, May 04, 2005 9:05 AM
To: Andrew G. Malis
Cc: [email-masked]; Ash, Gerald R (Jerry), ALABS; pwe3; Stewart
Bryant
Subject: Re: [PWE3] Generic vs Preferred CW

Stewart,

Matthew

>---------------------------------------------------------------------------
-----------------------------------------------------|
  |
|
  |        To:      Stewart Bryant <[email-masked]>
|
  |        cc:      "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>, pwe3
<[email-masked]>                                          |
  |        Subject: Re: [PWE3] Generic vs Preferred CW
|

>---------------------------------------------------------------------------
-----------------------------------------------------|

Stewart,

I prefer option a.  There is now another draft,
http://www.ietf.org/internet-drafts/draft-ash-avt-hc-over-mpls-protocol-00.t
xt

Thanks,
Andy

---------

At 4/25/2005 11:56 +0100, Stewart Bryant wrote:
>I am working on -04 of the CW draft that takes into a/c the feedback
>that I have received from the list and AD on -03.
>
>Before I complete this I need to ask the list to consider the following
>proposed text:
>
>b) Change the text to say that the encap MUST use the Preferred CW, and
>add exception text to the ATM draft.
>
>I think that option (b) is better, because it requires future
>encapsulations that do not adhere to the Preferred CW to draw attention
>to the technical reasons why.
>
>Views?
>
>- Stewart
>

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Wed, 4 May 2005 13:34:07 -0400

All,
The title of Figure 2 below should read:

"Figure 2: Example of a compliant MPLS Control Word"

Regards,
Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Mustapha Aissaoui
Sent: Wednesday, May 04, 2005 1:23 PM
To: 'pwe3'; 'Stewart Bryant'
Cc: [email-masked]
Subject: RE: [PWE3] Generic vs Preferred CW

Stewart,

    0                   1                   2                   3

    0                   1                   2                   3

Mustapha.

-----Original Message-----

Stewart,

Matthew

Stewart,

Thanks,
Andy

---------

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 05 May 2005 13:11:45 +0100

Mustapha Aissaoui wrote:
> Stewart,
> The CW text in the BCP seems to be causing much trouble to IESG 

Are you referring to
draft-ietf-mpls-ecmp-bcp-00
or
draft-ietf-pwe3-cw-03

I assume the latter.

I am not aware that this is "causing much trouble to IESG", I have
just seen the usual level of AD review comments.

> and to some

It has been shown that the common spec works for all of the encaps
that we have so far designed. There was no TECHNICAL reason why all the
ATM modes could not have adopted it. The only remaining encapsulation is
the one being worked on in AVT, and that has the additional criteria
that they are applying extreme compression.

There seems to be consensus for option (a) - essentially the original
text.

This does not prevent any encap from choosing a different approach, but
it does make the designers think very carefully about why they NEED
to do something different and then to make them explain that need.

> use). Nothing more, nothing less.

That draft is doing a different job. It is specifying how to avoid
ECMP in an MPLS network.

This draft is setting out the recommended CW for a suite of PW types.

>   The Generic PW MPLS Control Word is shown in Figure 1.

I am not sure what is to be gained by making it an example. It
is the format that we have agreed on for all of the encaps.
If a good technical reason exists to do something else, then
the designers simply have to explain why.

I would like to close on option (a).

Do we have consensus for that.

- Stewart

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Thu, 5 May 2005 13:33:06 -0400

Stewart,
Yes I support option (a) as per my email to this list a week or so ago. I am
acutally the one who provided the modifications to the the text in Section 3
to address the IESG comment. I thought this was all agreed to until I saw an
option (b) popping out. That what made me think this is still causing
trouble.

Hopefully, we are now closing on this once for all.

Regards,
Mustapha.

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]]
Sent: Thursday, May 05, 2005 8:12 AM
To: Mustapha Aissaoui
Cc: 'pwe3'; [email-masked]
Subject: Re: [PWE3] Generic vs Preferred CW

Are you referring to

I assume the latter.

I am not aware that this is "causing much trouble to IESG", I have just seen
the usual level of AD review comments.

> and to some
> of us. I recall the intent of this BCP was to make sure that PW
> packets do not get mistaken for IPv4 and IPv6 packets by routers
> performing ECMP or some other load-balancing. The proposed rule is to
> add a CW with a "0000" or "0001" in the first nibble. This is all
> covered by the Generic control word and all PW applications should
> adhere to this. The BCP should care less how to code the remaining fields
in the CW.

It has been shown that the common spec works for all of the encaps that we
have so far designed. There was no TECHNICAL reason why all the ATM modes
could not have adopted it. The only remaining encapsulation is the one being
worked on in AVT, and that has the additional criteria that they are
applying extreme compression.

There seems to be consensus for option (a) - essentially the original text.

This does not prevent any encap from choosing a different approach, but it
does make the designers think very carefully about why they NEED to do
something different and then to make them explain that need.

>
> What is referred to as the "preferred" control word is an example of a
> CW which adheres to the BCP and which is also used by most PW
> encapsulations today. We do not know it will be a good fit in the
> future and the BCP has no business into specifying what bits a
> specific PW application should be using. As an example, the MPLS BCP,
> i.e., draft-ietf-mpls-ecmp-bcp-00.txt, only mandates what values the
> first nibble of the payload should use (or not use). Nothing more, nothing
less.

That draft is doing a different job. It is specifying how to avoid ECMP in
an MPLS network.

>
> I am thus proposing the following text to go into Section 3. Comments
> are welcome.
>

I am not sure what is to be gained by making it an example. It is the format
that we have agreed on for all of the encaps.
If a good technical reason exists to do something else, then the designers
simply have to explain why.

- Stewart

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> , that follows the generic control word (the first four bits are 0000)
> but diverges from the preferred CW.  This draft defines a new
> pseudowire type, header-compressed VoIP over MPLS
> (voice/RTP/UDP/IP/MPLS labels).  The CW is
>
> only one octet in length, because for this application every octet
> counts and packet reordering is allowed.
>
> Thanks,
> Andy
>
> ---------
>
>>Before I complete this I need to ask the list to consider the
>>following proposed text:
>>
>>With the proposed changes to the CEP draft, the only encaps that do
>>not use the preferred CW is ATM 1 to 1 Cell Mode AAL5 PDU Frame Mode.
>>
>>b) Change the text to say that the encap MUST use the Preferred CW,
>>and add exception text to the ATM draft.
>>
>>encapsulations that do not adhere to the Preferred CW to draw
>>attention to the technical reasons why.
>>
>>Views?
>>
>>- Stewart
>>

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 05 May 2005 13:39:55 -0400

> just seen the usual level of AD review comments.

As far as I know, Thomas and I are the only current or recent ex-officio IESG 
members to have reviewed this text thus far. Once the WG decides on this and 
produces an updated spec, I will take it to the IESG at large for comment as 
rapidly as possible.

- Mark

>> packets do
>> but

---

From: "Mustapha Aissaoui" <[email-masked]>
Date: Thu, 5 May 2005 13:44:13 -0400

Mark,
My apologies. The comments about Section 3 came from the AD. I just
confirmed this by going through my archive of mails.

Mustapha.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of W.
Mark Townsley
Sent: Thursday, May 05, 2005 1:40 PM
To: Stewart Bryant
Cc: 'pwe3'; Mustapha Aissaoui; [email-masked]
Subject: Re: [PWE3] Generic vs Preferred CW

> just seen the usual level of AD review comments.

As far as I know, Thomas and I are the only current or recent ex-officio
IESG members to have reviewed this text thus far. Once the WG decides on
this and produces an updated spec, I will take it to the IESG at large for
comment as rapidly as possible.

- Mark

>> adhere to this. The BCP should care less how to code the remaining
>> fields in the CW.
>
>
> that we have so far designed. There was no TECHNICAL reason why all
> the ATM modes could not have adopted it. The only remaining
> encapsulation is the one being worked on in AVT, and that has the
> additional criteria that they are applying extreme compression.
>
> This does not prevent any encap from choosing a different approach,
> but it does make the designers think very carefully about why they
> NEED to do something different and then to make them explain that need.
>
>>
>> What is referred to as the "preferred" control word is an example of
>> a CW which adheres to the BCP and which is also used by most PW
>> first nibble of the payload should use (or not use). Nothing more,
>> nothing less.
>
>
> I am not sure what is to be gained by making it an example. It is the
> format that we have agreed on for all of the encaps.
> If a good technical reason exists to do something else, then the
> designers simply have to explain why.
>
>>
>>     0                   1                   2                   3
>> Cc: [email-masked]; Ash, Gerald R (Jerry), ALABS; pwe3;
>> Stewart Bryant
>>> -------
>>> -------
>> , that follows the generic control word (the first four bits are
>> 0000) but diverges from the preferred CW.  This draft defines a new

---

From: Luca Martini <[email-masked]>
Date: Fri, 06 May 2005 00:04:45 -0600

> Do we have consensus for that.
Yes. I agree with adopting option (a) as well. Now let's see what 
comments we get from the IESG. I am sure they will have an opinion ;-)

Luca