Subject: RE: [PWE3] Generic vs Preferred CW

From: "Yaakov Stein" <[email-masked]>
Date: Fri, 6 May 2005 13:45:53 +0200

Mustapha,  

> Yakov,
> You are right that the CW BCP is not just about the ECMP 
> issue. I obviously have not re-read the introduction for some time :-)

OK, we agree on the first point.

> I however do not agree with the idea of a single CW for all 
> applications. I know you have already proposed this, but in 
> practice, each technology has its own specifics. 

I can't agree more.
That's why the generic CW has te flag fields left for the "specifics".

To date there have only been 2 encap-dependent requirements
for the CW, namely flags (notably the defect flags in the TDM drafts
and the FECN/BECN flags in the FR draft) and pointers
(in the CEP draft).

Can you think of anything else that may be required 
that can not be supplied by the generic CW?

> I guess we 
> (or some other people) will have to make a decision for each 
> new application when it comes up.

But now we come to my second point, namely standardization.

Sure, maybe someone prefers some rearrangement of the fields,
or some other bit allocation. But the reason we need the IETF 
and PWE is to reach agreement / compromise on these issues.

Would you want the IP header to have the precise position of
the source address dependent on what the packet is carrying?
Why shouldn't the content of an MPLS packet determine
how many bits the label has?

Y(J)S

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: [email-masked]
Date: Fri, 6 May 2005 12:23:46 +0100

Yaakov,

See below.

Thanks,

Matthew

                      "Yaakov Stein"                                                                                                   
                      <[email-masked]         To:      [email-masked], "pwe3" <[email-masked]>, "Stewart Bryant"        
                      m>                       <[email-masked]>                                                                    
                      Sent by:                 cc:                                                                                     
                      pwe3-bounces@iet         Subject: RE: [PWE3] Generic vs Preferred CW                                             
                      f.org                                                                                                            

                      06/05/2005 12:45                                                                                                 

Mustapha,

I can't agree more.

MB> I think you mean the preferred CW.

MB> The context / semantics of the flags field is completely dependent on
the type of the PW. This is true for the length field as well. All this CW
does is provide a template. This is not a complete specification of the CW,
and cannot be if we insist on putting client information in the CW.

MB> And I believe that option (a) is a reasonable compromise that
recognises the fact that different current and future PW types may have
different requirements on the CW, while providing sufficient guidance that
future types should follow a common template.

MB> How is that relevant? the interpretation of the values in the CW is
dependent on the PW type.

MB>

Y(J)S

---

From: "Yaakov Stein" <[email-masked]>
Date: Fri, 6 May 2005 17:40:00 +0200

> A 1 size fits all approach is just silly, and 
> its no wonder folks will want to deviate from it.
> 
> The analogy for application adaptations into IP would be to 
> say that we don't actually need UDP (with/without RTP for 
> some cases) and TCP, so let's just define 1 adaptation that 
> will fit everything...why not, its exactly the same argument? 
>  The answer here of course is easy to see:
> Applications can be generally grouped into either messages, 
> files or streams, and their functional adaptation 
> requirements are clearly different.....so its pretty obvious 
> a single adaptation will be rather silly as some functional 
> fields will be turned-off for certain application types.

Neil, 

I think you summed up the point rather well,
but I will twist it around a bit.

There is an obvious difference between CO MPLS
and CL IP networks, and thus performance, 
defect handling, etc will all be impacted.

But most characteristics of the adaptation,
(and hence the encapsulation format) depend on
the application (read: client layer) and not on the 
infrastructure (read: server layer).
That's why the different PW types use the PW control
word somewhat differently (e.g. for some the sequence number
is MANDATORY while for others it is OPTIONAL;
some define various flags, etc).

Thus we COULD define different encapsulations,
if we wanted to stress the fact that one server layer is CO
and the other CL, but the differences would only be syntactical,
not semantic. For example, the L2TPv3 PW headers 
and the PWE ones are very different syntactically,
but share the same functionality (e.g. flow demux indicator, 
optional sequencing, various bits to represent the client's
state, etc)

But why SHOULD we use different syntax?
It certainly seems like a useful simplification,
just as standardized drivers or APIs are used in software engineering
to allow the same application to run over different hardware platforms, 
which admittedly may have completely different capabilities.

Y(J)S