Subject: Re: [Qirg] Qirg Digest, Vol 12, Issue 19

From: gyananjay rai <[email-masked]>
Date: Sat, 16 Mar 2019 01:48:55 +0530

Hi Rod ,

I am curious to know why the communication (Bell pair destributiion)
Is limited to link layer. Even though non cloning theorem ,qubit non
transmission and QKD omit a private and public network demarcation ,vlan
communication and security issue and routing requisites but what mechanisms
we have to handle topological complexity,quantum network demarcation. Does
destributed quantum computing ,intiator -responder will be evolved as
universal single destributed quantum network .But still intiator and
responder destributed arrangement need to have distinct demarcation. I feel
here the layer 3 introduction is necessary where protocols similar to BGP
can facilitate bell pair destributiion. Alternatively same can be
facilitated in layer 2.

My perpective is bell pair destributiion at earth and space are
heterogeneous and have different characteristics hence it should be at
network level .Faiciltating Bell pair destributiion within earth atmosphere
and in space (vacumn) is the reason....Super conducture and photons behave
differently

Sincerely
Gyananjay

On Sat, 16 Mar 2019, 00:32 , <[email-masked]> wrote:

> Send Qirg mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.irtf.org/mailman/listinfo/qirg
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Qirg digest..."
> Today's Topics:
>
>    1. Re: agenda (Rodney Van Meter)
>
>
>
> ---------- Forwarded message ----------
> From: Rodney Van Meter <[email-masked]>
> To: Gelard Patrick <[email-masked]>
> Cc: Rodney Van Meter <[email-masked]>, Wojciech Kozlowski <
> [email-masked]>, "[email-masked]" <[email-masked]>
> Bcc:
> Date: Fri, 15 Mar 2019 21:24:08 +0900
> Subject: Re: [Qirg] agenda
> An interesting question we have waffled about in our design is whether the
> satellite (or any entangled photon pair source, which we call an EPPS) is
> part of the link, or a node visible at the network level.  Our current
> stance is that it’s only part of the link, and can’t be addressed in (e.g.)
> our connection setup process.  It’s handled instead by a link-layer
> protocol. Why? Because nodes farther away than the ones receiving those
> photons never need to send a message to the EPPS.
>
> There are three major link timing regimes:
> * meet-in-the-middle, which we call M—>I<—M, memory—>interference<—memory
> or MIM
> * sender-receiver, which we call memory—>memory or MM
> * midpoint source, which we call memory<—source—>memory or MSM
>
> Cody Jones et al. (at least one of “al.” is on this list, I believe) did
> some great analysis on MSM links.
> https://arxiv.org/abs/1505.01536
>
> —Rod
>
>
> On Mar 15, 2019, at 7:35 PM, Gelard Patrick <[email-masked]>
> wrote:
>
> Thanks for your clarification.
>
> I was aiming at the scenario where low-earth orbit satellites are equipped
> with entangled photon sources.
>
> /Patrick
>
> -----Message d'origine-----
> De : Wojciech Kozlowski <[email-masked]>
> Envoyé : vendredi 15 mars 2019 10:21
> À : Gelard Patrick <[email-masked]>; [email-masked]
> Objet : Re: [Qirg] agenda
>
> Hi Patrick,
>
> Thanks for the feedback!
>
> I think the repeater<->satellite<->repeater chain can be abstracted as one
> link, not two, which means the satellite is not a node in a network (as it
> doesn't run a network stack). The satellite in that case would just be part
> of the link. Based on the paper you sent, that seems what the authors are
> doing as well.
>
> The definition of a link should be clarified in the draft to account for
> this. It is worth pointing out that even some "earthly" Bell Pair
> generation strategies also require a station at the mid-point as well even
> when just using optical fibres.
>
> Thanks,
> Wojtek
>
> On 14/03/2019 16:38, Gelard Patrick wrote:
>
> Hi Wojtek
>
> Very interesting draft.
>
> I have a little comment..
>
> You wrote :
>
> - “The key message here is that a network stack relies on the hardware
> being able to provide two services: Bell Pair generation across a link, and
> swap operation. In any network model it is assumed that the physical device
> is capable of providing both of these services and offers a suitable
> interface for their usage.”
>
> It may also be appropriate to separate these two functions (Bell Pair
> generation and swap operation ). I am thinking, for example, of the
> scenario where the generation of Bell pairs would be done by a satellite
> and the swap by ground nodes ( https://arxiv.org/abs/1410.5384 ).
>
>
> Thanks
> /Patrick
> De : Qirg <[email-masked]> De la part de Wojciech Kozlowski
> Envoyé : samedi 9 mars 2019 12:55 À : [email-masked] Objet : Re: [Qirg]
> agenda
>
> Hi all,
>
> I would like to add an item to the agenda.
>
> I would like to start work as a group on the first work item in the
> charter:
>
> An architectural framework delineating network node roles and definitions,
> to build a common vocabulary and serve as the first step toward a quantum
> network architecture.
>
> To start this I have just submitted a draft called "Architectural
> Principles for a Quantum Internet"
> https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/. The goal of
> the draft is to start this discussion. It consists of three parts:
> 1. An introduction to quantum information - my goal was to make this
> document self-contained so that people with no quantum background can
> understand it and make a contribution to the discussion. The introduction
> is brief and will not replace a proper tutorial (such as the one organised
> by Rodney and Tracy), but it should cover the basic concepts and how they
> fit together.
> 2. A brief review and summary of the current state of quantum networks. It
> introduces concepts such as Bell Pairs and entanglement swapping and how
> the pieces fit together.
> 3. I propose a set of goals and principles for the architecture. The goals
> define what a successful architecture achieves and the principles are
> guidelines to achieve it. This is the key point of the draft and the one
> that is up for discussion.
> I would also like to add that one other goal of this draft is to engage
> the classical networking people just like the tutorial organised by Rodney
> and Tracy.
> This draft is merely my attempt to start a discussion and I would very
> much like to see many iterations and would be very happy to see as many
> people contribute as possible and anyone should feel free to contribute.
> Any feedback now or at the meeting itself is more than welcome!
> Thanks,
> Wojtek
> On 09/03/2019 02:55, Rodney Van Meter wrote:
> Folks,
>
> We have a two-hour tutorial Monday 1610-1810.  Tracy Northup and I are
> handling that.
>
> I’m behind in getting the agenda put together for the upcoming RG meeting.
> The research group meeting will be 1120-1220 on Tuesday of IETF week.
> Agenda items?
>
> https://datatracker.ietf.org/meeting/104/agenda.html
>
> —Rod
>
>
>
> _______________________________________________
> Qirg mailing list
> mailto:[email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>

---

From: Rodney Van Meter <[email-masked]>
Date: Sat, 16 Mar 2019 13:10:45 +0900

> On Mar 16, 2019, at 5:18 AM, gyananjay rai <[email-masked]> wrote:
> 
> Hi Rod ,
> 
> Is limited to link layer.

*Physical* distribution of entanglement is inherently limited to the link layer.  The definition of link layer, in fact, can be “an organized structure for communicating across a physical channel capable of carrying an optical qubit state” or something like that.

Using entanglement swapping, entanglement is extended across multiple hops.

> Even though non cloning theorem ,qubit non transmission and QKD omit a private and public network demarcation ,vlan communication and security issue and routing requisites but what mechanisms we have to handle topological complexity,quantum network demarcation. Does destributed quantum computing ,intiator -responder will be evolved as universal single destributed quantum network .But still intiator and responder destributed arrangement need to have distinct demarcation. I feel here the layer 3 introduction is necessary where protocols similar to BGP can facilitate bell pair destributiion. Alternatively same can be facilitated in layer 2.

This connection setup is for setting up the control information used to build multi-hop entanglement.  This is definitely Layer 3/4 stuff.

This is akin to the 3-way TCP handshake, philosophically.

> 
> 
> 
> My perpective is bell pair destributiion at earth and space are heterogeneous and have different characteristics hence it should be at network level .Faiciltating Bell pair destributiion within earth atmosphere and in space (vacumn) is the reason....Super conducture and photons behave differently
> 
> 
> 
> Sincerely 
> Gyananjay 
> 
> On Sat, 16 Mar 2019, 00:32 , <[email-masked] <mailto:[email-masked]>> wrote:
>         [email-masked] <mailto:[email-masked]>
> 
>         https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>
>         [email-masked] <mailto:[email-masked]>
> 
>         [email-masked] <mailto:[email-masked]>
> 
> From: Rodney Van Meter <[email-masked] <mailto:[email-masked]>>
> To: Gelard Patrick <[email-masked] <mailto:[email-masked]>>
> Cc: Rodney Van Meter <[email-masked] <mailto:[email-masked]>>, Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Bcc: 
> An interesting question we have waffled about in our design is whether the satellite (or any entangled photon pair source, which we call an EPPS) is part of the link, or a node visible at the network level.  Our current stance is that it’s only part of the link, and can’t be addressed in (e.g.) our connection setup process.  It’s handled instead by a link-layer protocol. Why? Because nodes farther away than the ones receiving those photons never need to send a message to the EPPS.
> 
> * meet-in-the-middle, which we call M—>I<—M, memory—>interference<—memory or MIM
> Cody Jones et al. (at least one of “al.” is on this list, I believe) did some great analysis on MSM links.
> https://arxiv.org/abs/1505.01536 <https://arxiv.org/abs/1505.01536>
> 
> —Rod
> 
> 
>> On Mar 15, 2019, at 7:35 PM, Gelard Patrick <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> I was aiming at the scenario where low-earth orbit satellites are equipped with entangled photon sources.
>> 
>> /Patrick
>> 
>> De : Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>> 
>> À : Gelard Patrick <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>> I think the repeater<->satellite<->repeater chain can be abstracted as one link, not two, which means the satellite is not a node in a network (as it doesn't run a network stack). The satellite in that case would just be part of the link. Based on the paper you sent, that seems what the authors are doing as well.
>> 
>> The definition of a link should be clarified in the draft to account for this. It is worth pointing out that even some "earthly" Bell Pair generation strategies also require a station at the mid-point as well even when just using optical fibres.
>> 
>> Thanks,
>> Wojtek
>> 
>>> 	- “The key message here is that a network stack relies on the hardware being able to provide two services: Bell Pair generation across a link, and swap operation. In any network model it is assumed that the physical device is capable of providing both of these services and offers a suitable interface for their usage.”
>>> 
>>> It may also be appropriate to separate these two functions (Bell Pair generation and swap operation ). I am thinking, for example, of the scenario where the generation of Bell pairs would be done by a satellite and the swap by ground nodes ( https://arxiv.org/abs/1410.5384 <https://arxiv.org/abs/1410.5384> ).
>>> 
>>> 
>>> Thanks
>>> /Patrick
>>> De : Qirg <[email-masked] <mailto:[email-masked]>> De la part de Wojciech Kozlowski 
>>> Envoyé : samedi 9 mars 2019 12:55 À : [email-masked] <mailto:[email-masked]> Objet : Re: [Qirg] 
>>> agenda
>>> 
>>> Hi all,
>>> 
>>> I would like to start work as a group on the first work item in the charter:
>>> 
>>> An architectural framework delineating network node roles and definitions, to build a common vocabulary and serve as the first step toward a quantum network architecture.
>>> 
>>> To start this I have just submitted a draft called "Architectural Principles for a Quantum Internet" https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/ <https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/>. The goal of the draft is to start this discussion. It consists of three parts:
>>> 1. An introduction to quantum information - my goal was to make this document self-contained so that people with no quantum background can understand it and make a contribution to the discussion. The introduction is brief and will not replace a proper tutorial (such as the one organised by Rodney and Tracy), but it should cover the basic concepts and how they fit together.
>>> 2. A brief review and summary of the current state of quantum networks. It introduces concepts such as Bell Pairs and entanglement swapping and how the pieces fit together.
>>> 3.. I propose a set of goals and principles for the architecture. The goals define what a successful architecture achieves and the principles are guidelines to achieve it. This is the key point of the draft and the one that is up for discussion.
>>> I would also like to add that one other goal of this draft is to engage the classical networking people just like the tutorial organised by Rodney and Tracy.
>>> This draft is merely my attempt to start a discussion and I would very much like to see many iterations and would be very happy to see as many people contribute as possible and anyone should feel free to contribute. Any feedback now or at the meeting itself is more than welcome!
>>> Thanks,
>>> Wojtek
>>> We have a two-hour tutorial Monday 1610-1810.  Tracy Northup and I are handling that.
>>> 
>>> I’m behind in getting the agenda put together for the upcoming RG meeting. The research group meeting will be 1120-1220 on Tuesday of IETF week.  Agenda items?
>>> 
>>> https://datatracker.ietf.org/meeting/104/agenda.html <https://datatracker.ietf.org/meeting/104/agenda.html>
>>> 
>>> —Rod
>>> 
>>> 
>>> 
>>> mailto:[email-masked] <mailto:[email-masked]>
>>> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>
>>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>

---

From: Patrick Gelard <[email-masked]>
Date: Sat, 16 Mar 2019 08:31:40 +0100

It seems to me that the entanglement link layer or the end to end 
entanglement build bye a "layer 3/4" connection setup gives in the final 
an entanglement link between the end point which has a limited lifetime 
due to decoherence.

I would rather make the analogy with the VXLAN service, which consists 
in building an end-to-end ethernet link (layer 2)  on an IP network 
service (layer 3).  if we add the MP-BGP control we can obtain a service 
such as  EVPN.

/Patrick
Le 16/03/2019 à 05:10, Rodney Van Meter a écrit :
>
>> On Mar 16, 2019, at 5:18 AM, gyananjay rai <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi Rod ,
>>
> *Physical* distribution of entanglement is inherently limited to the 
> link layer.  The definition of link layer, in fact, can be “an 
> organized structure for communicating across a physical channel 
> capable of carrying an optical qubit state” or something like that.
>
>> Even though non cloning theorem ,qubit non transmission and QKD omit 
>> a private and public network demarcation ,vlan communication and 
>> security issue and routing requisites but what mechanisms we have to 
>> handle topological complexity,quantum network demarcation. Does 
>> responder destributed arrangement need to have distinct demarcation. 
>> I feel here the layer 3 introduction is necessary where protocols 
>> similar to BGP can facilitate bell pair destributiion. Alternatively 
>> same can be facilitated in layer 2.
>
> This connection setup is for setting up the control information used 
> to build multi-hop entanglement.  This is definitely Layer 3/4 stuff.
>
>> heterogeneous and have different characteristics hence it should be 
>> at network level .Faiciltating Bell pair destributiion within earth 
>> atmosphere and in space (vacumn) is the reason....Super conducture 
>> and photons behave differently
>>
>>
>>
>> Sincerely
>> Gyananjay
>>
>>     Cc: Rodney Van Meter <[email-masked]
>>     <mailto:[email-masked]>>, Wojciech Kozlowski
>>     <[email-masked] <mailto:[email-masked]>>,
>>     "[email-masked] <mailto:[email-masked]>" <[email-masked]
>>     <mailto:[email-masked]>>
>>     Bcc:
>>     An interesting question we have waffled about in our design is
>>     whether the satellite (or any entangled photon pair source, which
>>     we call an EPPS) is part of the link, or a node visible at the
>>     network level.  Our current stance is that it’s only part of the
>>     link, and can’t be addressed in (e.g.) our connection setup
>>     process.  It’s handled instead by a link-layer protocol. Why?
>>     Because nodes farther away than the ones receiving those photons
>>     never need to send a message to the EPPS.
>>
>>     Cody Jones et al. (at least one of “al.” is on this list, I
>>     believe) did some great analysis on MSM links.
>>>     On Mar 15, 2019, at 7:35 PM, Gelard Patrick
>>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>>
>>>     I was aiming at the scenario where low-earth orbit satellites
>>>     are equipped with entangled photon sources.
>>>
>>>     /Patrick
>>>
>>>     À : Gelard Patrick <[email-masked]
>>>     <mailto:[email-masked]>>; [email-masked]
>>>     <mailto:[email-masked]>
>>>     I think the repeater<->satellite<->repeater chain can be
>>>     abstracted as one link, not two, which means the satellite is
>>>     not a node in a network (as it doesn't run a network stack). The
>>>     satellite in that case would just be part of the link. Based on
>>>     the paper you sent, that seems what the authors are doing as well.
>>>
>>>     The definition of a link should be clarified in the draft to
>>>     account for this. It is worth pointing out that even some
>>>     "earthly" Bell Pair generation strategies also require a station
>>>     at the mid-point as well even when just using optical fibres.
>>>
>>>     Thanks,
>>>     Wojtek
>>>
>>>>     - “The key message here is that a network stack relies on the
>>>>     hardware being able to provide two services: Bell Pair
>>>>     generation across a link, and swap operation. In any network
>>>>     model it is assumed that the physical device is capable of
>>>>     providing both of these services and offers a suitable
>>>>     It may also be appropriate to separate these two functions
>>>>     (Bell Pair generation and swap operation ). I am thinking, for
>>>>     example, of the scenario where the generation of Bell pairs
>>>>     would be done by a satellite and the swap by ground nodes (
>>>>     https://arxiv.org/abs/1410.5384 ).
>>>>
>>>>
>>>>     Thanks
>>>>     /Patrick
>>>>     De : Qirg <[email-masked]
>>>>     <mailto:[email-masked]>> De la part de Wojciech Kozlowski
>>>>     Envoyé : samedi 9 mars 2019 12:55 À : [email-masked]
>>>>     <mailto:[email-masked]> Objet : Re: [Qirg]
>>>>     agenda
>>>>
>>>>     Hi all,
>>>>
>>>>     An architectural framework delineating network node roles and
>>>>     definitions, to build a common vocabulary and serve as the
>>>>     first step toward a quantum network architecture.
>>>>
>>>>     To start this I have just submitted a draft called
>>>>     "Architectural Principles for a Quantum Internet"
>>>>     https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/.
>>>>     The goal of the draft is to start this discussion. It consists
>>>>     of three parts:
>>>>     1. An introduction to quantum information - my goal was to make
>>>>     this document self-contained so that people with no quantum
>>>>     background can understand it and make a contribution to the
>>>>     discussion. The introduction is brief and will not replace a
>>>>     proper tutorial (such as the one organised by Rodney and
>>>>     Tracy), but it should cover the basic concepts and how they fit
>>>>     together.
>>>>     2. A brief review and summary of the current state of quantum
>>>>     networks. It introduces concepts such as Bell Pairs and
>>>>     entanglement swapping and how the pieces fit together.
>>>>     3.. I propose a set of goals and principles for the
>>>>     architecture. The goals define what a successful architecture
>>>>     achieves and the principles are guidelines to achieve it. This
>>>>     is the key point of the draft and the one that is up for
>>>>     discussion.
>>>>     I would also like to add that one other goal of this draft is
>>>>     to engage the classical networking people just like the
>>>>     tutorial organised by Rodney and Tracy.
>>>>     This draft is merely my attempt to start a discussion and I
>>>>     would very much like to see many iterations and would be very
>>>>     happy to see as many people contribute as possible and anyone
>>>>     should feel free to contribute. Any feedback now or at the
>>>>     meeting itself is more than welcome!
>>>>     Thanks,
>>>>     Wojtek
>>>>     I’m behind in getting the agenda put together for the upcoming
>>>>     RG meeting. The research group meeting will be 1120-1220 on
>>>>     Tuesday of IETF week. Agenda items?
>>>>

---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus