Subject: Re: [Qirg] Qirg Digest, Vol 12, Issue 10

From: gyananjay rai <[email-masked]>
Date: Wed, 13 Mar 2019 01:26:40 +0530

Hi ,

I can perceive only classical perspective of the draft due my limitation of
deeper insight of quantum mechanics.

1.I feel the draft is concluding entire data link,network and transport
layer in to one.If that is due to the fact that the achieving quantum
communication at layer 2 on top of abstracted higher layer of classical
communication ?
2. If entanglement is layer 2 phenomenon,what is layer3...teleportation we
can think/conceptualize  of as layer 3!
3.Can we add QKD/BQC at layer 4.
4.What about TTL (Qubit)

I just tried to find some analogies.

Sincerely
Gyananjay

On Wed, 13 Mar 2019, 00:32 , <[email-masked]> wrote:

> Send Qirg mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.irtf.org/mailman/listinfo/qirg
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Qirg digest..."
> Today's Topics:
>
>    1. Link layer service draft (Axel Dahlberg)
>
>
>
> ---------- Forwarded message ----------
> From: Axel Dahlberg <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc:
> Bcc:
> Date: Tue, 12 Mar 2019 10:50:42 +0000
> Subject: [Qirg] Link layer service draft
> Hi qirgers!
>
> As mentioned in an earlier email, I would like to discuss the service of a
> link layer protocol in a Quantum Internet. To aid this discussion we
> uploaded yesterday an initial draft (
> https://datatracker.ietf.org/doc/html/draft-dahlberg-ll-quantum) that
> specifies the service and interface of such a link layer. Note that this is
> version 00 and is meant as a kickstarter for the discussion. Questions that
> would be useful to discuss during the meeting are:
>
>         1. Is the specified service the service that higher layer
> protocols and applications want and need? Is there something missing? Is
> there something redundant?
>         2. Is it feasible to implement this service on different types of
> platforms and hardware? What limitations could there be? For example some
> platforms might not support the type K (create and               keep)
> requests. Conversely, are the capabilities that some hardware supports but
> that the specified link layer service restricts? Should multi-partite
> entangled states be part of the link layer?
>         3. In the draft, what needs to be further specified/clarified?
>
> We are happy to hear any feedback, comments, questions, suggestions and
> contributions.
>
> Looking forward to seeing you all in the meeting!
>
> /Axel Dahlberg
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>

---

From: Axel Dahlberg <[email-masked]>
Date: Wed, 13 Mar 2019 10:20:47 +0000

Hello Gyananjay!

Thanks for your email! Borrowing words from the classical internet stack has both its advantages and disadvantages. In a Quantum Internet, entanglement is the fundamental building block. One needs entanglement to bridge long distances between nodes in order for them to generate entanglement and transmit qubits. In the draft we define the service of the link layer in a Quantum Internet to generate entanglement between nodes that are directly connected by a quantum channel (possibly including automated quantum repeaters). On top of the link layer there will be a network layer which uses the short distance entanglement provided by the link layer to generated entanglement between distant nodes which are not directly connected by a quantum channel. Using such long distance entanglement provided by the layer 3 network layer, one can teleport qubits between distant nodes. It is not yet clear to me if there is a need for a “qubit transport layer” on top of the network layer to perform the teleportation or if this is part of an application layer.

I hope this brings some more clarity! I’m happy to continue the discussion.

/Axel Dahlberg

On 12 Mar 2019, at 20:56, gyananjay rai <[email-masked]<mailto:[email-masked]>> wrote:

Hi ,

I can perceive only classical perspective of the draft due my limitation of deeper insight of quantum mechanics.

1.I feel the draft is concluding entire data link,network and transport layer in to one.If that is due to the fact that the achieving quantum communication at layer 2 on top of abstracted higher layer of classical communication ?
2. If entanglement is layer 2 phenomenon,what is layer3...teleportation we can think/conceptualize  of as layer 3!
3.Can we add QKD/BQC at layer 4.
4.What about TTL (Qubit)

Sincerely
Gyananjay

On Wed, 13 Mar 2019, 00:32 , <[email-masked]<mailto:[email-masked]>> wrote:
Send Qirg mailing list submissions to
        [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
        https://www.irtf.org/mailman/listinfo/qirg
or, via email, send a message with subject or body 'help' to
        [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
        [email-masked]<mailto:[email-masked]>

---------- Forwarded message ----------
From: Axel Dahlberg <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Bcc:
Date: Tue, 12 Mar 2019 10:50:42 +0000
Subject: [Qirg] Link layer service draft
Hi qirgers!

As mentioned in an earlier email, I would like to discuss the service of a link layer protocol in a Quantum Internet. To aid this discussion we uploaded yesterday an initial draft (https://datatracker.ietf.org/doc/html/draft-dahlberg-ll-quantum) that specifies the service and interface of such a link layer. Note that this is version 00 and is meant as a kickstarter for the discussion. Questions that would be useful to discuss during the meeting are:

        1. Is the specified service the service that higher layer protocols and applications want and need? Is there something missing? Is there something redundant?
        2. Is it feasible to implement this service on different types of platforms and hardware? What limitations could there be? For example some platforms might not support the type K (create and               keep) requests. Conversely, are the capabilities that some hardware supports but that the specified link layer service restricts? Should multi-partite entangled states be part of the link layer?
        3. In the draft, what needs to be further specified/clarified?

We are happy to hear any feedback, comments, questions, suggestions and contributions.

/Axel Dahlberg

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg
_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg

---

From: Gelard Patrick <[email-masked]>
Date: Wed, 13 Mar 2019 13:11:19 +0000

Hi Axel,

Does this mean that the purpose of the "link layer" you propose is to distribute entangled pairs (e. g. singlets) to quantum communication nodes via a noisy quantum optical channel ? For example this could be a satellite distributing pairs of entangled photons via FSO (Free Space Optics ) ?

Before they can be used to teleport reliably for example, the entangled pairs must be purifie (i.e converted to almost-perfectly entangled states from the mixed entangled states that result from transmission through the noisy channel). This purification can accomplish, by performing local unitary operations and measurements on the shared entangled pairs and coordinating their actions through classical messages. This  can be thought of as a “logical link Control” (The Logical Link Control (LLC) layer is one of two sublayers that make up the Data Link Layer of the https://www.webopedia.com/TERM/O/OSI.html model. The Logical Link Control layer controls frame synchronization, flow control and error checking.) ? 

Entanglement swapping would concern the network layer ?

/Patrick

De : Qirg <[email-masked]> De la part de Axel Dahlberg
Envoyé : mercredi 13 mars 2019 11:21
Cc : [email-masked]
Objet : Re: [Qirg] Qirg Digest, Vol 12, Issue 10

Hello Gyananjay! 

/Axel Dahlberg  

On 12 Mar 2019, at 20:56, gyananjay rai <mailto:[email-masked]> wrote:

Hi ,

Sincerely 
Gyananjay 

On Wed, 13 Mar 2019, 00:32 , <mailto:[email-masked]> wrote:
Send Qirg mailing list submissions to
        mailto:[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
        https://www.irtf.org/mailman/listinfo/qirg
or, via email, send a message with subject or body 'help' to
        mailto:[email-masked]

You can reach the person managing the list at
        mailto:[email-masked]

---------- Forwarded message ----------
From: Axel Dahlberg <mailto:[email-masked]>
To: "mailto:[email-masked]" <mailto:[email-masked]>
Cc: 
Bcc: 
Date: Tue, 12 Mar 2019 10:50:42 +0000
Subject: [Qirg] Link layer service draft
Hi qirgers!

/Axel Dahlberg

mailto:[email-masked]
mailto:[email-masked]

---

From: Axel Dahlberg <[email-masked]>
Date: Wed, 13 Mar 2019 13:46:40 +0000

Hello Patrick!

Note, that the definition of the service of the link layer does not specify where/if purification or distillation is performed. For some systems, purification/distillation is perhaps necessary to achieve the request fidelity, however that’s an implementation choice. Many applications of a Quantum Internet does not require “almost-perfect” entangled states, such as for example QKD, which simply requires a minimum fidelity. Thus purification/distillation can be done on different levels of the stack depending on the need.

Regarding teleportation, the fidelity of the teleported state is directly proportional to the entangled state used, thus the required fidelity of the entangled pair used for teleportation depends on the required fidelity an application has of the teleported state.

Indeed, entanglement swapping would be performed by the network layer to create long-distance entanglement from short-distance entanglement, possibly interleaved with purification/distillation.

Thanks for your input Patrick!

/Axel Dahlberg
 
> On 13 Mar 2019, at 14:11, Gelard Patrick <[email-masked]> wrote:
> 
> Hi Axel,
> 
>

---

From: Gelard Patrick <[email-masked]>
Date: Wed, 13 Mar 2019 15:15:09 +0000

Hi Axel,

Ok

	This section defines the service that a link layer provides in a quantum network.
		- Allow the initializing node to specify a desired minimum fidelity[3] and maximum waiting time.
		- If success is notified, the generated entangled pair has with high confidence higher (or equal) fidelity than the desired minimum fidelity.

You don't need a process to measure if the entanglement fidelity is >= to the desired minimum fidelity ? If so, It will be also out of the scope of the "Quantum Link layer service" ? 

Perform good quantum error correction ( https://arxiv.org/pdf/quant-ph/9606012.pdf  ) will be the responsibility of the physical layer ?

Thanks
/Patrick
-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Axel Dahlberg
Envoyé : mercredi 13 mars 2019 14:47
Cc : [email-masked]
Objet : Re: [Qirg] Qirg Digest, Vol 12, Issue 10

Hello Patrick!

/Axel Dahlberg
 
> De : Qirg <[email-masked]> De la part de Axel Dahlberg Envoyé : 
> mercredi 13 mars 2019 11:21 Cc : [email-masked] Objet : Re: [Qirg] Qirg 
> Digest, Vol 12, Issue 10
> 
> Hello Gyananjay! 
> 
> Subject: [Qirg] Link layer service draft Hi qirgers!
>

---

From: Axel Dahlberg <[email-masked]>
Date: Wed, 13 Mar 2019 15:35:55 +0000

Hi Patrick!

One cannot measure the fidelity of a single entangled pair. One can only estimate the average fidelity of a collection of entangled pairs by measure a subset of them. Of course the confidence of the estimate of the average fidelity depends on the size of the subset. We envision that the link layer will intersperse entanglement generation with test rounds to estimate the fidelity of the entangled pairs. This is both used to check if a request can be satisfied (with high confidence) and to provide an estimate of the fidelity to the higher layers which we call the “goodness”.

/Axel Dahlberg

> On 13 Mar 2019, at 16:15, Gelard Patrick <[email-masked]> wrote:
> 
> Hi Axel,
> 
> Ok
>