Subject: [Qirg] Naming and addressing in a quantum network

From: Axel Dahlberg <[email-masked]>
Date: Thu, 28 Mar 2019 11:55:15 +0000

Hi qirgers!

In the QIRG meeting on Tuesday there was some questions regarding naming and addressing in a quantum network and in particular what the “Remote Node ID” refers to in the draft draft-dahlberg-ll-quantum-01 (https://tools.ietf.org/html/draft-dahlberg-ll-quantum-01) on the service of a link layer in a quantum network. I would like to continue the discussion here on the mailing list. Any feedback or thought are highly appreciated, especially from those of you who have experience on these topics. I have knowledge about the quantum but not so much about naming and addressing.

In the draft the Remote Node ID, used in the CREATE message for requesting entanglement generation, is needed to identify the remote node which the higher layer wants to create entanglement with. This is useful if there are multiple nodes connected to a single heralding station (automated repeater) where photons can be interfered, in a star-like topology. There is also another use for the identifiers of the nodes in the network, which concern identifying entanglement. The link layer provides a sequence number for the generated entanglement contained in the OK message. However, this sequence number SEQ is only unique with respect to the link (at least during the lifetime of the entangled pair). Together with IDs of the nodes holding the entanglement (ID_A and ID_B), the higher layer can construct an entanglement identifier as (ID_A, ID_B, SEQ) which is unique in the network and can be used by an entanglement manager. Note though that this assumes that the node IDs are unique in the network.

Looking forward to your thoughts and feedback!

/Axel Dahlberg

---

From: Michele AMORETTI <[email-masked]>
Date: Thu, 28 Mar 2019 12:22:53 +0000

Dear Axel,

the naming/addressing topic is very important in networking and, personally, I like it very much.

A challenging problem is to define meaningful but compact names, that may be associated to addresses (in IP networks), although the association may not be necessary (for example, in named data networking it is not: https://named-data.net/).

In recent years I worked on this topic in the context of the Internet of Things, in collaboration with the Drakkar group of the LIG Lab (Grenoble, France).
Our proposal is described in the following paper:

M. Amoretti et al., DINAS: A Lightweight and Efficient Distributed Naming Service for All-IP Wireless Sensor Networks, IEEE Internet of Things Journal, vol. 4, no. 3, June 2017.
https://ieeexplore.ieee.org/document/7784700

In summary: use Bloom filters to derive compact binary names from a set of keywords that describe the nodes.

Cheers

Michele Amoretti, Ph.D.
Associate Professor of Computer Engineering
http://dsg.ce.unipr.it/people/michele-amoretti/
- Distributed Systems Group, Department of Engineering and Architecture
- Quantum Information Science http://www.qis.unipr.it<http://www.qis.unipr.it/>
University of Parma, Italy

________________________________
Da: Qirg <[email-masked]> per conto di Axel Dahlberg <[email-masked]>
Inviato: giovedì 28 marzo 2019 12:55
A: [email-masked]
Oggetto: [Qirg] Naming and addressing in a quantum network

Hi qirgers!

/Axel Dahlberg

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 28 Mar 2019 14:07:38 +0100

We have done a lot of work in the LISP WG on naming and addressing in the last decade. And quantum repeaters can be assigned opaque endpoint-IDs (LISP EIDs) which are independent of where they are attached to the classical network. And a LISP overlay can be used to deliver classical messages, used for Bell Pairing, among quantum nodes.

For the physics community, I suggest you do the short read of https://datatracker.ietf.org/doc/draft-ietf-lisp-introduction.

Dino

> On Mar 28, 2019, at 1:22 PM, Michele AMORETTI <[email-masked]> wrote:
> 
> Dear Axel,
> 
> - Quantum Information Science http://www.qis.unipr.it 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Axel Dahlberg <[email-masked]>
Date: Sat, 30 Mar 2019 11:03:30 +0000

Hi Michele and Dino!

Thanks a lot for your pointers for naming and addressing. I will have a look at this.

/Axel Dahlberg

________________________________
From: Qirg <[email-masked]> on behalf of Dino Farinacci <[email-masked]>
Sent: 28 March 2019 14:07:38
To: Michele AMORETTI
Cc: [email-masked]
Subject: Re: [Qirg] R: Naming and addressing in a quantum network

Dino