Subject: [Qirg] agenda

From: Rodney Van Meter <[email-masked]>
Date: Sat, 9 Mar 2019 10:55:42 +0900

Folks,

We have a two-hour tutorial Monday 1610-1810.  Tracy Northup and I are handling that.

I’m behind in getting the agenda put together for the upcoming RG meeting. The research group meeting will be 1120-1220 on Tuesday of IETF week.  Agenda items?

https://datatracker.ietf.org/meeting/104/agenda.html <https://datatracker.ietf.org/meeting/104/agenda.html>

—Rod

---

From: Axel Dahlberg <[email-masked]>
Date: Sat, 9 Mar 2019 10:06:09 +0000

Great Rodney!

I will put up a draft before the deadline on Monday defining the service and interface of a link layer for a quantum network. If there is time on the schedule I would also be happy to discuss this during the meeting on Tuesday.

See you in Prague!

/Axel Dahlberg

________________________________
From: Qirg <[email-masked]> on behalf of Rodney Van Meter <[email-masked]>
Sent: 09 March 2019 02:55:42
To: [email-masked]
Cc: Rodney Van Meter
Subject: [Qirg] agenda

Folks,

https://datatracker.ietf.org/meeting/104/agenda.html

—Rod

---

From: Shota NAGAYAMA <[email-masked]>
Date: Sat, 9 Mar 2019 19:21:11 +0900

Hi All,

I'm planning to work on "quantum ping" in the IETF Hackathon. Could I have
time to talk about this work in the QIRG meeting?

My plan is not implementing, just discussing and writing a document. What
is the abstraction of the quantum ping, what functionalities quantum ping
should have, how such functionalities should be realized in quantum plane
and classical plane, etc. Actually this is continued work from the last
IETF Hackathon with Hirotaka Nakajima and Shigeya Suzuki.
Whoever wants to join is welcome.

--Shota

On Sat, Mar 9, 2019 at 11:00 AM Rodney Van Meter <[email-masked]> wrote:

> I’m behind in getting the agenda put together for the upcoming RG meeting.
> The research group meeting will be 1120-1220 on Tuesday of IETF week.
> Agenda items?
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>

---

From: Wojciech Kozlowski <[email-masked]>
Date: Sat, 9 Mar 2019 12:54:31 +0100

Hi all,

I would like to add an item to the agenda.

I would like to start work as a group on the first work item in the charter:

/An architectural framework delineating network node roles and 
definitions, to build a common vocabulary and serve as the first step 
toward a quantum network architecture.

/To start this I have just submitted a draft called "Architectural 
Principles for a Quantum Internet" 
https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/. The goal 
of the draft is to start this discussion. It consists of three parts:

 1. An introduction to quantum information - my goal was to make this
    document self-contained so that people with no quantum background
    can understand it and make a contribution to the discussion. The
    introduction is brief and will not replace a proper tutorial (such
    as the one organised by Rodney and Tracy), but it should cover the
    basic concepts and how they fit together.
 2. A brief review and summary of the current state of quantum networks.
    It introduces concepts such as Bell Pairs and entanglement swapping
    and how the pieces fit together.
 3. I propose a set of goals and principles for the architecture. The
    goals define what a successful architecture achieves and the
    principles are guidelines to achieve it. This is the key point of
    the draft and the one that is up for discussion.

I would also like to add that one other goal of this draft is to engage 
the classical networking people just like the tutorial organised by 
Rodney and Tracy.

This draft is merely my attempt to start a discussion and I would very 
much like to see many iterations and would be very happy to see as many 
people contribute as possible and anyone should feel free to contribute. 
Any feedback now or at the meeting itself is more than welcome!

Thanks,
Wojtek

On 09/03/2019 02:55, Rodney Van Meter wrote:
> I’m behind in getting the agenda put together for the upcoming RG 
> meeting. The research group meeting will be 1120-1220 on Tuesday of 
> IETF week.  Agenda items?
>

---

From: Gelard Patrick <[email-masked]>
Date: Thu, 14 Mar 2019 15:38:49 +0000

Hi Wojtek

Very interesting draft. 

I have a little comment.. 

You wrote :

	- “The key message here is that a network stack relies on the hardware being able to provide two services: Bell Pair generation across a link, and swap operation. In any network model it is assumed that the physical device is capable of providing both of these services and offers a suitable interface for their usage.”

It may also be appropriate to separate these two functions (Bell Pair generation and swap operation ). I am thinking, for example, of the scenario where the generation of Bell pairs would be done by a satellite and the swap by ground nodes ( https://arxiv.org/abs/1410.5384 ).

Thanks
/Patrick
De : Qirg <[email-masked]> De la part de Wojciech Kozlowski
Envoyé : samedi 9 mars 2019 12:55
À : [email-masked]
Objet : Re: [Qirg] agenda

Hi all,

An architectural framework delineating network node roles and definitions, to build a common vocabulary and serve as the first step toward a quantum network architecture.

To start this I have just submitted a draft called "Architectural Principles for a Quantum Internet" https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/. The goal of the draft is to start this discussion. It consists of three parts:
1. An introduction to quantum information - my goal was to make this document self-contained so that people with no quantum background can understand it and make a contribution to the discussion. The introduction is brief and will not replace a proper tutorial (such as the one organised by Rodney and Tracy), but it should cover the basic concepts and how they fit together.
2. A brief review and summary of the current state of quantum networks. It introduces concepts such as Bell Pairs and entanglement swapping and how the pieces fit together.
3. I propose a set of goals and principles for the architecture. The goals define what a successful architecture achieves and the principles are guidelines to achieve it. This is the key point of the draft and the one that is up for discussion.
I would also like to add that one other goal of this draft is to engage the classical networking people just like the tutorial organised by Rodney and Tracy.
This draft is merely my attempt to start a discussion and I would very much like to see many iterations and would be very happy to see as many people contribute as possible and anyone should feel free to contribute. Any feedback now or at the meeting itself is more than welcome!
Thanks,
Wojtek
On 09/03/2019 02:55, Rodney Van Meter wrote:
Folks, 

—Rod

mailto:[email-masked]

---

From: Wojciech Kozlowski <[email-masked]>
Date: Fri, 15 Mar 2019 10:21:24 +0100

Hi Patrick,

Thanks for the feedback!

I think the repeater<->satellite<->repeater chain can be abstracted as 
one link, not two, which means the satellite is not a node in a network 
(as it doesn't run a network stack). The satellite in that case would 
just be part of the link. Based on the paper you sent, that seems what 
the authors are doing as well.

The definition of a link should be clarified in the draft to account for 
this. It is worth pointing out that even some "earthly" Bell Pair 
generation strategies also require a station at the mid-point as well 
even when just using optical fibres.

Thanks,
Wojtek

---

From: Gelard Patrick <[email-masked]>
Date: Fri, 15 Mar 2019 10:35:08 +0000

Thanks for your clarification. 

I was aiming at the scenario where low-earth orbit satellites are equipped with entangled photon sources.

/Patrick

-----Message d'origine-----
De : Wojciech Kozlowski <[email-masked]> 
Envoyé : vendredi 15 mars 2019 10:21
À : Gelard Patrick <[email-masked]>; [email-masked]
Objet : Re: [Qirg] agenda

Hi Patrick,

Thanks for the feedback!

I think the repeater<->satellite<->repeater chain can be abstracted as one link, not two, which means the satellite is not a node in a network (as it doesn't run a network stack). The satellite in that case would just be part of the link. Based on the paper you sent, that seems what the authors are doing as well.

The definition of a link should be clarified in the draft to account for this. It is worth pointing out that even some "earthly" Bell Pair generation strategies also require a station at the mid-point as well even when just using optical fibres.

Thanks,
Wojtek

On 14/03/2019 16:38, Gelard Patrick wrote:
> Envoyé : samedi 9 mars 2019 12:55 À : [email-masked] Objet : Re: [Qirg] 
> agenda
>
> Hi all,
>

---

From: Rodney Van Meter <[email-masked]>
Date: Fri, 15 Mar 2019 21:24:08 +0900

An interesting question we have waffled about in our design is whether the satellite (or any entangled photon pair source, which we call an EPPS) is part of the link, or a node visible at the network level.  Our current stance is that it’s only part of the link, and can’t be addressed in (e.g.) our connection setup process.  It’s handled instead by a link-layer protocol. Why? Because nodes farther away than the ones receiving those photons never need to send a message to the EPPS.

There are three major link timing regimes:
* meet-in-the-middle, which we call M—>I<—M, memory—>interference<—memory or MIM
* sender-receiver, which we call memory—>memory or MM
* midpoint source, which we call memory<—source—>memory or MSM

Cody Jones et al. (at least one of “al.” is on this list, I believe) did some great analysis on MSM links.
https://arxiv.org/abs/1505.01536 <https://arxiv.org/abs/1505.01536>

—Rod

> On Mar 15, 2019, at 7:35 PM, Gelard Patrick <[email-masked]> wrote:
>