Subject: [Qirg] document status

From: Rodney Van Meter <[email-masked]>
Date: Tue, 26 Mar 2019 15:41:02 +0100

Thanks for a very successful meeting today.  There were excellent comments/questions from the floor that will really advance the documents, which will have a positive impact on the embryonic networks that people are building today.

Here’s what I think the current document status is.  n.b.: of course
the official status is in
https://datatracker.ietf.org/group/qirg/documents/, this is a snapshot
for discussion and FYI.

I was concerned about having screwed up the naming of several I-Ds, but we’re in good shape.

RG drafts:

1. Architectural Principles for a Quantum Internet
   draft-irtf-qirg-principles-00
   status: adopted as an RG work item in the meeting 2019/3/26
   (status was already "adopted" in datatracker, so we confirmed that)
   No objections?
   (Because we adopted the draft, the current I-D name is fine.)
   Wojciech is currently the only author, but numerous hands went up
   in the session today when asked if they would contribute to such a
   document.  I expect this will go forward and that those who
   contribute substantially will be added as authors of the document.
   (In the pleasant hypothetical where a lot of people contribute,
   we'll reorganize a bit into "editor(s)" and "contributors".)

Individual drafts:

1. Advertising Entanglement Capabilities in Quantum Networks
   draft-kaws-qirg-advent-02
   status: active individual submission
   I haven't talked to the authors directly, but this I-D jumped to
   -02 *today*.  Can the authors comment on what the changes are to
   the document, and how they want to proceed?

2. The Link Layer service in a Quantum Internet
   draft-dahlberg-ll-quantum-01
   status: active individual submission
   This I-D moved to -01 *today*.  Axel, can you comment on what
   changed between -00 and -01?  There were *excellent* questions
   today that I'm sure will drive some interesting design decisions,
   especially around identifiers for nodes.  (Not that _anyone_ in
   IETF *ever* has an opinion about a naming/identifier/locator
   architecture...)

3. Connection Setup in a Quantum Network
   draft-van-meter-qirg-quantum-connection-setup-00
   status: active individual submission
   This is what our current Quantum Internet simulator *does*, in
   terms of the content of messages exchanged.  As it moves to
   implementation for a real network, those messages could be carried
   over a variety of mechanisms.  We're happy to have feedback on
   relevant protocols that might be amenable to extensions for this.

—Rod

---

From: Axel Dahlberg <[email-masked]>
Date: Tue, 26 Mar 2019 15:23:22 +0000

Hi Rodney! Thanks for organizing the meeting. Was very interesting and useful!

Regarding the changes from 00 to 01 of the link layer draft. The only difference is that I've updated the link to our link layer paper on arXiv.

/Axel Dahlberg

________________________________
From: Qirg <[email-masked]> on behalf of Rodney Van Meter <[email-masked]>
Sent: 26 March 2019 15:41:02
To: [email-masked]
Cc: Rodney Van Meter
Subject: [Qirg] document status

RG drafts:

Individual drafts:

—Rod

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

---

From: Melchior Aelmans <[email-masked]>
Date: Wed, 27 Mar 2019 11:00:00 +0100

Hi Rod,

>    the document, and how they want to proceed?

This was me making a mistake. It is fixed now again. There should have been
only one comment added: "It could be worth investigating the use of a
distance-vector routing protocol to limit flooding." but I removed one
author as well.
I've just uploaded a new version.
Let me follow-up with the co-authors to see what the next steps are.

Regards,
Melchior

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 27 Mar 2019 14:08:58 +0100

This whole area is new to me, so it's quite likely my question has already
been thought about.

My understanding is that the goal of quantum networking is to create (and
possibly manage) entangled qubits.  Each entangled qubit is an object that
exists in precisely two locations at any point in time, and has other
properties (in particular fidelity).

I am wondering why we are trying to map classical networking concepts like
"quantum connections" and packet store+forward onto this problem domain.
Has anyone looked at using a different framework (for instance content
defined networking)?  It might be a more natural starting point.

Also, I am thinking that it might be useful to construct a data model that
shows how entangled qubits are created, moved, destroyed, etc. This could
also show any physics constraints (for instance, cases where bits need to
be transported on the quantum link). The tutorial shows some of this, but I
think it is incomplete.

Stephen

---

From: Wojciech Kozlowski <[email-masked]>
Date: Wed, 27 Mar 2019 14:32:02 +0100

On 27/03/2019 14:08, Stephen Botzko wrote:
> This whole area is new to me, so it's quite likely my question has 
> already been thought about.
>
> My understanding is that the goal of quantum networking is to create 
> (and possibly manage) entangled qubits.  Each entangled qubit is an 
> object that exists in precisely two locations at any point in time, 
> and has other properties (in particular fidelity).
>
The goal of quantum networking is to create, distribute, and manage 
*Bell Pairs* which consist of two qubits split across two locations. 
It's not one qubit in two places.

> I am wondering why we are trying to map classical networking concepts 
> like "quantum connections" and packet store+forward onto this problem 
> domain.  Has anyone looked at using a different framework (for 
> instance content defined networking)?  It might be a more natural 
> starting point.
>
The reason for starting with the standard framework is that it is well 
understood, there is a wealth of available literature on the topic, and 
also there are many experts who understand the subject. A lot of people 
have also noticed similarities between certain classical protocols like 
RSVP and the problem of distributing Bell Pairs so it seems natural to 
pursue this direction.

However, I wouldn't say that this is the only way to go or that some 
other framework might not be more optimal. In fact, Rod, one of the 
group's chair, has for example proposed to use a recursive architecture 
(https://www.nii.ac.jp/pi/n8/8_65.pdf). I haven't heard anyone suggest 
content defined networking for quantum yet, but if one were to come up 
I'm sure the group would also be interested in such a proposal.

> Also, I am thinking that it might be useful to construct a data model 
> that shows how entangled qubits are created, moved, destroyed, etc. 
> This could also show any physics constraints (for instance, cases 
> where bits need to be transported on the quantum link). The tutorial 
> shows some of this, but I think it is incomplete.
>
That is a good point, and might be worth adding to the "architectural 
principles" work which will be going on in the near future.

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 27 Mar 2019 15:38:20 +0100

On Wed, Mar 27, 2019 at 2:32 PM Wojciech Kozlowski <[email-masked]>
wrote:

> The goal of quantum networking is to create, distribute, and manage *Bell
> Pairs* which consist of two qubits split across two locations. It's not one
> qubit in two places.
>
> [SB]Thanks for the correction.  A Bell Pair is the object, not an
entangled qubit.

> [SB] There are some similarities, since RSVP does require each router on a
> path to commit to provide a precious resource (bandwidth).  But the
> bandwidth reservation in RSVP has some persistence - by contrast, the each
> Quantum Repeater on a path is committing to perform a discrete
> transaction.    And RSVP isn't fundamental to classical networking (and
> AFAIK was never widely deployed).
>

> However, I wouldn't say that this is the only way to go or that some other
> framework might not be more optimal. In fact, Rod, one of the group's
> chair, has for example proposed to use a recursive architecture (
> https://www.nii.ac.jp/pi/n8/8_65.pdf). I haven't heard anyone suggest
> content defined networking for quantum yet, but if one were to come up I'm
> sure the group would also be interested in such a proposal.
>
[SB] Ideally that model would be a driver of the overall network
architecture.

> Qirg mailing [email-masked]://www.irtf.org/mailman/listinfo/qirg
>
>

---

From: Marcello Caleffi <[email-masked]>
Date: Wed, 27 Mar 2019 18:24:22 +0100

> Il giorno 27 mar 2019, alle ore 14:32, Wojciech Kozlowski <[email-masked]> ha scritto:
> 
>> This whole area is new to me, so it's quite likely my question has already been thought about.
>> 
>> My understanding is that the goal of quantum networking is to create (and possibly manage) entangled qubits.  Each entangled qubit is an object that exists in precisely two locations at any point in time, and has other properties (in particular fidelity).
>> 
> The goal of quantum networking is to create, distribute, and manage *Bell Pairs* which consist of two qubits split across two locations. It's not one qubit in two places.

I would say that quantum networking aims at teleporting qubits between remote nodes (which may or may not — then entanglement swapping seems a suitable candidate — be directly connected through quantum links).

Teleporting needs entanglement.

Bell pairs are the simplest form of entanglement. But they are not the only form of entanglement.

I believe that sooner or later we should start looking into multipartite entanglement as done by the physics community in the last ten years or so. 

> 
>> I am wondering why we are trying to map classical networking concepts like "quantum connections" and packet store+forward onto this problem domain.  Has anyone looked at using a different framework (for instance content defined networking)?  It might be a more natural starting point.
>> 
> The reason for starting with the standard framework is that it is well understood, there is a wealth of available literature on the topic, and also there are many experts who understand the subject. A lot of people have also noticed similarities between certain classical protocols like RSVP and the problem of distributing Bell Pairs so it seems natural to pursue this direction.
> 
> However, I wouldn't say that this is the only way to go or that some other framework might not be more optimal. In fact, Rod, one of the group's chair, has for example proposed to use a recursive architecture (https://www.nii.ac.jp/pi/n8/8_65.pdf <https://www.nii.ac.jp/pi/n8/8_65.pdf>). I haven't heard anyone suggest content defined networking for quantum yet, but if one were to come up I'm sure the group would also be interested in such a proposal.
> 
>> Also, I am thinking that it might be useful to construct a data model that shows how entangled qubits are created, moved, destroyed, etc. This could also show any physics constraints (for instance, cases where bits need to be transported on the quantum link). The tutorial shows some of this, but I think it is incomplete. 
>> 
> That is a good point, and might be worth adding to the "architectural principles" work which will be going on in the near future.
> 
>> Stephen
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>
>

---

From: Patrick Gelard <[email-masked]>
Date: Wed, 27 Mar 2019 20:40:49 +0100

Hi,

Software-Defined Networking (SDN) could also be use to orchestrate and 
automate/program the reservation of classical networking resources. And 
therefore by analogy SDN could be used to program the entanglement routing.

>>I would say that quantum networking aims at teleporting qubits between 
remote nodes

it seems to me that quantum networking can be used for other quantum 
services which don't use teleportation  (QKD based on entanglement, 
super dense coding, ...) !!!

/Patrick

Le 27/03/2019 à 18:24, Marcello Caleffi a écrit :
>
>> Il giorno 27 mar 2019, alle ore 14:32, Wojciech Kozlowski 
>> <[email-masked] <mailto:[email-masked]>> ha scritto:
>>
> I would say that quantum networking aims at teleporting qubits between 
> remote nodes (which may or may not — then entanglement swapping seems 
> a suitable candidate — be directly connected through quantum links).
>
> I believe that sooner or later we should start looking into 
> multipartite entanglement as done by the physics community in the last 
> ten years or so.
>
>>
>>> I am wondering why we are trying to map classical networking 
>>> concepts like "quantum connections" and packet store+forward onto 
>>> this problem domain.  Has anyone looked at using a different 
>>> framework (for instance content defined networking)?  It might be a 
>>> more natural starting point.
>>>
>> The reason for starting with the standard framework is that it is 
>> well understood, there is a wealth of available literature on the 
>> topic, and also there are many experts who understand the subject. A 
>> lot of people have also noticed similarities between certain 
>> classical protocols like RSVP and the problem of distributing Bell 
>> Pairs so it seems natural to pursue this direction.
>>
>> group's chair, has for example proposed to use a recursive 
>> architecture (https://www.nii.ac.jp/pi/n8/8_65.pdf). I haven't heard 
>> anyone suggest content defined networking for quantum yet, but if one 
>> were to come up I'm sure the group would also be interested in such a 
>> proposal.
>>
>>> Also, I am thinking that it might be useful to construct a data 
>>> model that shows how entangled qubits are created, moved, destroyed, 
>>> etc. This could also show any physics constraints (for instance, 
>>> cases where bits need to be transported on the quantum link). The 
>>> tutorial shows some of this, but I think it is incomplete.
>>>

---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus

---

From: Marcello Caleffi <[email-masked]>
Date: Wed, 27 Mar 2019 21:28:22 +0100

Hi Patrick,

> Il giorno 27 mar 2019, alle ore 20:40, Patrick Gelard <[email-masked]> ha scritto:
> 
> Hi,
> 
> Software-Defined Networking (SDN) could also be use to orchestrate and automate/program the reservation of classical networking resources. And therefore by analogy SDN could be used to program the entanglement routing.
> 
> >>I would say that quantum networking aims at teleporting qubits between remote nodes
> 
> it seems to me that quantum networking can be used for other quantum services which don't use teleportation  (QKD based on entanglement, super dense coding, ...) !!!
> 

Indeed.

But, m2c, I seriously doubt super dense coding could ever be the killer application for a network paradigm shift such as the one required by entanglement distribution.. It seems much easier (and less expensive) to simply double the bandwidth..

QKD, well, again m2c, QKD can (might? not sure whether there is a definitive answer in terms of practical key rate) benefit from entanglement -- depending on the scheme — whereas distributed quantum computing (or blind computing) seems quite strongly dependent on entanglement and they both may be killer application since no entangled-less network can provide such services

Anyhow, these are my personal feelings .. What about multipartite entanglement? Don’t you believe we should generalize quantum networks to it?

>>> However, I wouldn't say that this is the only way to go or that some other framework might not be more optimal. In fact, Rod, one of the group's chair, has for example proposed to use a recursive architecture (https://www.nii.ac.jp/pi/n8/8_65.pdf). I haven't heard anyone suggest content defined networking for quantum yet, but if one were to come up I'm sure the group would also be interested in such a proposal.
>>> 
> 	Garanti sans virus. www.avast.com

---

From: Gelard Patrick <[email-masked]>
Date: Thu, 28 Mar 2019 06:38:59 +0000

-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Marcello Caleffi
Envoyé : mercredi 27 mars 2019 21:28
À : Patrick Gelard <[email-masked]>
Cc : Wojciech Kozlowski <[email-masked]>; [email-masked]
Objet : Re: [Qirg] Question on the Network Model for Quantum Networks

Hi Patrick,

Indeed.

Anyhow, these are my personal feelings .. What about? Don’t you believe we should generalize quantum networks to it?

[Patrick] In classical Network we have unicast, multicast and aycast IP communication service, thus why not have different modes of connectivity in quantum networks that can increase, for example, distributed computing power. Building  To be able to build interconnection network graphs of multipartite entanglement would be relevant in my opinion.  Now what are the physical challenges to achieve multipartite entanglement ?

---

From: Wojciech Kozlowski <[email-masked]>
Date: Thu, 28 Mar 2019 10:29:55 +0100

> But, m2c, I seriously doubt super dense coding could ever be the killer application for a network paradigm shift such as the one required by entanglement distribution.. It seems much easier (and le…
While super dense coding may not be the killer application, I am more in 
favour of the view that the network only provides the entanglement and 
teleportation is one of the services/applications on top of it - just 
like TCP is a reliable delivery service built on top of the IP 
best-effort datagram service.

This distinction comes from the fact that most applications currently 
proposed use entangled states as their building block and as Patrick 
pointed out they may not teleport any quantum state. You could implement 
all applications using teleportation, but this might lead to situations 
where you create a Bell Pair in order to teleport a qubit that is part 
of a Bell Pair since what the application needs is a Bell Pair.

Some applications will need teleportation, but for some it will be 
unnecessary overhead, especially in the case of anything QKD based as 
Patrick pointed out.
> [Patrick] In classical Network we have unicast, multicast and aycast IP communication service, thus why not have different modes of connectivity in quantum networks that can increase, for example,…
Multipartite entanglement is definitely a service that is desirable - 
there are proposed applications that build on top of GHZ states and some 
that use W states (both are multipartite). However, to me, what is not 
clear is where it should be done. One could generate these states at the 
physical layer and then distribute them via teleportation. Another 
option is to build these states up from Bell Pairs. This may be less 
efficient, but it may also not be - this is not clear yet. In this case 
one would have to answer whether it's the network stack that does this, 
or it's a service layer on top of the network stack (layer 4 like 
TCP/UDP) or it should be done by the application itself.

One of the members of this list, Alexander Pirker, has done some work on 
building quantum networks using multipartite states. You can read more 
about it here: https://arxiv.org/abs/1810.03556.

---

From: Marcello Caleffi <[email-masked]>
Date: Thu, 28 Mar 2019 11:46:01 +0100

> Il giorno 28 mar 2019, alle ore 10:29, Wojciech Kozlowski <[email-masked]> ha scritto:
> 
> 
> 
> While super dense coding may not be the killer application, I am more in favour of the view that the network only provides the entanglement and teleportation is one of the services/applications on top of it - just like TCP is a reliable delivery service built on top of the IP best-effort datagram service.
> 
> This distinction comes from the fact that most applications currently proposed use entangled states as their building block and as Patrick pointed out they may not teleport any quantum state. You could implement all applications using teleportation, but this might lead to situations where you create a Bell Pair in order to teleport a qubit that is part of a Bell Pair since what the application needs is a Bell Pair.

This sounds reasonable.

> 
> Some applications will need teleportation, but for some it will be unnecessary overhead, especially in the case of anything QKD based as Patrick pointed out.
> Multipartite entanglement is definitely a service that is desirable - there are proposed applications that build on top of GHZ states and some that use W states (both are multipartite). However, to me, what is not clear is where it should be done. One could generate these states at the physical layer and then distribute them via teleportation. Another option is to build these states up from Bell Pairs. This may be less efficient, but it may also not be - this is not clear yet. In this case one would have to answer whether it's the network stack that does this, or it's a service layer on top of the network stack (layer 4 like TCP/UDP) or it should be done by the application itself.

Or it should be done at the physical layer. If entanglement is the resource, then the shift between classical and quantum protocol stack can be
from transmitting bits to entangling two (or multiple) adjacent nodes with bell states (GHZ/W/etc.)

> One of the members of this list, Alexander Pirker, has done some work on building quantum networks using multipartite states. You can read more about it here: https://arxiv.org/abs/1810.03556.
> 
>>> /Patrick
>>> 
>> 
>>