Subject: [Qirg] Working on draft on GitHub?

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 2 Apr 2019 09:46:03 +0200

Hi QIRG,

I'm currently absorbing the first round of feedback for 
draft-irtf-qirg-principles-00. People also asked some non-editorial 
questions and made suggestions on what should be included. As mentioned 
in my presentation I would like to open the floor to the QIRG and make 
it easy for us to discuss these questions.

I noticed some other WGs at the IETF use GitHub for working on drafts 
and I was thinking of doing the same. That way we can use its issue and 
pull request system for collaborating. But before I do that I wanted to 
check if anybody has any objections to that?

Thanks,
Wojtek

---

From: Rodney Van Meter <[email-masked]>
Date: Tue, 2 Apr 2019 16:53:36 +0900

There was a tutorial on using github on Sunday.  I’ll admit I skipped out on that, planning to watch the video, which I have not yet done.

But I’m happy to see stuff develop via github.  That’s my personal opinion, I don’t think there’s a need to make it QIRG policy, but hard to imagine anyone objecting.

Note that this draft *is* an RG work item now, so it’s important that everyone can contribute, but they can continue to do so via the list, even if they don’t github.

—Rod

> On Apr 2, 2019, at 4:46 PM, Wojciech Kozlowski <[email-masked]> wrote:
> 
> Hi QIRG,
> 
> I'm currently absorbing the first round of feedback for draft-irtf-qirg-principles-00. People also asked some non-editorial questions and made suggestions on what should be included. As mentioned in my presentation I would like to open the floor to the QIRG and make it easy for us to discuss these questions.
> 
> I noticed some other WGs at the IETF use GitHub for working on drafts and I was thinking of doing the same. That way we can use its issue and pull request system for collaborating. But before I do that I wanted to check if anybody has any objections to that?
> 
> Thanks,
> Wojtek
> 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 2 Apr 2019 10:07:20 +0200

I wasn't aware of the tutorial. I just found the recording 
(https://www.youtube.com/watch?v=xyw_mUM1p-g&list=PLC86T-6ZTP5h1oFBcEjNAee2z6hAyv_hN&index=5&t=0s) 
and it's all about I-Ds and not just git so I'll watch it before uploading.

Good point about contributions on the list. I'll see if the tutorial 
says anything about it, but otherwise relevant parts of the discussion 
can be brought to the mailing list and obviously every now and then a 
version will be posted to the mailing list for comments.

Wojtek

---

From: Bruno Rijsman <[email-masked]>
Date: Tue, 2 Apr 2019 08:08:25 -0300

No objection.

We use Git to work on the draft in the RIFT working group and it works very well.

There is even an IETF working group on the topic of using Git:

* Working group page: https://datatracker.ietf.org/wg/git/about/ <https://datatracker.ietf.org/wg/git/about/>

* Draft on how to use git for writing drafts: https://datatracker.ietf.org/wg/git/documents/ <https://datatracker.ietf.org/wg/git/documents/>

* Video of the IETF-104 meeting of the Git working group: https://youtu.be/8BattBHWoHc <https://youtu.be/8BattBHWoHc>

* Video of the IETF-104 tutorial on using Git: https://youtu.be/xyw_mUM1p-g <https://youtu.be/xyw_mUM1p-g>

> On Apr 2, 2019, at 4:46 AM, Wojciech Kozlowski <[email-masked]> wrote:
> 
> Hi QIRG,
>

---

From: Max Franke <[email-masked]>
Date: Tue, 02 Apr 2019 14:28:56 +0200

TAPS had similar issues, as in a lot of the discussion has moved from the mailing list to issues on github. It was solved by using a script that creates digests from the Github activity. You can find the one set up by Brian Trammel for TAPS here: https://github.com/ietf-tapswg/github-notify-ml

Max

Am 02.04.2019 10:07 schrieb Wojciech Kozlowski <[email-masked]>:

Wojtek

Qirg mailing list

[email-masked]

---

From: John Wroclawski <[email-masked]>
Date: Tue, 2 Apr 2019 10:43:35 -0400

Hi,
Just noting that there's been quite a bit of discussion across the IETF about use of GitHub for drafts over the past couple of years, with some strong views on both sides, noting both positive benefits and concern about engagement and visibility of process if one does so. 

Now there’s a whole working group on the topic <https://datatracker.ietf.org/wg/git/about/>, which is in the process of adopting an expired Internet-Draft <https://datatracker.ietf.org/doc/draft-thomson-github-bcp/> as a WG item. Several points discussed in that draft are probably relevant even though this is the IRTF not the IETF.

Personally I think I’d favor keeping technical discussion centered on the email list, even if actual documents are maintained on GitHub - it seems likely to keep it more interactive and keep more people engaged. Generating digests from a script tends to keep people “informed" but not “engaged” - for that they’d still have to work with GH if you go that way. Some folks have talked about two-way mechanisms, which I think would be neat, but I’m not sure if anyone’s actually worked something useful out for real.
cheers, -john

> On Apr 2, 2019, at 8:28 AM, Max Franke <[email-masked]> wrote:
>