Subject: [Qirg] Link layer draft on GitHub

From: Axel Dahlberg <[email-masked]>
Date: Sat, 27 Apr 2019 17:42:35 +0000

Dear Qirgers!

I just wanted to inform you that the draft defining the link layer service and interface in a quantum network is now also on GitHub such we can easily keep track of open issues, todos and changes.

Feel free to add issues or make pull requests.

You can find the repo here:
https://github.com/SoftwareQuTech/draft-dahlberg-qirg-ll-quantum

/Axel Dahlberg

---

From: Gelard Patrick <[email-masked]>
Date: Mon, 29 Apr 2019 08:11:05 +0000

Hi Axel,

- "Once an entangled pair has been generated, the nodes need to be able to agree on which qubits are involved in which entangled pair in order to use it, thus another main task of the link
layer is to provide an entanglement identifier."
- "For a successful request, provide an entanglement identifier to allow higher layers to use identify the entangled pair in the network without the need for further communication."

In the case of multi-link, doesn't quantum indiscernibility lead to difficulties in identifying qubits ?

Thanks
/Patrick

De : Qirg <[email-masked]> De la part de Axel Dahlberg
Envoyé : samedi 27 avril 2019 19:43
À : [email-masked]
Objet : [Qirg] Link layer draft on GitHub

Dear Qirgers! 

/Axel Dahlberg

---

From: Axel Dahlberg <[email-masked]>
Date: Mon, 29 Apr 2019 08:28:09 +0000

Hi Patrick!

With multi-link do you mean a multipartite entangled state? (Like a GHZ-state https://en.wikipedia.org/wiki/Greenberger%E2%80%93Horne%E2%80%93Zeilinger_state<https://en.wikipedia.org/wiki/Greenberger–Horne–Zeilinger_state>?).

I think I’m not fully understanding your question. Let me try to explain what we mean here and see if it clears up your question. Lets say that A and B share two entangled pairs, i.e. A has two qubits q_A, q_A' and B has two qubits q_B, q_B’, where q_A and q_B are entangled and similarly q_A’ and q_B’. Lets now say that A and B want to perform some action which requires one entangled pair. Clearly they should use the qubits (q_A and q_B) or (q_A’ and q_B’) and not for example (q_A and q_B’). Now this entanglement identifier simply gives them a way to relate an abstract entangled pair to a qubit. I.e. they might have two entanglement ids EntID and EntID’, together with a mapping:

Node A:
{EntID: q_A, EntID': q_A’}

Node B:
{EntID: q_B, EntID': q_B’}

/Axel Dahlberg

On 29 Apr 2019, at 10:11, Gelard Patrick <[email-masked]<mailto:[email-masked]>> wrote:

Hi Axel,

Thanks
/Patrick

De : Qirg <[email-masked]<mailto:[email-masked]>> De la part de Axel Dahlberg
Envoyé : samedi 27 avril 2019 19:43
À : [email-masked]<mailto:[email-masked]>
Objet : [Qirg] Link layer draft on GitHub

Dear Qirgers!

/Axel Dahlberg

---

From: Gelard Patrick <[email-masked]>
Date: Mon, 29 Apr 2019 08:40:31 +0000

>> With multi-link do you mean a multipartite entangled state?
Not exactly.

For example : You have a not B that share an entanglement qubits pair with node A, but also share other pairs with other nodes : one with a node C and  the other with node D.

node B has different qubits entangled at the same time (possible indiscernibility ?) and belonging to different data links (i.e multi-link layer).

/Patrick

De : Qirg <[email-masked]> De la part de Axel Dahlberg
Envoyé : lundi 29 avril 2019 10:28
Cc : [email-masked]
Objet : Re: [Qirg] Link layer draft on GitHub

Hi Patrick!

Node A:

Node B:

/Axel Dahlberg

Hi Axel,

Thanks
/Patrick

Dear Qirgers!

/Axel Dahlberg

---

From: Axel Dahlberg <[email-masked]>
Date: Mon, 29 Apr 2019 08:49:27 +0000

Hi Patrick!

I see! In this case it would work similar to what I wrote above. We apply a tag/id to relate the entanglement to a qubit. If you’re asking whether the qubits are actually physically indistinguishable (https://en.wikipedia.org/wiki/Identical_particles), they are not since they are for example at different spatial positions in the quantum memory.

/Axel Dahlberg

Not exactly.

/Patrick

De : Qirg <[email-masked]<mailto:[email-masked]>> De la part de Axel Dahlberg
Envoyé : lundi 29 avril 2019 10:28
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [Qirg] Link layer draft on GitHub

Hi Patrick!

With multi-link do you mean a multipartite entangled state? (Like a GHZ-state https://en.wikipedia.org/wiki/Greenberger%E2%80%93Horne%E2%80%93Zeilinger_state?).

Node A:

Node B:

/Axel Dahlberg

Hi Axel,

Thanks
/Patrick

Dear Qirgers!

/Axel Dahlberg

---

From: Gelard Patrick <[email-masked]>
Date: Mon, 29 Apr 2019 08:52:04 +0000

>> If you’re asking whether the qubits are actually physically indistinguishable (https://en.wikipedia.org/wiki/Identical_particles),
Yes
>> they are not since they are for example at different spatial positions in the quantum memory.
Thank

/Patrick

De : Qirg <[email-masked]> De la part de Axel Dahlberg
Envoyé : lundi 29 avril 2019 10:49
Cc : [email-masked]
Objet : Re: [Qirg] Link layer draft on GitHub

Hi Patrick!

/Axel Dahlberg

Not exactly.

/Patrick

Hi Patrick!

Node A:

Node B:

/Axel Dahlberg

Hi Axel,

Thanks
/Patrick

Dear Qirgers!

/Axel Dahlberg