Subject: Re: [Qirg] Other Security-Related Activities related to Quantum Computing...

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 19 Jul 2019 08:55:12 +0000

Hi Max and you qirgers,

I came through this message while doing my review of pending emails for the coming IETF (what, as you can see, it is difficult for me to do on a timely manner…) and it made me think, together with some discussions I had during the IETF 104 Hackathon, that some of the experiments we have recently made on our metro infrastructure in Madrid could be of interest to the group, and that we could even prepare a document for the QIRG documenting them, and making some proposals based on them.

Since I see no QIRG meeting this time, I was wondering if some of you would be interested in exploring this way and have an initial discussion on it.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 26/03/2019, 19:17, "Qirg on behalf of Dr. Pala" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi QIRG,

I just wanted to provide a very short summary of some of the efforts that are going on, today, and that are aimed at mitigating the (possible) factorization threats for "classic" algorithms in cryptography. The work is not focused on the use of Quantum-Based techniques, but to provide a way to protect our trust infrastructures (PKIs) today and in the long run. In a nutshell, we are working on two different time-horizons.

For short-term solution, the use of PSKs mixed with PublicKey cryptography provides the possibility to secure data today that is "quantum-resistant". This leaves the distribution of the PSK quite an open problem that might be solved with QKD where possible/available.

For the long term, there are two different activities going on right now.

The first activity is about selecting the set of algorithms that can be proven to be secure in a post quantum-computing world. Hash-based signatures have already been standardized, however other schemes that can provide different characteristics (e.g., encryption, key exchange, etc.). Although the process has been going on for a while, it will take several more years to identify the best ones.

The second activity (for the long run) is how to provide hybrid infrastructures that can use "traditional" and "quantum-resistant" cryptography together. The approach is meant to provide (a) backward compatibility (as much as possible) for devices that, today, do not understand the new algorithms, (b) provide protection for high-value target (e.g., Root and Intermediate CAs), and (c) integrate the use of the hybrid approach to protect all parts of a PKI: not only certificates but also revocation information and provisioning services.

I know this is orthogonal with the work that the group has focused on so far (nothing to do with transmitting (q)-bits on the fiber or networking), however I think it might be useful for people on the list to have an overview of other quantum-related activities from the security area.

Last but not least, I want to thank again for the organization of the workshop - unfortunately I could attend only the first half because of conflicts, but I really liked the lecture and I wanted to thank again everybody!

Cheers,
Max
--
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
[OpenCA Logo]

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: JW <[email-masked]>
Date: Fri, 19 Jul 2019 06:39:26 -0400

Hi Diego,I will be in Montreal and am interested in discussing this among other qirg topics./John 
-------- Original message --------From: "Diego R. Lopez" <[email-masked]>

Hi Max and you qirgers,
 
I came through this message while doing my review of pending emails for the coming IETF (what, as you can see, it is difficult for me to do on a timely manner…) and it made me think, together
 with some discussions I had during the IETF 104 Hackathon, that some of the experiments we have recently made on our metro infrastructure in Madrid could be of interest to the group, and that we could even prepare a document for the QIRG documenting them,
 and making some proposals based on them.

Be goode,

Dr Diego R. Lopez
Telefonica I+D
 
e-mail: [email-masked]
Tel:         +34 913 129 041
Mobile:  +34 682 051 091

On 26/03/2019, 19:17, "Qirg on behalf of Dr. Pala" <[email-masked] on behalf of
[email-masked]> wrote:

Hi QIRG,
I just wanted to provide a very short summary of some of the efforts that are going on, today, and that are aimed at mitigating the (possible) factorization threats for "classic" algorithms in cryptography. The work is not focused
 on the use of Quantum-Based techniques, but to provide a way to protect our trust infrastructures (PKIs) today and in the long run. In a nutshell, we are working on two different time-horizons.
For short-term solution, the use of PSKs mixed with PublicKey cryptography provides the possibility to secure data today that is "quantum-resistant". This leaves the distribution of the PSK quite an open problem that might
 be solved with QKD where possible/available.
For the long term, there are two different activities going on right now.
The first activity is about selecting the set of algorithms that can be proven to be secure in a post quantum-computing world. Hash-based signatures have already been standardized, however other schemes that can provide
 different characteristics (e.g., encryption, key exchange, etc.). Although the process has been going on for a while, it will take several more years to identify the best ones.
The second activity (for the long run) is how to provide hybrid infrastructures that can use "traditional" and "quantum-resistant" cryptography together. The approach is meant to provide (a) backward compatibility (as much
 as possible) for devices that, today, do not understand the new algorithms, (b) provide protection for high-value target (e.g., Root and Intermediate CAs), and (c) integrate the use of the hybrid approach to protect all parts of a PKI:
not only certificates but also revocation information and provisioning services.
I know this is orthogonal with the work that the group has focused on so far (nothing to do with transmitting (q)-bits on the fiber or networking), however I think it might be useful for people on the list to have an overview of
 other quantum-related activities from the security area.
Last but not least, I want to thank again for the organization of the workshop - unfortunately I could attend only the first half because of conflicts, but I really liked the lecture and I wanted to thank again everybody!
Cheers,
Max

-- 

Best Regards,

Massimiliano Pala, Ph.D.
OpenCA Labs Director

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la
 lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination,
 distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a
 leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Bruno Rijsman <[email-masked]>
Date: Fri, 19 Jul 2019 13:00:14 +0200

Hello Diego and John,

I am also interested in participating in any QIRG related discussion that might take place at IETF105 in Montreal (even though there is no formal QIRG workgroup meeting scheduled).

My main interest is in the area of routing and traffic engineering for Quantum Networks, but I would be interested in keeping up to date on other topics as well.

I will be attending the IETF remotely; hence it would be nice if some sort of web conference (Google hangout, Zoom, etc.) could be set up if such a meeting does happen. I can set that up if needed.

— Bruno

> On Jul 19, 2019, at 12:39 PM, JW <[email-masked]> wrote:
> 
> Hi Diego,
> 
> I will be in Montreal and am interested in discussing this among other qirg topics.
> 
> /John 
> 
> -------- Original message --------
> From: "Diego R. Lopez" <[email-masked]>
> Hi Max and you qirgers,
> 
>  
> 
> https://www.linkedin.com/in/dr2lopez/ <https://www.linkedin.com/in/dr2lopez/> 
> 
>  
> 
> e-mail: [email-masked] <mailto:[email-masked]>
> Tel:         +34 913 129 041
> 
> Mobile:  +34 682 051 091
> 
> On 26/03/2019, 19:17, "Qirg on behalf of Dr. Pala" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
>  
> 
> Hi QIRG,
> 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: nalini elkins <[email-masked]>
Date: Fri, 19 Jul 2019 05:57:03 -0700

Diego,

I will be in Montreal also & would be interested.

Nalini

On Fri, Jul 19, 2019 at 3:39 AM JW <[email-masked]> wrote:

> I came through this message while doing my review of pending emails for
> the coming IETF (what, as you can see, it is difficult for me to do on a
> timely manner…) and it made me think, together with some discussions I had
> during the IETF 104 Hackathon, that some of the experiments we have
> recently made on our metro infrastructure in Madrid could be of interest to
> the group, and that we could even prepare a document for the QIRG
> documenting them, and making some proposals based on them.
>
>
>
> Since I see no QIRG meeting this time, I was wondering if some of you
> would be interested in exploring this way and have an initial discussion on
> it.
>
>
>
> Be goode,
>
>
>
> --
>
> On 26/03/2019, 19:17, "Qirg on behalf of Dr. Pala" <[email-masked]
> on behalf of [email-masked]> wrote:
>
>
>
> Hi QIRG,
>
> I just wanted to provide a very short summary of some of the efforts that
> are going on, today, and that are aimed at mitigating the (possible)
> factorization threats for "classic" algorithms in cryptography. The work is
> not focused on the use of Quantum-Based techniques, but to provide a way to
> protect our trust infrastructures (PKIs) today and in the long run. In a
> nutshell, we are working on two different time-horizons.
>
> *For short-term solution*, the use of PSKs mixed with PublicKey
> cryptography provides the possibility to secure data today that is
> "quantum-resistant". This leaves the distribution of the PSK quite an open
> problem that might be solved with QKD where possible/available.
>
> *For the long term*, there are two different activities going on right
> now.
>
> *The first activity* is about selecting the set of algorithms that can be
> proven to be secure in a post quantum-computing world. Hash-based
> signatures have already been standardized, however other schemes that can
> provide different characteristics (e.g., encryption, key exchange, etc.).
> Although the process has been going on for a while, it will take several
> more years to identify the best ones.
>
> *The second activity* (for the long run) is how to provide hybrid
> infrastructures that can use "traditional" and "quantum-resistant"
> cryptography together. The approach is meant to provide (a) backward
> compatibility (as much as possible) for devices that, today, do not
> understand the new algorithms, (b) provide protection for high-value target
> (e.g., Root and Intermediate CAs), and (c) integrate the use of the hybrid
> approach to protect all parts of a PKI: *not only certificates but also
> revocation information and provisioning services*.
>
> I know this is orthogonal with the work that the group has focused on so
> far (nothing to do with transmitting (q)-bits on the fiber or networking),
> however I think it might be useful for people on the list to have an
> overview of other quantum-related activities from the security area.
>
> *Last but not least, I want to thank again for the organization of the
> workshop - unfortunately I could attend only the first half because of
> conflicts, but I really liked the lecture and I wanted to thank again
> everybody!*
>
> Cheers,
> Max
>
> --
>
> Best Regards,
>
> Massimiliano Pala, Ph.D.
> OpenCA Labs Director
>
>
> ------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição

-- 
Thanks,
Nalini Elkins
President
Enterprise Data Center Operators
www.e-dco.com

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sat, 20 Jul 2019 04:27:02 +0000

Hi,

What if we get together during one of the lunch breaks, sit at the break-out room and talk about this and other matters? Wednesday looks like the best day for me…

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 19/07/2019, 13:57, "nalini elkins" <[email-masked]<mailto:[email-masked]>> wrote:

Diego,

Nalini

On Fri, Jul 19, 2019 at 3:39 AM JW <[email-masked]<mailto:[email-masked]>> wrote:
Hi Diego,

/John

-------- Original message --------
From: "Diego R. Lopez" <[email-masked]<mailto:[email-masked]>>
Hi Max and you qirgers,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi QIRG,

Cheers,
Max
--
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
Error! Filename not specified.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg

--
Thanks,
Nalini Elkins
President
Enterprise Data Center Operators
www.e-dco.com<http://www.e-dco.com>

---

From: 박춘걸(Biz Total Solution Projec) <[email-masked]>
Date: Sat, 20 Jul 2019 11:49:23 +0000

Hello!
This is Peter Park from KT(Korea Telecom).

We are also interested in Qirg activities and expecting a meeting in Montreal.

B.R,
Peter

========================================================
Dr. Peter(Choongul) Park
Team Leader / KT Infra Lab.
34046 70 Yuseong-daero 1689beon-gil Yuseong-gu Daejeon Korea(South)
T: +82.10.2879.7463 / F: +82.42.870.8779

From: Diego R. Lopez [mailto:[email-masked]]
Sent: Saturday, July 20, 2019 1:27 PM
To: nalini elkins <[email-masked]>; JW <[email-masked]>; Dr. Pala <[email-masked]>
Cc: [email-masked]
Subject: Re: [Qirg] Other Security-Related Activities related to Quantum Computing...

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Diego,

Nalini

/John

-------- Original message --------

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi QIRG,

Cheers,
Max

이 메일은 지정된 수취인만을 위해 작성되었으며, 중요한 정보나 저작권을 포함하고 있을 수 있습니다. 어떠한 권한 없이, 본 문서에 포함된 정보의 전부 또는 일부를 무단으로 제3자에게 공개, 배포, 복사 또는 사용하는 것을 엄격히 금지합니다. 만약, 본 메일이 잘못 전송된 경우, 발신인 또는 당사에 알려주시고, 본 메일을 즉시 삭제하여 주시기 바랍니다.
This E-mail may contain confidential information and/or copyright material. This email is intended for the use of the addressee only. If you receive this email by mistake, please either delete it without reproducing, distributing or retaining copies thereof or notify the sender immediately.

---

From: Yoav Nir <[email-masked]>
Date: Sun, 21 Jul 2019 07:10:07 -0400

Wednesday lunch is the WG chairs meeting.  But that’s OK. Every other day at lunch is something or other.  The mornings tend to be more free (and late afternoon too)

Anyway, side meetings should be registered here:
https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings <https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings>

> On 20 Jul 2019, at 0:27, Diego R. Lopez <[email-masked]> wrote:
> 
> Hi,
>  
> On 19/07/2019, 13:57, "nalini elkins" <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Diego, 
>  
> On Fri, Jul 19, 2019 at 3:39 AM JW <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi Diego, 
>>  
>> From: "Diego R. Lopez" <[email-masked] <mailto:[email-masked]>>
>> Hi Max and you qirgers,
>>  
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>
> 
>  
> -- 
> Thanks,
> Nalini Elkins
> President
> www.e-dco.com <http://www.e-dco.com/>
>  
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>

---

From: "Dr. Pala" <[email-masked]>
Date: Sun, 21 Jul 2019 09:16:11 -0400

Hi Diego, all,

As you know, I am interested in the topic from a very practical 
standpoint (i.e., building trust infrastructures that are usable and 
quantum resistant). Please let me know when we can meet, I would be 
interested to join in. Our current draft that might be relevant is 
available here:

https://github.com/EntrustDatacard/draft-ounsworth-composite-sigs

Cheers,
Max

On 7/20/19 12:27 AM, Diego R. Lopez wrote:
>
> Hi,
>
> What if we get together during one of the lunch breaks, sit at the 
> break-out room and talk about this and other matters? Wednesday looks 
> like the best day for me…
>
> Be goode,
>
> --
>
>     I came through this message while doing my review of pending
>     emails for the coming IETF (what, as you can see, it is difficult
>     for me to do on a timely manner…) and it made me think, together
>     with some discussions I had during the IETF 104 Hackathon, that
>     some of the experiments we have recently made on our metro
>     infrastructure in Madrid could be of interest to the group, and
>     that we could even prepare a document for the QIRG documenting
>     them, and making some proposals based on them.
>
>     Since I see no QIRG meeting this time, I was wondering if some of
>     you would be interested in exploring this way and have an initial
>     discussion on it.
>
>     Be goode,
>
>     --
>
>     <mailto:[email-masked]>
>
>     Tel: +34 913 129 041
>
>     Mobile:  +34 682 051 091
>
>     On 26/03/2019, 19:17, "Qirg on behalf of Dr. Pala"
>     <[email-masked] <mailto:[email-masked]> on behalf of
>     [email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi QIRG,
>
>     I just wanted to provide a very short summary of some of the
>     efforts that are going on, today, and that are aimed at mitigating
>     the (possible) factorization threats for "classic" algorithms in
>     cryptography. The work is not focused on the use of Quantum-Based
>     techniques, but to provide a way to protect our trust
>     infrastructures (PKIs) today and in the long run. In a nutshell,
>     we are working on two different time-horizons.
>
>     "quantum-resistant". This leaves the distribution of the PSK quite
>     an open problem that might be solved with QKD where
>     possible/available.
>
>     *For the long term*, there are two different activities going on
>     right now.
>
>     /The first activity/ is about selecting the set of algorithms that
>     can be proven to be secure in a post quantum-computing world.
>     Hash-based signatures have already been standardized, however
>     other schemes that can provide different characteristics (e.g.,
>     encryption, key exchange, etc.). Although the process has been
>     going on for a while, it will take several more years to identify
>     the best ones.
>
>     /The second activity/ (for the long run) is how to provide hybrid
>     cryptography together. The approach is meant to provide (a)
>     backward compatibility (as much as possible) for devices that,
>     today, do not understand the new algorithms, (b) provide
>     protection for high-value target (e.g., Root and Intermediate
>     CAs), and (c) integrate the use of the hybrid approach to protect
>     all parts of a PKI: /not only certificates but also revocation
>     information and provisioning services/.
>
>     I know this is orthogonal with the work that the group has focused
>     on so far (nothing to do with transmitting (q)-bits on the fiber
>     or networking), however I think it might be useful for people on
>     the list to have an overview of other quantum-related activities
>     from the security area.
>
>     */Last but not least, I want to thank again for the organization
>     of the workshop - unfortunately I could attend only the first half
>     because of conflicts, but I really liked the lecture and I wanted
>     to thank again everybody!/*
>
>     Cheers,
>     Max
>
>     -- 
>
>     Best Regards,
>
>     Massimiliano Pala, Ph.D.
>     OpenCA Labs Director
>
>     *Error! Filename not specified.*
>
>     ------------------------------------------------------------------------
>
>
>     Este mensaje y sus adjuntos se dirigen exclusivamente a su
>     destinatario, puede contener información privilegiada o
>     confidencial y es para uso exclusivo de la persona o entidad de
>     destino. Si no es usted. el destinatario indicado, queda
>     notificado de que la lectura, utilización, divulgación y/o copia
>     sin autorización puede estar prohibida en virtud de la legislación
>     vigente. Si ha recibido este mensaje por error, le rogamos que nos
>     lo comunique inmediatamente por esta misma vía y proceda a su
>     destrucción.
>
>     confidential information intended only for the use of the
>     individual or entity named above. If the reader of this message is
>     not the intended recipient, you are hereby notified that any
>     dissemination, distribution or copying of this communication is
>     strictly prohibited. If you have received this transmission in
>     error, do not read it. Please immediately reply to the sender that
>     you have received this communication in error and then delete it.
>
>     Esta mensagem e seus anexos se dirigem exclusivamente ao seu
>     destinatário, pode conter informação privilegiada ou confidencial
>     e é para uso exclusivo da pessoa ou entidade de destino. Se não é
>     vossa senhoria o destinatário indicado, fica notificado de que a
>     leitura, utilização, divulgação e/ou cópia sem autorização pode
>     estar proibida em virtude da legislação vigente. Se recebeu esta
>     mensagem por erro, rogamos-lhe que nos o comunique imediatamente
>     por esta mesma via e proceda a sua destruição
>
> www.e-dco.com <http://www.e-dco.com>
>
>
> ------------------------------------------------------------------------
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su 
> destinatario, puede contener información privilegiada o confidencial y 
> es para uso exclusivo de la persona o entidad de destino. Si no es 
> usted. el destinatario indicado, queda notificado de que la lectura, 
> utilización, divulgación y/o copia sin autorización puede estar 
> prohibida en virtud de la legislación vigente. Si ha recibido este 
> mensaje por error, le rogamos que nos lo comunique inmediatamente por 
> esta misma vía y proceda a su destrucción.
>
> confidential information intended only for the use of the individual 
> or entity named above. If the reader of this message is not the 
> intended recipient, you are hereby notified that any dissemination, 
> distribution or copying of this communication is strictly prohibited. 
> If you have received this transmission in error, do not read it. 
> Please immediately reply to the sender that you have received this 
> communication in error and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu 
> destinatário, pode conter informação privilegiada ou confidencial e é 
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa 
> senhoria o destinatário indicado, fica notificado de que a leitura, 
> utilização, divulgação e/ou cópia sem autorização pode estar proibida 
> em virtude da legislação vigente. Se recebeu esta mensagem por erro, 
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e 
> proceda a sua destruição
-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sun, 21 Jul 2019 15:25:48 +0000

Hi,

Thanks for the remark,  Yoav!
I have registered the meeting in the Wiki page (room Coller, from 14:00 to 16:00) and updated the invitation I sent accordingly.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 21/07/2019, 07:10, "Yoav Nir" <[email-masked]<mailto:[email-masked]>> wrote:

Anyway, side meetings should be registered here:
https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings

On 20 Jul 2019, at 0:27, Diego R. Lopez <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Diego,

Nalini

/John

-------- Original message --------

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi QIRG,

--
Thanks,
Nalini Elkins
President
Enterprise Data Center Operators
www.e-dco.com<http://www.e-dco.com/>

---

From: nalini elkins <[email-masked]>
Date: Sun, 21 Jul 2019 11:50:23 -0400

All,

My interests are in problem diagnostics and performance measurement.

I have put up the simulated quantum network.  It would be great to have a
lab with real equipment.

I also have a number of packet traces & am working on getting a Wireshark
dissector.   Still need to look at some of the breakouts to see what should
be done.

Nalini

On Sun, Jul 21, 2019 at 9:16 AM Dr. Pala <[email-masked]> wrote:

> Hi Diego, all,
>
> As you know, I am interested in the topic from a very practical standpoint
> (i.e., building trust infrastructures that are usable and quantum
> resistant). Please let me know when we can meet, I would be interested to
> join in. Our current draft that might be relevant is available here:
>
> break-out room and talk about this and other matters? Wednesday looks like
> the best day for me…
>
>
>
> Be goode,
>
> --
>
> On 19/07/2019, 13:57, "nalini elkins" <[email-masked]> wrote:
>
>
>
> Diego,
>
>
>

---

From: "Dr. Pala" <[email-masked]>
Date: Tue, 23 Jul 2019 13:52:39 -0400

Hi Diego, all,

just a small fix - unless I am mistaken, it seems you missed a slot 
(14:00-14:30) in the reservation for the Collar room. You might want to 
reserve also that slot to prevent other bookings :D

Cheers,
Max

On 7/21/19 11:25 AM, Diego R. Lopez wrote:
> I have registered the meeting in the Wiki page (room Coller, from 
> 14:00 to 16:00) and updated the invitation I sent accordingly.
>
> Be goode,
>
> --
>
> Wednesday lunch is the WG chairs meeting.  But that’s OK. Every other 
> day at lunch is something or other.  The mornings tend to be more free 
> (and late afternoon too)
>
>     On 20 Jul 2019, at 0:27, Diego R. Lopez
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     break-out room and talk about this and other matters? Wednesday
>     looks like the best day for me…
>
>     Be goode,
>
>     --
>
>         emails for the coming IETF (what, as you can see, it is
>         difficult for me to do on a timely manner…) and it made me
>         think, together with some discussions I had during the IETF
>         104 Hackathon, that some of the experiments we have recently
>         made on our metro infrastructure in Madrid could be of
>         interest to the group, and that we could even prepare a
>         document for the QIRG documenting them, and making some
>         proposals based on them.
>
>         Since I see no QIRG meeting this time, I was wondering if some
>         of you would be interested in exploring this way and have an
>         initial discussion on it.
>
>         Be goode,
>
>         --
>
>         <[email-masked] <mailto:[email-masked]>on behalf
>         [email-masked] <mailto:[email-masked]>> wrote:
>
>         Hi QIRG,
>
>         efforts that are going on, today, and that are aimed at
>         mitigating the (possible) factorization threats for "classic"
>         algorithms in cryptography. The work is not focused on the use
>         of Quantum-Based techniques, but to provide a way to protect
>         our trust infrastructures (PKIs) today and in the long run. In
>         a nutshell, we are working on two different time-horizons.
>
>         *For short-term solution*, the use of PSKs mixed with
>         PublicKey cryptography provides the possibility to secure data
>         today that is "quantum-resistant". This leaves the
>         distribution of the PSK quite an open problem that might be
>         solved with QKD where possible/available.
>
>         *For the long term*, there are two different activities going
>         on right now.
>
>         /The first activity/is about selecting the set of algorithms
>         that can be proven to be secure in a post quantum-computing
>         world. Hash-based signatures have already been standardized,
>         however other schemes that can provide different
>         characteristics (e.g., encryption, key exchange, etc.).
>         Although the process has been going on for a while, it will
>         take several more years to identify the best ones.
>
>         /The second activity/(for the long run) is how to provide
>         hybrid infrastructures that can use "traditional" and
>         "quantum-resistant" cryptography together. The approach is
>         meant to provide (a) backward compatibility (as much as
>         possible) for devices that, today, do not understand the new
>         algorithms, (b) provide protection for high-value target
>         (e.g., Root and Intermediate CAs), and (c) integrate the use
>         of the hybrid approach to protect all parts of a PKI:/not only
>         certificates but also revocation information and provisioning
>         services/.
>
>         I know this is orthogonal with the work that the group has
>         focused on so far (nothing to do with transmitting (q)-bits on
>         the fiber or networking), however I think it might be useful
>         for people on the list to have an overview of other
>         quantum-related activities from the security area.
>
>         */Last but not least, I want to thank again for the
>         organization of the workshop - unfortunately I could attend
>         only the first half because of conflicts, but I really liked
>         the lecture and I wanted to thank again everybody!/*
>
>         Cheers,
>         Max
>
>         --
>
>         Best Regards,
>
>         Massimiliano Pala, Ph.D.
>         OpenCA Labs Director
>
>         confidencial y es para uso exclusivo de la persona o entidad
>         de destino. Si no es usted. el destinatario indicado, queda
>         notificado de que la lectura, utilización, divulgación y/o
>         copia sin autorización puede estar prohibida en virtud de la
>         legislación vigente. Si ha recibido este mensaje por error, le
>         rogamos que nos lo comunique inmediatamente por esta misma vía
>         y proceda a su destrucción.
>
>         The information contained in this transmission is privileged
>         and confidential information intended only for the use of the
>         individual or entity named above. If the reader of this
>         message is not the intended recipient, you are hereby notified
>         that any dissemination, distribution or copying of this
>         communication is strictly prohibited. If you have received
>         this transmission in error, do not read it. Please immediately
>         reply to the sender that you have received this communication
>         in error and then delete it.
>
>         destinatário, pode conter informação privilegiada ou
>         confidencial e é para uso exclusivo da pessoa ou entidade de
>         destino. Se não é vossa senhoria o destinatário indicado, fica
>         notificado de que a leitura, utilização, divulgação e/ou cópia
>         sem autorização pode estar proibida em virtude da legislação
>         vigente. Se recebeu esta mensagem por erro, rogamos-lhe que
>         nos o comunique imediatamente por esta mesma via e proceda a
>         sua destruição
>
-- 
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
OpenCA Logo

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 23 Jul 2019 18:01:51 +0000

Hi Max,

Thanks for noting this! I’ve just corrected it…

Dr Diego R. Lopez
Telefonica I+D

On 23/07/2019, 13:52, "Dr. Pala" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Diego, all,

just a small fix - unless I am mistaken, it seems you missed a slot (14:00-14:30) in the reservation for the Collar room. You might want to reserve also that slot to prevent other bookings :D

Cheers,
Max

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Diego,

Nalini

/John

-------- Original message --------

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi QIRG,

---

From: JW <[email-masked]>
Date: Tue, 23 Jul 2019 14:37:00 -0400

Hi Diego,Just making sure I am on the same page.   Tomorrow's discussion is moving from 12:00(- 1:30) to 2:00(- 2:30)?Thanks,John
-------- Original message --------From: "Diego R. Lopez" <[email-masked]> ...

Hi Max,

 
Dr Diego R. Lopez
Telefonica I+D

On 23/07/2019, 13:52, "Dr. Pala" <[email-masked]> wrote:

Hi Diego, all,

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 21/07/2019, 07:10, "Yoav Nir" <[email-masked]> wrote:

 

 

Hi,

 

Be goode,

--

 

Dr Diego R. Lopez

Telefonica I+D

 

Tel:         +34 913 129 041

Mobile:  +34 682 051 091

 

 

Diego, 

Nalini

Hi Diego, 

 

/John 

-------- Original message --------

Hi Max and you qirgers,

I came through this message while doing my review of pending emails for the coming IETF (what, as you can see, it is difficult for me to do on a timely manner…) and
 it made me think, together with some discussions I had during the IETF 104 Hackathon, that some of the experiments we have recently made on our metro infrastructure in Madrid could be of interest to the group, and that we could even prepare a document for
 the QIRG documenting them, and making some proposals based on them.

 

Be goode,

--

 

Dr Diego R. Lopez

Telefonica I+D

 

Tel:         +34 913 129 041

Mobile:  +34 682 051 091

 

On 26/03/2019, 19:17, "Qirg on behalf of Dr. Pala" <[email-masked] on
 behalf of [email-masked]> wrote:

Hi QIRG,

I just wanted to provide a very short summary of some of the efforts that are going on, today, and that are aimed at mitigating the (possible) factorization threats for "classic" algorithms in cryptography.
 The work is not focused on the use of Quantum-Based techniques, but to provide a way to protect our trust infrastructures (PKIs) today and in the long run. In a nutshell, we are working on two different time-horizons.

For short-term solution, the use of PSKs mixed with PublicKey cryptography provides the possibility to secure data today that is "quantum-resistant".
 This leaves the distribution of the PSK quite an open problem that might be solved with QKD where possible/available.

The first activity is about selecting
 the set of algorithms that can be proven to be secure in a post quantum-computing world. Hash-based signatures have already been standardized, however other schemes that can provide different characteristics (e.g., encryption, key exchange, etc.). Although
 the process has been going on for a while, it will take several more years to identify the best ones.

The second activity (for the long run)
 is how to provide hybrid infrastructures that can use "traditional" and "quantum-resistant" cryptography together. The approach is meant to provide (a) backward compatibility (as much as possible) for devices that, today, do not understand the new algorithms,
 (b) provide protection for high-value target (e.g., Root and Intermediate CAs), and (c) integrate the use of the hybrid approach to protect all parts of a PKI: not only certificates but also revocation information
 and provisioning services.

I know this is orthogonal with the work that the group has focused on so far (nothing to do with transmitting (q)-bits on the fiber or networking), however I think it might be useful for people on the list
 to have an overview of other quantum-related activities from the security area.

Last but not least, I want to thank again for the organization of the workshop - unfortunately I could attend only the first half because of conflicts, but I really liked the lecture and I wanted to
 thank again everybody!

Cheers,
Max

-- 

Best Regards, 

Massimiliano Pala, Ph.D.
OpenCA Labs Director

 

 

-- 

Thanks,

Nalini Elkins

President

www.e-dco.com

 

 

-- 

Best Regards,

Massimiliano Pala, Ph.D.
OpenCA Labs Director

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 23 Jul 2019 18:50:39 +0000

Hi John,

Tomorrow’s discussion will start at 2PM, in the Coller room… I’ve reserved a two hour slot, to have time enough to address anything that comes along on QKD.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 23/07/2019, 14:39, "Qirg on behalf of JW" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Diego,

Just making sure I am on the same page.   Tomorrow's discussion is moving from 12:00(- 1:30) to 2:00(- 2:30)?

Thanks,
John

-------- Original message --------
...

Hi Max,

Dr Diego R. Lopez
Telefonica I+D

Hi Diego, all,

Cheers,
Max

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Diego,

Nalini

/John

-------- Original message --------

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Hi QIRG,

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
--
Best Regards,
Massimiliano Pala, Ph.D.
OpenCA Labs Director
[Image removed by sender. OpenCA Logo]

---

From: JW <[email-masked]>
Date: Tue, 23 Jul 2019 14:55:43 -0400

Perfect, thanks!

Hi John,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

On 23/07/2019, 14:39, "Qirg on behalf of JW" <[email-masked] on behalf of
[email-masked]> wrote:

Hi Diego,

 

Thanks,

John

-------- Original message --------

...

Hi Max,

--

Dr Diego R. Lopez

Telefonica I+D

Tel:         +34 913 129 041

Mobile:  +34 682 051 091

 

Hi Diego, all,

Hi,

Be goode,

--

Dr Diego R. Lopez

Telefonica I+D

Tel:         +34 913 129 041

Mobile:  +34 682 051 091

 

 

 

 

Hi,

 

Be goode,

--

 

Dr Diego R. Lopez

Telefonica I+D

 

Tel:         +34 913 129 041

Mobile:  +34 682 051 091

 

 

Diego, 

Nalini

Hi Diego, 

 

/John 

-------- Original message --------

Hi Max and you qirgers,

I came through this message while doing my review of pending emails for the coming IETF (what, as you can see, it is difficult for me to do on a timely manner…) and it made me think, together with some discussions
 I had during the IETF 104 Hackathon, that some of the experiments we have recently made on our metro infrastructure in Madrid could be of interest to the group, and that we could even prepare a document for the QIRG documenting them, and making some proposals
 based on them.

 

Be goode,

--

 

Dr Diego R. Lopez

Telefonica I+D

 

Tel:         +34 913 129 041

Mobile:  +34 682 051 091

 

On 26/03/2019, 19:17, "Qirg on behalf of Dr. Pala" <[email-masked] on behalf of [email-masked]>
 wrote:

Hi QIRG,

Cheers,
Max

-- 

Best Regards, 

Massimiliano Pala, Ph.D.
OpenCA Labs Director

 

 

-- 

Thanks,

Nalini Elkins

President

www.e-dco.com

 

 

-- 

Best Regards, 

Massimiliano Pala, Ph.D.
OpenCA Labs Director