Subject: [Qirg] I-D Action: draft-irtf-qirg-principles-01.txt

From: [email-masked]
Date: Fri, 06 Sep 2019 08:37:22 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Quantum Internet Proposed Research Group RG of the IRTF.

        Title           : Architectural Principles for a Quantum Internet
        Authors         : Wojciech Kozlowski
                          Stephanie Wehner
	Filename        : draft-irtf-qirg-principles-01.txt
	Pages           : 21
	Date            : 2019-09-06

Abstract:
   The vision of a quantum internet is to fundamentally enhance Internet
   technology by enabling quantum communication between any two points
   on Earth.  To achieve this goal, a quantum network stack should be
   built from the ground up as the physical nature of the communication
   is fundamentally different.  The first realisations of quantum
   networks are imminent, but there is no practical proposal for how to
   organise, utilise, and manage such networks.  In this memo, we
   attempt lay down the framework and introduce some basic architectural
   principles for a quantum internet.  This is intended for general
   guidance and general interest, but also to provide a foundation for
   discussion between physicists and network specialists.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-qirg-principles-01
https://datatracker.ietf.org/doc/html/draft-irtf-qirg-principles-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-qirg-principles-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Gelard Patrick <[email-masked]>
Date: Mon, 9 Sep 2019 08:09:17 +0000

Hi,

Hi,

>>The vision of a quantum internet is to fundamentally enhance Internet technology by enabling quantum communication between any two points on Earth.  To achieve this goal, a quantum network stack should be built from the ground up as the physical nature of the communication is fundamentally different.

It seem that also the communication need is fundamentally different between classical computing and quantum computing.

One of the goal of the classical internet is to provide end-to-end IP connectivity so that applications running on computer could exchange digital data, audio or video.  it is the applications that generate the data flows 

On the other hand the purpose of quantum networks is not to exchange classical information on a quantum channel, but rather to distribute Bell pairs. Quantum computer would use these bell pairs to build qubit registers to perform calculations. It does not seem that it is the application that generates the qubit flow. Quantum application requested the Bell Pair.

The data plane of quantum network seem mainly based on row level which is based on quantum channel to transmit/forward fly qubit and swap them with Memory/Matter « qubit » of the end host (End-to-end entangled qubit). The control plan is based on classical network and can follow the standard protocols stack. 

/Patrick
-----Message d'origine-----
De : Qirg <[email-masked]> De la part de [email-masked]
Envoyé : vendredi 6 septembre 2019 17:37
À : [email-masked]
Cc : [email-masked]
Objet : [Qirg] I-D Action: draft-irtf-qirg-principles-01.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

---

From: Rodney Van Meter <[email-masked]>
Date: Mon, 9 Sep 2019 17:42:10 +0900

Exactly.

In fact, in first-generation repeater networks, the process is more akin to a distributed computation along the path than transmission of a message.

Note that end nodes can also be measurement-only, without memory.

An interesting question is whether nodes can be transmit-only, without memory.

Rodney Van Meter
Professor, Faculty of Environment and Information Studies
Keio University, Japan
[email-masked]

> On Sep 9, 2019, at 17:09, Gelard Patrick <[email-masked]> wrote:
> 
> Hi,
> 
> Hi,
>

---

From: Gelard Patrick <[email-masked]>
Date: Mon, 9 Sep 2019 09:02:27 +0000

>>An interesting question is whether nodes can be transmit-only, without memory.
There is study/experiment on all-photonic quantum repeater : https://www.ntt-review.jp/archive/ntttechnical.php?contents=ntr201907sr3.html -  https://www.nature.com/articles/s41566-019-0468-5   ; I don't know if this study answer the question.

/Patrick
-----Message d'origine-----
De : Rodney Van Meter <[email-masked]> 
Envoyé : lundi 9 septembre 2019 10:42
À : Gelard Patrick <[email-masked]>
Cc : Rodney Van Meter <[email-masked]>; [email-masked]
Objet : Re: [Qirg] I-D Action: draft-irtf-qirg-principles-01.txt

Exactly.

Rodney Van Meter
Professor, Faculty of Environment and Information Studies Keio University, Japan [email-masked]

> One of the goal of the classical internet is to provide end-to-end IP 
> connectivity so that applications running on computer could exchange 
> digital data, audio or video.  it is the applications that generate 
> the data flows
> 
> De : Qirg <[email-masked]> De la part de 
> [email-masked] Envoyé : vendredi 6 septembre 2019 17:37 À : 
> [email-masked] Cc : [email-masked] Objet : [Qirg] I-D Action: 
> draft-irtf-qirg-principles-01.txt
> 
>

---

From: Gelard Patrick <[email-masked]>
Date: Thu, 12 Sep 2019 13:14:43 +0000

Hi,

Concerning relation to classical networks :

	Regarding the data plan, there are a large number of studies that are interested in hybridizing it with a terrestrial network of transparent optical network transport.

		Quantum information processing with space-division multiplexing optical fibres ( https://arxiv.org/abs/1905.12644 )
		Quantum communications in reconfigurable optical networks: DWDM QKD through a ROADM (  https://ieeexplore.ieee.org/document/5465339   ) 
		Optical networking for quantum key distribution and quantum communications ( https://iopscience.iop.org/article/10.1088/1367-2630/11/10/105001/meta  ) 
		Dense wavelength multiplexing of 1550 nm QKD with strong classical channels in reconfigurable networking environments ( https://iopscience.iop.org/article/10.1088/1367-2630/11/4/045012/meta )
		...
	"Would other networking paradigms, such as SDN or ICN, be a better fit for quantum networks?"

		The use of « Software Defined Optical Networks (SDON) » ( https://link.springer.com/article/10.1186/s41476-019-0105-4 ) for the control plan to the hybrid network (classic and quantum) has naturally been studied. There are a large number of studies in the context of QKD. 

However I am agree with :  "It would be best if quantum networks could seamlessly integrate into existing networks in order to avoid having to reinvent the wheel, to benefit from developments happening in the classical networking community, and to reduce deployment complexity and costs. Perhaps this itself is worth stating as a goal or principle."  Now, this leads to integrating into the conventional network control plane, the control specifications of the quantum network.

/Patrick
-----Message d'origine-----

Exactly.

Rodney Van Meter