Subject: [Qirg] Comments on draft-irtf-qirg-principles-00

From: Chonggang Wang <[email-masked]>
Date: Fri, 6 Sep 2019 09:44:59 +0000

Hi All,

I have reviewed the "Architectural Principles for a Quantum Internet" draft and would like to provide the following comments.

  *   Overall, it is a concise and well written draft.
  *   Section 1 - It's not explicitly clear what "Fully quantum network" looks like. Also, will "Partial quantum network" possible? In addition, section 5.1 describes a model of a quantum network. Should "fully quantum network" be explicitly defined somewhere (e.g. in Section 5.1)?
  *   Section 2 - "necessary to be understand" - It's a typo.
  *   Section 2.1 - In the paragraph of "Upon measurement ...", suggest adding a statement that |a|^2 + |b|^2 = 1 or |a| and |b| have been normalized.
  *   Section 2.2 - "two qubit register" appears several times. Suggest changing "two qubit" to "two-qubit". In addition, is "register" here the same as "memory" being described at some later sections?
  *   Section 4 - Suggest adding an explicit definition on "quantum connectivity"
  *   Section 4.1 - "...connecting a quantum network...". It's not connecting a quantum network but to connect nodes within a quantum network. It might be better to say "connecting quantum nodes" or "establishing connectivity within a quantum network".
  *   Section 4.2 - The sentence "Despite the no-cloning ...." is incomplete.
  *   Section 4.2 - "Nevertheless, due to the promise of fault-tolerance and its ...., this may eventually". "its" and "this" in this sentence are not very clear.
  *   Section 4.3.1 - This section briefly describes Bell Pairs as additional background on quantum information. It would read better to move it to Section 2, right after Section 2.2 "Multiple qubits".
  *   Section 4.3.2 - "Note he process" - It's a typo
  *   Section 4.3.3 - "Reducing the problem to one of generating ...". This sentence seems to follow with Section 4.3.2 on Teleportation, but it lacks a clue by having it as the first sentence in 4.3.3, especially what's the "problem" in this sentence.
  *   Section 4.3.4 - "Neither the Bell Pair of the swapping operations...". Suggest changing "the Bell Pair" to "the generation of Bell Pair" or other Bell Pair related operations, since "the Bell Pair" itself is not an operation.
  *   Section 4.3.4 - This section is about "Distillation", but the term "Distillation" has not been used or defined in this section.
  *   Section 5.2.1 - Wonder if it helps to add some brief description and/or references on fidelity measurement. Especially, a later section 5.3.2 describes "2. Fidelity is part of the service"
  *   Section 5.3.1 - "6. Easy to manage and monitor". Can we define "the quantum resource" and give some quantum resource examples (e.g. memory, bell pairs, connectivity, time? )
  *   Section 5.3.2 - In "6. Parallelise quantum operations", suggest changing "swap operations" to "swapping operations".
  *   Section 8 - "...funding received the Quantum Internet Alliance"- It's a typo.

Thanks,
CG
[Banner]

[Banner] [Banner]
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Wojciech Kozlowski <[email-masked]>
Date: Fri, 6 Sep 2019 15:59:10 +0000

I have incorporated most of your comments. Those that I have not, I explain in-line below:

On Fri, 2019-09-06 at 09:44 +0000, Chonggang Wang wrote:
Hi All,

I have reviewed the “Architectural Principles for a Quantum Internet” draft and would like to provide the following comments.

  *   Overall, it is a concise and well written draft.
  *   Section 1 – It’s not explicitly clear what “Fully quantum network” looks like. Also, will “Partial quantum network” possible? In addition, section 5.1 describes a model of a quantum network. Should “fully quantum network” be explicitly defined somewhere (e.g. in Section 5.1)?

This is a very good question and actually not very simple to incorporate since there is a lot of detail to cover here. I left this point for later.

  *
  *   Section 2 – “necessary to be understand” – It’s a typo.
  *   Section 2.1 – In the paragraph of “Upon measurement …”, suggest adding a statement that |a|^2 + |b|^2 = 1 or |a| and |b| have been normalized.
  *   Section 2.2 – “two qubit register” appears several times. Suggest changing “two qubit” to “two-qubit”. In addition, is “register” here the same as “memory” being described at some later sections?

Yes, in the context of this example (though in general two-qubits states are not necessarily in memory, e.g. they can be photons flying down a fibre)

  *
  *   Section 4 – Suggest adding an explicit definition on “quantum connectivity”

Good point. Didn't have time. Would you be willing to write something on this?

  *
  *   Section 4.1 – “…connecting a quantum network…”. It’s not connecting a quantum network but to connect nodes within a quantum network. It might be better to say “connecting quantum nodes” or “establishing connectivity within a quantum network”.
  *   Section 4.2 – The sentence “Despite the no-cloning ….” is incomplete.
  *   Section 4.2 – “Nevertheless, due to the promise of fault-tolerance and its …., this may eventually”. “its” and “this” in this sentence are not very clear.
  *   Section 4.3.1 – This section briefly describes Bell Pairs as additional background on quantum information. It would read better to move it to Section 2, right after Section 2.2 “Multiple qubits”.

Possibly, but I wanted the first few sections to be very basic. If more people feel this would help in presentation, we can move it.

  *
  *   Section 4.3.2 – “Note he process” – It’s a typo
  *   Section 4.3.3 – “Reducing the problem to one of generating …”. This sentence seems to follow with Section 4.3.2 on Teleportation, but it lacks a clue by having it as the first sentence in 4.3.3, especially what’s the “problem” in this sentence.
  *   Section 4.3.4 – “Neither the Bell Pair of the swapping operations…”. Suggest changing “the Bell Pair” to “the generation of Bell Pair” or other Bell Pair related operations, since “the Bell Pair” itself is not an operation.
  *   Section 4.3.4 – This section is about “Distillation”, but the term “Distillation” has not been used or defined in this section.
  *   Section 5.2.1 – Wonder if it helps to add some brief description and/or references on fidelity measurement. Especially, a later section 5.3.2 describes “2. Fidelity is part of the service”
  *   Section 5.3.1 – “6. Easy to manage and monitor”. Can we define “the quantum resource” and give some quantum resource examples (e.g. memory, bell pairs, connectivity, time? )

Good question. Added a point in the CONTRIBUTING section on defining resources (see link to GitHub in my other e-mail).

  *
  *   Section 5.3.2 – In “6. Parallelise quantum operations”, suggest changing “swap operations” to “swapping operations”.
  *   Section 8 – “…funding received the Quantum Internet Alliance”- It’s a typo.

Thanks,
CG
[Banner]

[Banner] [Banner]

_______________________________________________

Qirg mailing list

[email-masked]<mailto:[email-masked]>

https://www.irtf.org/mailman/listinfo/qirg