Subject: [Qirg] minutes from 191014 online meeting

From: Axel Dahlberg <[email-masked]>
Date: Mon, 14 Oct 2019 12:46:59 +0000

Here are the minutes from today’s meeting:

Participants:
Wojciech Kozlowski
Gyananjay Rai
Stephen Diadamo
Axel Dahlberg
Bruno Rijsman
Piotr Rydlichowski
Sothy Shan
Hannu Flinck
John Woodworth
Rana Sircar
Patrick Gelard
Marcello Caleffi
Cheng-Hsin Hsu
Kuo
Ocket8888
aUser

Initials used below:
PG = Patrick Gelard
WK = Wojciech Kozlow
BR = Bruno Rijsman
RS = Rana Sircar

Minutes:
WK:
agenda:
How to work on GitHub.
SD setup repo to work on the draft.

SD:
Advantages of using a github repo for the draft.
It's hard to tell who works on what, helpful to keep track of projects.
Webhooks are setup for updates on repo to be sent to the mailing list.

WK:
Will use webhooks more frequently, link is already shared.

SD:
It would be more helpful to change projects to issues.

WK:
recap:
relation between quantum networks to classical networks
content of email from the 1st October (probably 2nd that day)
highlight challenges for setup quantum vs classical network
quantum network does not have payload carrying packets but rather entanglement, does not carry control information
requires classical control information in parallel to quantum communication
this model is also used in QKD networks

abstract model of the network
both quantum and non-quantum dataplane
decision making nodes, make decision based on non-quantum-information

all: no comments

WK:
might be hard to discuss relation between quantum and classical
what kind of requirements are we trying to cover?
question raised on mailing list, (AXIS? I didn't here the comment here)
highlevel example, want to maximise use of quantum resource
don't want to block quantum resource due to non-quantum operations

RS:
talk of communication, async or not
in quantum, are we considering sync communication? Since sync required?

WK:
what do you mean with async?

RS:
not an ACC for every delivery, in async the message can come anything, when and how do you detect it?
if it is sync, we know in what time period it is coming?

WK:
checking whether something arrives vs knowing

BR:
Is this in-scope or out? Should QIRG concentrate on only higher-level?

WK:
maybe no need for exact protocols
async might not be obvious for classical network people
classically can be put in a buffer, not as straight-forward for qubits
can't peek whether it is entangled.

RS:
How do the node know if it should measure? Is the qubit entangled or not?

WK:
don't send untangled qubits
good to include description of heralding
this should make it into the draft

WK:
comment about distinction between internet and network
we are perhaps lose about this
unlike classical internet where network layer was develop to glue local network technologies together

BR:
I do think it applies to quantum networks as well
we have not agreed on what technology to use
we might use various technologies
our architecture should allow different types of technologies
I think there is a quite strong analogy

WK:
there is a slight dist. for LL in quantum and classical
in classical you can construct an entire network using only LL
in quantum ,currently, you can't construct a full network

BR:
early classical network, x25 might be ten hops, another ten hops of another link layer, bridged by network layer
in quantum network the analogy might be using NV for some hops and then some hops using another technology
there is data protocol but there also difference in the network layer

AD:
current proposal for link layer does not only two-node network
there is a parameter in the CREATE message for which remote node
can be a network of for example multiple nodes connected to a single heralding station

RS:
add to Bruno, if you have to links which are connected which satellite, you might need a bridge
in network layer you might not be to aware of the difference in technology

WK:
there might be boundaries between different technologies
interconnect

BR:
one of the differences between having distinct administrative domains, run by different companies

WK:
clarify, network layer provides the service of generating entanglement between possible remote nodes

BR:
yes, near-term, what about in future? with error-correcting could network layer do other than entanglement

WK:
possibly expand on this in the draft

WK:
question, transport layer?
we teleport qubits, similar to TCP vs UDP
should we include this in the draft?

all: no comments

WK:
conclusion, not touch on transport layer in draft

WK:
similarities with MPLS and quantum networks
does anyone has some comments to add which are relevant for this draft
this is very interesting, but not sure if this should feature in the draft

BR:
important point to raise, not details but a high-level point, will make a PR for this

PG (chat)
is it possible to have a hybrid direct transmission and entanglement?

WK:
I think yes

WK:
is there consensus?
of everything in email (1st Oct and call)
receiver with heralding, how does each end get not raised by RS
clarify inter-networking, boundaries
BR will add brief point on MPLS

happy to see contributions
send snippet of text through email (list or direct), get credit

work on this before next IETF
use github with webhooks

bye!

/Axel Dahlberg

---

From: Rodney Van Meter <[email-masked]>
Date: Mon, 14 Oct 2019 21:50:13 +0900

Doh!!! I put it in my calendar at the wrong time.  Sorry to have missed y’all.

Thanks, Axel, for the minutes.  I will get them posted.

I haven’t heard from the IETF scheduling gods, but I’ve requested a slot for us on Tuesday afternoon or Wednesday.  We’ll see if they can accommodate us.

—Rod

Rodney Van Meter
Professor, Faculty of Environment and Information Studies
Keio University, Japan
[email-masked]

> On Oct 14, 2019, at 21:46, Axel Dahlberg <[email-masked]> wrote:
> 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Axel Dahlberg <[email-masked]>
Date: Mon, 14 Oct 2019 12:54:54 +0000

Hi Rodney!

Unfortunately I won’t make it to Singapore but if there is time I can remotely give a very brief (5 min) overview of what has changed in the link layer draft since the last meeting and see if there are any comments.

/Axel Dahlberg

On 14 Oct 2019, at 14:50, Rodney Van Meter <rdv=[email-masked]<mailto:rdv=[email-masked]>> wrote:

—Rod

Rodney Van Meter
Professor, Faculty of Environment and Information Studies
Keio University, Japan
[email-masked]<mailto:[email-masked]>

On Oct 14, 2019, at 21:46, Axel Dahlberg <[email-masked]<mailto:[email-masked]>> wrote:

Participants:
Wojciech Kozlowski
Gyananjay Rai
Stephen Diadamo
Axel Dahlberg
Bruno Rijsman
Piotr Rydlichowski
Sothy Shan
Hannu Flinck
John Woodworth
Rana Sircar
Patrick Gelard
Marcello Caleffi
Cheng-Hsin Hsu
Kuo
Ocket8888
aUser

Initials used below:
PG = Patrick Gelard
WK = Wojciech Kozlow
BR = Bruno Rijsman
RS = Rana Sircar

Minutes:
WK:
agenda:
How to work on GitHub.

SD:

WK:

SD:

WK:
recap:

all: no comments

WK:

RS:

WK:

RS:

WK:

BR:

WK:

RS:

WK:

WK:

BR:

WK:

BR:

AD:

RS:

WK:

BR:

WK:

BR:

WK:

WK:

all: no comments

WK:

WK:

BR:

PG (chat)

WK:
I think yes

WK:
is there consensus?

bye!

/Axel Dahlberg
_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 14 Oct 2019 14:05:57 +0000

Also, recordings are available of the two calls. Currently they're hosted on my DropBox as I haven't figured out a better place for them. If somebody has any suggestion, let me know.

Virtual meeting 2019-09-30: https://www.dropbox.com/s/zmut1mi06u0eg6x/qirgdraftprinciples%20on%202019-09-30%2011%3A54.mp4?dl=0
Virtual meeting 2019-10-14: https://www.dropbox.com/s/wnwkade2ofagug0/qirgdraftprinciples%20on%202019-10-14%2011%3A46.mp4?dl=0

On Mon, 2019-10-14 at 21:50 +0900, Rodney Van Meter wrote:
Doh!!! I put it in my calendar at the wrong time.  Sorry to have missed y’all.

—Rod

Rodney Van Meter

Participants:
Wojciech Kozlowski
Gyananjay Rai
Stephen Diadamo
Axel Dahlberg
Bruno Rijsman
Piotr Rydlichowski
Sothy Shan
Hannu Flinck
John Woodworth
Rana Sircar
Patrick Gelard
Marcello Caleffi
Cheng-Hsin Hsu
Kuo
Ocket8888
aUser

Initials used below:
PG = Patrick Gelard
WK = Wojciech Kozlow
BR = Bruno Rijsman
RS = Rana Sircar

Minutes:
WK:
agenda:
How to work on GitHub.

SD:

WK:

SD:

WK:
recap:

all: no comments

WK:

RS:

WK:

RS:

WK:

BR:

WK:

RS:

WK:

WK:

BR:

WK:

BR:

AD:

RS:

WK:

BR:

WK:

BR:

WK:

WK:

all: no comments

WK:

WK:

BR:

PG (chat)

WK:
I think yes

WK:
is there consensus?

bye!

/Axel Dahlberg

Qirg mailing list

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Mon, 21 Oct 2019 14:45:52 +0000

Might I ask for one clarification?

From: Qirg <[email-masked]> On Behalf Of Axel Dahlberg
Sent: Monday, October 14, 2019 8:47 AM
To: [email-masked]
Subject: [Qirg] minutes from 191014 online meeting

Initials used below:
WK = Wojciech Kozlow

WK:

Might you expand on what you mean by the distinction in the link levels? Is it:

  *   Because link levels in Quantum Networks are essentially “data-only” (the entangled qubits), while in a classical network, you can both data and control over the same link?
  *   Because the “forwarding” operation between links is radically different between classical and quantum networks?
  *   Something else?

Thanks!

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 22 Oct 2019 08:53:08 +0000

Inline

On Mon, 2019-10-21 at 14:45 +0000, Scott Fluhrer (sfluhrer) wrote:
Might I ask for one clarification?

Initials used below:
WK = Wojciech Kozlow

WK:

It's the second point. In a classical network while layers 2 and 3 are quite different they both perform forwarding of some form so you can have a pure L2 network (LAN) as well as an L3 network. The act of generating entanglement over a quantum link will require some protocol and I was thinking of this as the link layer of the quantum network (as motivated by the QIRG link layer draft and related paper). However, this model leaves entanglement swapping (the quantum equivalent of forwarding) to the network layer.

In other words, with this definition of layers the link layer does not perform any switching as entanglement swapping isn't part of its definition. It is only responsible for generating entanglement with a directly connected neighbour leaving swapping (forwarding) to the network layer.

However, having said that, this shows that I implicitly assumed a certain stack definition with that statement. I'd prefer to avoid defining a stack in this draft explicitly or implicitly as there are at least two stack proposals that have been put forward and I think it would be preferable not to commit to either. Nevertheless, the separation of responsibilities between link generation and entanglement swapping is a good idea, but whether this separation must be a layer boundary is less clear.

Thanks!

Qirg mailing list

---

From: Axel Dahlberg <[email-masked]>
Date: Tue, 22 Oct 2019 09:57:22 +0000

Hi!

I’m not sure I fully agree with this distinction. The link layer, at least as we defined it in https://arxiv.org/abs/1903.09778, can in fact include entanglement swapping, since what we call a “link” (or directly connected) can also be a chain of automated repeaters.
These “automated” repeaters do perform entanglement swapping, however they do this using fixed logic that does not depend on any higher layer.
In my view the difference is that entanglement generation in the link layer uses a dedicated resource (e.g. a heralding station, a chain of repeaters etc) for the involved pair of nodes, as compared to the network layer.
(Note that this dedicated resource can also be a time-slot in a heralding station connecting multiple nodes.)

/Axel Dahlberg

On 22 Oct 2019, at 10:53, Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>> wrote:

Inline

From: Qirg <[email-masked]<mailto:[email-masked]>> On Behalf Of Axel Dahlberg
Sent: Monday, October 14, 2019 8:47 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Qirg] minutes from 191014 online meeting

Initials used below:
WK = Wojciech Kozlow

WK:

Thanks!

Qirg mailing list

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 22 Oct 2019 12:02:24 +0000

Good point. So swapping indeed need not be a construct confined to a layer.

However, in what you describe I wouldn't call that forwarding as there is no decision making in that process, i.e. no table look up to determine next hop/link. As I understand, with that definition of a link layer, you still can't build a switch that can determine which link to swap with (assuming that you have more than just two links) based on the contents of a look up table.

Could you clarify what you mean by "In my view the difference is that entanglement generation in the link layer uses a dedicated resource"? I'm not sure I understand this sentence.

On Tue, 2019-10-22 at 11:57 +0200, Axel Dahlberg wrote:
Hi!

/Axel Dahlberg

Inline

Initials used below:
WK = Wojciech Kozlow

WK:

Thanks!

Qirg mailing list

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 22 Oct 2019 12:40:53 +0000

Hi,

The more I think about this, the stronger the impression I have we are “starting the house from the roof”, as we are talking about layers and devices that are applicable to current classical data networks, trying to make mappings that would not necessarily hold when actual quantum networks are deployed. We might need to start by analyzing and defining how to build reliable physical paths, much as classical networks started by dealing with circuit switching, consolidating the foundations of networking mechanisms before packets and layering came into play.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 22/10/2019, 14:02, "Qirg on behalf of Wojciech Kozlowski" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

/Axel Dahlberg

Inline

Initials used below:
WK = Wojciech Kozlow

WK:

·         Because link levels in Quantum Networks are essentially “data-only” (the entangled qubits), while in a classical network, you can both data and control over the same link?

·         Because the “forwarding” operation between links is radically different between classical and quantum networks?

·         Something else?

Thanks!

Qirg mailing list

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Axel Dahlberg <[email-masked]>
Date: Tue, 22 Oct 2019 12:51:06 +0000

Consider the case when there is a single heralding station, connected to more than two nodes emitting photons entangled with their local qubits. One might use a strategy where each pair of nodes are assigned a predetermined time-slot when they are allowed to send photons to the midpoint, in case they wish to generate entanglement. Furthermore, the midpoint then knows, based on what the current timeslot is, to whom it should announce the measurement outcome. I don’t know if this fits your picture of a lookup table but the midpoint does a lookup from a timeslot to a pair of nodes.

Regarding “dedicated resources”, I mean that there is some resource (physical, timeslot etc) which is dedicated to be used for a single pair of nodes for entanglement generation. Let me know if it’s still unclear :)

/Axel Dahlberg

On 22 Oct 2019, at 14:02, Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>> wrote:

/Axel Dahlberg

Inline

Initials used below:
WK = Wojciech Kozlow

WK:

Thanks!

Qirg mailing list

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 22 Oct 2019 13:01:44 +0000

That makes sense. So it does look like there can be some form of switching at this level, just not swap based. The switching happens at the mid-point in this case rather than the repeater.

On Tue, 2019-10-22 at 14:51 +0200, Axel Dahlberg wrote:
Consider the case when there is a single heralding station, connected to more than two nodes emitting photons entangled with their local qubits. One might use a strategy where each pair of nodes are assigned a predetermined time-slot when they are allowed to send photons to the midpoint, in case they wish to generate entanglement. Furthermore, the midpoint then knows, based on what the current timeslot is, to whom it should announce the measurement outcome. I don’t know if this fits your picture of a lookup table but the midpoint does a lookup from a timeslot to a pair of nodes.

/Axel Dahlberg

/Axel Dahlberg

Inline

Initials used below:
WK = Wojciech Kozlow

WK:

Thanks!

Qirg mailing list