Subject: Re: [Qirg] Qirg Digest, Vol 18, Issue 28

From: gyananjay rai <[email-masked]>
Date: Wed, 23 Oct 2019 02:10:33 +0530

Hi,

Its interesting..However we can sight classical networking phenomenon to
visualise the quantum networking architecture:

Layer 2 -LL-we are trying to make layer 2 (Switching layer ,CAM table and
repeater) with entanglement generation. However layer 2 architecture does
not deal with routing alogorthim. As for as my understanding of below Axel
is trying to formulate a routing protocols  and alogorthim like RIP
:distance-Vector (hop count) ,linkstate-OSPF,BGP etc.

However my thought Will be to formulate  LL as for local system and can
somewhat work for a physical or hardware specific control systems.

You can design the layer to table /headers/control systems dimmed so fit
for time slot specific to entanglement generation.

Layer 3: Engagement swapping can be designed for remote systems and
transmission and control logics (headers to be more specific).Here we can
formulate our algorithms for routing to remote systems or remote quantum
system.

*I wanted to bring teleportation phenomenon in our quantum network
architecture also.

Gyananjay Rai

Layer 2-LL is entag

On Tue, 22 Oct 2019, 18:32 , <[email-masked]> wrote:

> Send Qirg mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.irtf.org/mailman/listinfo/qirg
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Qirg digest..."
> Today's Topics:
>
>    1. Re: minutes from 191014 online meeting (Wojciech Kozlowski)
>
>
>
> ---------- Forwarded message ----------
> From: Wojciech Kozlowski <[email-masked]>
> To: Axel Dahlberg <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Bcc:
> Date: Tue, 22 Oct 2019 13:01:44 +0000
> Subject: Re: [Qirg] minutes from 191014 online meeting
> That makes sense. So it does look like there can be some form of switching
> at this level, just not swap based. The switching happens at the mid-point
> in this case rather than the repeater.
>
> On Tue, 2019-10-22 at 14:51 +0200, Axel Dahlberg wrote:
>
> Consider the case when there is a single heralding station, connected to
> more than two nodes emitting photons entangled with their local qubits. One
> might use a strategy where each pair of nodes are assigned a predetermined
> time-slot when they are allowed to send photons to the midpoint, in case
> they wish to generate entanglement. Furthermore, the midpoint then knows,
> based on what the current timeslot is, to whom it should announce the
> measurement outcome. I don’t know if this fits your picture of a lookup
> table but the midpoint does a lookup from a timeslot to a pair of nodes.
>
> Regarding “dedicated resources”, I mean that there is some resource
> (physical, timeslot etc) which is dedicated to be used for a single pair of
> nodes for entanglement generation. Let me know if it’s still unclear :)
>
> /Axel Dahlberg
>
> On 22 Oct 2019, at 14:02, Wojciech Kozlowski <[email-masked]>
> wrote:
>
> Good point. So swapping indeed need not be a construct confined to a layer.
>
> However, in what you describe I wouldn't call that forwarding as there is
> no decision making in that process, i.e. no table look up to determine next
> hop/link. As I understand, with that definition of a link layer, you still
> can't build a switch that can determine which link to swap with (assuming
> that you have more than just two links) based on the contents of a look up
> table.
>
> Could you clarify what you mean by "In my view the difference is that
> entanglement generation in the link layer uses a dedicated resource"? I'm
> not sure I understand this sentence.
>
> On Tue, 2019-10-22 at 11:57 +0200, Axel Dahlberg wrote:
>
> Hi!
>
> I’m not sure I fully agree with this distinction. The link layer, at least
> as we defined it in https://arxiv.org/abs/1903.09778, can in fact include
> entanglement swapping, since what we call a “link” (or directly connected)
> can also be a chain of automated repeaters.
> These “automated” repeaters do perform entanglement swapping, however they
> do this using fixed logic that does not depend on any higher layer.
> In my view the difference is that entanglement generation in the link
> layer uses a dedicated resource (e.g. a heralding station, a chain of
> repeaters etc) for the involved pair of nodes, as compared to the network
> layer.
> (Note that this dedicated resource can also be a time-slot in a heralding
> station connecting multiple nodes.)
>
> /Axel Dahlberg
>
> On 22 Oct 2019, at 10:53, Wojciech Kozlowski <[email-masked]>
> wrote:
>
> Inline
>
> On Mon, 2019-10-21 at 14:45 +0000, Scott Fluhrer (sfluhrer) wrote:
>
> Might I ask for one clarification?
>
> *From:* Qirg <[email-masked]> *On Behalf Of *Axel Dahlberg
> *Sent:* Monday, October 14, 2019 8:47 AM
> *To:* [email-masked]
> *Subject:* [Qirg] minutes from 191014 online meeting
>
>
> Initials used below:
> WK = Wojciech Kozlow
>
>
>
> WK:
> there is a slight dist. for LL in quantum and classical
> in classical you can construct an entire network using only LL
> in quantum ,currently, you can't construct a full network
>
> Might you expand on what you mean by the distinction in the link levels?
> Is it:
>
>
>    - Because link levels in Quantum Networks are essentially “data-only”
>    (the entangled qubits), while in a classical network, you can both data and
>    control over the same link?
>    - Because the “forwarding” operation between links is radically
>    different between classical and quantum networks?
>    - Something else?
>
>
> It's the second point. In a classical network while layers 2 and 3 are
> quite different they both perform forwarding of some form so you can have a
> pure L2 network (LAN) as well as an L3 network. The act of generating
> entanglement over a quantum link will require some protocol and I was
> thinking of this as the link layer of the quantum network (as motivated by
> the QIRG link layer draft and related paper). However, this model leaves
> entanglement swapping (the quantum equivalent of forwarding) to the network
> layer.
>
> In other words, with this definition of layers the link layer does not
> perform any switching as entanglement swapping isn't part of its
> definition. It is only responsible for generating entanglement with a
> directly connected neighbour leaving swapping (forwarding) to the network
> layer.
>
> *However*, having said that, this shows that I implicitly assumed a
> certain stack definition with that statement. I'd prefer to avoid defining
> a stack in this draft explicitly or implicitly as there are at least two
> stack proposals that have been put forward and I think it would be
> preferable not to commit to either. Nevertheless, the separation of
> responsibilities between link generation and entanglement swapping is a
> good idea, but whether this separation must be a layer boundary is less
> clear.
>
>
> Thanks!
>
>
> _______________________________________________
>
> Qirg mailing list
>
> [email-masked]
>
> https://www.irtf.org/mailman/listinfo/qirg
>
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>
>
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>

---

From: Gelard Patrick <[email-masked]>
Date: Wed, 23 Oct 2019 07:26:49 +0000

Hi,

Although there are similarities / analogies they remain fundamental differences :

-          The data link layer organizes the bit stream into a data unit called a frame which is the data link layer PDUs, and this data structure is not the same as the physical layer transmission frame. The data link layer usually adds both a header and trailer to the data presented by the network layer. The data plan of the quantum network isn’t structured in frame just Qbits/Qdits.

-          The quantum communication between two nodes more closely resembles a coordinated computation distributed among the set of nodes forming the path between the two nodes than a store-and-forward network session  (From Rodney)

-          Temporally, operations may not even happen left-to-right along the chain of repeaters, again violating the notion that data is moving (from Rodney). Sometimes, depending on how you think of things, the entangled state can be used atemporally  ((From Rodney)

-          …

Axel Dahlberg wrote: “Consider the case when there is a single heralding station, connected to more than two nodes emitting photons entangled with their local qubits. One might use a strategy where each pair of nodes are assigned a predetermined time-slot when they are allowed to send photons to the midpoint, in case they wish to generate entanglement.”

There is a similarity with the Acces Control. The Data Link Layer who performs framing, physical addressing, and error detection also performs access control (this determines whose turn it is to send over or control the link, an issue that becomes more and more interesting as the number of devices sharing the link grows). For example in LANs, this media access control (MAC) forms a sublayer of the data link layer.

Bests Regard
/Patrick

De : Qirg <[email-masked]> De la part de gyananjay rai
Envoyé : mardi 22 octobre 2019 22:41
À : [email-masked]
Objet : Re: [Qirg] Qirg Digest, Vol 18, Issue 28

Hi,

Its interesting..However we can sight classical networking phenomenon to visualise the quantum networking architecture:

Layer 2 -LL-we are trying to make layer 2 (Switching layer ,CAM table and repeater) with entanglement generation. However layer 2 architecture does not deal with routing alogorthim. As for as my understanding of below Axel is trying to formulate a routing protocols  and alogorthim like RIP :distance-Vector (hop count) ,linkstate-OSPF,BGP etc.

However my thought Will be to formulate  LL as for local system and can somewhat work for a physical or hardware specific control systems.

You can design the layer to table /headers/control systems dimmed so fit for time slot specific to entanglement generation.

Layer 3: Engagement swapping can be designed for remote systems and transmission and control logics (headers to be more specific).Here we can formulate our algorithms for routing to remote systems or remote quantum system.

*I wanted to bring teleportation phenomenon in our quantum network architecture also.

Gyananjay Rai

Layer 2-LL is entag

On Tue, 22 Oct 2019, 18:32 , <[email-masked]<mailto:[email-masked]>> wrote:
Send Qirg mailing list submissions to
        [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
        https://www.irtf.org/mailman/listinfo/qirg
or, via email, send a message with subject or body 'help' to
        [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
        [email-masked]<mailto:[email-masked]>

---------- Forwarded message ----------
From: Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>>
To: Axel Dahlberg <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Bcc:
Date: Tue, 22 Oct 2019 13:01:44 +0000
Subject: Re: [Qirg] minutes from 191014 online meeting
That makes sense. So it does look like there can be some form of switching at this level, just not swap based. The switching happens at the mid-point in this case rather than the repeater.

On Tue, 2019-10-22 at 14:51 +0200, Axel Dahlberg wrote:
Consider the case when there is a single heralding station, connected to more than two nodes emitting photons entangled with their local qubits. One might use a strategy where each pair of nodes are assigned a predetermined time-slot when they are allowed to send photons to the midpoint, in case they wish to generate entanglement. Furthermore, the midpoint then knows, based on what the current timeslot is, to whom it should announce the measurement outcome. I don’t know if this fits your picture of a lookup table but the midpoint does a lookup from a timeslot to a pair of nodes.

Regarding “dedicated resources”, I mean that there is some resource (physical, timeslot etc) which is dedicated to be used for a single pair of nodes for entanglement generation. Let me know if it’s still unclear :)

/Axel Dahlberg

On 22 Oct 2019, at 14:02, Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>> wrote:

However, in what you describe I wouldn't call that forwarding as there is no decision making in that process, i.e. no table look up to determine next hop/link. As I understand, with that definition of a link layer, you still can't build a switch that can determine which link to swap with (assuming that you have more than just two links) based on the contents of a look up table.

Could you clarify what you mean by "In my view the difference is that entanglement generation in the link layer uses a dedicated resource"? I'm not sure I understand this sentence.

I’m not sure I fully agree with this distinction. The link layer, at least as we defined it in https://arxiv.org/abs/1903.09778<https://arxiv.org/abs/1903..09778>, can in fact include entanglement swapping, since what we call a “link” (or directly connected) can also be a chain of automated repeaters.
These “automated” repeaters do perform entanglement swapping, however they do this using fixed logic that does not depend on any higher layer.
In my view the difference is that entanglement generation in the link layer uses a dedicated resource (e.g. a heralding station, a chain of repeaters etc) for the involved pair of nodes, as compared to the network layer.
(Note that this dedicated resource can also be a time-slot in a heralding station connecting multiple nodes.)

/Axel Dahlberg

On 22 Oct 2019, at 10:53, Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>> wrote:

Inline

From: Qirg <[email-masked]<mailto:qirg-bounces@irtf..org>> On Behalf Of Axel Dahlberg
Sent: Monday, October 14, 2019 8:47 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Qirg] minutes from 191014 online meeting

Initials used below:
WK = Wojciech Kozlow

WK:

Might you expand on what you mean by the distinction in the link levels? Is it:

  *   Because link levels in Quantum Networks are essentially “data-only” (the entangled qubits), while in a classical network, you can both data and control over the same link?
  *   Because the “forwarding” operation between links is radically different between classical and quantum networks?
  *   Something else?

It's the second point. In a classical network while layers 2 and 3 are quite different they both perform forwarding of some form so you can have a pure L2 network (LAN) as well as an L3 network. The act of generating entanglement over a quantum link will require some protocol and I was thinking of this as the link layer of the quantum network (as motivated by the QIRG link layer draft and related paper). However, this model leaves entanglement swapping (the quantum equivalent of forwarding) to the network layer.

In other words, with this definition of layers the link layer does not perform any switching as entanglement swapping isn't part of its definition.. It is only responsible for generating entanglement with a directly connected neighbour leaving swapping (forwarding) to the network layer.

However, having said that, this shows that I implicitly assumed a certain stack definition with that statement. I'd prefer to avoid defining a stack in this draft explicitly or implicitly as there are at least two stack proposals that have been put forward and I think it would be preferable not to commit to either. Nevertheless, the separation of responsibilities between link generation and entanglement swapping is a good idea, but whether this separation must be a layer boundary is less clear.

Thanks!

Qirg mailing list

[email-masked]<mailto:[email-masked]>

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg