Subject: [Qirg] Similarities between RSVP IETF (RFC 2205) protocol and connection Setup in a Quantum Network

From: Gelard Patrick <[email-masked]>
Date: Tue, 19 Nov 2019 12:40:16 +0000

Hi all,

There are similarities between  RSVP  IETF (RFC 2205) protocol and connection Setup in a Quantum Network ( https://tools.ietf.org/html/draft-van-meter-qirg-quantum-connection-setup-00 ) even if the goal isn't the same.

- RSVP was designed independently of any network architecture offering a QoS such as IntServ for example. It is RFC 2210 that defines how to implement the Qos of the IntServ architecture using the RSVP protocol / the setup connection must also be independent of any quantum network architecture

- Reservation at the request of the receiver like setup connection which use the recipient to establish rules and Bell pairs distribution

- RSVP is not a routing protocol. It must be integrated with routing and admission control functions. Connection Setup also needs the support of a routing protocol to reach the receiver.

Messages :

Path: setting the path (logical state).

Resv: reservation request.

ResvTear: deletes the reservation status

PathTear: clears the path state.

ResvErr: reservation error,

PathErr: path error.

ResvConf: reservation confirmation.

/Patrick

-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Frédéric Grosshans
Envoyé : mardi 12 novembre 2019 12:50
À : Patrick Gelard <[email-masked]>; [email-masked]; Gelard Patrick <[email-masked]>
Objet : Re: [Qirg] Multipatite entanglement

Hi Patrick,

Le 11/11/2019 à 09:04, Patrick Gelard a écrit :

> Now regarding the control plan for deploying such a service, he seems

> to me that one of the questions is: should we develop a new control

> plan or adapt some traditional network control plans (e.g Resource

> Reservation Protocol (RSVP) Mulicast ; SDN ; etc.) that could do the job?

My problem with this is that I'm a physicist with a really elementary knowledge (if any!) of network protocols. For example, in the theoretician's protocol we designed with Clément Meignant and Damian Markham, [arXiv:1811.05445 https://arxiv.org/abs/1811.05445],a<https://arxiv.org/abs/1811.05445%5d,a> key ingredient of GHZ state generation (which is a primitive for the following) is to find a subtree of the network linking the end-nodes.

The operation on nodes of the tree are then local, and look a bit like entanglement-swapping for a repeater line, bit on a tree.

I guess the control plan would look a lot like the one for multicast, but it's pure speculation from me.

Cheers,

        Frédéric

_______________________________________________

Qirg mailing list

[email-masked]<mailto:[email-masked]>

https://www.irtf.org/mailman/listinfo/qirg

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 20 Nov 2019 11:12:07 +0800

Note for RSVP to work as you describe, you need a multicast source-based distribution tree set up prior to any Path message sent. 

And Path message refreshes happen to new receivers when new branches are formed on the multicast distribution tree. 

And also note that quantum repeaters are not likely to be deployed initially on the same sides of a classical channel. What I mean is you could have this topology:

QR —— CR ——- CR —— QR

where CR is a classical router and entanglement swapping happens by each QR. 

Dino

> On Nov 19, 2019, at 8:40 PM, Gelard Patrick <[email-masked]> wrote:
> 
> 
> Hi all,
>  
> There are similarities between  RSVP  IETF (RFC 2205) protocol and connection Setup in a Quantum Network ( https://tools.ietf.org/html/draft-van-meter-qirg-quantum-connection-setup-00 ) even if the goal isn’t the same.
>  
> My problem with this is that I’m a physicist with a really elementary knowledge (if any!) of network protocols. For example, in the theoretician’s protocol we designed with Clément Meignant and Damian Markham, [arXiv:1811.05445 https://arxiv.org/abs/1811.05445],a key ingredient of GHZ state generation (which is a primitive for the following) is to find a subtree of the network linking the end-nodes.
> I guess the control plan would look a lot like the one for multicast, but it‘s pure speculation from me.
>  
>  
> Cheers,
>  
>         Frédéric
>  
> [email-masked]
> [email-masked]

---

From: Gelard Patrick <[email-masked]>
Date: Wed, 20 Nov 2019 07:57:47 +0000

Hi dino,

In the text.

/Patrick

De : Dino Farinacci <[email-masked]>
Envoyé : mercredi 20 novembre 2019 04:12
À : Gelard Patrick <[email-masked]>
Cc : [email-masked]; Frédéric Grosshans <[email-masked]>; Rodney Van Meter <rdv=[email-masked]>
Objet : Re: [Qirg] Similarities between RSVP IETF (RFC 2205) protocol and connection Setup in a Quantum Network

Note for RSVP to work as you describe, you need a multicast source-based distribution tree set up prior to any Path message sent.
[PG]Yes, This is what I mention when I write “RSVP is not a routing protocol. It must be integrated with routing”.  Just as for the point to point where a path must first be established. Just as for the establishment of quantum network connection as recalled in Rodney's presentation : Stages of the Problem!•Need to select a path (routing) https://arxiv.org/1206.5655

Note that the key issues of Inserv and RSVP is scaling.

For point-to-point, there is also a scaling problem for its use in traffic engineering of the MPLS protocol (RSVP-TE : describes the use of standard RSVP [RFC2205<https://tools.ietf.org/html/rfc2205>] to  establish Label Switched Paths (LSPs)). Moreover, concerning the traffic engineering of MPLS, the per-connection traffic steering model of MPLS-TE does not easily exploit the load balancing offered by Equal Cost MultiPath (ECMP) routing in plain IP networks. In addition to other problems, this led IETF (SPRING) to define the concept of “segment Routing” (SR :  https://tools.ietf.org/html/rfc8402 ) ;  A concept that can be useful in establishing the path selecting quantum repeaters.

The Segment Routing offers an innovative and simple approach to enable traffic engineering. Additional information is simply placed in the packets that will condition their processing: a list of segments is added in each datagram and defines the network path that must be used. Segment Routing thus offers a very simple option for the implementation of traffic engineering without the need for additional states on the equipment, which allows to add a large number of rules without overloading the routers and complicating the infrastructure operation. The SR architecture can leverage both distributed and centralized network control paradigms to provide efficient network solutions, and thus in a centralized network control the programmability from controllers, which is a prerequisite for SDN infrastructures.

Good entry point for SR : “Segment Routing: a Comprehensive Survey of Research Activities, Standardization Efforts and Implementation Results” https://arxiv.org/abs/1904.03471

QR —— CR ——- CR —— QR

where CR is a classical router and entanglement swapping happens by each QR.
[PG]CR could be in path of the control plan of quantum network, but not in the data plane (i.e quantum channel). It should be noted that can use also quantum channel to encode classical information (bits. For example dense coding) and thus to transport the control plan

Dino

On Nov 19, 2019, at 8:40 PM, Gelard Patrick <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Messages :

PathErr: path error.

/Patrick

-----Message d'origine-----
De : Qirg <[email-masked]<mailto:[email-masked]>> De la part de Frédéric Grosshans
Envoyé : mardi 12 novembre 2019 12:50
À : Patrick Gelard <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Gelard Patrick <[email-masked]<mailto:[email-masked]>>
Objet : Re: [Qirg] Multipatite entanglement

Hi Patrick,

My problem with this is that I’m a physicist with a really elementary knowledge (if any!) of network protocols. For example, in the theoretician’s protocol we designed with Clément Meignant and Damian Markham, [arXiv:1811.05445 https://arxiv.org/abs/1811.05445],a<https://arxiv.org/abs/1811.05445%5d,a> key ingredient of GHZ state generation (which is a primitive for the following) is to find a subtree of the network linking the end-nodes.

Cheers,

        Frédéric

Qirg mailing list

---

From: "Diego R. Lopez" <[email-masked]>
Date: Wed, 20 Nov 2019 09:55:49 +0000

Hi,

Just a reflection on the last statement made by Patrick, in the hope we continue the convergence path we seem to have initiated during the meeting yesterday

Patrick said:

And I’d like to propose we talk about:

  *   A control plane, probably qualifying it as “quantum control plane”, as it is essentially not different from a classical control plane, with the difference of the plane being controlled
And

  *   A quantum plane, that is the equivalent to a classical data plane. I think the differences here are big enough to use a different denomination.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 20/11/2019, 15:58, "Qirg on behalf of Gelard Patrick" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi dino,

In the text.

/Patrick

QR —— CR ——- CR —— QR

Dino

Hi all,

Messages :

PathErr: path error.

/Patrick

-----Message d'origine-----
De : Qirg <[email-masked]<mailto:[email-masked]>> De la part de Frédéric Grosshans
Envoyé : mardi 12 novembre 2019 12:50
À : Patrick Gelard <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Gelard Patrick <[email-masked]<mailto:[email-masked]>>
Objet : Re: [Qirg] Multipatite entanglement

Hi Patrick,

Cheers,

        Frédéric

Qirg mailing list

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 20 Nov 2019 19:26:03 +0800

I think you don’t need any of these mechanisms. If you look at the follownig topologies, all you need is for the the two QRs to talk to each other. They are nothing more than two hosts on an IP network connected via two CRs:

QR —— CR ——- CR —— QR

It is overkill to use RSVP and SR. They are protocols to route packets. If you use SR, you don’t need to construct a path between two QRs. All the QRs need to do is talk to each other. And you can pair up QRs with an app level path mechanism.

Dino

> On Nov 20, 2019, at 3:57 PM, Gelard Patrick <[email-masked]> wrote:
> 
> Hi dino,
>  
> In the text.
>  
> /Patrick
>  
> For point-to-point, there is also a scaling problem for its use in traffic engineering of the MPLS protocol (RSVP-TE : describes the use of standard RSVP [RFC2205] to  establish Label Switched Paths (LSPs)). Moreover, concerning the traffic engineering of MPLS, the per-connection traffic steering model of MPLS-TE does not easily exploit the load balancing offered by Equal Cost MultiPath (ECMP) routing in plain IP networks. In addition to other problems, this led IETF (SPRING) to define the concept of “segment Routing” (SR :  https://tools.ietf.org/html/rfc8402 ) ;  A concept that can be useful in establishing the path selecting quantum repeaters.
>

---

From: Bruno Rijsman <[email-masked]>
Date: Wed, 20 Nov 2019 13:15:47 +0100

RSVP-TE AND GMPLS
=================

TL;DR: In my opinion the ideas in (G)MPLS and RSVP-TE are very applicable to quantum networks. At the very least we should use the concepts of (G)MPLS and RSVP-TE as inspiration for quantum networks. I think there might even be a possibility to extend the existing protocols / implementations for quantum networks.

SCOPE
-----

I want to start by being clear on the scope of applicability of (G)MPLS and RSVP-TE because there is some confusion about this on the mailing list.

I am *not* talking about using (G)MPLS and RSVP-TE to facilitate communication between the control plane on one quantum router and the control plane on another quantum router over the classical channel.

Indeed, for that we just need TCP/IP connectivity and any simple classical routing protocol (OSPF, ISIS, BGP, whatever) will do. We don't need anything complicated like (G)MPLS or RSVT-TE here.

What I am suggesting here is to use (G)MPLS and RSVP-TE or similar mechanisms to achieve the following:

(a) Compute the path for a quantum circuit over a sequence of quantum channels. I.e. what is the sequence of point-to-point link Bell pairs that we are going to "stitch together" (using swapping and distillation) to produce the desired end-to-end Bell pairs that are consumed by the application.

(b) Make sure that each end-to-end quantum circuit gets the required capacity in terms of Bell pairs per second (Bpps) and fidelity that is needed by the application. For that we need to "know" the capacity (in Bpps) of each individual link, we need to keep track of how much of that link capacity is already consumed by other circuits and how much remaining capacity is still available. We need to take the remaining capacity into account when we compute the 'best' path for each quantum circuit.

(c) Actually signal a quantum circuit once its path has been decided. We need to visit each quantum router on the path and install some state (Rodney calls it rules) that will cause the right sequence of actions (swaps, distillations, etc.) to happen at the right rate and under the right conditions to create the desired end-to-end quantum circuit.

INTRO
-----

First, a *very* brief (and hence somewhat simplified) introduction to RSVP-TE and GMPLS for those not familiar with it.

Consider the following example network topology:

 E1      R2----R3      E3
   \    /        \    /
    \  /          \  /
     R1            R5
    /  \          /  \
   /    \        /    \
 E2      +--R4--+      E4

E = End-point = Label Edge Router (LER) in MPLS terminology

R = Router = Label Switched Router (LSR) in MPLS terminology

Let's assume all links are 1 Gbps.

The job of RSVP-TE is to signal circuits from end-point to end-point. These circuits are called LSPs in MPLS terminology.

Each circuit can asks for a specific amount of bandwidth, and it is the job of RSVP-TE to signal a path that guarantees the requested bandwidth, or to deny the request if the bandwidth is not available (this is called call admission control, CAC).

Let's say we want to signal two circuits:

C1: E1->E3, 600 Mbps

C2: E2->E5, 700 Mbps

Let's say circuit C1 is established first [Note1].

The process of bringing circuit C1 up consist of the following steps:

* The ingress node E1 receives a request to establish a circuit of 600 Mbps to egress node E3.

* Ingress node E1 computes the optimal route for the circuit to E3 [Note2].

* In order to compute that path, E1 needs to know the full topology of the network. E1 uses a traditional link-state routing protocol such as OSPF or ISIS for that purpose. This is why we say that RSVP-TE needs a routing protocol.

* Not only that, E1 also needs to know how much bandwidth is still available on each link. For this reason both OSPF and ISIS have been enhanced with so-called traffic engineering (TE) extensions to flood not just the topology, but also the available bandwidth. This is called OSPF-TE and ISIS-TE.

* Given the topology and the bandwidth information for the whole network, ingress node E1 can compute the optimal path using the so-called constrained shortest path first (CSPF) algorithm.

* In this case the optimal path is E1 -> R1 -> R4 -> R5 -> E3

* Now that the so-called "path computation" function has been performed, it is time to actually signal the path. This is where RSVP-TE comes in.

* E1 takes the computed route, gives it to RSVP-TE as an explicit route object (ERO) and asks RSVP-TE to signal the path.

* RSVP-TE sends PATH messages, following the computed route in the ERO hop-by-hop, towards egress node E3. Then RSVP-TE sends RESV messages, following the computed route hop-by-hop in reverse, back to ingress node E1. The net result of this signaling is that the circuit is installed. All the necessary state (in this case MPLS label swaps) is installed on each router on the path.

* The installation of the end-to-end circuit has consumed some of the bandwidth on the network: we have consumed 600 Mbps out of the available 1 Gbps on links E1-R1, R1-R4, R4-R5, and R5-E3. Thus, we have 400 Mbps remaining on this link. OSPF-TE or ISIS-TE floods this information across the entire network.

Now let's say that we signal circuit C2 (E2->E4) next.

This follows the exact same sequence of steps as described above, with one difference.

When E2 computes the path by running the CSPF algorithm, it will detect that the shortest path E2->R1->R4->R5->E4 no longer has the required bandwidth of 700 Mbps available. For that reason, it will choose the longer path E2->R1->R2->R3->R5->E4.

Everything that I have described so far assumes that we are running an MPLS network, where we are forwarding data packets, namely MPLS packets. When RSVP-TE signals the end-to-end circuit, it allocates in-labels and out-labels on each hop, and it installs the circuit by populating MPLS swaps, pushes, and pops into the MPLS forwarding tables.

There is a generalization of MPLS which is called generalized MPLS (GMPLS).

In GMPLS, we use the same control plane (OSPF-TE/ISIS-TE + RSVP-TE) for a network that is not an MPLS network, or not even a packet switched network.

GMPLS is used for example for:

* Time division multiplexed networks (TDM) to compute the path for TDM circuits and to install the path by creating time-slot cross connects on the TDM switches.

* Optical transport networks (OTN) to compute the path for optical circuits in dense wavelength division multiplexed (DWDM) networks and to install the path by creating wavelength cross-connects using MEMS switches.

Finally, everything I have described so far assumes that the path computation is computed by the head-end of the circuit (which is what is considered a "distributed" control plane in MPLS networks). There is another model where a centralized path computation element or SDN controller is used to compute the path.

There are two sub-variations of that centralized model. In one variation the centralized controller talks to only to the head-end of the circuit, which then uses RSVP-TE (using the ERO provided by the controller) to install the path. In the other variation, the centralized controller talks directly to each router on the path (using OpenFlow or P4 or something similar) to install the circuit.

APPLICABILITY TO QUANTUM NETWORKS
---------------------------------

I thinks the (G)MPLS and RSVP-TE model is very applicable to quantum networks for the following reasons:

(1) It is not accurate to think of quantum networks in the same manner as a normal packet forwarding network. We are not forwarding a packet hop-by-hop, doing a lookup in a forwarding table to decide at each hop where we go next. As has been pointed out, a quantum network is more like a distributed computation where the quantum routers cooperate to produce end-to-end Bell pairs at the desired end-points at the desired rate. A "circuit" is a much more natural abstraction for this. An application could request that the quantum network creates a "circuit" from A to Z, and produces X bell pairs per second at fidelity Y at A and Z.

(2) Quantum networks will, at least initially, be extremely resource constrained. The capacity of links, in terms of Bell pairs per second, will be extremely limited. This a traffic engineering function where we keep track of the available and consumed resources will IMHO be essential.

(3) The state that is installed in each quantum router to implement a quantum circuit is much more complicated than a simple IP forwarding table entry or a simple MPLS forwarding table entry. It is much more akin to the complex rules that Rodney alludes to in his draft. I foresee a much more sophistical mechanism for distributing information about the network. Not only do we need to know the remaining available bandwidth, but also other constraints (e.g. available quantum memory) and attributes (e.g. is swap deterministic or not). I also foresee a much more sophisticated path computation function that only understands topology and resource available to compute the 'best' path, but that also understands the non-linear effects in quantum networks (e.g. non-linear slowdown of Bell pair rate as the circuit gets longer due to increased need for distillation etc.) For that reason, I think a centralized controller will make more sense, at least initially.

(4) MPLS has already been generalized into GMPLS to control non-packet-switched networks, such as TDM or OTN networks. These generalizations can be used to control quantum networks.

NOTES
-----

[Note 1] The fact that we are signaling circuits sequentially means that we are doing a greedy local optimization. There are alternative approaches, which are even more applicable to quantum networks, where the path computation is done by a centralized path computation element (PCE), or software defined networking (SDN) controller. This allows the path computation function to use more sophisticated algorithms and obtain a global optimum rather than a local greedy optimum. This approach is particularly useful in optical transport networks (OTN) where the optimization has to take all sorts of non-linearities into account (e.g. fiber losses). I think we are in a similar situation with quantum networks.

[Note 2] In the model alluded to in [Note 1] the path computation would be done by the centralized controller, instead of the ingress node. IETF has actually standardized a protocol between the ingress node and the controller specifically for this purpose. It is called the path computation element protocol (PCEP).

[Note 3] I plan to contribute a much reduced and summarized version of this as the MPLS section for the architectural principles draft.

— Bruno

> On Nov 20, 2019, at 12:26 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 20 Nov 2019 20:59:41 +0800

IMO it is overkill. You don’t need complexity at this level. You just want a classical network to run your control-plane protocols between quantum repeaters. You’ll have your own complexities to deal with, you shouldn’t load more up with classical stuff.

Dino

> On Nov 20, 2019, at 8:15 PM, Bruno Rijsman <[email-masked]> wrote:
> 
> RSVP-TE AND GMPLS
> =================
>

---

From: Bruno Rijsman <[email-masked]>
Date: Wed, 20 Nov 2019 14:07:35 +0100

For simple linear chains of quantum repeaters, I agree with you.  

In such a topology we should have an optimized / much simpler protocol to deal with the linear chain, and abstract the linear chain as a single hop in the “network layer topology”.  

This is similar to not representing optical repeaters or Ethernet hubs in the classical layer 3 network topology.

But for arbitrary quantum network topologies that includes many quantum routers, each with more than 2 links (so, truly a router, not a repeater), you will need something more sophisticated. 

Admittedly, complex arbitrary layer 3 topologies are still far away in the future for quantum networks. We are still working on building the first the linear chains of repeaters. So, yes, we need to crawl before we walk.

— Bruno

> On Nov 20, 2019, at 1:59 PM, Dino Farinacci <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 20 Nov 2019 21:32:42 +0800

> On Nov 20, 2019, at 9:07 PM, Bruno Rijsman <[email-masked]> wrote:
> 

Right, but hops between QRs are not important. You want to focus on connecting pairs of QRs together so the entanglement swap can occur at long topology (and physical) distances. Like this:

QR1 —— ATT —— QR2 —— VZ —— QR3 —— lab—— QR4

where ATT and VZ are service provider clouds with dozens of CR hops. And lab is your internal enterprise network with a few hops.

I think in the above topology what you want to achiieve (please correct me if I’m wrong) that the qubit from QR1 is teleported to QR4 by having an entanglement swap at QR2/QR3.

> This is similar to not representing optical repeaters or Ethernet hubs in the classical layer 3 network topology.

Optical repeaters and ethernet hubs if SNMP managed would be hosts with accessible IP addresses on the layer-3 network.

> But for arbitrary quantum network topologies that includes many quantum routers, each with more than 2 links (so, truly a router, not a repeater), you will need something more sophisticated. 

I don’t believe you do. And I can explain face-to-face. But I can explain a solution where you can determine a  path at “your app layer” and *also* allow the QR to be mobile without “your app layer” havinig to know the classical path changed.

> Admittedly, complex arbitrary layer 3 topologies are still far away in the future for quantum networks. We 

No, they really are not. You can do the topology above if you just act as hosts. All QR1 needs to know is to send control packets to QR2 and the underlying routing system will deliver packets to QR2. You could even, as a pilot use DNS, and create naming pairs to find each other.

This isn’t a hard problem.

> are still working on building the first the linear chains of repeaters. So, yes, we need to crawl before we walk.

Understand.

Dino

---

From: Bruno Rijsman <[email-masked]>
Date: Wed, 20 Nov 2019 14:59:34 +0100

One minor answer >>> below.

But before I address the main comment, can I ask you a clarifying question to fully understand the scenario that you have in mind?

In your scenario, are the service providers ATT and VZ only providing classical connectivity for the classical channel ([A] below) or are they also offering quantum connectivity for the quantum channel ([B] below)?

In everything I have described until now, I was actually only considering intra-domain quantum routing and not yet inter-domain quantum routing, which is even further away into the future IMHO.

[A] Service provider provides only classical channel (CC):
                   
 CC      CC     CC     CC     CC     CC   CC    CC
 +----CR----CR---+     +---CR----CR---+   +--CR--+
 |   |........|  |     |  |.........| |   | |..| |
 |      ATT      |     |     VZ       |   | Lab  |
 |                \   /               \   /      \
QR1----------------QR2-----------------QR4--------QR5
          QC                 QC              QC

[B] Service provider provides both classical channel (CC) and quantum channel (QC):
       
    CC+   CC+   CC+    CC+   CC+   CC+    CC+   CC+
    QC    QC    QC     QC    QC    QC     QC    QC
QR1----QR----QR----QR2----QR----QR----QR4----QR----QR5
      |........|         |........|         |..|
       ATT                VZ                Lab

— Bruno

> On Nov 20, 2019, at 2:32 PM, Dino Farinacci <[email-masked]> wrote:
> 

>>> Exactly, they are represented as hosts (not routers) on the network. So, they do not appear as nodes in the layer-3 topology flooded by OSPF / ISIS / etc. In fact, they do not appear at all in the routing protocol (which only advertises subnets, not individual hosts).

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 20 Nov 2019 22:29:44 +0800

> In your scenario, are the service providers ATT and VZ only providing classical connectivity for the classical channel ([A] below) or are they also offering quantum connectivity for the quantum cha…

Classic connectivity. The QRs can be at their customer sites. And if ISPs provide QRs that sites need to pair with (good luck with that), then you will have to know the IP addresses of the ISP QRs (good luck with that).

> In everything I have described until now, I was actually only considering intra-domain quantum routing and not yet inter-domain quantum routing, which is even further away into the future IMHO.

I don’t see why. 

>  +----CR----CR---+     +---CR----CR---+   +--CR--+

Right, they are not routers. Just like your laptop right now is not pariticaping in OSPF/IS-IS.

Dino

---

From: Bruno Rijsman <[email-masked]>
Date: Wed, 20 Nov 2019 15:40:55 +0100

See 2>>> below

> On Nov 20, 2019, at 3:29 PM, Dino Farinacci <[email-masked]> wrote:
> 
> Classic connectivity. The QRs can be at their customer sites.

2>>> In that case, you just use standard routing protocols (default route or BGP if you are multi-homed) for the classical traffic that goes over the service provider network. Nothing fancy needed here (no RSVP in specific).

2>>> And in this case the quantum topology is a simple linear chain, so once again, nothing fancy needed here either. We use the specialized repeater protocol, collapse the multi-hop quantum chain into a single quantum layer-3 hop, and the whole topology simplifies to a single layer-3 point-to-point link. No RSVP needed, once again.

> And if ISPs provide QRs that sites need to pair with (good luck with that),

2>>> Right, this is scenarios [B] which is indeed way more complicated, because… (see next comment)

> then you will have to know the IP addresses of the ISP QRs (good luck with that).
> 

2>>> (That’s the least of your concerns, that’s like knowing the IP address of the Service Provider’s BGP router for peering. The bigger concern is in the next comment….)

>> In everything I have described until now, I was actually only considering intra-domain quantum routing and not yet inter-domain quantum routing, which is even further away into the future IMHO.

2>>> The reasons why inter-domain routing / traffic engineering is far more complicated than intra-domain routing / traffic engineering are that (a) inter domain routing protocols optimize policy considerations (= money) rather than technical considerations (= shortest path) and (b) service providers don’t want to leak the internal details of their networks (topology, utilization, etc.) to their customers. We need to crawl and walk before we consider running a marathon :-)