Subject: [Qirg] multi-partite entanglement

From: Rodney Van Meter <[email-masked]>
Date: Wed, 20 Nov 2019 17:13:28 +0900

I did some thinking about this last night and tonight.  I realized that the approach we’ve proposed for bipartite won’t work.  We propose that the information for planning be accumulated on the outbound leg from the initiator to the responder, then the RuleSets constructed at the responder, and the RuleSets distributed on the return leg.  One of the nice things about this is e.g. if you’re a user and you want to connect to quantumgooduckduckgogle.com, then one of quantumgooduckduckgogle.com’s potential value adds business-wise is the ability to do a better job of connection planning than you as an individual can, or better than duckgooduckquantum.com can, and they can upgrade that ability autonomously.

With one initiator and multiple responders, obviously that doesn’t work.

But the multi-partite process is *SO* complex; for example, you may be better off building a Steiner tree on a graph, whereas the initial request by the initiator might follow a set of (partially overlapping) two-terminal paths.  So how do you pick the path, collect the information about the links & nodes, perform the planning, and distribute?

I want bipartite and multipartite to be separate also because of the difficulty of getting enough people to understand and review even the two-party operation, and because multi-party state generation in an experimental network is still much farther away.  I want the mechanism we are defining here to be used by those building networks (e.g., Delft), and a more complex protocol is less likely to be adopted.

—Rod

Rodney Van Meter
Professor, Faculty of Environment and Information Studies
Keio University, Japan
[email-masked]

---

From: Bruno Rijsman <[email-masked]>
Date: Thu, 21 Nov 2019 09:38:03 +0100

The classical equivalent to quantum multi-partite entanglement signaling is point-to-multipoint (P2MP) label switched paths.See, for example, slide 15 in this presentation: https://archive.nanog.org/meetings/nanog49/presentations/Sunday/P2MP.pdf <https://archive.nanog.org/meetings/nanog49/presentations/Sunday/P2MP.pdf>  In the classical case, the head-end or a centralized controller computes the path.  The middle and tail nodes don’t have to do anything more complicated than allocating resources (in-labels), programming the data plane (MPLS swaps), and signaling. They don’t have to do anything remotely similar to rule-set computation.

You are correct to say that in a quantum network it is unlikely that the end-points of the P2MP graph have enough global information or computational power to compute the optimal rule-set for the entire graph. This indeed feels like a case where a logically centralized controller would have to compute the rule-set as well as the path of the spanning tree P2MP graph (this would be “quantumgoodduckduckgfogle.com in your example, although in practice the controller would more likely be run by the same organization as the one that runs the network itself.)

— Bruno

> On Nov 20, 2019, at 9:13 AM, Rodney Van Meter <rdv=[email-masked]> wrote:
> 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg