Subject: [Qirg] COINRG and QIR : interaction for generic architecture of quantum computation node ?

From: Kuhn Nicolas <[email-masked]>
Date: Mon, 25 Nov 2019 09:43:44 +0000

Hi all,

Despite my interest in QIRG activity, I could not attend the meeting at last IETF106 for conflict with other meetings reasons.
However, I could attend COINRG.
I think there is an opportunity for interaction between QIRG and COINRG.

The draft "Directions for Computing in the Network" [https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/] mentions a terminology towards a novel "computing in the network (COIN)" approach that revisits the function split between computing and networking.
The document takes one example: "Compute-First Networking with ICN". To assess whether the proposed terminology is generic, it may be interesting to consider other use-cases where the computing is spread within the network.
Another example could then be "Interconnected Quantum Computers".
Indeed, the charter of QIRG mentions an architectural framework to support a first step toward a quantum network architecture [https://datatracker.ietf.org/rg/qirg/about/].

I am not sure about the way towards an interaction between those activities, but starting email discussions may pull a trigger.

I hope this helps,
Kind regards,

Nicolas

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 25 Nov 2019 02:39:30 -0800

Thanks.

At the QIRG meeting last week COIN was mentioned so maybe there is an
opportunity to indeed start a dialogue.

mjm

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

On November 25, 2019 at 10:44:55 AM, Kuhn Nicolas ([email-masked])
wrote:

Hi all,

Despite my interest in QIRG activity, I could not attend the meeting at
last IETF106 for conflict with other meetings reasons.

The draft “Directions for Computing in the Network” [
https://datatracker.ietf.org/doc/draft-kutscher-coinrg-dir/] mentions a
terminology towards a novel "computing in the network (COIN)" approach that
revisits the function split between computing and networking.

The document takes one example: “Compute-First Networking with ICN”. To
assess whether the proposed terminology is generic, it may be interesting
to consider other use-cases where the computing is spread within the
network.

Another example could then be “Interconnected Quantum Computers”.

Indeed, the charter of QIRG mentions an architectural framework to support
a first step toward a quantum network architecture [
https://datatracker.ietf.org/rg/qirg/about/].

I am not sure about the way towards an interaction between those
activities, but starting email discussions may pull a trigger.

I hope this helps,

Kind regards,

Nicolas

-- 
Coin mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/coin