Subject: Re: [Qirg] Update to draft-irtf-qirg-principles

From: David Ros <[email-masked]>
Date: Wed, 26 Feb 2020 11:59:35 +0100

> On 24 Feb 2020, at 13:41, [email-masked] wrote:
> 
> From: Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>>
> To: Rodney Van Meter <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Subject: Re: [Qirg] Update to draft-irtf-qirg-principles
> Message-ID: <[email-masked] <mailto:[email-masked]>>
> Content-Type: text/plain; charset="windows-1252"
> 
>> For an architecture doc, I?d say one of the things we need to do is substantially raise the # of references, in context, of course.
> 
> 
> This is something I was wondering about and it came up when I was working with Sara on the elementary link generation. What is the right number of references? As an IRTF document (as opposed to an IETF doc) we have flexibility to define what is suitable. Here are some of my thoughts on this:
> 
> 
>  1.  I kept the number of references light, because the intended audience who will benefit the most from this doc (IETF folk) will probably not benefit much from dense physics-heavy quantum networking academic literature.
>  2.  This is an intro document to set the stage for further discussion, not an academic review of the field.
>  3.  Academics for understandable reasons care about being cited, but RFCs don't go into a citation count anyway (I think).
>  4.  Nevertheless, adding references means that the interested reader knows where to look and acknowledges the fields' origin.
> 
> There is likely a meaningful compromise between my spartan reference list and a full blown review reference list which will cite a 100 papers before the end of the first paragraph. Thoughts, citation suggestions, and PRs all welcome on this topic.
> 
> Opinions from readers on the list who are not physicists or academics particularly welcome.

Hi,

Silent lurker here, chiming in with a couple of data points and my personal opinion. You could say I’m part of the intended audience — I am just starting to look into quantum networking, I’m not a physicist and, though I'm an academic, I've been involved a little in I*TF before, both as draft contributor and as RG co-chair.

TL;DR: I think a compromise, as you say, would be the right approach and more in line with I*TF documents *roughly* similar in intent. IMHO the reference list could (should) be a little longer, while avoiding as much as possible direct physics-heavy citations. Whether that is possible given the subject matter is another thing… E.g. is there any introductory / tutorial-like material that is not currently cited?

====

FWIW:

a) RFC 6077 "Open Issues in Internet Congestion Control", a product of an IRTF group, has 10+ pages of references.

b) RFC 6297 "A Survey of Lower-than-Best-Effort Transport Protocols”, a product of an IETF group, has 5+ pages of references.

Even if (b) is about a pretty narrow topic — way narrower than (a)’s — and is an IETF document, it still has quite a few references. (Note, I contributed to (b) but not to (a), so I’m not saying this is the right way to go just because we did it in (b).)

Yes, both are survey(-like) documents, but I’d argue that the quantum-principles draft is both survey- and tutorial-like.

If you look at other recent documents with “architectural” in the title, you’ll typically find 2-5 pages of references, and many of these are arguably much narrower in scope — and about topics way more familiar to the I*TF community, e.g. IP anycast — than the quantum-principles document. Another draft from an IRTF group (draft-irtf-nwcrg-nwc-ccn-reqs) has 3+ pages of references. So providing a little more background pointers, while not overwhelming your intended I*TF readership, may be a reasonable approach.

Regards,

David

---

From: Rodney Van Meter <[email-masked]>
Date: Wed, 26 Feb 2020 21:10:36 +0900

Thanks, David.

Wojtek, I’ll try to put together a pull request for some more references, though it’s not going to happen before my talk in Denver next week.  Will try to make it happen before the I-D deadline.

I think it’s valuable in a document like this for not only specific references to be included for technical topics, but also to point toward the right people.  When I find a researcher in a particular area, often through some reference, I try to go check to see what their current work is and whether they have advanced in some way that saves me pain. In particular, they are of course kind of physics oriented, but we definitely should be citing some of the things out of Wolfgang Dur’s group in the last few years. First authors Zwerger and Pirker, especially.

—Rod

Rodney Van Meter
Professor, Faculty of Environment and Information Studies
Keio University, Japan
[email-masked]

> On Feb 26, 2020, at 19:59, David Ros <[email-masked]> wrote:
> 
> 
>> On 24 Feb 2020, at 13:41, [email-masked] <mailto:[email-masked]> wrote:
>> 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: David Ros <[email-masked]>
Date: Wed, 26 Feb 2020 13:20:22 +0100

Rodney, 

> On 26 Feb 2020, at 13:10, Rodney Van Meter <[email-masked]> wrote:
> 
> Thanks, David.
> 
> I think it’s valuable in a document like this for not only specific references to be included for technical topics, but also to point toward the right people.

Indeed, this could be helpful too, esp. since the groups (and typical publishing venues) may not always be those I*TF folks are more familiar with, or keep track of.

Thanks,

David

>  When I find a researcher in a particular area, often through some reference, I try to go check to see what their current work is and whether they have advanced in some way that saves me pain. In particular, they are of course kind of physics oriented, but we definitely should be citing some of the things out of Wolfgang Dur’s group in the last few years. First authors Zwerger and Pirker, especially.
> 
> —Rod
> 
> Rodney Van Meter
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
>> On Feb 26, 2020, at 19:59, David Ros <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> [email-masked] <mailto:[email-masked]>