Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

From: Chonggang Wang <[email-masked]>
Date: Tue, 4 Feb 2020 20:09:29 +0000

Hi Patrick,

Sorry for the delay.

Thank you for your new question on measurement-based quantum computing. Please see my new responses blow.

Best regards,
Chonggang

-----Original Message-----
From: Qirg <[email-masked]> On Behalf Of Gelard Patrick
Sent: Thursday, January 30, 2020 10:38 AM
To: Chonggang Wang <[email-masked]>; [email-masked]
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Chonggang,

Thank you for taking the remarks into account.

4.2 "Programming quantum multicomputers require exploiting quantum teleportation but also only entanglement (or even multi-entanglement for multi-party computation) without the need of teleportation. Isn't it ?"
[CW] - We were trying to use this case to show that quantum teleportation (as one of approaches) can be used to support distributed quantum computing; as a result, entanglement is needed (i.e. for teleportation). But as you commented, non-teleportation-based approach could also enable distributed quantum computing/multi-party computation. Wonder if I misunderstood your question.
[PG] It was a question.  Does distributed measurement-based quantum computing require teleportation function to perform distributed computing ?  In the measurement-based model, quantum computation is driven by single-site measurements on a large entangled quantum state known as a cluster state. The generation of the distributed cluster state may require the implementation of repeater which is based on teleportation, but what about the distributed computation base on measurement only ?
[CW] - I would agree that distributed computation based on measurement only may not need repeater/teleportation. I will add some texts to clarify that use case #2 mainly focus on non-measurement-based distributed quantum computing.

For information : Concerning "Quantum Key Distribution" ETSI has also produced use cases.: https://www.etsi.org/deliver/etsi_gs/qkd/001_099/002/01.01.01_60/gs_qkd002v010101p.pdf
[CW] - Thanks for bringing this spec to our attention. Since it is about QKD use cases, I will cite it in our document.

Best regards
Patrick ( my  first name ;-) )

-----Message d'origine-----
De : Chonggang Wang <[email-masked]> Envoyé : mardi 28 janvier 2020 16:58 À : Gelard Patrick <[email-masked]>; [email-masked] Cc : Wojciech Kozlowski <[email-masked]> Objet : RE: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Gelard,

Thank you again for your good comments/questions. We have revised the use case document according to all feedback from you and a few other people. The v01 was just uploaded and can be accessed from the following link.
https://tools.ietf.org/html/draft-wang-qirg-quantum-internet-use-cases-01

Answers to your comments/questions are also provided below. Would you please review v01 and our answers and let us know if your comments have been addressed? If you have any new comment, we will be happy to address it and improve the document furthermore.

1. "The concept of "Control Plane Applications" is indeed not clear.  For example In the list " Control Plane Applications using Quantum Internet:" there is not the control plan to select a path to distribute entanglement or quantum keys in the context of QKD network based on trusted nodes (Key relai : https://www.itu.int/en/ITU-T/Workshops-and-Seminars/2019060507/Documents/Masahiro_Takeoka%20_V2_Presentation.pdf ). And so this does not belong to the application control plan?"
[CW] - We rewrote and expanded section 4 to further clarify the concept of control plane.  We believe that QKD is similar to SIP and other control plane functions in the classic Internet.

2. "There can be different axes of classification of application services requiring a quantum internet, who can bring other complementary looks.  For example by industry sector like Quantum computing, Quantum metrology, Quantum sensor, Quantum telecom, ..., from which it is possible to decline use cases with specific need (e.g : Distributed quantum sensing - https://arxiv.org/abs/1910.14156 ; Networked quantum sensing - https://arxiv.org/abs/1702..04271 ; Distributed quantum computing - https://arxiv.org/pdf/1810.08421.pdf , https://www.researchgate.net/publication/2192461_Distributed_quantum_computing_A_distributed_Shor_algorithm ; One-Way Quantum Computing in distributed architectures - https://arxiv.org/abs/0906.2725 ; ... etc)"
[CW] - We created a new section 4.3 "Other Possible Classifications" to reflect your points. If you have more specific comments, we would like to incorporate them into and enhance 4.3 furthermore.

3. Concerning QKDN there also this presentation https://www.itu.int/en/ITU-T/Workshops-and-Seminars/2019060507/Documents/Hao_Qin_Presentation.pdf
[CW] - Thanks for bringing this presentation to our attention. We added this reference and revised the description on "large-scale QKD" in section 5.1.

4. "Remark concerning the Use case 5.2.  Distributed Quantum Computing:
4.1 "2.  The quantum computer A first establishes a shared entanglement with the quantum computer B (i.e., there are two entangled bits: |q1> at A and |q2> at B).". The computer A Established a shared entanglement with the quantum computer B in the sense of a connection Setup  defined in the draft-van-meter-qirg-quantum-connection-setup-00 ?"
[CW] - In general, the answer is yes. But if A and B are one-hop away and can directly exchange qubits reliably, complex connection setup may not be needed.

4.2 "Programming quantum multicomputers require exploiting quantum teleportation but also only entanglement (or even multi-entanglement for multi-party computation) without the need of teleportation. Isn't it ?"
[CW] - We were trying to use this case to show that quantum teleportation (as one of approaches) can be used to support distributed quantum computing; as a result, entanglement is needed (i.e. for teleportation). But as you commented, non-teleportation-based approach could also enable distributed quantum computing/multi-party computation. Wonder if I misunderstood your question.
[PG] It was a question.  Does distributed measurement-based quantum computing require teleportation function to perform distributed computing ?  In the measurement-based model, quantum computation is driven by single-site measurements on a large entangled quantum state known as a cluster state. The generation of the distributed cluster state may require the implementation of repeater which is based on teleportation, but what about the distributed computation base on measurement only ?

4.3. Can we decline orders of magnitude of requirements such as entangled qubits rate, Quantum Bits Error Rate, ... ?
[CW] - Good question! This may need more investigations. We will consider these metrics in future version(s).

Best regards,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Tuesday, January 21, 2020 8:36 AM
To: Chonggang Wang <[email-masked]>; [email-masked]
Cc: Wojciech Kozlowski <[email-masked]>
Subject: RE: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi,

Remark concerning the Use case 5.1.  Secure Communication Setup.

1/  Quantum Key Distribution(QKD);Components and Internal Interfaces : https://www.etsi.org/deliver/etsi_gr/QKD/001_099/003/02.01.01_60/gr_QKD003v020101p.pdf

NOTE: Entanglement-based schemes where entangled states are prepared externally to Alice and Bob are not normally considered "prepare-and-measure". Schemes where entanglement is generated within Alice can still be considered "prepare-and-measure". Send-and-return schemes can still be "prepare-and-measure" if the information content from which keys will be derived is prepared within Alice before being sent to Bob for measurement.

2/ A series of loopholes have been identified due to the imperfections of measurement devices. There are several solutions to take into account these attacks such as for example measurement-device-independent quantum key distribution https://arxiv.org/abs/1912.09642  This operational solutions can work differently than the steps of BB84 protocol.

3/ It would be necessary to be able to extract the requirements on the networks. For this use case you consider that the targeted step is "prepared and measured" ( https://pure.tudelft.nl/portal/files/47533107/qim_final_V7_FINAL.pdf ) ? And thus no need  entanglement distribution for long distance  ? The need for this use case is to have QKD Network base on trusted relays to take in account long distance communications  ?

Best regards
/Patrick

-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Gelard Patrick Envoyé : mardi 21 janvier 2020 11:48 À : Chonggang Wang <[email-masked]>; [email-masked] Cc : Wojciech Kozlowski <[email-masked]> Objet : Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Chonggang,

Thank you, it is an Interesting initiative.

1/The concept of "Control Plane Applications" is indeed not clear.

For example In the list " Control Plane Applications using Quantum Internet:" there is not the control plan to select a path to distribute entanglement or quantum keys in the context of QKD network based on trusted nodes (Key relai : https://www.itu.int/en/ITU-T/Workshops-and-Seminars/2019060507/Documents/Masahiro_Takeoka%20_V2_Presentation.pdf ). And so this does not belong to the application control plan ?

2/ There can be different axes of classification of application services requiring a quantum internet, who can bring other complementary looks.

For example by industry sector like Quantum computing, Quantum metrology, Quantum sensor, Quantum telecom, ..., from which it is possible to decline use cases with specific need (e.g : Distributed quantum sensing - https://arxiv.org/abs/1910.14156 ; Networked quantum sensing - https://arxiv.org/abs/1702.04271 ; Distributed quantum computing - https://arxiv.org/pdf/1810.08421.pdf , https://www.researchgate.net/publication/2192461_Distributed_quantum_computing_A_distributed_Shor_algorithm ; One-Way Quantum Computing in distributed architectures - https://arxiv.org/abs/0906.2725 ; ... etc)

I have not yet read in detail the use cases

Best Regards
/Patrick

-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Chonggang Wang Envoyé : lundi 20 janvier 2020 21:56 À : Wojciech Kozlowski <[email-masked]>; [email-masked] Objet : Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Wojciech,

Thank you for your feedback and good questions on our use case draft.

We will look into your questions and answer them in the mailing list and on a fast update of the draft.

Best regards,
Chonggang

-----Original Message-----
From: Qirg <[email-masked]> On Behalf Of Wojciech Kozlowski
Sent: Monday, January 20, 2020 11:44 AM
To: [email-masked]
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi,

Great work on starting with a use case draft! It will definitely be useful.

I'm still going through the text so I can't provide a full commentary/feedback, but I do already have one question:

You separate applications into control and data plane applications. However, it's not clear to me what exactly separates the two groups. Could you expand on that?

And one other important point about the end-node definition.

You write in your end-node definition that that it must be a quantum computer.
That is not the case. An end-node without full fault-tolerant capabilities, a quantum memory, or even a universal gate set is still useful. For QKD you don't even need to store the qubits at the end-nodes (prepare-and-measure stage in Wehner's Quantum Internet paper). Perhaps this is what you had in mind when you wrote quantum computer, but it is important to make it clear that end-nodes don't have to be as capable as quantum routers/repeaters.

You also write that classical connectivity in the end-node is optional. I can't think of any application that would not need classical connectivity as well to coordinate with the application's remote. In general, I would say that all quantum network connected nodes also have classical connectivity.

Other than that, I'm still slowly going through the draft.

Wojtek

On Thu, 2020-01-16 at 14:33 +0000, Chonggang Wang wrote:
> Dear All,
>
> We were thinking a use case document would be beneficial for QIRG. As
> such, we just prepared and uploaded a document on quantum internet use cases.
>
> Your feedback and/or any interest in co-developing this document is welcomed.
>
> Best regards,
> CG
>
> -----Original Message-----
> From: [email-masked] <[email-masked]>
> Sent: Wednesday, January 15, 2020 8:57 PM
> To: Chonggang Wang <[email-masked]>; Chonggang Wang <
> [email-masked]>; Akbar Rahman
> <[email-masked]>
> Subject: New Version Notification for
> draft-wang-qirg-quantum-internet-use-
> cases-00.txt
>
>
> A new version of I-D,
> draft-wang-qirg-quantum-internet-use-cases-00.txt
> has been successfully submitted by Akbar Rahman and posted to the IETF
> repository.
>
> Name:draft-wang-qirg-quantum-internet-use-cases
> Revision:00
> Title:Applications and Use Cases for the Quantum Internet Document
> date:2020-01-15 Group:Individual Submission
> Pages:14
> URL:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_inte
> rnet-2Ddrafts_draft-2Dwang-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases-2
> D00.txt&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k
> 8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy
> 0rzAssyFXySKEI&s=PMzmzur07rBP5gr4m8p4JB85MZMdmkT_WANusdrgIeY&e=
>
> Status:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> org_doc_draft-2Dwang-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases_&d=DwIC
> Ag&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWU
> ARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFXySKEI
> &s=oE_6J9C-NK3Sg0X7tc15r37wija6fVyTtkTweA8H32I&e=
>
> Htmlized:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> ml_draft-2Dwang-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases-2D00&d=DwICA
> g&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUA
> RpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFXySKEI&
> s=RUyxLSfDa9jkZJYQm-NwM55Qktzvkeez-xfrDiLI-LQ&e=
>
> Htmlized:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> org_doc_html_draft-2Dwang-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases&d=
> DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC
> 7RWUARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFXy
> SKEI&s=hz2EZoCivsq91uNRPLpqD2ypMzVutblGbCGcNqKaY0s&e=
>
>
>
> Abstract:
>    The Quantum Internet has the potential to improve Internet protocol
>    and application functionality by incorporating quantum information
>    technology into the infrastructure of the overall Internet.  In this
>    document, we provide an overview of some applications expected to be
>    used on the Quantum Internet, and then categorize them using the
>    standard telecommunications classification of control plane versus
>    data plane functionality.  We then provide detailed use cases for
>    selected applications which can help steer the development of the
>    requisite Quantum Internet functionality.
>
>
>
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
> [Banner]
>
>
> [Banner]<
> https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d
> =DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCju
> C7RWUARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFX
> ySKEI&s=m5U3d47laqzfhiupIF0tuDwrDhJtosQdWAh3uvK3jls&e=
>  >
> ABI White Paper<
> https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d
> =DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCju
> C7RWUARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFX
> ySKEI&s=m5U3d47laqzfhiupIF0tuDwrDhJtosQdWAh3uvK3jls&e=
>  >
> This e-mail is intended only for the use of the individual or entity
> to which it is addressed, and may contain information that is
> privileged, confidential and/or otherwise protected from disclosure to
> anyone other than its intended recipient. Unintended transmission
> shall not constitute waiver of any privilege or confidentiality
> obligation. If you received this communication in error, please do not
> review, copy or distribute it, notify me immediately by email, and
> delete the original message and any attachments. Unless expressly
> stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.
> _______________________________________________
> Qirg mailing list
> [email-masked]
>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFXySKEI&s=nhxvSfcS-vT6ceZUnfRHsesl_Y73nfFC4qQadCS-nu4&e=
_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg
[Banner]

[Banner]<https://secure-web.cisco.com/1aj_7_qtiYBr31G1EDHBoZ81MSrA1GP_YW5W_j-bR8svpodZunvO2WBmvQ6WOkyMYvscX6KyApVGsOHllC-2CsnNDlQSZaAHVm4dGzxyHfDz2hwop_0nlT8P_v8Qe-r_zN23tiWBq0QsDFmfPMBeyAhuVb46hyowEOBogJrCHo5IFIF6GxJoZ7eeY2u7TDdsutPQbZNj5DMOIAN5QpHaG2Jr_lGSd-3PaQakDkCkUzxdD3uSs3YO5hWXwlaKytYFbcNQe38HFvWN5raehgeqyBJYkZ-5A29sIL8FYe8MLdFctywXwSdEzQvrTPbUDeazp0Ok0e_GiknluVsWxR7IkrPC5guVnjo-_1k8xKvNt5z7wdm8rH34E_9dJya8OWP6-lH0laP6ATI4Y_2hfSDY40Pn3PYB1T-L7wNbgoj6Wjjwl-syBTqEPQ3lu_8rBhucI1-mt_yBZeMW5bU01USNNd0FdW1Nox11Q5Z8N4WPav04/https%3A%2F%2Fidcc.me%2F2ZVMLEv>
ABI White Paper<https://secure-web.cisco.com/1aj_7_qtiYBr31G1EDHBoZ81MSrA1GP_YW5W_j-bR8svpodZunvO2WBmvQ6WOkyMYvscX6KyApVGsOHllC-2CsnNDlQSZaAHVm4dGzxyHfDz2hwop_0nlT8P_v8Qe-r_zN23tiWBq0QsDFmfPMBeyAhuVb46hyowEOBogJrCHo5IFIF6GxJoZ7eeY2u7TDdsutPQbZNj5DMOIAN5QpHaG2Jr_lGSd-3PaQakDkCkUzxdD3uSs3YO5hWXwlaKytYFbcNQe38HFvWN5raehgeqyBJYkZ-5A29sIL8FYe8MLdFctywXwSdEzQvrTPbUDeazp0Ok0e_GiknluVsWxR7IkrPC5guVnjo-_1k8xKvNt5z7wdm8rH34E_9dJya8OWP6-lH0laP6ATI4Y_2hfSDY40Pn3PYB1T-L7wNbgoj6Wjjwl-syBTqEPQ3lu_8rBhucI1-mt_yBZeMW5bU01USNNd0FdW1Nox11Q5Z8N4WPav04/https%3A%2F%2Fidcc.me%2F2ZVMLEv> This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

[Banner]

[Banner]<https://idcc.me/2ZVMLEv>
ABI White Paper<https://idcc.me/2ZVMLEv> This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg
[Banner]

[Banner]<https://www.interdigital.com/features/mwc-2020>
Mobile World Congress 2020<https://www.interdigital.com/features/mwc-2020>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 10 Feb 2020 16:41:55 +0000

HI Chonggang,

Thanks for including my feedback. I have now read your draft in more detail. I attach a version with some in-line remarks (search for >>>) about the first few sections - they are all minor.

In general I think there's lots to discuss about the classification and the use cases in the later sections, but perhaps such a discussion would be good for an actual meeting? I'm still not sure if QIRG will be meeting in Vancouver (Rodney?), but whichever IETF will be next might be worth adding to the agenda.

Thanks,
Wojtek

On Tue, 2020-01-28 at 15:50 +0000, Chonggang Wang wrote:
Hi Wojceich,

Thank you again for your good comments on the use case document. We have revised the document according to all comments from you and a few other people. The v01 was just uploaded and can be accessed from the following link.
https://tools.ietf.org/html/draft-wang-qirg-quantum-internet-use-cases-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dwang-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases-2D01&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=Yl6ZZJgXjO0-KzW0QsZbF_2rwCY5rEtT1F0uUEAlxTE&e=>

1. "You separate applications into control and data plane applications. However, it's not clear to me what exactly separates the two groups. Could you expand on that?"
[CW] - We rewrote and expanded section 4 to further clarify the concepts.

2. "And one other important point about the end-node definition.   You write in your end-node definition that that it must be a quantum computer.  That is not the case. An end-node without full fault-tolerant capabilities, a quantum memory, or even a universal gate set is still useful. For QKD you don't even need to store the qubits at the end-nodes (prepare-and-measure stage in Wehner's Quantum Internet paper). Perhaps this is what you had in mind when you wrote quantum computer, but it is important to make it clear that end-nodes don't have to be as capable as quantum routers/repeaters. "
[CW] - Agreed and we clarified the end-node definition to reflect your points.

3. "You also write that classical connectivity in the end-node is optional. I can't think of any application that would not need classical connectivity as well to coordinate with the application's remote. In general, I would say that all quantum network connected nodes also have classical connectivity."
[CW] - Agreed and we clarified the end-node definition to reflect your point.

4. "Quantum Key Distribution(QKD);Components and Internal Interfaces : https://www.etsi.org/deliver/etsi_gr/QKD/001_099/003/02.01.01_60/gr_QKD003v020101p.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.etsi.org_deliver_etsi-5Fgr_QKD_001-5F099_003_02.01.01-5F60_gr-5FQKD003v020101p.pdf&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=f8UqUDuYVJ81YCc6F6tyCugOS2LfOJgBQnrBUaSobdM&e=>  NOTE: Entanglement-based schemes where entangled states are prepared externally to Alice and Bob are not normally considered "prepare-and-measure". Schemes where entanglement is generated within Alice can still be considered "prepare-and-measure". Send-and-return schemes can still be "prepare-and-measure" if the information content from which keys will be derived is prepared within Alice before being sent to Bob for measurement."
[CW] - The last paragraph of section 5.1 was revised to reflect your points.

5. “A series of loopholes have been identified due to the imperfections of measurement devices. There are several solutions to take into account these attacks such as for example measurement-device-independent quantum key distribution https://arxiv.org/abs/1912.09642<https://urldefense.proofpoint.com/v2/url?u=https-3A__arxiv.org_abs_1912.09642&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=dnmk-npspZBud2lZcwBM_VQlzWsb1VT_Rz1JsPzSVvk&e=>  This operational solutions can work differently than the steps of BB84 protocol.”
[CW] - The last paragraph of 5.1 was revised to reflect your points.

6. “It would be necessary to be able to extract the requirements on the networks. For this use case you consider that the targeted step is "prepared and measured" ( https://pure.tudelft.nl/portal/files/47533107/qim_final_V7_FINAL.pdf ) ? And thus no need  entanglement distribution for long distance  ? The need for this use case is to have QKD Network base on trusted relays to take in account long distance communications?”
[CW] - The need for this use case is not only about trusted replays, but also entanglement distribution for long distance. In other words, our aim for having this use case is  to explain and show there are a variety of QKD protocols which may operate differently, and we need to consider as many as requirements from most of them, if not all. As such, we revised the last sentence in section 5.1 as follows:
              “As a result, the Quantum Internet in Figure 1 in order to support secure communication setup especially in large-scale deployment may contain quantum  channels, quantum repeaters/routers [I-D.irtf-qirg-principles], entanglement and entanglement distribution [I-D. van-meter-qirg-quantum-connection-setup-01], and/or trusted QKD relays.”

-----Original Message-----
From: Chonggang Wang
Sent: Monday, January 20, 2020 3:56 PM
To: Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Wojciech,

Best regards,
Chonggang

-----Original Message-----
From: Qirg <[email-masked]<mailto:[email-masked]>> On Behalf Of Wojciech Kozlowski
Sent: Monday, January 20, 2020 11:44 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi,

Wojtek

On Thu, 2020-01-16 at 14:33 +0000, Chonggang Wang wrote:
> From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
> To: Chonggang Wang <[email-masked]<mailto:[email-masked]>>; Chonggang Wang <
> [email-masked]<mailto:[email-masked]>>; Akbar Rahman
> <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>
>
_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=cyCgu8AyFHjHCsse0yIulD_-i6-Y2g2Pme95aPNeYJQ&e=>

[http://www.interdigital.com/resources/img_new/logo.png]

[https://www.interdigital.com/resources/uploads/email/August-Email_v7.jpg]<https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=UKRL50t45cbbn8qlcg41u78fR0-vf1zWsyzJssm5eM0&e=>
ABI White Paper<https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=UKRL50t45cbbn8qlcg41u78fR0-vf1zWsyzJssm5eM0&e=>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 10 Feb 2020 16:42:25 +0000

Forgot to actually attach document

On Mon, 2020-02-10 at 17:41 +0100, Wojciech Kozlowski wrote:
HI Chonggang,

Thanks,
Wojtek

-----Original Message-----
From: Chonggang Wang
Sent: Monday, January 20, 2020 3:56 PM
To: Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Wojciech,

Best regards,
Chonggang

-----Original Message-----
From: Qirg <[email-masked]<mailto:[email-masked]>> On Behalf Of Wojciech Kozlowski
Sent: Monday, January 20, 2020 11:44 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi,

Wojtek

---

From: Chonggang Wang <[email-masked]>
Date: Mon, 10 Feb 2020 17:28:01 +0000

Hi Wojtek,

Thank you for your feedback and detailed inline remarks. We will look at and incorporate them into v03.

I agree with you that a discussion in a F2F meeting (either Vancouver or Madrid) will be very helpful.

Thanks,
Chonggang

From: Wojciech Kozlowski <[email-masked]>
Sent: Monday, February 10, 2020 11:42 AM
To: [email-masked]; Chonggang Wang <[email-masked]>
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Thanks,
Wojtek

-----Original Message-----
From: Chonggang Wang
Sent: Monday, January 20, 2020 3:56 PM
To: Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Wojciech,

Best regards,
Chonggang

-----Original Message-----
From: Qirg <[email-masked]<mailto:[email-masked]>> On Behalf Of Wojciech Kozlowski
Sent: Monday, January 20, 2020 11:44 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi,

Wojtek

[Banner]

---

From: Rodney Van Meter <[email-masked]>
Date: Fri, 21 Feb 2020 08:44:33 +0900

Hi Chonggang,

I’ve been passively following the work here. As RG chair, I think this is important, and I’m happy you’re working on it and getting good feedback from others. I’ve only skimmed the I-D, not read it in detail so far, though.  Loking forward to talking about it in real time, if not in person, at Vancouver.

<chair hat off>
On the content…

Re: position verification, my understanding is that it has been proven *impossible* in the quantum realm, which is a *very* interesting result:
@Article{buhrman14:_posit_based_quant_crypt,
  author = 	 {Harry Buhrman and Nishanth Chandran and Serge Fehr
                  and Ran Gelles and Vipul Goyal and Rafail Ostrovsky
                  and Christian Schaffner},
  title = 	 {Position-based Quantum Cryptography: Impossibility
                  and Constructions},
  journal = {SIAM Journal on Computing},
  year = 	 2014,
  volume = 	 43,
  number = 	 1,
  pages = 	 {150--178},
  month = 	 feb,
  comment = {Prior to this, Chandran had shown that position-based
                  classical position-based cryptography (Defined in
                  this paper as, "The goal of position-based
                  cryptography is to use the geographical position of
                  a party as its only 'credential'.") is impossible, but
                  the quantum version was an open question.  That is,
                  a group of colluders can fool a classical position
                  verification scheme, but could a group of quantum
                  colluders fool a quantum verifier?  Turns out, the
                  answer is "yes" if the colluders have access to
                  pre-prepared entanglement, and so, sadly, even
                  quantum position-based crypto appears not to be
                  useful.  Interesting set of references.}
}

Trying not to say “you should cite me!”, and I don’t think I have time to contribute as an author to I’m happy to stay as an outside observer, but I’ve spent a lot of time working on apps for a Quantum Internet, and given a bunch of talks on it.  Overall, I divide uses of quantum networks up into three areas:

* crypto functions: QKD, byzantine agreement, etc. Check out Ben-Or and Hassidim, and (ahem) Taherkhani & Van Meter. We were hoping QBA would make a good second app for QI, after basic QKD, but it’s harder than we thought — one-part-in-a-million error rates, couple of hundred qubits, etc. as resources.
* sensor (& reference frame) functions: clock sync — there are at least three or four proposals for this; also position reference frames, etc. An important one here is Gottesman’s interferometry.  Note that I put QKD on the border between cerypto & sensor, since its function is to act as detection of a physical eavesdropper.
* distributed computing: Broadbent, Kashefi, Fitsimons, Barz and their blind computation is one of *the* best reasons to build a QI — but it has *tremendous* resource requirements in its current form.  Finding lower-resource uses for blind QC is a great research area, IMO.

Rodney Van Meter
Professor, Faculty of Environment and Information Studies
Keio University, Japan
[email-masked]

> On Feb 11, 2020, at 2:28, Chonggang Wang <[email-masked]> wrote:
> 
> Hi Wojtek,
>  
> From: Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>> 
> To: [email-masked] <mailto:[email-masked]>; Chonggang Wang <[email-masked] <mailto:[email-masked]>>
> https://tools.ietf.org/html/draft-wang-qirg-quantum-internet-use-cases-01 <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dwang-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases-2D01&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=Yl6ZZJgXjO0-KzW0QsZbF_2rwCY5rEtT1F0uUEAlxTE&e=>
>  
> 4. "Quantum Key Distribution(QKD);Components and Internal Interfaces :https://www.etsi.org/deliver/etsi_gr/QKD/001_099/003/02.01.01_60/gr_QKD003v020101p.pdf <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.etsi.org_deliver_etsi-5Fgr_QKD_001-5F099_003_02.01.01-5F60_gr-5FQKD003v020101p.pdf&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=f8UqUDuYVJ81YCc6F6tyCugOS2LfOJgBQnrBUaSobdM&e=>  NOTE: Entanglement-based schemes where entangled states are prepared externally to Alice and Bob are not normally considered "prepare-and-measure". Schemes where entanglement is generated within Alice can still be considered "prepare-and-measure". Send-and-return schemes can still be "prepare-and-measure" if the information content from which keys will be derived is prepared within Alice before being sent to Bob for measurement."
> 5. “A series of loopholes have been identified due to the imperfections of measurement devices. There are several solutions to take into account these attacks such as for example measurement-device-independent quantum key distribution https://arxiv.org/abs/1912.09642 <https://urldefense.proofpoint.com/v2/url?u=https-3A__arxiv.org_abs_1912.09642&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=dnmk-npspZBud2lZcwBM_VQlzWsb1VT_Rz1JsPzSVvk&e=>  This operational solutions can work differently than the steps of BB84 protocol.”
> 6. “It would be necessary to be able to extract the requirements on the networks. For this use case you consider that the targeted step is "prepared and measured" (https://pure.tudelft.nl/portal/files/47533107/qim_final_V7_FINAL.pdf <https://pure.tudelft.nl/portal/files/47533107/qim_final_V7_FINAL.pdf> ) ? And thus no need  entanglement distribution for long distance  ? The need for this use case is to have QKD Network base on trusted relays to take in account long distance communications?”
> To: Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> From: Qirg <[email-masked] <mailto:[email-masked]>> On Behalf Of Wojciech Kozlowski
> To: [email-masked] <mailto:[email-masked]>
> > From: [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>
> > To: Chonggang Wang <[email-masked] <mailto:[email-masked]>>; Chonggang Wang <
> > [email-masked] <mailto:[email-masked]>>; Akbar Rahman
> > <[email-masked] <mailto:[email-masked]>>
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_inte <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_inte>
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf>.
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht>
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf>.
> > submission until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> > 
> > The IETF Secretariat
> > 
> > [Banner]
> > 
> > 
> > [Banner]<
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d <https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d>
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d <https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d>
> > [email-masked] <mailto:[email-masked]>
> > 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFXySKEI&s=nhxvSfcS-vT6ceZUnfRHsesl_Y73nfFC4qQadCS-nu4&e= <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=hwXW-AMJfMiAk-XdtOdqxqwr2uDYy0rzAssyFXySKEI&s=nhxvSfcS-vT6ceZUnfRHsesl_Y73nfFC4qQadCS-nu4&e=>
> >  
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/qirg <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=cyCgu8AyFHjHCsse0yIulD_-i6-Y2g2Pme95aPNeYJQ&e=>
>  
> 
> 
> 
>  <https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=UKRL50t45cbbn8qlcg41u78fR0-vf1zWsyzJssm5eM0&e=>
> ABI White Paper <https://urldefense.proofpoint.com/v2/url?u=https-3A__idcc.me_2ZVMLEv&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=UKRL50t45cbbn8qlcg41u78fR0-vf1zWsyzJssm5eM0&e=>
>  <https://www.interdigital.com/features/mwc-2020> 
> Mobile World Congress 2020 <https://www.interdigital.com/features/mwc-2020>
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>

---

From: Chonggang Wang <[email-masked]>
Date: Tue, 25 Feb 2020 15:50:07 +0000

Hi Rodney,

Thank you for your comments from QIRG the chair’s and an individual’s perspective. I embedded some responses below and will discuss with my coauthors for a revision.

Best regards,
Chonggang

From: Rodney Van Meter <[email-masked]>
Sent: Thursday, February 20, 2020 6:45 PM
To: Chonggang Wang <[email-masked]>
Cc: Rodney Van Meter <[email-masked]>; Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: Re: [Qirg] New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Chonggang,

I’ve been passively following the work here. As RG chair, I think this is important, and I’m happy you’re working on it and getting good feedback from others. I’ve only skimmed the I-D, not read it in detail so far, though.  Loking forward to talking about it in real time, if not in person, at Vancouver.
[CW: Thank you for the support. We will continue to improve this use case document based on all comments from you and the QIRG team]

<chair hat off>
On the content…

[CW: Thank you for bringing this good reference. We will double check the feasibility of “position verification” and may remove it from the use case set. ]

* crypto functions: QKD, byzantine agreement, etc. Check out Ben-Or and Hassidim, and (ahem) Taherkhani & Van Meter. We were hoping QBA would make a good second app for QI, after basic QKD, but it’s harder than we thought — one-part-in-a-million error rates, couple of hundred qubits, etc. as resources.
* sensor (& reference frame) functions: clock sync — there are at least three or four proposals for this; also position reference frames, etc. An important one here is Gottesman’s interferometry.  Note that I put QKD on the border between cerypto & sensor, since its function is to act as detection of a physical eavesdropper.
* distributed computing: Broadbent, Kashefi, Fitsimons, Barz and their blind computation is one of *the* best reasons to build a QI — but it has *tremendous* resource requirements in its current form.  Finding lower-resource uses for blind QC is a great research area, IMO.
[CW: Thank you for the valuable comment. Currently, the use case document covers the 1st and 3rd area at some degree although we were thinking to write something on sensor functions. We will try to organize use cases according to those three areas you mentioned above, in next version of the use case document.]

Rodney Van Meter
Professor, Faculty of Environment and Information Studies
Keio University, Japan
[email-masked]<mailto:[email-masked]>

On Feb 11, 2020, at 2:28, Chonggang Wang <[email-masked]<mailto:[email-masked]>> wrote:

Hi Wojtek,

Thanks,
Chonggang

From: Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>>
Sent: Monday, February 10, 2020 11:42 AM
To: [email-masked]<mailto:[email-masked]>; Chonggang Wang <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Thanks,
Wojtek

4. "Quantum Key Distribution(QKD);Components and Internal Interfaces :https://www.etsi.org/deliver/etsi_gr/QKD/001_099/003/02.01.01_60/gr_QKD003v020101p.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.etsi.org_deliver_etsi-5Fgr_QKD_001-5F099_003_02.01.01-5F60_gr-5FQKD003v020101p.pdf&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=8Ul7lqKxYXuSiZKDc4OC4pCtVgjWDs557p5GfzN9FsM&s=f8UqUDuYVJ81YCc6F6tyCugOS2LfOJgBQnrBUaSobdM&e=>  NOTE: Entanglement-based schemes where entangled states are prepared externally to Alice and Bob are not normally considered "prepare-and-measure". Schemes where entanglement is generated within Alice can still be considered "prepare-and-measure". Send-and-return schemes can still be "prepare-and-measure" if the information content from which keys will be derived is prepared within Alice before being sent to Bob for measurement."
[CW] - The last paragraph of section 5.1 was revised to reflect your points.

6. “It would be necessary to be able to extract the requirements on the networks. For this use case you consider that the targeted step is "prepared and measured" (https://pure.tudelft.nl/portal/files/47533107/qim_final_V7_FINAL.pdf ) ? And thus no need  entanglement distribution for long distance  ? The need for this use case is to have QKD Network base on trusted relays to take in account long distance communications?”
[CW] - The need for this use case is not only about trusted replays, but also entanglement distribution for long distance. In other words, our aim for having this use case is  to explain and show there are a variety of QKD protocols which may operate differently, and we need to consider as many as requirements from most of them, if not all. As such, we revised the last sentence in section 5.1 as follows:
              “As a result, the Quantum Internet in Figure 1 in order to support secure communication setup especially in large-scale deployment may contain quantum  channels, quantum repeaters/routers [I-D.irtf-qirg-principles], entanglement and entanglement distribution [I-D. van-meter-qirg-quantum-connection-setup-01], and/or trusted QKD relays.”

-----Original Message-----
From: Chonggang Wang
Sent: Monday, January 20, 2020 3:56 PM
To: Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi Wojciech,

Best regards,
Chonggang

-----Original Message-----
From: Qirg <[email-masked]<mailto:[email-masked]>> On Behalf Of Wojciech Kozlowski
Sent: Monday, January 20, 2020 11:44 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Qirg] FW: New Version Notification for draft-wang-qirg-quantum-internet-use-cases-00.txt

Hi,

Wojtek

On Thu, 2020-01-16 at 14:33 +0000, Chonggang Wang wrote:
> submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.
>
> The IETF Secretariat
>
> [Banner]
>
>
> [Banner]<

[Banner]

[Banner]

[Banner]<https://www.interdigital.com/white_papers/streaming-media-report->
ABI - Streaming Media Report<https://www.interdigital.com/white_papers/streaming-media-report->
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.