Subject: Re: [Qirg] I-D Action: draft-wang-qirg-quantum-internet-use-cases-04.txt

From: Melchior Aelmans <[email-masked]>
Date: Thu, 5 Mar 2020 15:46:13 +0100

Dear authors,

Thanks for the interesting read.

A few minor changes I would like to suggest;

"The end-nodes run applications that provide some value added service for
the end-users such as processing and transmission of voice, video or data."
--> ""The end-nodes expose applications  that provide services to the
end-user including processing and transmission of voice, video or data".
The way this is currently described is too narrow imho.

"The physical connections between the various nodes in the Internet
include Digital Subscriber Lines (DSLs), fiber optics, etc." --> "The
connections between the various nodes could include Digital Subscriber
Lines (DSLs), fiber optics, etc."

Again, currently it's too narrow. Large parts of the internet are
connected via satellite for example.

"Quantum Internet will provide intrinsic benefits such as better
end-user and network security." --> "Quantum Internet will provide
intrinsic benefits such as better end-to-end and network security"

It is not securing the end-user itself :)

I would also like to ask the authors, and I'm offering to help, to
redefine or perhaps reconsider the use of the words control-plane and
data-plane.

The way they are currently used in the draft could cause confusion
with how these 2 terms are used in general in the 'classical network'
or better the way current network equipment operates.

I would advise not to use these 2 terms for describing the separation
between protocols and applications.
As written, I'm happy to help redefine that part.

Thanks again for the work!

Regards,

Melchior

On Tue, Mar 3, 2020 at 6:09 PM <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
>         Title           : Applications and Use Cases for the Quantum
> Internet
>         Authors         : Chonggang Wang
>                           Akbar Rahman
>                           Ruidong Li
>         Filename        : draft-wang-qirg-quantum-internet-use-cases-04.txt
>         Pages           : 19
>         Date            : 2020-03-03
>
> Abstract:
>    The Quantum Internet has the potential to improve Internet
>    application functionality by incorporating quantum information
>    technology into the infrastructure of the overall Internet.  In this
>    document, we provide an overview of some applications expected to be
>    used on the Quantum Internet, and then categorize them using various
>    classification schemes.  The intent of this document is to provide a
>    common understanding and framework of applications and use cases for
>    the Quantum Internet.
>
>
> The IETF datatracker status page for this draft is:
>
> https://datatracker.ietf.org/doc/draft-wang-qirg-quantum-internet-use-cases/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-wang-qirg-quantum-internet-use-cases-04
>
> https://datatracker.ietf.org/doc/html/draft-wang-qirg-quantum-internet-use-cases-04
>
> A diff from the previous version is available at:
>
> https://www.ietf.org/rfcdiff?url2=draft-wang-qirg-quantum-internet-use-cases-04
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Joseph Touch <[email-masked]>
Date: Thu, 5 Mar 2020 07:13:53 -0800

Som suggestions:

- regarding physical classical connections:
	directly connections that include fiber optics, DSL, and coax cable and wireless that include WIFI, WiMax, cellular (Edge, 3G, 4G, LTE, 5G), bluetooth, and satellite

Also: 
> I would also like to ask the authors, and I'm offering to help, to redefine or perhaps reconsider the use of the words control-plane and data-plane. 
> The way they are currently used in the draft could cause confusion with how these 2 terms are used in general in the 'classical network' or better the way current network equipment operates.
> I would advise not to use these 2 terms for describing the separation between protocols and applications.

+1 

Joe

---

From: Chonggang Wang <[email-masked]>
Date: Wed, 25 Mar 2020 18:43:29 +0000

Dear Melchior,

Sorry for our late response. Thank you for your helpful feedback. Based on your comments, we made some updates and just uploaded a new v05. I also added a few inline responses below for each of your comments.

Please let us know if your comments have been addressed.

Thanks,
Chonggang

From: Qirg <[email-masked]> On Behalf Of Melchior Aelmans
Sent: Thursday, March 5, 2020 9:46 AM
To: [email-masked]
Subject: Re: [Qirg] I-D Action: draft-wang-qirg-quantum-internet-use-cases-04.txt

Dear authors,

"The end-nodes run applications that provide some value added service for the end-users such as processing and transmission of voice, video or data." --> ""The end-nodes expose applications  that provide services to the end-user including processing and transmission of voice, video or data".
The way this is currently described is too narrow imho.

CW – Good suggestion and changes have been taken.

"The physical connections between the various nodes in the Internet include Digital Subscriber Lines (DSLs), fiber optics, etc." --> "The connections between the various nodes could include Digital Subscriber Lines (DSLs), fiber optics, etc."

Again, currently it's too narrow. Large parts of the internet are connected via satellite for example.

CW – Made some changes as you (and Joe Touch) have suggested.

"Quantum Internet will provide intrinsic benefits such as better end-user and network security." --> "Quantum Internet will provide intrinsic benefits such as better end-to-end and network security"

CW – Thanks for the suggestion

CW – Thank you for your willingness to help on “control vs data plane aspect”. We welcome your contribution. As such, this has not been addressed in v05 yet. I have sent your two offline emails, but no heard back from you. Please feel free to let us know if you still like to propose some texts as you originally planned.

Regards,

Melchior

On Tue, Mar 3, 2020 at 6:09 PM <[email-masked]<mailto:[email-masked]>> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Applications and Use Cases for the Quantum Internet
        Authors         : Chonggang Wang
                          Akbar Rahman
                          Ruidong Li
        Filename        : draft-wang-qirg-quantum-internet-use-cases-04.txt
        Pages           : 19
        Date            : 2020-03-03

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf..org/doc/draft-wang-qirg-quantum-internet-use-cases/<https://datatracker.ietf.org/doc/draft-wang-qirg-quantum-internet-use-cases/>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

[email-masked]<mailto:[email-masked]>
[Banner]

[Banner]<https://www.interdigital.com/white_papers/streaming-media-report->

ABI - Streaming Media Report<https://www.interdigital.com/white_papers/streaming-media-report->
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.