Subject: Re: [Qirg] Pull request for new section "Comparison with multi-protocol label switched (MPLS) networks."

From: Wojciech Kozlowski <[email-masked]>
Date: Thu, 5 Mar 2020 15:54:32 +0000

Hi Bruno,

I finally got around to merging. I've made two minor edits: (i) I changed the intro paragraphs to better put it into context. The key value of this section is that it relates to concepts networking people know and understand so I thought it's important to highlight that this is not an architecture proposal, but a though experiment to outline how a network can be built. (ii) I combined a few paragraphs together.

Final text: https://github.com/Wojtek242/draft-irtf-qirg-principles/blob/69cf47ee0eec902f3b6dc483b8198d8b4bbc64d5/draft-irtf-qirg-principles-03.txt
Diff (of my edits): https://github.com/Wojtek242/draft-irtf-qirg-principles/commit/69cf47ee0eec902f3b6dc483b8198d8b4bbc64d5

I will be uploading the IETF 107 version of the draft on Monday (which is the deadline).

Thanks,
Wojtek

On Mon, 2020-02-17 at 15:37 -0600, Bruno Rijsman wrote:
Hi Woj,

I have updated the GitHub pull request for the new section to compare quantum networks to classical networks (https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/3<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_Wojtek242_draft-2Dirtf-2Dqirg-2Dprinciples_pull_3&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=ierDab_Kye53z6jREXO55QYyjvpd-Oejh_81TGUPpk8&s=D8pJduvZiHxVrglMYoNjrO1tUcRD3kc9s_YfBTa5W0s&e=>)

I tried to make it more compact (about half the size, 2 pages now) and more consistent with the style of the rest of the draft (less wooly language).

I also included some points that came up in the thread with Patrick Gelard (e.g. the GMPLS reference).

Have a look at it, don’t be shy to let me know if more polishing is still needed.

— Bruno

PS: There is a merge conflict on the .txt file. Just merge only the .xml file and re-generate the .txt file.

---

From: Bruno Rijsman <[email-masked]>
Date: Thu, 5 Mar 2020 18:06:51 -0600

Hi Woj,

Thank you very much merging the pull request.

I reviewed your changes and I agree with them.

— Bruno

> On Mar 5, 2020, at 9:54 AM, Wojciech Kozlowski <[email-masked]> wrote:
> 
> Hi Bruno,
> 
> Final text: https://github.com/Wojtek242/draft-irtf-qirg-principles/blob/69cf47ee0eec902f3b6dc483b8198d8b4bbc64d5/draft-irtf-qirg-principles-03.txt <https://github.com/Wojtek242/draft-irtf-qirg-principles/blob/69cf47ee0eec902f3b6dc483b8198d8b4bbc64d5/draft-irtf-qirg-principles-03.txt>
> Diff (of my edits): https://github.com/Wojtek242/draft-irtf-qirg-principles/commit/69cf47ee0eec902f3b6dc483b8198d8b4bbc64d5 <https://github.com/Wojtek242/draft-irtf-qirg-principles/commit/69cf47ee0eec902f3b6dc483b8198d8b4bbc64d5>
> 
>> I have updated the GitHub pull request for the new section to compare quantum networks to classical networks (https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/3 <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_Wojtek242_draft-2Dirtf-2Dqirg-2Dprinciples_pull_3&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=ierDab_Kye53z6jREXO55QYyjvpd-Oejh_81TGUPpk8&s=D8pJduvZiHxVrglMYoNjrO1tUcRD3kc9s_YfBTa5W0s&e=>)
>>

---

From: Rodney Van Meter <[email-masked]>
Date: Fri, 6 Mar 2020 09:17:35 +0900

Wojtek,

About two weeks ago, I started working on a list of things I’d like to see in the draft, but I’m afraid I’m not going to be able to turn them into text and an actual pull request by Monday. My apologies.  A few are absolute nits, a few are rather big.

Put these on your TODO list, and maybe we can find time to work on them together F2F sometime during the week in Vancouver?

Comments for Wojtek on QIRG architecture I-D:

* overall, the flow and structure are much better than -00. I
  particularly like 6.2 now, though I'm not sure it's finished yet.
* additional refs:
  - Dur group (Pirker, Zwerger)
  - (more stuff from us, e.g. my book?)
  - Kimble
  - Mark Wilde
  - Jones on links?
  - all-optical?
  - triangle inequality for routing
  - Riefel
  - Simon on QEC
  - Dur review of purification
  - distributed algorithm zoo
  - something from Pan?
  - Broadbent
  - Gottesman
  - Wootters, Park, Ortigoso on no-cloning
* needs a little wordsmithing here and there at some point
* security needs work
* needs to talk about logical differences at network boundaries
  (differences in error management parallels the other two very well)
* should cover 1G, 2G, 3G
* "support tomorrow's dist q apps" is time-sensitive, and why
  is it different from the apps just above it?
* does doc accommodate all-optical links or paths?
* does doc describe 1G as a distributed computation?
  - important corollary: state along the path v. stateless forwarding
  - equally important corollary: resource reservation/multiplexing
* just a shade more on apps, as parallel I-D is developing
* describe time-skewed Bell pairs
* "Therefore, we cannot use the same methods known from
   classical computing for the purposes of error detection and
   correction." ==> without modification, though both codes derived
   from classical and wholy unique to quantum are known (cite Simon?)
  Overall, this paragraph needs work to be both more accurate and
  clearer.
  reconcile w/ later ACK that QEC exists
* "through a variety of checksums" -- not entirely accurate.
  how about "through both error detection and error correction mechanisms"?
* section on direct transmission needs work
  --> make it a subsection of 4.1, titled "inadequacy of direct
      transmission"?
* "challenges" v. "new challenges" is awkward
* use the name "Dirac's ket notation"
  (makes it easier for neophytes to find)
* expand CNOT first time it's used
* connection architecture v. network architecture

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 9 Mar 2020 09:01:23 +0000

> Put these on your TODO list, and maybe we can find time to work on them
> together F2F sometime during the week in Vancouver?
> 

Sure, sounds good to me. Perhaps, we can have a side meeting to address the
draft as a whole. If time allows this could be just an extension to the one I
already scheduled or we might need another one.