Subject: [Qirg] draft-wang-qirg-quantum-internet-use-cases-04; MVDB03

From: VAN DEN BOSSCHE Mathias <[email-masked]>
Date: Tue, 10 Mar 2020 11:03:28 +0000

Doc: draft-wang-qirg-quantum-internet-use-cases-04

ID : MVDB 03

Page/section: pp 5-6/ § 4.3

Proposal/Question:

It looks like the definition of network planes is a bit confusing.
Moreover the descritpion of the management plane is missing.
I propose below first set of inputs regarding the way the planes could be described.
BTW, this is more for an architecture document than for a use case document.

Explanation:

Whereas the OSI protocol stack layers are probably of little help, the broader concepts of network planes are likely to be helpful. The usual distinction
between network planes is

- User/data plane: data traffic generation & forwarding
- Control plane : establish connection, authenticate users, enforce QoS policy
- Management plane : defines the rules to be applied by the control plane

Let us see how this maps on a QIN.

First, there are two high level functionalities (call them e.g. "macrofunctions")
* end-to-end physical link set-up functionality to create entanglement between the targeted end nodes
* functionality to send the q-info among entangled end nodes
Probably each deserves its own protocol stack. The latter is probably simple as it involves less elements.

Then, inspecting each macrofunction, one finds

* The end-to-end physical link set-up involves the following steps
  - the physical establishment of segment entanglement, that requires
    . physical entangled system (e.g. photon pairs) distribution
    . heralding(*) of the entangled system availability
    . distillation and storage of fewer, more entangled systems
  - the swapping/routing of entanglement from segment to segment that requires
    . identifying which neighbouring node are to be connected
      (routing table? centralised f° of resource?)
    . Bell-state measurement at the common node
    . Transmission(*) of BSM results to neighbouring nodes
    . unitary transformation to lift ambiguity at the routed node

* The transmission of the q-information involves
  - the above set-up of entanglement among end nodes
  - Bell-state measurement at the sender node
  - Transmission of BSM to the receiver node(*)
  - unitary transformation to lift ambiguity at the routed node

(*) this implies a classical network with its own stack that is taken for granted

Trying to abstract this into functions and planes, the result could be

User plane with the functions
* The BSM of the qbit to be transmitted & entangled-channel local part
* The creation of elementary entanglement resource between each pair of contiguous nodes
* The weaving(**) of entanglement though contiguous links by swapping
* The auxiliary classical network to transfer the BSM results
* The unitary transformation on the received qbit entangled-channel remote part to lift its ambiguity

Control plane with
* The authentication of end nodes
* The establishment of the auxiliary channel to transfer the heralding data
* The establishment of a quantum communication session between 2 authenticated end nodes
* The monitoring of the network resource level (fidelity and number of available entangled parts)
* The definition of the paths along which to weave(**) the end-to-end entanglement

Management plane with
* The rules to determine the paths along which to weave(**) the end-to-end entanglement
* The rules to prioritise the creation of entanglement resource among the network
* The set of acceptable KPI values of the network.

(**) I prefer weaving because routing carries the meaning of something that is pushed while what entanglement set-up does is more a spider-like work.

Discussion:

TBD

Decision:

TBD

[@@ THALES ALENIA SPACE INTERNAL @@]

---

From: Chonggang Wang <[email-masked]>
Date: Wed, 25 Mar 2020 18:53:15 +0000

Hi Mathias,

Please see our responses below to your feedback.

From: Qirg <[email-masked]> On Behalf Of VAN DEN BOSSCHE Mathias
Sent: Tuesday, March 10, 2020 7:03 AM
To: [email-masked]
Subject: [Qirg] draft-wang-qirg-quantum-internet-use-cases-04; MVDB03

ID : MVDB 03

Proposal/Question:

CW - This has not been addressed in v05 yet. Melchior Aelmans had a similar/related comment and he kindly offered help to propose some texts. We are waiting for his inputs. Expect to address this comment in next v06. BTW, your description below about data/control/management planes are very nice. Thanks!

Explanation:

Control plane with

Management plane with

Discussion:

TBD

Decision:

TBD

[Banner]

[Banner]<https://www.interdigital.com/white_papers/streaming-media-report->

ABI - Streaming Media Report<https://www.interdigital.com/white_papers/streaming-media-report->
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.