Subject: [Qirg] Information from expired drafts?

From: VAN DEN BOSSCHE Mathias <[email-masked]>
Date: Mon, 27 Apr 2020 08:51:03 +0000

Dear all,

I hope this e-mail finds you all fine even if working from home for most of us.

The current status of the QIRG documents includes only

*        Architectural Principles for a Quantum Internet (draft-irtf-qirg-principles-03<https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/>)

*        Applications and Use Cases for the Quantum Internet (draft-wang-qirg-quantum-internet-use-cases-05<https://datatracker.ietf.org/doc/draft-wang-qirg-quantum-internet-use-cases/>)

In the past, there used to be at least two more drafts (obviously expired) :

*        The link layer service in a Quantum Internet (draft-dahlberg-11-quantum-03)

*        Advertising entanglement capabilities in Quantum Networks (draft-kaws-qirg-advent-03)
(Has there been more?)

I do not see all the information of the expired draft in the current active ones. Even the type of questions addressed then is no more addresses in the current document (it could be that the questions remain relevant, while the solutions proposed in the past could evolve).

So my question is, how does the group handle this kind of situation to avoid useful information loss?
Is it still possible to discuss expired draft (the community has probably  grown significantly since they expired and they might thus receive a different audience)?

Just let us know

All the best

Mathias

[@@ THALES ALENIA SPACE INTERNAL @@]

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 27 Apr 2020 12:46:57 +0000

Hi Mathias,

The drafts expired due to inactivity - there was not enough effort going into them within the QIRG. Nevertheless, I agree with you that their content is valuable and interesting.

The expired drafts still exist and I assume there is a process for restarting them if there is interest in doing so. I agree with you that as the community matures, the number of people able and willing to contribute and/or provide feedback to those drafts will increase (and hopefully it already has).

If you have something about those drafts you would like to discuss on the mailing list, I would encourage you to do so. If the discussions turn out to be of interest to the community then they can signal that it might be time to restart work on those drafts.

At least two of the drafts refer to research work that has been published so one can also directly discuss the relevant papers (I assume the relevant drafts cite the research work on which they are based).

For everybody's convenience here are links to all expired drafts I am aware of:
- The Link Layer service in a Quantum Internet: https://www.ietf.org/archive/id/draft-dahlberg-ll-quantum-03.txt
- Advertising Entanglement Capabilities in Quantum Networks: https://www.ietf.org/archive/id/draft-kaws-qirg-advent-03.txt<https://www.ietf.org/archive/id/draft-kaws-qirg-advent-03.txt
->
- Connection Setup in a Quantum Network: https://tools.ietf.org/id/draft-van-meter-qirg-quantum-connection-setup-00.txt

Thanks,
Wojtek

On Mon, 2020-04-27 at 08:51 +0000, VAN DEN BOSSCHE Mathias wrote:
Dear all,

·        Architectural Principles for a Quantum Internet (draft-irtf-qirg-principles-03<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-2Dprinciples_&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=uQ2nVb10Xv_iRXjatqH_2xQSAyvP6ygjd4X88INGNj8&s=P7fBo3wxNAjOM4m9hf0XEZWMdIob5z4-buST6BCYiiw&e=>)

·        Applications and Use Cases for the Quantum Internet (draft-wang-qirg-quantum-internet-use-cases-05<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dwang-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases_&d=DwMFAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=uQ2nVb10Xv_iRXjatqH_2xQSAyvP6ygjd4X88INGNj8&s=s6laoVi5iuZqZV-G435wsGYh2csarD2l0shJXhNUiDM&e=>)

·        The link layer service in a Quantum Internet (draft-dahlberg-11-quantum-03)

·        Advertising entanglement capabilities in Quantum Networks (draft-kaws-qirg-advent-03)
(Has there been more?)

Just let us know

All the best

Mathias

_______________________________________________

Qirg mailing list

[email-masked]<mailto:[email-masked]>

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=uQ2nVb10Xv_iRXjatqH_2xQSAyvP6ygjd4X88INGNj8&s=z1rkIb-IDGQyIHMXhU9ybVyqc91WPBJFQoSrVsjTESs&e=

---

From: Axel Dahlberg <[email-masked]>
Date: Tue, 28 Apr 2020 08:31:31 +0000

Hi Mathias (and others)!

Yes, I hadn't realise that our draft (for a link layer service) was about to expire. Unfortunately I have not had so much time for it recently due to other tasks. But if someone wants to contribute or discuss that's great. So I agree that it is good if it doesn't get lost. Btw, there is a github repo for the draft which can also be used to work on issues etc: https://github.com/SoftwareQuTech/draft-dahlberg-qirg-ll-quantum

/Axel Dahlberg

________________________________
From: Qirg <[email-masked]> on behalf of Wojciech Kozlowski <[email-masked]>
Sent: 27 April 2020 14:46:57
To: [email-masked]
Subject: Re: [Qirg] Information from expired drafts?

Hi Mathias,

For everybody's convenience here are links to all expired drafts I am aware of:
- The Link Layer service in a Quantum Internet: https://www.ietf.org/archive/id/draft-dahlberg-ll-quantum-03.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Ddahlberg-2Dll-2Dquantum-2D03.txt&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=Giyep6MrynuiK3I4kCr9RY-AJjtXwneonqvQLHi5k4g&s=5-eNMqdb6Nl3G0JexDyVrxLm1d1BDHlmX9sem_sZgOA&e=>
- Advertising Entanglement Capabilities in Quantum Networks: https://www.ietf.org/archive/id/draft-kaws-qirg-advent-03.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dkaws-2Dqirg-2Dadvent-2D03.txt-2D&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=Giyep6MrynuiK3I4kCr9RY-AJjtXwneonqvQLHi5k4g&s=RyyOGkymskVltX4YPNojM5ctOpa13iQbPRbruvUc_74&e=>
- Connection Setup in a Quantum Network: https://tools.ietf.org/id/draft-van-meter-qirg-quantum-connection-setup-00.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_id_draft-2Dvan-2Dmeter-2Dqirg-2Dquantum-2Dconnection-2Dsetup-2D00.txt&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=Giyep6MrynuiK3I4kCr9RY-AJjtXwneonqvQLHi5k4g&s=X3DRj4lRN2Ct1zC5DvhgI1VgFeQy6wY-2eIttJZObUo&e=>

Thanks,
Wojtek

Just let us know

All the best

Mathias

Qirg mailing list

---

From: Gelard Patrick <[email-masked]>
Date: Tue, 28 Apr 2020 14:15:50 +0000

Hi Axel,

The draft https://www.ietf.org/archive/id/draft-dahlberg-ll-quantum-03.txt does not define a link layer protocol, but defines an interface ("Quantum Link Layer Service Access Point") to allow the upper layers to use a link layer service regardless of the specificity of the physical quantum layers.

It seems to me that to validate this project you have to be able to test it with a quantum network simulator to complete the tests that can be done in physics laboratories.

It seems that you have tested with the NetSquid network simulator (https://netsquid.org/), the link layer protocol for quantum networks that you defined in this article https://arxiv.org/abs/1903.09778 article. Have you developed with NetSquid an interface that meets the specifications defined in the draft  "draft-dahlberg-ll-quantum-03.txt" ?

Thanks,
Patrick

De : Qirg <[email-masked]> De la part de Axel Dahlberg
Envoyé : mardi 28 avril 2020 10:32
À : [email-masked]
Objet : Re: [Qirg] Information from expired drafts?

Hi Mathias (and others)!

Yes, I hadn't realise that our draft (for a link layer service) was about to expire. Unfortunately I have not had so much time for it recently due to other tasks. But if someone wants to contribute or discuss that's great. So I agree that it is good if it doesn't get lost. Btw, there is a github repo for the draft which can also be used to work on issues etc: https://github..com/SoftwareQuTech/draft-dahlberg-qirg-ll-quantum<https://github.com/SoftwareQuTech/draft-dahlberg-qirg-ll-quantum>

/Axel Dahlberg

________________________________
From: Qirg <[email-masked]<mailto:[email-masked]>> on behalf of Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>>
Sent: 27 April 2020 14:46:57
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Qirg] Information from expired drafts?

Hi Mathias,

For everybody's convenience here are links to all expired drafts I am aware of:
- The Link Layer service in a Quantum Internet: https://www.ietf.org/archive/id/draft-dahlberg-ll-quantum-03.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Ddahlberg-2Dll-2Dquantum-2D03.txt&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=Giyep6MrynuiK3I4kCr9RY-AJjtXwneonqvQLHi5k4g&s=5-eNMqdb6Nl3G0JexDyVrxLm1d1BDHlmX9sem_sZgOA&e=>
- Advertising Entanglement Capabilities in Quantum Networks: https://www.ietf.org/archive/id/draft-kaws-qirg-advent-03.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dkaws-2Dqirg-2Dadvent-2D03.txt-2D&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=Giyep6MrynuiK3I4kCr9RY-AJjtXwneonqvQLHi5k4g&s=RyyOGkymskVltX4YPNojM5ctOpa13iQbPRbruvUc_74&e=>
- Connection Setup in a Quantum Network: https://tools.ietf.org/id/draft-van-meter-qirg-quantum-connection-setup-00.txt<https://urldefense..proofpoint.com/v2/url?u=https-3A__tools.ietf.org_id_draft-2Dvan-2Dmeter-2Dqirg-2Dquantum-2Dconnection-2Dsetup-2D00.txt&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=Giyep6MrynuiK3I4kCr9RY-AJjtXwneonqvQLHi5k4g&s=X3DRj4lRN2Ct1zC5DvhgI1VgFeQy6wY-2eIttJZObUo&e=>

Thanks,
Wojtek

Just let us know

All the best

Mathias

Qirg mailing list

---

From: Axel Dahlberg <[email-masked]>
Date: Tue, 28 Apr 2020 16:09:43 +0000

Hi Patrick!

Indeed, the draft concerns the interface and service of a link layer in a quantum network. In the paper you mention (https://arxiv.org/abs/1903.09778) we indeed develop a specific link layer protocol that provides the service and interface described in the draft in this group. In the paper describing the protocol we have also done simulations and benchmarks of the protocol using the NetSquid simulator, in particular using realistic noise models for a hardware platform using nitrogen-vacancies in diamond.

/Axel Dahlberg

________________________________
From: Gelard Patrick <[email-masked]>
Sent: 28 April 2020 16:15:50
To: Axel Dahlberg; [email-masked]
Subject: RE: [Qirg] Information from expired drafts?

Hi Axel,

The draft https://www.ietf.org/archive/id/draft-dahlberg-ll-quantum-03.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Ddahlberg-2Dll-2Dquantum-2D03.txt&d=DwQFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=VajwzgtVE8RfD03BtBUJCJy5lB2GEWg8iSDA-kqYOmA&s=DxOX26_Bee5eu-xq6-TBjM53TcVUTJ0nBoDolr3tMC4&e=> does not define a link layer protocol, but defines an interface (“Quantum Link Layer Service Access Point”) to allow the upper layers to use a link layer service regardless of the specificity of the physical quantum layers.

It seems that you have tested with the NetSquid network simulator (https://netsquid.org/<https://urldefense.proofpoint.com/v2/url?u=https-3A__netsquid.org_&d=DwQFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=VajwzgtVE8RfD03BtBUJCJy5lB2GEWg8iSDA-kqYOmA&s=jglpJXFJTYwxzfUKFTWRMzrjSiJCDXNzqhk60dMsFIQ&e=>), the link layer protocol for quantum networks that you defined in this article https://arxiv.org/abs/1903.09778<https://urldefense.proofpoint.com/v2/url?u=https-3A__arxiv.org_abs_1903.09778&d=DwQFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=VajwzgtVE8RfD03BtBUJCJy5lB2GEWg8iSDA-kqYOmA&s=s_ENd4qc8ITPQcFpJ6N1kOOBl83Xdk-X1RjYum-ZCq0&e=> article. Have you developed with NetSquid an interface that meets the specifications defined in the draft  “draft-dahlberg-ll-quantum-03.txt” ?

Thanks,
Patrick

Hi Mathias (and others)!

Yes, I hadn't realise that our draft (for a link layer service) was about to expire. Unfortunately I have not had so much time for it recently due to other tasks. But if someone wants to contribute or discuss that's great. So I agree that it is good if it doesn't get lost. Btw, there is a github repo for the draft which can also be used to work on issues etc: https://github..com/SoftwareQuTech/draft-dahlberg-qirg-ll-quantum<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_SoftwareQuTech_draft-2Ddahlberg-2Dqirg-2Dll-2Dquantum&d=DwMFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=3e1cwIYn2WshPFT-r2aOqFVsO8uPGPnpt9arrWJ7r0M&m=VajwzgtVE8RfD03BtBUJCJy5lB2GEWg8iSDA-kqYOmA&s=OiowNKgKevL1JmHXUypn3xILFtsWoDwU0gMHICJXXFI&e=>

/Axel Dahlberg

Hi Mathias,

Thanks,
Wojtek

Just let us know

All the best

Mathias

Qirg mailing list