Subject: Re: [Qirg] Pull request for 'new challenges' subsection 'The first quantum networks may not be "routing and forwarding" networks.'

From: Wojciech Kozlowski <[email-masked]>
Date: Fri, 3 Apr 2020 09:32:21 +0000

Hi Shota,

Thanks for your contribution!

I've reviewed your update. My detailed review comments are on the GitHub repo: https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/5#pullrequestreview-387089034

In summary:

Overall, I think your contribution makes a very important point that will be very useful for people coming from a classical background. My comments are mostly about clarifying what you meant. With further clarifications, your contribution can be merged.

I am also not sure about this "routing and forwarding" and "routing and swapping" terminology. Is it common? I know of "store-and-forward" and perhaps we can say "store-and-swap" which highlights the need for memory (some proposals do not need a memory, not sure if they will be practical any time soon though). Also "store-and-swap" suggests we can keep things in memory for a long time which is not the case. I think this would be a good point to discuss. I would definitely suggest leaving routing completely out of this section as it is not actually discussed at all.

Wojtek

On Tue, 2020-03-31 at 14:02 +0900, Shota NAGAYAMA wrote:
Hi Wojtek,

How are things going? I'm looking forward to your review.

BTW, it's very nice that now you are a co-chair of the group :)

Thanks,
Shota
------------------------------------------------
永山翔太 Shota Nagayama
[email-masked]<mailto:[email-masked]>
https://shota.io/<https://urldefense.proofpoint.com/v2/url?u=https-3A__shota.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=e7e0ouv4Yq7s8KyDdBBHKM7RF-nKr_0iLOZsRcyKMxk&e=>
https://qitf.org/<https://urldefense.proofpoint.com/v2/url?u=https-3A__qitf.org_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=y3h0gz6GnUT9x1OpbKkqX_2CMG3DZ5pMnFpmwIExaTI&e=>
https://r4d.mercari.com<https://urldefense.proofpoint.com/v2/url?u=https-3A__r4d.mercari.com&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=7AWoJwX6ypg-cUFHSwdyQaxiRB4mWAUdlwWH0CMNmyg&e=>

On Mon, Mar 9, 2020 at 5:53 PM Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>> wrote:
Hi Shota,

Thanks for your contribution. I haven't had time to look at it yet so I won't include it in the draft I upload today. I will try to review it before Vancouver though so at least the work can still go on.

Thanks,
Wojtek

On Fri, 2020-03-06 at 01:51 +0900, Shota NAGAYAMA wrote:
Hi,

I finally made a pull request for 'The first quantum networks may not be "routing and forwarding" networks.' subsection in the new challenges section. This subsection tells what is caused by the fact that Bell pairs are undirected network resources. Please find it.

https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/5<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_Wojtek242_draft-2Dirtf-2Dqirg-2Dprinciples_pull_5&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=-sTHDClmClG4EIhCAKj9azqNfPLpgPb_e0cEi-3bmys&e=>

------------------------------------------------
永山翔太 Shota Nagayama
[email-masked]<mailto:[email-masked]>
https://shota.io/<https://urldefense.proofpoint.com/v2/url?u=https-3A__shota.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=Qx2Pi5RpW5eFvMfMQc_CwyafjSl8U7c1ZtiUXV8imDo&e=>
https://qitf.org/<https://urldefense.proofpoint.com/v2/url?u=https-3A__qitf.org_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=n0L3EMEwnxHvv2LAuLvgxvvKDoaCjL9PRCiPtFfUTV8&e=>
https://r4d.mercari.com<https://urldefense.proofpoint.com/v2/url?u=https-3A__r4d.mercari.com&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=fOR-fYIq-0jJJzCMkbmHPjRgDX9VvP5tEEGb7S39W4M&e=>

_______________________________________________

Qirg mailing list

[email-masked]<mailto:[email-masked]>

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=AsjKClF3rnjkQc4PUebFFsqBP_YQrh5cNjyCqvalD68&e=

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=xwTVo7VAuf97wRriYn1xNDrsJRtkD5tIx94Wcce68ps&e=>

---

From: Shota NAGAYAMA <[email-masked]>
Date: Sat, 18 Apr 2020 08:35:24 +0900

Hi Wojtek,

I've updated the pull request.
I meant to clarify that routing would be the same, however, it might have
been confusing. I have left out routing; just store-and-forward and
store-and-swap are compared. And I added a section about generations.
Please see other points on the pull request page and the document.

--Shota
------------------------------------------------
永山翔太 Shota Nagayama
[email-masked]
https://shota.io/
https://qitf.org/
https://r4d.mercari.com

On Fri, Apr 3, 2020 at 6:32 PM Wojciech Kozlowski <[email-masked]>
wrote:

> I've reviewed your update. My detailed review comments are on the GitHub
> repo:
> https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/5#pullrequestreview-387089034
>
> In summary:
>
> Overall, I think your contribution makes a very important point that will
> be very useful for people coming from a classical background. My comments
> are mostly about clarifying what you meant. With further clarifications,
> your contribution can be merged.
>
>
> I am also not sure about this "routing and forwarding" and "routing and
> swapping" terminology. Is it common? I know of "store-and-forward" and
> perhaps we can say "store-and-swap" which highlights the need for memory
> (some proposals do not need a memory, not sure if they will be practical
> any time soon though). Also "store-and-swap" suggests we can keep things in
> memory for a long time which is not the case. I think this would be a good
> point to discuss. I would definitely suggest leaving routing completely out
> of this section as it is not actually discussed at all.
>
>
> Wojtek
>
>
> [email-masked]
> https://shota.io/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__shota.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=e7e0ouv4Yq7s8KyDdBBHKM7RF-nKr_0iLOZsRcyKMxk&e=>
> https://qitf.org/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__qitf.org_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=y3h0gz6GnUT9x1OpbKkqX_2CMG3DZ5pMnFpmwIExaTI&e=>
> https://r4d.mercari.com
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__r4d.mercari.com&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=7AWoJwX6ypg-cUFHSwdyQaxiRB4mWAUdlwWH0CMNmyg&e=>
>
>
> On Mon, Mar 9, 2020 at 5:53 PM Wojciech Kozlowski <[email-masked]>
> wrote:
>
> Hi Shota,
>
> Thanks for your contribution. I haven't had time to look at it yet so I
> won't include it in the draft I upload today. I will try to review it
> before Vancouver though so at least the work can still go on.
>
> Thanks,
> Wojtek
>
> I finally made a pull request for 'The first quantum networks may not be
> "routing and forwarding" networks.' subsection in the new challenges
> section. This subsection tells what is caused by the fact that Bell pairs
> are undirected network resources. Please find it.
>
> https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/5
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_Wojtek242_draft-2Dirtf-2Dqirg-2Dprinciples_pull_5&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=-sTHDClmClG4EIhCAKj9azqNfPLpgPb_e0cEi-3bmys&e=>
>
> [email-masked]
> https://shota.io/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__shota.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=Qx2Pi5RpW5eFvMfMQc_CwyafjSl8U7c1ZtiUXV8imDo&e=>
> https://qitf.org/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__qitf.org_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=n0L3EMEwnxHvv2LAuLvgxvvKDoaCjL9PRCiPtFfUTV8&e=>
> https://r4d.mercari.com
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__r4d.mercari.com&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=wLaiWvpUZ5lb_P0nUOLjyde3okLuO2zPyxHFWPr3_VM&s=fOR-fYIq-0jJJzCMkbmHPjRgDX9VvP5tEEGb7S39W4M&e=>
>
> [email-masked]
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSe8nfX7Q27kWqyic_1YxDWtHXWE-492zzxBnKyvcDA&s=xwTVo7VAuf97wRriYn1xNDrsJRtkD5tIx94Wcce68ps&e=>
>
>

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 27 Apr 2020 12:20:24 +0000

Hi Shota,

Thanks for the update! I've just reviewed it: https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/5#pullrequestreview-400873270

Summary of my comments (follow the link for details):

I would like to spend some more time on the generation section though. I need to think more about what this section should contribute to the document. There is nothing wrong with what you wrote, I'd just rather not include it until I'm clear on what its contents should be and then I'll come back to your contribution.

However, the text about directionality, once you have a look at my proposed changes, can already be included. Since the generation section is currently in the same PR, if you would like your contributions merged sooner, please submit the section about generations as a separate PR, and I will merge the rest.

Thanks,

Wojtek

On Sat, 2020-04-18 at 08:35 +0900, Shota NAGAYAMA wrote:
Hi Wojtek,

I've updated the pull request.
I meant to clarify that routing would be the same, however, it might have been confusing. I have left out routing; just store-and-forward and store-and-swap are compared. And I added a section about generations. Please see other points on the pull request page and the document.

--Shota
------------------------------------------------
永山翔太 Shota Nagayama
[email-masked]<mailto:[email-masked]>
https://shota.io/<https://urldefense.proofpoint.com/v2/url?u=https-3A__shota.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=AdZ85HJUabhoLYQUDalsUH2UWKETdx8VYzF89o2FgTI&s=W1Dk7HRbhwba24hJPb0j3cNNRjQX3Qhi-qYejXhGGdY&e=>
https://qitf.org/<https://urldefense.proofpoint.com/v2/url?u=https-3A__qitf.org_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=AdZ85HJUabhoLYQUDalsUH2UWKETdx8VYzF89o2FgTI&s=QjsA76ECOj4SzbwZP1_NVqZbEi18Eaq7kx1Ty8PbVvg&e=>
https://r4d.mercari.com<https://urldefense.proofpoint.com/v2/url?u=https-3A__r4d.mercari.com&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=AdZ85HJUabhoLYQUDalsUH2UWKETdx8VYzF89o2FgTI&s=SA7SzipWOrNiFcQfsdO72wJheFD3TpWHiYjuW9gVXB4&e=>

On Fri, Apr 3, 2020 at 6:32 PM Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>> wrote:
Hi Shota,

I've reviewed your update. My detailed review comments are on the GitHub repo: https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/5#pullrequestreview-387089034<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_Wojtek242_draft-2Dirtf-2Dqirg-2Dprinciples_pull_5-23pullrequestreview-2D387089034&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=AdZ85HJUabhoLYQUDalsUH2UWKETdx8VYzF89o2FgTI&s=epUqRQwb6LPd2qi2Qipww5ec3JG1D74NvadCBq7WQNQ&e=>

In summary:

Wojtek

Thanks,
Shota

Thanks,
Wojtek

Qirg mailing list

---

From: VAN DEN BOSSCHE Mathias <[email-masked]>
Date: Mon, 27 Apr 2020 14:34:25 +0000

Hi all,

Looking at the discussion on github, I am a bit puzzled at this idea of store-and-forward.  Actually, it deserves a motivation.
As we put it in the early generations, QIN establish an end-to-end entanglement link, and when it is ready, use it to send qbits directly end to end.
In a telephone network, it is like pulling a new copper or a new fiber anytime you want to make a call.

Later generations are proposed that tend to look more like classical networks (store-and-forward, i.e. routing, transport, etc).
It is clear that doing this will require progress in the nodes. But is it worth the pain? Of course in classical networks, pulling a new line is awfully costly.
Would it be so with entanglement ? Do we have to let us drive by analogy with classical networks? Aren’t there more options for
next generations (e.g. quantum broadcast with multipartite entanglement, etc)?

Just to get some light

Mathias

[@@ THALES ALENIA SPACE INTERNAL @@]

De : Qirg [mailto:[email-masked]] De la part de Wojciech Kozlowski
Envoyé : lundi 27 avril 2020 14:20
À : [email-masked]
Cc : [email-masked]
Objet : Re: [Qirg] Pull request for 'new challenges' subsection 'The first quantum networks may not be "routing and forwarding" networks.'

Hi Shota,

Thanks,

Wojtek

--Shota

In summary:

Wojtek

Thanks,
Shota

Thanks,
Wojtek

Qirg mailing list

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Mon, 27 Apr 2020 15:18:28 +0000

I would like to point out that there are certainly classical networks that use “circuit switching”, that is, setting up a long term network path between two end points, and then using that path to allow the two end points to communicate.  Examples of this would be both MPLS and OTN.

On the other hand, we shouldn’t feel constrained to do what classical networks do.  For one, the relative costs for a Quantum Network would be, at times, radically different than the corresponding costs for a classical one.  For a Quantum Network, control traffic (that is, the traffic used to manage the flow through the network) can be done using classical bits, and so are almost free in comparision to the data traffic bits (which are qubits); if we could reduce by one the number of qubits that need to be exchanged, at the cost of exchanging a megabyte of classical control traffic, it would make sense for us (but would make absolutely no sense in the classical case).

Hence, while it makes sense to use classical protocols as a source of ideas (they thought about it a lot, and so perhaps we can reuse some of what they came up with), we need to remember that the things they optimized for are not always the things we need to optimize for…

From: Qirg <[email-masked]> On Behalf Of VAN DEN BOSSCHE Mathias
Sent: Monday, April 27, 2020 10:34 AM
To: [email-masked]
Subject: Re: [Qirg] Pull request for 'new challenges' subsection 'The first quantum networks may not be "routing and forwarding" networks.'

Hi all,

Just to get some light

Mathias

De : Qirg [mailto:[email-masked]] De la part de Wojciech Kozlowski
Envoyé : lundi 27 avril 2020 14:20
À : [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [Qirg] Pull request for 'new challenges' subsection 'The first quantum networks may not be "routing and forwarding" networks.'

Hi Shota,

Thanks,

Wojtek

--Shota

In summary:

Wojtek

Thanks,
Shota

Thanks,
Wojtek

Qirg mailing list

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 28 Apr 2020 13:59:46 +0000

Fair point Mathias.

I'm still thinking about how best to include the generations into the draft. Most practical work is focused on what some call the first generation and the draft itself is heavily inspired by this particular generation.

Subsequent generations describe the new possibilities as our technological capabilities increase. I'm not exactly clear if a new generation fully obsoletes the previous one, because whilst they improve upon the previous generation in certain aspects they also come with higher requirements in other areas.

I'm pretty sure there is quite a bit of interest in including generations in this draft - at least a mention on what they are even though the focus is on the first. I think this point merits some discussion so I wills start off by leaving two articles that I usually refer to on this subject:

- https://www.nature.com/articles/srep20463 (should be open access)
- https://ieeexplore.ieee.org/abstract/document/7010905/

The second article isn't open access and I can't find an arXiv version. I'm not the author so I'm not sure how okay it is to just share the pdf on a public mailing list as much as I'd like to do just that. I'd rather avoid the same trouble Sci-Hub got into. If somebody who knows copyright law knows how to correctly distribute such articles, please let me know.

To answer your question Mathias, I tried phrasing that 3G enables rather than warrants direct transmission though I have some reading up to do since I don't really spend much time thinking about anything other than 1G. It may be, that as you say, that an infrastructure we deploy puts certain constraints on how the technology develops which is sort of the reason why I don't spend much time thinking about what will be when 3G becomes possible.

Ultimately, my impression is that the progression 1G->2G->3G is more about reducing classical communication that causes latency. As Scott said, we can send Megabytes of data if that helps, but latency is usually the focus in this progression.

Thanks,
Wojtek

On Mon, 2020-04-27 at 15:18 +0000, Scott Fluhrer (sfluhrer) wrote:
I would like to point out that there are certainly classical networks that use “circuit switching”, that is, setting up a long term network path between two end points, and then using that path to allow the two end points to communicate.  Examples of this would be both MPLS and OTN.

Hi all,

Just to get some light

Mathias

Hi Shota,

Thanks for the update! I've just reviewed it: https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/5#pullrequestreview-400873270<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_Wojtek242_draft-2Dirtf-2Dqirg-2Dprinciples_pull_5-23pullrequestreview-2D400873270&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=0t7Khb_IckCCk62CLYBL3K6GC1lJFnJi-SxvcdXy0ps&s=td4j-NUySEg_1AMWyxCg-xLep1ki_8m7xCxi-XeeOV8&e=>

Thanks,

Wojtek

--Shota

In summary:

Wojtek

Thanks,
Shota

Thanks,
Wojtek

Qirg mailing list

Qirg mailing list

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=0t7Khb_IckCCk62CLYBL3K6GC1lJFnJi-SxvcdXy0ps&s=Qh9EQs0OUnn6Nw3voV0VAFmol43Sv3zKY00Q5qBGaFA&e=