Subject: [Qirg] draft-irtf-qirg-principles: goals and principles

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 12 May 2020 16:47:00 +0000

Dear QIRG,

To make progress on the Architectural Principles draft one last item of work remains which is section 6: goals and principles. Most of the document is informative and more of a review in content. However, this section allows us to bring some innovative and fresh ideas to the table and it would be great if as the QIRG we could try and do that.

The section is already non-empty so what I'm looking for is to

  *   go over what's currently written and review it
  *   discuss any further additions to both goals and principles

Anybody who has read and understood the contents of the draft so far should be able to contribute. Experts in network system design particularly welcome.

As this was meant to be a side meeting in Vancouver, to make progress I would like to organise a 1 hour long virtual meeting on either June 2 or June 3. If you would like to contribute, please fill out your availability using the link below by Monday May 18. For those for whom the time chosen might not be convenient, we will make sure the session is recorded.

https://framadate.org/qvA3TcT8M3E1JTi9<https://urldefense.proofpoint.com/v2/url?u=https-3A__framadate.org_qvA3TcT8M3E1JTi9&d=DwMBAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=90FSMEVguEJgVtbIKzB2Buv9z0nhgXvQzkSyKLVW64E&s=NnK6PpDgAbJ7WAN9SfMmqeuOIdFefQFWVaKDvC4non4&e=>

Once this section is complete, the draft will go through some editorial updates + an update on 3 repeater generations currently also in the works. If possible, this might make the draft ready for the next stage by IETF 108.

Regards,
Wojtek

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 12 May 2020 17:42:58 +0000

Hi all,

Added two more dates for additional flexibility: June 9 and June 10 (same times). So the meeting options are now June 2, 3, 9, or 10.

Doodle link: https://framadate.org/qvA3TcT8M3E1JTi9

Regards,
Wojtek

On Tue, 2020-05-12 at 16:47 +0000, Wojciech Kozlowski wrote:
Dear QIRG,

Regards,
Wojtek

_______________________________________________

Qirg mailing list

[email-masked]<mailto:[email-masked]>

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=4iOAVB7x-f948YabTRLMEpjLtlLc_Pu7Z2k6YrBUvNQ&s=LRs-q6_VLHR0mYnMS6LuKUiyzeQgVlaWDYCNARMEJLY&e=

---

From: Wojciech Kozlowski <[email-masked]>
Date: Fri, 15 May 2020 08:18:43 +0000

Dear QIRG,

A reminder to fill out your availability for a call about the Architectural Principles draft: https://framadate.org/qvA3TcT8M3E1JTi9<https://urldefense.proofpoint.com/v2/url?u=https-3A__framadate.org_qvA3TcT8M3E1JTi9&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=zLIAUo2eMK5Pa3NVVOWel5d4_g_YmATW19AzZCYFPvo&s=B7F-gTOGAdXgv-d9S-EQZp3vbFXldElkqgrfxO16h2A&e=>

A bit of background on what I want to do here:

Sections 1-5 set the scene as to what quantum networks are, how they function, etc. Section 6 is about looking forward. Given that we know the building blocks, what do we actually want to build with them? What matters more, what matters less? What should one keep in mind when designing protocols?

My inspiration for section 6 is the following paper by David Clark "The Design Philosophy of the DARPA Internet Protocols": https://dl.acm.org/doi/pdf/10.1145/52324.52336

And the following RFC: https://tools.ietf.org/html/rfc1958

As RFC 1958 shows this need does not need to be an extensive section, but it's a good place to think a bit how the challenges introduced in the first few sections translate into protocol design.

This section will definitely benefit from protocol design/implementation experience.

Cheers,
Wojtek

On Tue, 2020-05-12 at 17:42 +0000, Wojciech Kozlowski wrote:
Hi all,

Doodle link: https://framadate.org/qvA3TcT8M3E1JTi9<https://urldefense.proofpoint.com/v2/url?u=https-3A__framadate.org_qvA3TcT8M3E1JTi9&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=zLIAUo2eMK5Pa3NVVOWel5d4_g_YmATW19AzZCYFPvo&s=B7F-gTOGAdXgv-d9S-EQZp3vbFXldElkqgrfxO16h2A&e=>

Regards,
Wojtek

Regards,
Wojtek

Qirg mailing list

Qirg mailing list

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=zLIAUo2eMK5Pa3NVVOWel5d4_g_YmATW19AzZCYFPvo&s=8tIuHVZW_RKSH5MF2E4Rd8DDX-Xmtr-5YvhjCcu7MMI&e=

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 19 May 2020 15:03:57 +0000

I have scheduled a virtual meeting on June 9 at 12:00 UTC. Below are the call details and a calendar event is attached.

Datatracker: https://datatracker.ietf.org/meeting/interim-2020-qirg-02/session/qirg
Agenda: Review section 6 of draft-irtf-qirg-principles<https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/> and discuss possible additions

draft-irtf-qirg-principles: goals and principles
Hosted by Quantum Internet Research Group

Tuesday, Jun 9, 2020 5:00 am | 1 hour | (UTC-07:00) Pacific Time (US & Canada)
Meeting number: 617 400 539
Password: a37wSAQ2DDZ
Agenda: Review section 6 of draft and discuss possible additions
https://ietf.webex.com/ietf/j.php?MTID=md099578b71f8df25a5fb5d22e3d9916c

Join by video system
Dial [email-masked]<mailto:[email-masked]>
You can also dial 173.243.2.68 and enter your meeting number.

Join by phone
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 617 400 539

On Fri, 2020-05-15 at 08:18 +0000, Wojciech Kozlowski wrote:
Dear QIRG,

My inspiration for section 6 is the following paper by David Clark "The Design Philosophy of the DARPA Internet Protocols": https://dl.acm.org/doi/pdf/10.1145/52324.52336<https://urldefense.proofpoint.com/v2/url?u=https-3A__dl.acm.org_doi_pdf_10.1145_52324.52336&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=NTkjIPMzNW9-rV2psBThpbL_4SczzcreTN9eN2ftlUA&s=zPp6wUaEq0Y3k-EEysQV3ujLntmrsVWYIWKfRUkMmmA&e=>

And the following RFC: https://tools.ietf.org/html/rfc1958<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc1958&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=NTkjIPMzNW9-rV2psBThpbL_4SczzcreTN9eN2ftlUA&s=giqVITq9aRkr8ZF_pAbOZJVkz1yuK51Rl36ZjKJIm6o&e=>

Cheers,
Wojtek

Regards,
Wojtek

Regards,
Wojtek

Qirg mailing list

Qirg mailing list

Qirg mailing list

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=NTkjIPMzNW9-rV2psBThpbL_4SczzcreTN9eN2ftlUA&s=Yf22wROFnok5rddTyXB2c1CiPz0QZ45g3dcXK49dXlU&e=