Subject: [Qirg] Discrete/Continuous variable encodings

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 9 Jun 2020 15:14:55 +0000

Dear QIRG,

One point that was raised on the call today was whether it's a goal to support
continuous variable qubits as well as discrete variable qubits.

The consensus appeared to be that something should be included, but that it's
quite a heavy topic on its own.

Last year, Patrick Gelard, did submit a PR for the draft in which he proposed
that such encoding diversity be a goal so I think that's the best point to
start a discussion from (look for lines 1111-1127): 
https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/1/files

I was initially reluctant to include this section (and I haven't so far) as it
appeared to me that it goes too deep into the physical layer. If CV vs DV can
be kept entirely within the hardware and there is no reason to expose it beyond
that, it might be best to keep it out of the draft. If it does somehow affect
the protocol design landscape then I think it's a point worth mentioning.

Question to the community:
1. Is it worth having something about CV vs DV? Does it have an impact on the
protocol design landscape?
2. If it is, does the contribution above cover the subject?

Cheers,
Wojtek

---

From: Steve Willis <[email-masked]>
Date: Tue, 9 Jun 2020 11:41:19 -0400

I think you have to acknowledge CV as possible alternate encoding which leads us to 

Does the current document set cover the issues for CV? 
What the issues in CV-DV repeater interoperability? 

And my solution? Address this in a future revision. 

Steve

> On Jun 9, 2020, at 11:14 AM, Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Dear QIRG,
> 
> https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/1/files <https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/1/files>
> 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Gelard Patrick <[email-masked]>
Date: Tue, 16 Jun 2020 14:37:37 +0000

Dear All,

Sorry, I realize that I did not answer the right message. I put my answers back here to keep track.

>>Does it have an impact on the protocol design landscape?
At the “quantum data/user plane level”, the concept of protocol remains to be clarified, however what can be said about discreet and continuous variables :

There are two complementary approaches, each exploiting only one aspect of the “wave-particle duality” of light. One utilizes the particle-like discrete nature of light to encode quantum information, the other, which harnesses wave-like continuous nature of light, is based on continuous variables to encode quantum information.

The conceptual difference between these two approaches is analogous to classical digital (discrete) and analog (continuous) signal processing and thus the procedures to harness these different technologies will probably be very different :

From http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.752.8683&rep=rep1&type=pdf  :

Both approaches have advantages and disadvantages in terms of the practical realization of optical Quantum Information Processing (QIP). Qubit QIP enables high fidelity of operations, but experimental realizations have been probabilistic and mostly required post-selection of successful events. This is due to the low creation and detection efficiencies of photonic qubits.

On the other hand, CV QIP is deterministic, thanks to on-demand entanglement resources and efficient homodyne measurement; however, the fidelity of operations is limited by the imperfection of the entanglement. In recent years, there has been significant progress in combining both technologies with a view to realizing hybrid protocols that overcome the current limitations of optical QIP.

Now, these notions of discrete and continuous variables, could be just linked to a principle of heterogeneity :

For example it could be mentioned : in the continuity of the heterogeneity principle of the classical internet ( https://tools.ietf.org/html/rfc1958 : 3.1 Heterogeneity is inevitable and must be supported by design), an heterogeneity principle  is expected to be take into account for the design of the quantum internet: Multiple types of quantum terminal/host, quantum network nodes, protocols/mechanisms, encoding quantum information (discrete (DV) and/or continuous (CV) variables) and applications will co-exit and interoperate. The capability to support heterogeneity should be enforced for quantum internet.

Best Regards
PS
For continuous variables the term “Qumode” is used, but however the notion of qubits remains applicable (CV-Qubit: In this approach, a qubit is composed of two coherent states, | ± α>, where ±α are the coherent amplitudes - |ψ> = cα |α> + c-α |-α>  : https://arxiv.org/abs/1007.1279 )

-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Wojciech Kozlowski
Envoyé : mardi 9 juin 2020 17:15
À : [email-masked]
Objet : [Qirg] Discrete/Continuous variable encodings

Dear QIRG,

One point that was raised on the call today was whether it's a goal to support continuous variable qubits as well as discrete variable qubits.

The consensus appeared to be that something should be included, but that it's quite a heavy topic on its own.

Last year, Patrick Gelard, did submit a PR for the draft in which he proposed that such encoding diversity be a goal so I think that's the best point to start a discussion from (look for lines 1111-1127):
https://github.com/Wojtek242/draft-irtf-qirg-principles/pull/1/files

I was initially reluctant to include this section (and I haven't so far) as it appeared to me that it goes too deep into the physical layer. If CV vs DV can be kept entirely within the hardware and there is no reason to expose it beyond that, it might be best to keep it out of the draft. If it does somehow affect the protocol design landscape then I think it's a point worth mentioning.

Question to the community:
1. Is it worth having something about CV vs DV? Does it have an impact on the protocol design landscape?
2. If it is, does the contribution above cover the subject?

Cheers,
Wojtek

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg