Subject: [Qirg] Suggestions for architecture-04

From: Joseph D Touch <[email-masked]>
Date: Mon, 17 Aug 2020 21:55:42 +0000

Hi, all,

Jumping in on the discussion (let me know if these would be easier to separate out), some thoughts below:

  *   Sec 5.3.1 could omit the “automated quantum nodes”
     *   They’re just degenerate cases of quantum routers with two quantum channels.
  *   Sec 5.3.2 should distinguish between quantum channels and classical as follows
     *   The quantum channels, at least as described, are direct (though, see below)
     *   The classical channels can be multihop classical paths

Finally, in classical architecture, I like to find equivalences within the architecture (e.g., see https://www.strayalpha.com/pubs/isi-tr-711.pdf). Here, in particular:

  *   That a multiparty link and a router are equivalent
     *   Where a multiparty link uses a MAC to determine forwarding, but a router determines it in-band
  *   That a link and a tunnel are equivalent
     *   Where a tunnel is an encapsulation-based link that can be applied recursively, and a physical link is just the base case of that recursion

In quantum nets, I think the multiparty link and router equivalence holds, e.g., a single fiber could have multiple taps at different wavelengths or that are switched based on control info where frequency and timing can determine destination (same as FDMA and TDMA classical links). Granted that some other classical multiparty link and MAC examples may not have quantum corollaries.

I’m still thinking about the tunnel example; in some sense, it could be just what quantum teleportation achieves (I think this is likely, given previous work Rod and I did on QRNA). We’d need to make sure the control protocols were similarly recursive, though.

It might be useful to add a section discussing these issues.

Joe

--
Dr. Joseph Touch
Sr Distributed Systems Data Architect
Information Systems and Cyber Division
The Aerospace Corporation
424-254-4357 cell

---

From: Wojciech Kozlowski <[email-masked]>
Date: Wed, 19 Aug 2020 08:23:30 +0000

Hi Joe,

Thanks for the comments! See my replies inline.

Cheers,
Wojtek

On Mon, 2020-08-17 at 21:55 +0000, Joseph D Touch wrote:
Hi, all,

[WK] Agreed, but I find that experimentalists (at least those I interact with) use this term regularly and thus I used this term to make a connection to their terminology.

     *

[WK] Good point. Will add that in the next iteration.

Finally, in classical architecture, I like to find equivalences within the architecture (e.g., see https://www.strayalpha.com/pubs/isi-tr-711.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.strayalpha.com_pubs_isi-2Dtr-2D711.pdf&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=84H0o9QVcWkrnBhBpSpT2P-_swIvZg5HoGx2t-kVrnw&s=1xG_RcY47VZqwfpoC3yX4pn6LNHfG-OXB67pWZ3wHAI&e=>). Here, in particular:

[WK] If I follow your train of thought correctly, I think I would also add cases where the link has the mid-point in the middle and you can then connect multiple quantum routers to the same mid-point (and perhaps optical switches) achieving something similar to an L2 LAN (which is what I assume you mean by multiparty link) in classical network.

[WK] That sounds plausible, but I think a discussion of tunnels and recursive architectures is beyond the scope of this particular document as I tried to stay far away from concrete architecture proposals and discussions. However, the idea is interesting. If there is enough material to develop this thought it would be nice to develop in a discussion on the mailing list.

Joe

_______________________________________________

Qirg mailing list

[email-masked]<mailto:[email-masked]>

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=84H0o9QVcWkrnBhBpSpT2P-_swIvZg5HoGx2t-kVrnw&s=J38fDOoCV3fDMV5umtCTV0tLOhI3kU8bkH16krmLPi8&e=

---

From: Joseph D Touch <[email-masked]>
Date: Wed, 19 Aug 2020 20:30:04 +0000

Hi, Wojtek,

See below [jt]…

Thanks,
Joe

From: Qirg <[email-masked]> on behalf of Wojciech Kozlowski <[email-masked]>
Date: Wednesday, August 19, 2020 at 1:25 AM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Qirg] Suggestions for architecture-04

Hi Joe,

Cheers,
Wojtek

[jt] it is certainly useful to keep the term in that case, but it might be useful to describe it as a special case of a quantum router (under that entry), rather than as a implying it is distinct.

     *

[jt] I’m thinking of a link where a single transmitter goes into a classical optical switch under classical control. E.g., consider fibers all going into a controllable patch-panel. That looks a lot like a multi-drop optical channel – but doesn’t rely on optical interaction to make the decision. That way a single endpoint can reach other endpoints via classical control. This is distinct from a quantum router, which (IMO) basically terminates every optical link and runs as an endpoint for teleportation protocols.

[jt] agreed that recursion is not useful in this doc per se, but I want to try to make sure the descriptions in this doc don’t get in the way of future recursive considerations. I.e., it informs my architectural thinking for this doc.

Joe

Qirg mailing list

---

From: Wojciech Kozlowski <[email-masked]>
Date: Fri, 21 Aug 2020 16:21:13 +0000

Inline

On Wed, 2020-08-19 at 20:30 +0000, Joseph D Touch wrote:
Hi, Wojtek,

See below [jt]…

Thanks,
Joe

Hi Joe,

Cheers,
Wojtek

[WK] They are slightly distinct as one will use automated quantum nodes to build long-distance repeater chains that on a network level function may appear as a single logical link. They are slightly different from a quantum router in that they won't be running a control plane and thus won't be routing.

     *

[WK] Sounds reasonable and good to keep in mind. I'll think about adding a note that the links don't have to be point-to-point and can connect multiple nodes.

[WK] I don't think it does. If there is something that does get in the way let me know as I'm in favour of making sure this solution isn't precluded by this document.

Joe

Qirg mailing list