Subject: Re: [Qirg] New Version Notification for draft-irtf-qirg-principles-05.txt

From: Gelard Patrick <[email-masked]>
Date: Thu, 8 Oct 2020 09:21:58 +0000

Dear QIRG, Dear Wojtek

The document begins to provide a homogeneous and coherent overall system vision. After a first reading however, I have some comments :

1/ 5.5.  Physical constraints
With linear optics, it is not possible to detect perfectly the 4 states of Bell. There are methods to measure 3 of the 4 Bell states, but the probability of success is lower than the two-state method : https://journals.aps.org/pra/abstract/10.1103/PhysRevA.74.022303 

Shouldn't we mention this constraint ?

2/ 5.1.  Challenge - 3.  An entangled pair is only useful if the locations of both qubits are known ... A relevant pair identifier, a means of communication between the pair owners, and an association between the pair ID and the individual qubits is sufficient.
Axel had opened an interesting debate on  "Naming and addressing in a quantum network".  For the ID "node Bruno" had proposed the use of the IP address. For the ID node Bruno had proposed the use of the IP address, but the debate on the identification of Bell pairs "link layer" remained open to take In account node with multi-interface (automated repeater or controllable quantum nodes) and the possibility on the same interface to swap differently the qubit of the pairs of "bell" generated by the  quantum links to which the interface is attached.  

Shouldn't there be a dedicated paragraph presenting this addressing and naming problem/challenge in a quantum network ? 

3/ 5.5.2.  Rate 
Shouldn't there be a paragraph devoted to the definition of metrics to define what the quality of service of quantum communications could be? or should it rather be in the document draft-irtf-qirg-quantum-internet-use-cases-02.txt 

Best regards
Patrick

-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Wojciech Kozlowski
Envoyé : mercredi 30 septembre 2020 02:17
À : [email-masked]
Objet : [Qirg] FW: New Version Notification for draft-irtf-qirg-principles-05.txt

Dear QIRG,

I have just updated the draft-irtf-qirg-principles. Please see: https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/

This version now includes changes from the last round of feedback after the last meeting and finally an expanded list of references as well.

This version is now ready for a final review by the RG while I figure out the next steps to finalise its submission for RFC status. So those of you who have only been following updates and discussions, now is a good time to give it a full read.

Cheers,
Wojtek

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 30 September 2020 02:08
To: Wojciech Kozlowski <[email-masked]>; Angela Sara Cacciapuoti <[email-masked]>; Stephanie Wehner - EWI <[email-masked]>; [email-masked]; Shota Nagayama <[email-masked]>; Angela Cacciapuoti <[email-masked]>; Rodney Van Meter <[email-masked]>; [email-masked]; Marcello Caleffi <[email-masked]>; Stephanie Wehner - EWI <[email-masked]>; Bruno Rijsman <[email-masked]>
Subject: New Version Notification for draft-irtf-qirg-principles-05.txt

A new version of I-D, draft-irtf-qirg-principles-05.txt has been successfully submitted by Wojciech Kozlowski and posted to the IETF repository.

Name:		draft-irtf-qirg-principles
Revision:	05
Title:		Architectural Principles for a Quantum Internet
Document date:	2020-09-29
Group:		qirg
Pages:		37
URL:            https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_id_draft-2Dirtf-2Dqirg-2Dprinciples-2D05.txt&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=1TPbVK5s-y-eVgSHl_oEdUSlPV4nm81lQ1Tqnh3RYrI&e= 
Status:         https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-2Dprinciples_&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=JBdRVdq1fAuroDTxsSIZghSv7KGiMlgoKNWVZ4mRuNY&e= 
Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dirtf-2Dqirg-2Dprinciples&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=J2PW8RY87WPo4vkbeevhJb_5nam4It_mzxn-Gr3H__8&e= 
Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dirtf-2Dqirg-2Dprinciples-2D05&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=hZl4H3JtLn_v8UPjscXX5sX80hgmdIhAWR1lpTlfkTY&e= 
Diff:           https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dirtf-2Dqirg-2Dprinciples-2D05&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=xekmxO_qFy8NROhnLGYytLX7zJgxCEmq4loqYhs2idc&e= 

Abstract:
   The vision of a quantum internet is to fundamentally enhance Internet
   technology by enabling quantum communication between any two points
   on Earth.  To achieve this goal, a quantum network stack should be
   built from the ground up to account for the fundamentally new
   properties of quantum entanglement.  The first realisations of
   quantum networks are imminent, but there is no practical proposal for
   how to organise, utilise, and manage such networks.  In this memo, we
   attempt to lay down the framework and introduce some basic
   architectural principles for a quantum internet.  This is intended
   for general guidance and general interest, but also to provide a
   foundation for discussion between physicists and network specialists.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

---

From: Wojciech Kozlowski <[email-masked]>
Date: Thu, 15 Oct 2020 10:09:37 +0000

Hi Patrick,

Thanks for the feedback! All you concerns are valid and I agree with all of them, but they get a bit too detailed for the principles doc. Nevertheless they are suitable to tackle elsewhere or bring to the QIRG as a presentation at one of our meetings.

Some extra details in-line.

Cheers,
WOjtek

> From: Gelard Patrick <[email-masked]>
> Sent: 08 October 2020 11:22
> To: [email-masked]; Wojciech Kozlowski <[email-masked]>
> Subject: RE: New Version Notification for draft-irtf-qirg-principles-05.txt
> 
> Dear QIRG, Dear Wojtek
> 
> The document begins to provide a homogeneous and coherent overall
> system vision. After a first reading however, I have some comments :
> 
> With linear optics, it is not possible to detect perfectly the 4 states of Bell.
> There are methods to measure 3 of the 4 Bell states, but the probability of
> success is lower than the two-state method :
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__journals.aps.org_pra_abstract_10.1103_PhysRevA.74.022303&d=DwIFA
> w&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =9Gg_IC02U77prwr71I8LEH33gcZmCwpgAMXlZKJqCjw&s=TUE5Dm9VnfnVd-
> B6bdOAB9w2pARTuswyNfm6oFjr6Mw&e=
> 

[WK] To me, this is getting into too much hardware detail that might not even be visible above the hardware level. If we include this, we would have to include many other hardware level concerns.

> 
> 2/ 5.1.  Challenge - 3.  An entangled pair is only useful if the locations of both
> qubits are known ... A relevant pair identifier, a means of communication
> between the pair owners, and an association between the pair ID and the
> individual qubits is sufficient.
> Axel had opened an interesting debate on  "Naming and addressing in a
> quantum network".  For the ID "node Bruno" had proposed the use of the IP
> address. For the ID node Bruno had proposed the use of the IP address, but
> the debate on the identification of Bell pairs "link layer" remained open to
> take In account node with multi-interface (automated repeater or
> controllable quantum nodes) and the possibility on the same interface to
> swap differently the qubit of the pairs of "bell" generated by the  quantum
> links to which the interface is attached.
> 
> Shouldn't there be a dedicated paragraph presenting this addressing and
> naming problem/challenge in a quantum network ?

[WK] Naming and addressing is a bit of a bottomless pit. However, I also don't think it's a particularly special challenge for quantum networks just something that has to be done and agreed on at some point.

> 
> 3/ 5.5.2.  Rate
> Shouldn't there be a paragraph devoted to the definition of metrics to define
> what the quality of service of quantum communications could be? or should
> it rather be in the document draft-irtf-qirg-quantum-internet-use-cases-
> 02.txt

[WK] The current document already mentions fidelity which is a relevant metric. But yes, more than that will be needed. However, I do not feel there is enough knowledge and practical experience currently to meaningfully define a set of metrics so in my opinion this makes it not suitable for the architecture document.

> De : Qirg <[email-masked]> De la part de Wojciech Kozlowski Envoyé :
> mercredi 30 septembre 2020 02:17 À : [email-masked] Objet : [Qirg] FW: New
> Version Notification for draft-irtf-qirg-principles-05.txt
> 
> Dear QIRG,
> 
> I have just updated the draft-irtf-qirg-principles. Please see:
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-
> 2Dprinciples_&d=DwIFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =9Gg_IC02U77prwr71I8LEH33gcZmCwpgAMXlZKJqCjw&s=3TI7Ctn-ic01-
> R8BUXNslgAH1Q34IkuYJ2KdrFyod7Y&e=
> 
> This version now includes changes from the last round of feedback after the
> last meeting and finally an expanded list of references as well.
> 
> This version is now ready for a final review by the RG while I figure out the
> next steps to finalise its submission for RFC status. So those of you who have
> only been following updates and discussions, now is a good time to give it a
> full read.
> 
> Cheers,
> Wojtek
> 
> To: Wojciech Kozlowski <[email-masked]>; Angela Sara Cacciapuoti
> <[email-masked]>; Stephanie Wehner - EWI
> <[email-masked]>; [email-masked]; Shota Nagayama
> <[email-masked]>; Angela Cacciapuoti
> <[email-masked]>; Rodney Van Meter
> <[email-masked]>; [email-masked]; Marcello Caleffi
> <[email-masked]>; Stephanie Wehner - EWI
> <[email-masked]>; Bruno Rijsman <[email-masked]>
> A new version of I-D, draft-irtf-qirg-principles-05.txt has been successfully
> submitted by Wojciech Kozlowski and posted to the IETF repository.
> 
> URL:            https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_id_draft-2Dirtf-2Dqirg-2Dprinciples-
> 2D05.txt&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=1TPbVK5s-y-
> eVgSHl_oEdUSlPV4nm81lQ1Tqnh3RYrI&e=
> Status:         https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-
> 2Dprinciples_&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=JBdRVdq1fAuro
> DTxsSIZghSv7KGiMlgoKNWVZ4mRuNY&e=
> Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dirtf-2Dqirg-
> 2Dprinciples&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=J2PW8RY87WPo
> 4vkbeevhJb_5nam4It_mzxn-Gr3H__8&e=
> Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dirtf-2Dqirg-2Dprinciples-
> 2D05&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=hZl4H3JtLn_v8U
> PjscXX5sX80hgmdIhAWR1lpTlfkTY&e=
> Diff:           https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dirtf-2Dqirg-2Dprinciples-
> 2D05&d=DwICaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =SSULa8dwWw4MHiAdGgPAIlUWnktaFomiUUtns5HZ3xE&s=xekmxO_qFy8N
> ROhnLGYytLX7zJgxCEmq4loqYhs2idc&e=
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.irtf.org_mailman_listinfo_qirg&d=DwIFAw&c=XYzUhXBD2cD-
> CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =9Gg_IC02U77prwr71I8LEH33gcZmCwpgAMXlZKJqCjw&s=LrCit76fxmkbDqxV
> DiXM9rBZ0VMDO4l3HmuClGZQ7n8&e=