Subject: Re: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

From: Gelard Patrick <[email-masked]>
Date: Wed, 7 Oct 2020 14:17:41 +0000

Dear Chonggang,

Somes feedback

1/ 4.3.  Control vs Data Plane Classification
 The internet draft "Principles for a Quantum Internet" doesn't seem to mention a native quantum control plan (i.e based on quantum communication, E.g quatum ping) : 

Control plane protocols for quantum networks will have  responsibilities similar to their classical counterparts, namely   drawing the network topology, resource management, populating data   plane tables, etc.  They will not manipulate quantum data themselves   and they operate by exchanging classical messages only.  Therefore   there is no separate quantum and classical control plane.  There is   only one network control plane.

Should we not make these two documents consistent?

2/ 6.2.  Requirements 
In coherence with "Quantum internet: A vision for the road ahead" and "Principles for a Quantum Internet" should it not be necessary to define system metrics making it possible to express the quality of service requirements expected by the quantum applications I.e expected entanglement fidelity,  loss tolerance, error tolerance, Bell pair rate, Bell pair traffic profil (i.e bursty profil. For example if we use satellite LEO to generate Bell pair we may be interested in wanting to know what would be the impact on applications of Bell pair transmission breaks during phases of non-visibility of the satellite by ground stations), latence, time synchronization of nodes, ...  ?

Best Regards
Patrick

-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Chonggang Wang
Envoyé : mercredi 30 septembre 2020 16:06
À : [email-masked]
Objet : Re: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Dear QIRG,

Quantum internet use cases have been updated to address the comments received during IETF July meeting. Please refer to https://datatracker.ietf.org/doc/draft-irtf-qirg-quantum-internet-use-cases/.

We would like to get your feedback on this new version and if the use case draft can be considered for next steps.

Best regards,
Chonggang

-----Original Message-----
From: Qirg <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, September 18, 2020 7:46 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Quantum Internet Research Group RG of the IRTF.

        Title           : Applications and Use Cases for the Quantum Internet
        Authors         : Chonggang Wang
                          Akbar Rahman
                          Ruidong Li
                          Melchior Aelmans
Filename        : draft-irtf-qirg-quantum-internet-use-cases-02.txt
Pages           : 23
Date            : 2020-09-18

Abstract:
   The Quantum Internet has the potential to improve application
   functionality by incorporating quantum information technology into
   the infrastructure of the overall Internet.  In this document, we
   provide an overview of some applications expected to be used on the
   Quantum Internet, and then categorize them using various
   classification schemes.  Some general requirements for the Quantum
   Internet are also discussed.  The intent of this document is to
   provide a common understanding and framework of applications and use
   cases for the Quantum Internet.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-qirg-quantum-internet-use-cases/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-qirg-quantum-internet-use-cases-02
https://datatracker.ietf.org/doc/html/draft-irtf-qirg-quantum-internet-use-cases-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-qirg-quantum-internet-use-cases-02

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg
[Banner]

[Banner]<https://www.6gsymposium.com/?utm_source=interdigital&utm_medium=signature&utm_campaign=6gsymposium2020>

Join us at the First Annual 6G Symposium Virtual Event<https://www.6gsymposium.com/?utm_source=interdigital&utm_medium=signature&utm_campaign=6gsymposium2020>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

---

From: Wojciech Kozlowski <[email-masked]>
Date: Thu, 8 Oct 2020 08:33:33 +0000

Hi all,

I started going through the new draft and I have some questions that would help me before I progress further:
* I am struggling to understand the difference between Quantum Subnetwork and Quantum Internet. Is the difference the same as between a classical subnetwork and the classical Internet? The definitions in the text are too vague for me.
* Additionally, some further comments in-line below in response to Patrick's comments.

> From: Qirg <[email-masked]> On Behalf Of Gelard Patrick
> Sent: 07 October 2020 16:18
> To: Chonggang Wang <[email-masked]>; [email-masked]
> Subject: Re: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-
> 02.txt
> 
> Dear Chonggang,
> 
> Somes feedback
> 
> 1/ 4.3.  Control vs Data Plane Classification  The internet draft "Principles for a
> Quantum Internet" doesn't seem to mention a native quantum control plan
> (i.e based on quantum communication, E.g quatum ping) :
> 
> Control plane protocols for quantum networks will have  responsibilities
> similar to their classical counterparts, namely   drawing the network topology,
> resource management, populating data   plane tables, etc.  They will not
> manipulate quantum data themselves   and they operate by exchanging
> classical messages only.  Therefore   there is no separate quantum and
> classical control plane.  There is   only one network control plane.
> 

[WK] Patrick is right. It would be beneficial to get these two documents consistent and he is also right that with the latest changes I made I seem to exclude a quantum ping from the control plane. This is worth picking up on. As a start, a question to everybody: is the definition in the principles draft too strict then?

> 2/ 6.2.  Requirements
> In coherence with "Quantum internet: A vision for the road ahead" and
> "Principles for a Quantum Internet" should it not be necessary to define
> system metrics making it possible to express the quality of service
> requirements expected by the quantum applications I.e expected
> entanglement fidelity,  loss tolerance, error tolerance, Bell pair rate, Bell pair
> traffic profil (i.e bursty profil. For example if we use satellite LEO to generate
> Bell pair we may be interested in wanting to know what would be the impact
> on applications of Bell pair transmission breaks during phases of non-visibility
> of the satellite by ground stations), latence, time synchronization of nodes,
> ...  ?
> 

[WK] I think these numbers would be great, but really hard to come up with without a more detailed analysis. However, identifying which stage an application requires is already quite informative in terms of requirements. For example, identifying whether we only need a "quantum memory" stage network vs "fault-tolerant" already tells us a lot.

> De : Qirg <[email-masked]> De la part de Chonggang Wang Envoyé :
> mercredi 30 septembre 2020 16:06 À : [email-masked] Objet : Re: [Qirg] I-D
> Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt
> 
> Dear QIRG,
> 
> Quantum internet use cases have been updated to address the comments
> received during IETF July meeting. Please refer to
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-2Dquantum-2Dinternet-
> 2Duse-2Dcases_&d=DwIFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=ScCiYNV0YHMuwv
> Q9EO9Pg2DpMUILknHf77NGTuuu24Q&e= .
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-2Dquantum-2Dinternet-
> 2Duse-2Dcases_&d=DwIFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=ScCiYNV0YHMuwv
> Q9EO9Pg2DpMUILknHf77NGTuuu24Q&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dirtf-2Dqirg-2Dquantum-2Dinternet-2Duse-
> 2Dcases-2D02&d=DwIFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=KSHcjW7jCfeh3ws
> S75EyRdWTPdm6wox1tKWCh0i_EoU&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dirtf-2Dqirg-2Dquantum-
> 2Dinternet-2Duse-2Dcases-2D02&d=DwIFAw&c=XYzUhXBD2cD-
> CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=PqYaD-
> P1uYemX5KMDp67_mL8sz6KYBE_pwkE869Nhgs&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dirtf-2Dqirg-2Dquantum-
> 2Dinternet-2Duse-2Dcases-2D02&d=DwIFAw&c=XYzUhXBD2cD-
> CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=V3FasdcOnxQiM6s
> yp-OClMyL9y9IsvAr0m4m2DTaY2g&e=
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-
> 2Ddrafts_&d=DwIFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=Hwq4UCag4XW_1
> UFXZM-cw47xdeFD55h3U9TQqMHx4Yg&e=
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.irtf.org_mailman_listinfo_qirg&d=DwIFAw&c=XYzUhXBD2cD-
> CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=4T2oNNxQRVdPId
> CTJVle2wo1tQ3JooBoUm9HX3Yl1nA&e=
> [Banner]
> 
> [Banner]<https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.6gsymposium.com_-3Futm-5Fsource-3Dinterdigital-26utm-
> 5Fmedium-3Dsignature-26utm-5Fcampaign-
> 3D6gsymposium2020&d=DwIFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=NxCbRqWTfZnM2
> MBvewu6-h-h_BGyflCmCjOze2xJrYs&e= >
> 
> Join us at the First Annual 6G Symposium Virtual
> Event<https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.6gsymposium.com_-3Futm-5Fsource-3Dinterdigital-26utm-
> 5Fmedium-3Dsignature-26utm-5Fcampaign-
> 3D6gsymposium2020&d=DwIFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=NxCbRqWTfZnM2
> MBvewu6-h-h_BGyflCmCjOze2xJrYs&e= > This e-mail is intended only for
> the use of the individual or entity to which it is addressed, and may contain
> information that is privileged, confidential and/or otherwise protected from
> disclosure to anyone other than its intended recipient. Unintended
> transmission shall not constitute waiver of any privilege or confidentiality
> obligation. If you received this communication in error, please do not review,
> copy or distribute it, notify me immediately by email, and delete the original
> message and any attachments. Unless expressly stated in this e-mail, nothing
> in this message or any attachment should be construed as a digital or
> electronic signature.
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.irtf.org_mailman_listinfo_qirg&d=DwIFAw&c=XYzUhXBD2cD-
> CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=4T2oNNxQRVdPId
> CTJVle2wo1tQ3JooBoUm9HX3Yl1nA&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.irtf.org_mailman_listinfo_qirg&d=DwIFAw&c=XYzUhXBD2cD-
> CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =vRyl9_Ww9DdYXXeBUp6F4AhPhy7qC0fH2FLcbGIntTI&s=4T2oNNxQRVdPId
> CTJVle2wo1tQ3JooBoUm9HX3Yl1nA&e=

---

From: Gelard Patrick <[email-masked]>
Date: Fri, 9 Oct 2020 08:40:37 +0000

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----
De : Wojciech Kozlowski <[email-masked]> 
Envoyé : jeudi 8 octobre 2020 10:34
À : Gelard Patrick <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked]
Objet : RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hi all,

> Subject: Re: [Qirg] I-D Action: 
> draft-irtf-qirg-quantum-internet-use-cases-
> 02.txt
> 
> Dear Chonggang,
> 
> Somes feedback
> 
> 1/ 4.3.  Control vs Data Plane Classification  The internet draft 
> "Principles for a Quantum Internet" doesn't seem to mention a native 
> quantum control plan (i.e based on quantum communication, E.g quatum ping) :
> 

[WK] Patrick is right. It would be beneficial to get these two documents consistent and he is also right that with the latest changes I made I seem to exclude a quantum ping from the control plane. This is worth picking up on. As a start, a question to everybody: is the definition in the principles draft too strict then?
[PG] This probably requires more work to identify more precisely what could be native quantum network control services.

> "Principles for a Quantum Internet" should it not be necessary to 
> define system metrics making it possible to express the quality of 
> service requirements expected by the quantum applications I.e expected 
> entanglement fidelity,  loss tolerance, error tolerance, Bell pair 
> rate, Bell pair traffic profil (i.e bursty profil. For example if we 
> use satellite LEO to generate Bell pair we may be interested in 
> wanting to know what would be the impact on applications of Bell pair 
> transmission breaks during phases of non-visibility of the satellite 
> by ground stations), latence, time synchronization of nodes, ...  ?
> 

[WK] I think these numbers would be great, but really hard to come up with without a more detailed analysis. However, identifying which stage an application requires is already quite informative in terms of requirements. For example, identifying whether we only need a "quantum memory" stage network vs "fault-tolerant" already tells us a lot.
[PG] The objective is to start identifying the relevant metrics for the QoS expected by the applications of a quantum network. 
Then targeting orders of magnitude of these metrics for given classes of applications will require extensive statistical testing, off course.  For classical communications it is aimed intervals, bounds, but not precise values. 
http://wiki.martin.lncc.br/ziviani-cursos-ga-redes-2010-2/file/internet2apps-qo-s-needs.pdf
https://www.jaist.ac.jp/~razvan/publications/qos_measurement.pdf
...
Concerning the QBER metric it seems to me that for the QKD service we are beginning to have orders of magnitude.  
In the document "Principles for a Quantum Internet" it is mentioned "Interestingly, quantum applications do not need perfect fidelity to   be able to execute -- as long as the fidelity is above some   application-specific threshold, they will simply operate at lower   rates.  Therefore, rather than trying to ensure that we always   deliver perfect states (a technologically challenging task)   applications will specify a minimum threshold for the fidelity and   the network will try its best to deliver it."  It would be nice to have orders of magnitude of the threshold for different class of application.   

Now it may indeed be a whole document to be done on the QoS metrics of a quantum network.

> We would like to get your feedback on this new version and if the use 
> case draft can be considered for next steps.
> 
> Best regards,
> Chonggang
> 
> Subject: [Qirg] I-D Action: 
> draft-irtf-qirg-quantum-internet-use-cases-02.txt
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> the use of the individual or entity to which it is addressed, and may 
> contain information that is privileged, confidential and/or otherwise 
> protected from disclosure to anyone other than its intended recipient. 
> Unintended transmission shall not constitute waiver of any privilege 
> or confidentiality obligation. If you received this communication in 
> error, please do not review, copy or distribute it, notify me 
> immediately by email, and delete the original message and any 
> attachments. Unless expressly stated in this e-mail, nothing in this 
> message or any attachment should be construed as a digital or electronic signature.
>

---

From: Gelard Patrick <[email-masked]>
Date: Fri, 9 Oct 2020 12:41:23 +0000

Hi all

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----

Hi all,

[PG] I had asked to distinguish between the notions of quantum networks and quantum internet resulting from the analogy with the classical internet (INTER-NETwork).
This distinction should be in accordance with the paragraph "5.4.  Network boundaries" from  the draft Principles for a Quantum Internet". 

For the Classical Internet. In today's Internet, two forms of interconnection model exists between networks: peering and transit. 
The peering is a process where two Internet networks connect and exchange traffic. There are two main types of peering:  Public peering is typically done through an Internet Exchange Point (IXP : https://en.wikipedia.org/wiki/Internet_exchange_point ) and private peering which is when two or more networks agree to exchange their traffic in a private establishment.
Peering cannot be enough for everything, because two operators can simply be too far apart for that [.] We then call on operators who have a larger presence on the planet, the "forwarders". The various forwarders connect to each other through peering agreements and the loop is closed.
When we talk about these subjects from a technical point of view, we sometimes talk about Tier 1, 2 and 3 actors. The largest are the so-called Tier 1 operators ( https://en.wikipedia.org/wiki/Tier_1_network ) . They have developed a long distance network and have direct interconnections with other major operators worldwide. They do not use any transit service to access all of the networks that make up the Internet. 
Example in France https://www.arcep.fr/fileadmin/reprise/observatoire/ipv6/Barometer_of_Data_interconnection_in_France_2020.pdf 

The quantum internet will also be a network of networks where the concept of network interconnection (interconnection of quantum autonomous system) will surely also play an important role. From a technical point of view, different quantum interconnection modes should also emerge from the schemes identified in the paragraph "4.4.1.  Elementary link generation", in order to propagate the entanglement between distinct quantum networks.

---

From: Chonggang Wang <[email-masked]>
Date: Tue, 13 Oct 2020 13:51:53 +0000

Hello Patrick,

Thank you for your explanation (and of course previous inputs) on quantum network vs quantum internet.

I include additional feedback below with [CW].

Thanks,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Friday, October 9, 2020 8:41 AM
To: Wojciech Kozlowski <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hi all

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----
De : Wojciech Kozlowski <[email-masked]> Envoyé : jeudi 8 octobre 2020 10:34 À : Gelard Patrick <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked] Objet : RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hi all,

[CW]: Peering is connecting between Internet Autonomous Systems.  However, an Autonomous System itself may be made of many subnets.  So I don't think an autonomous system and subnet are identical. But I tend to agree "Quantum Subnetwork vs Quantum Internet" is similar to "subnetwork vs Internet" that we have today. It's envisioned that in the future Quantum Internet as a global infrastructure will consist of various "smaller networks" (e.g., for an organization, located in a region, etc.), which is referred to "Quantum Subnetwork".  We will rephases both definitions and make them more clear. We can update the draft to clarify these concepts as they will be required to integrate to the rest of the Internet.

[Banner]

---

From: Chonggang Wang <[email-masked]>
Date: Tue, 13 Oct 2020 13:58:32 +0000

Hello Patrick, Wojtek,

Thank you very much for your feedback and comments on the use case document.

I provide you below with some responses beginning with [CW].

Best regards,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Friday, October 9, 2020 4:41 AM
To: Wojciech Kozlowski <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----

Hi all,

[WK] Patrick is right. It would be beneficial to get these two documents consistent and he is also right that with the latest changes I made I seem to exclude a quantum ping from the control plane. This is worth picking up on. As a start, a question to everybody: is the definition in the principles draft too strict then?
[PG] This probably requires more work to identify more precisely what could be native quantum network control services.
[CW] Fully agree to have both documents consistent. Will update "Use Case" document based on the feedback from QIRG and news changes to "Principles for a Quantum Internet".

[CW] I have the same feeling as Wojtek. Figure 5 "Example Use Cases in Different Quantum Internet Stages" presents "each stage vs application requires".

Now it may indeed be a whole document to be done on the QoS metrics of a quantum network.
[CW] Yes, better to have a separate document covering QoS aspects of a quantum network.

[Banner]

---

From: Gelard Patrick <[email-masked]>
Date: Wed, 14 Oct 2020 07:38:47 +0000

[PG2]

Best regards
Patrick

-----Message d'origine-----
De : Chonggang Wang <[email-masked]> 
Envoyé : mardi 13 octobre 2020 15:52
À : Gelard Patrick <[email-masked]>; Wojciech Kozlowski <[email-masked]>; [email-masked]
Objet : RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hello Patrick,

Thanks,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Friday, October 9, 2020 8:41 AM
To: Wojciech Kozlowski <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hi all

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----

Hi all,

[CW]: Peering is connecting between Internet Autonomous Systems.  However, an Autonomous System itself may be made of many subnets.  So I don't think an autonomous system and subnet are identical. But I tend to agree "Quantum Subnetwork vs Quantum Internet" is similar to "subnetwork vs Internet" that we have today. It's envisioned that in the future Quantum Internet as a global infrastructure will consist of various "smaller networks" (e.g., for an organization, located in a region, etc.), which is referred to "Quantum Subnetwork".  We will rephases both definitions and make them more clear. We can update the draft to clarify these concepts as they will be required to integrate to the rest of the Internet.
[PG2] Why do you use the term subnetwork instead of Network ? When we talk about the Internet, we often refer to the notion of  network of networks that consists of private, public, academic, business, and government networks of local to global scope, linked by a broad array of electronic, wireless, and optical networking technologies. The concept of autonomous networks enables reflected the fact that the Internet has no single centralized governance in either technological implementation or policies for access and usage; each constituent network sets its own policies.
The fundamental element on which the notion of the internet is based is the concept of "network interconnection" (example of quantum interconnection of different physical platforms : https://phys.org/news/2020-06-quantum-internet.html).

[Banner]

---

From: Chonggang Wang <[email-masked]>
Date: Tue, 20 Oct 2020 00:47:25 +0000

Hello Patrick,

Thanks for your further feedback. On your key question:

> (snip) . Why do you use the term subnetwork instead of Network ? When we talk about the Internet, we often refer to the notion of  network of networks . (snip)

That is correct but subnetworks have also been defined since the beginning of the Internet as a refinement of the idea of "network of networks" specifically for IP routing flexibility.  Specifically there is a good RFC to understand the concept: 

--- from RFC917 (https://tools.ietf.org/html/rfc917) ---
INTERNET SUBNETS
We discuss the utility of "subnets" of Internet networks, which are logically visible sub-sections of a single Internet network.  For administrative or technical reasons, many organizations have chosen
to divide one Internet network into several subnets, instead of acquiring a set of Internet network numbers.
-------------------------------------------------------------------------

And then of course we can find some nice descriptions such as https://en.wikipedia.org/wiki/Subnetwork for further reading.

So the key question to you and the QIRG community is whether Quantum Networks will also support this concept of subnetworks or not?  Looking forward to your response.

Best regards,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]> 
Sent: Wednesday, October 14, 2020 3:39 AM
To: Chonggang Wang <[email-masked]>; Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

[PG2]

Best regards
Patrick

-----Message d'origine-----
De : Chonggang Wang <[email-masked]> Envoyé : mardi 13 octobre 2020 15:52 À : Gelard Patrick <[email-masked]>; Wojciech Kozlowski <[email-masked]>; [email-masked] Objet : RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hello Patrick,

Thanks,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Friday, October 9, 2020 8:41 AM
To: Wojciech Kozlowski <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hi all

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----

Hi all,

[Banner]

[Banner]<https://secure-web.cisco.com/1DsWCKd3p17MxkNA6J3C9EmWrsEAsze37C4rLaqa1AHg-qJN8P1Wr1LdhC1OlXzLYd927zB9e9VkXX9mRW1lnBXleAIWnuNozD7Vx2-2ru0AVHsjHKg6DmXO3GTStrNfiNYizoAYoyZOdM75Y_Jzsf0fyV5TLZwEHEVxqqKfqhdb0Tyipypx18ynC8-EwQpSRrcVKIurYN4Keif4EDsr6Xj3uxqQBFJsZEAHY0qd5RppqiMTIz3lZu0MQK6JOsRq_ZK6ALswuKXy22NCyWGI0g0O54756DlXV5iFPD2r2eK2Ed8KB24umCm6so_j2IT5boL6_kw0BwDN7g86NJoPo-bI5vZsSpNw0WK5jqfRpZtQPdHzCItkMzGh2D2Q-jBCD9Gsezci-SHXzLe3z8B4ysg1tmWatkyA_3kuDlHP5YtNdKs0RdiREET_In_tjwtRC38FqaxLYNrt87cyQR130yw/https%3A%2F%2Fwww.6gsymposium.com%2F%3Futm_source%3Dinterdigital%26utm_medium%3Dsignature%26utm_campaign%3D6gsymposium2020>

Join us at the First Annual 6G Symposium Virtual Event<https://secure-web.cisco.com/1DsWCKd3p17MxkNA6J3C9EmWrsEAsze37C4rLaqa1AHg-qJN8P1Wr1LdhC1OlXzLYd927zB9e9VkXX9mRW1lnBXleAIWnuNozD7Vx2-2ru0AVHsjHKg6DmXO3GTStrNfiNYizoAYoyZOdM75Y_Jzsf0fyV5TLZwEHEVxqqKfqhdb0Tyipypx18ynC8-EwQpSRrcVKIurYN4Keif4EDsr6Xj3uxqQBFJsZEAHY0qd5RppqiMTIz3lZu0MQK6JOsRq_ZK6ALswuKXy22NCyWGI0g0O54756DlXV5iFPD2r2eK2Ed8KB24umCm6so_j2IT5boL6_kw0BwDN7g86NJoPo-bI5vZsSpNw0WK5jqfRpZtQPdHzCItkMzGh2D2Q-jBCD9Gsezci-SHXzLe3z8B4ysg1tmWatkyA_3kuDlHP5YtNdKs0RdiREET_In_tjwtRC38FqaxLYNrt87cyQR130yw/https%3A%2F%2Fwww.6gsymposium.com%2F%3Futm_source%3Dinterdigital%26utm_medium%3Dsignature%26utm_campaign%3D6gsymposium2020>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Gelard Patrick <[email-masked]>
Date: Tue, 20 Oct 2020 06:12:19 +0000

Hi Chonggang,

>> So the key question to you and the QIRG community is whether Quantum Networks will also support this concept of subnetworks or not?  Looking forward to your response.
Yes it is the question. Subnetworks is an IP concept, which allows to segment the network by the notion of address https://en.wikipedia.org/wiki/Subnetwork#/media/File:Subnetting_Concept-en.svg 
Encapsulation does not apply to quantum network's "data plane" ! On the other hand, encapsulation applies to the control plan, not natively quantum.

Best regards,
Patrick

-----Message d'origine-----
De : Chonggang Wang <[email-masked]> 
Envoyé : mardi 20 octobre 2020 02:47
À : Gelard Patrick <[email-masked]>; Wojciech Kozlowski <[email-masked]>; [email-masked]
Objet : RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hello Patrick,

Thanks for your further feedback. On your key question:

> (snip) . Why do you use the term subnetwork instead of Network ? When 
> we talk about the Internet, we often refer to the notion of  network 
> of networks . (snip)

--- from RFC917 (https://tools.ietf.org/html/rfc917) --- INTERNET SUBNETS We discuss the utility of "subnets" of Internet networks, which are logically visible sub-sections of a single Internet network.  For administrative or technical reasons, many organizations have chosen to divide one Internet network into several subnets, instead of acquiring a set of Internet network numbers.
-------------------------------------------------------------------------

Best regards,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Wednesday, October 14, 2020 3:39 AM
To: Chonggang Wang <[email-masked]>; Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

[PG2]

Best regards
Patrick

-----Message d'origine-----

Hello Patrick,

Thanks,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Friday, October 9, 2020 8:41 AM
To: Wojciech Kozlowski <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hi all

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----

Hi all,

[Banner]

---

From: Chonggang Wang <[email-masked]>
Date: Fri, 30 Oct 2020 17:34:49 +0000

Dear Patrick, Wojtek, 

I have not received any further comments from QIRG since our last email discussion. 

I was starting to capture and reflect what we have discussed in email; as a result of that, v03 of the use case document was just uploaded. 
https://datatracker.ietf.org/doc/draft-irtf-qirg-quantum-internet-use-cases/

In v03, I replaced "quantum subnetworks" with "quantum network" to avoid potential confusions, since "quantum network" can be applied to both quantum internet control plane & data plane as being discussed, although subnetwork was indeed adopted in some IETF RFCs.  

Thank you again for your review and feedback for improving the document. 

Chonggang  

-----Original Message-----
From: Gelard Patrick <[email-masked]> 
Sent: Wednesday, October 14, 2020 3:39 AM
To: Chonggang Wang <[email-masked]>; Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

[PG2]

Best regards
Patrick

-----Message d'origine-----

Hello Patrick,

Thanks,
Chonggang

-----Original Message-----
From: Gelard Patrick <[email-masked]>
Sent: Friday, October 9, 2020 8:41 AM
To: Wojciech Kozlowski <[email-masked]>; Chonggang Wang <[email-masked]>; [email-masked]
Subject: RE: [Qirg] I-D Action: draft-irtf-qirg-quantum-internet-use-cases-02.txt

Hi all

Answer in the text [PG]

Best regards
Patrick

-----Message d'origine-----

Hi all,

[Banner]