Subject: Re: [Qirg] Review QIRG draft - Quantum Internet use cases

From: Chonggang Wang <[email-masked]>
Date: Fri, 22 Jan 2021 18:59:29 +0000

Dear Álvaro,

Thank you very much for your detailed reviewing and comments on quantum internet use case documents. They are very helpful. Based on your feedback, we have made substantial updates and generated/uploaded a new version 04 of the document (https://datatracker.ietf.org/doc/draft-irtf-qirg-quantum-internet-use-cases/).

Some of your comments are about editorial changes, which we have incorporated in the new version. For other comments on technology clarifications, I copied them below and added our one-to-one responses [CW]. Please kindly let us know if your comments have been addressed and/or if you have any additional feedback to improve the document furthermore.

~~~~~~~~~~~ Comments from Álvaro ~~~~~~~~~~
Comment #1 (on LOCC term on pp.3)
Step 2 says that "the result is sent to another quantum node", but this is not necessarily true: quantum nodes can exchange any classical information, not only measurement results.
(for an example, see https://en.wikipedia.org/wiki/LOCC#State_preparation)
Also, the way LOCC is explained does not seem too accurate to me. I would explain it more like "A method where nodes communicate in rounds, in which (i) they can send any classical information to each other, (ii) they can perform local quantum operations individually, and (iii) the actions performed in each round can depend on the results from previous rounds."
[CW]: Adopted the suggested texts.

Comment #2 (on pp.4)
I am not sure if QKD has been defined before. Maybe include it in the Terms & Acronyms list?
[CW]: Added the following QKD definition to Section 3.
“Quantum Key Distribution (QKD) - A method that leverages quantum mechanics such as non-cloning theorem to securely distribute security keys from a sender to a receiver.”

Comment #3 (on Fast Byzantine Negotiation on pp.5)
I don't know much about blockchain, but I think if you mention this, you should give a good reference that explains how quantum Byzantine agreement is related to blockchain (I am afraid I don't know any)
[CW]: Rephased the description by replacing blockchain with consensus protocols to avoid any confusion about blockchain, which is not the focus of this document.
“Fast Byzantine negotiation - Refers to a Quantum-based method for fast agreement in Byzantine negotiations [Fitzi], for example, to reduce the number of expected communication rounds and in turn achieve faster agreement, in contrast to classical Byzantine negotiations. This can be used for improving consensus protocols such as practical Byzantine Fault Tolerance(pBFT), as well as other distributed computing features which use Byzantine negotiations.”

Comment #4 (on Radio Frequency Sensing on pp.5)
Maybe I misunderstood the abstract of these two papers, but I think this is not what they discuss in them. In Zhuang they present a quantum-assisted supervised learning tool, while in Fan they designed a physical transducer to convert microwaves to optical photons.
Maybe I am missing something here, but I don't see the relation between this statement and the references.
[CW]: Replaced “Radio frequency measurement” with “High sensitivity sensing” with a new reference.
“High sensitivity sensing - Refers to applications that leverage quantum phenomena to achieve reliable nanoscale sensing of physical magnitudes. For example, [Guo2020] uses an entangled quantum network for measuring the average phase shift among multiple distributed nodes, to achieve high-sensitivity and distributed quantum sensing.”

Comment #5 (on Control/Data Plane Classification on pp.6)
It is not very clear to me if you mean classical secret sharing (the secret is a bit string) or quantum secret sharing (the secret is a quantum state).
If you mean classical secret sharing, I am not sure if it is worth mentioning this: if you can do it with classical communications, why bother using qubits?
If you mean quantum secret sharing, this is not usually related to superdense coding, so I would not mix those two concepts. More info about quantum secret sharing in these papers:
10.1103/PhysRevA.59.1829
10.1103/PhysRevLett.83.648
10.1145/509907.510000
If I was unclear here, we can discuss more about it :)
[CW]: It meant classical secret sharing. And using superdense coding is alternative and more secure way compared to the way with classical communications. In order to avoid potential confusion, the following sentences are just removed from the document.
[Quantum superdense encoding can be leveraged to implement a secret sharing application to share secrets between two parties.  This secret sharing application based on quantum superdense encoding can be classified as control plane functionality.]

Comment #6 (on QKD on pp.9)
Actually, the bits that are correct are not directly used as secret key. They usually employ part of them to check if there were any errors (these could happen if someone tampered with the qubits).
Also, as a final step, they usually perform information reconciliation and privacy amplification. Maybe it is worth mentioning that.
[CW]: Revised the last step as the following
“Both nodes discard any measurement bit under different quantum basis and remaining bits could be used as the secret key. Both nodes usually employ a part of the remaining bits to check if there were any errors and another part of the remaining bits will be taken as the secret key. Both nodes usually also perform information reconciliation and privacy amplification.”

Comment #7 (on Secure Quantum Computing on pp.11)
Before concluding Section 5.2, I would at least mention some protocols for private quantum computing or any other work done in the same direction, in the same way that you explained BB84 can be used for secure communications in Section 5.1.
Otherwise, the goal of the application is clear but I miss a brief explanation on how to achieve it (or at least some references).
[CW]: Added 4 new references and descriptions on: circuit-based Blind Quantum Computation (BQC), measurement-based BQC, hybrid BQC, and BQC with multiple servers. Please refer to the rewritten 5.2.

Comment #8 (on LOCC on pp.14)
Entanglement is generated at one of the nodes: this node generates two entangled particles and sends one of them to the other. I would mention that this step requires quantum communication between both nodes.
[CW]: Revised as suggested.
“A shared entanglement is established between the quantum computer A and the quantum computer B (i.e., there are two entangled qubits: |q1> at A and |q2> at B). For example, the quantum computer A can generate two entangled qubits (i.e., |q1> and |q2>) and sends |q2> to the quantum computer B via quantum communications.”

Comment #9 (on Distributed QC on pp.15)
I think quantum teleportation is excessively emphasized here, as it is a very basic routine. I would also mention more complex protocols, such as the verifiable secret sharing schemes (see, e.g., 10.1145/509907.510000 and 10.1103/PhysRevA.101.032332)
[CW]: Added both references and the following new sentences to 5.3.
“According to [Cuomo], quantum teleportation enables a new communication paradigm, referred to as teledata [VanMeter01], which moves quantum states among qubits to distributed quantum computers.  In addition, distributed quantum computation also needs the capability of remotely performing quantum computation on qubits on distributed quantum computers, which can be enabled by the technique called telegate [VanMeter02].”
……
“Another example of distributed quantum computing is secure Multi-Party Quantum Computation (MPQC) [Crepeau], which can be regarded as a quantum version of classical secure Multi-Party Computing (MPC). In secure MPQC, multiple participants jointly perform quantum computation on a set of input quantum states, which are prepared and provided by different participants.  One of primary aims of secure MPQC is to guarantee that each participant will not know input quantum states provided by other participants.  Secure MPQC relies on verifiable quantum secret sharing [Lipinska].”

Best regards,
Chonggang

From: Qirg <[email-masked]<mailto:[email-masked]>> On Behalf Of Álvaro Gómez Iñesta
Sent: Sunday, November 22, 2020 1:18 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Qirg] Review QIRG draft - Quantum Internet use cases

Dear C. Wang, A. Rahman, et al.

I am Álvaro, a PhD student in Wehner’s Group at QuTech (TU Delft). I was asked by Wojciech Kozlowski to review this QIRG draft: https://www.ietf.org/archive/id/draft-irtf-qirg-quantum-internet-use-cases-03.txt.

My comments focus on the quantum aspects of the document. Please find them attached and feel free to reach me for deeper discussions. I hope you find them useful!

Best,
Álvaro Gómez Iñesta

[Banner]

[Banner]<https://www.interdigital.com/features/sustainability-in-a-wireless-world>

Sustainability in a Wireless World: Research dedicated to understanding the impact of our technologies on the planet.<https://www.interdigital.com/features/sustainability-in-a-wireless-world>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Álvaro Gómez Iñesta <[email-masked]>
Date: Mon, 25 Jan 2021 13:58:32 +0000

Dear Chonggang,

Thanks for your email. The document looks good to me, I am happy with the updates and have no additional feedback.

Best,
Álvaro Gómez Iñesta

El 22 ene 2021, a las 19:59, Chonggang Wang <[email-masked]<mailto:[email-masked]>> escribió:

Dear Álvaro,

Thank you very much for your detailed reviewing and comments on quantum internet use case documents. They are very helpful. Based on your feedback, we have made substantial updates and generated/uploaded a new version 04 of the document (https://datatracker.ietf.org/doc/draft-irtf-qirg-quantum-internet-use-cases/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases_&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=GNLqDs4NH2drD5VC5VSVgQDl_7lhoYmXb6S0E-T8B74&m=5_LatihAsmN8qFzmEP4KaTyiGW5JcYHvV8alyeNR5S0&s=-i9XZzzdlXW49yqUUe6oQO2QZB8F1Av6UZotf31kyJ0&e=>).

(for an example, see https://en.wikipedia.org/wiki/LOCC#State_preparation<https://urldefense.proofpoint.com/v2/url?u=https-3A__en.wikipedia.org_wiki_LOCC-23State-5Fpreparation&d=DwQGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=GNLqDs4NH2drD5VC5VSVgQDl_7lhoYmXb6S0E-T8B74&m=5_LatihAsmN8qFzmEP4KaTyiGW5JcYHvV8alyeNR5S0&s=h4JoS4ObZI_y-UlOk02TDSG6a95qsak3CdzsbadCEIU&e=>)

Comment #2 (on pp.4)

Best regards,
Chonggang

I am Álvaro, a PhD student in Wehner’s Group at QuTech (TU Delft). I was asked by Wojciech Kozlowski to review this QIRG draft: https://www.ietf.org/archive/id/draft-irtf-qirg-quantum-internet-use-cases-03.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_archive_id_draft-2Dirtf-2Dqirg-2Dquantum-2Dinternet-2Duse-2Dcases-2D03.txt&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=GNLqDs4NH2drD5VC5VSVgQDl_7lhoYmXb6S0E-T8B74&m=5_LatihAsmN8qFzmEP4KaTyiGW5JcYHvV8alyeNR5S0&s=ab_aMUg26rxLW9C6yL8zs5bFUUv1rDzoFlutXMTInIM&e=>.

Best,
Álvaro Gómez Iñesta

[Banner]

[Banner]<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.interdigital.com_features_sustainability-2Din-2Da-2Dwireless-2Dworld&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=GNLqDs4NH2drD5VC5VSVgQDl_7lhoYmXb6S0E-T8B74&m=5_LatihAsmN8qFzmEP4KaTyiGW5JcYHvV8alyeNR5S0&s=n_bWRSmLbiqlQRiNLYgZYXOpnq56QKjhkw18_g92_EI&e=>

Sustainability in a Wireless World: Research dedicated to understanding the impact of our technologies on the planet.<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.interdigital.com_features_sustainability-2Din-2Da-2Dwireless-2Dworld&d=DwMGaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=GNLqDs4NH2drD5VC5VSVgQDl_7lhoYmXb6S0E-T8B74&m=5_LatihAsmN8qFzmEP4KaTyiGW5JcYHvV8alyeNR5S0&s=n_bWRSmLbiqlQRiNLYgZYXOpnq56QKjhkw18_g92_EI&e=>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.