Subject: [Qirg] Review of draft-irtf-qirg-principles-06

From: John Mattsson <[email-masked]>
Date: Thu, 11 Mar 2021 10:08:45 +0000

Hi,

I think this document is very well-written. It is also a very useful document. I have some comments below but otherwise I think this document is ready for WGLC and publication.

Cheers,
John

- Abstract:
"The first realisations of quantum networks are imminent"

My understanding is that several quantum networks have been built in the past.
One by DARPA in Massachusetts 2001 and one in Vienna 2003 to name a few...
https://en.wikipedia.org/wiki/Quantum_network
I think the sentence needs to be reformulated.

- Section 1:
OLD "such as secure communications"
NEW "such as quantum cryptography"

Talking about "communication" is quite limiting. It like saying that
classic crypto is all about communication. There are a lot of
exciting quantum cryptography research that may turn out to be
practically useful in the future.
https://en.wikipedia.org/wiki/Quantum_cryptography

- Section 2.1:

"a |0> + b |1>"

Would maybe be good to mention that a and b are complex

- Section 4.1.2. No-cloning theorem

I think the document need to explain that it is still possible to produce imperfect copies.
Might also be good to mention some other theorems like the no-communication theorem, no-teleportation theorem, no-deletion theorem... Especially no-communication theorem, no-teleportation theorem would be good to mention with a few sentences each.

- Section 4.4.1

"since photons cannot be stored"

Maybe change to "photons are hard to store". A easy way to "store" a photon for a short period of time is to send it through a local optical fibre loop.

- Section 4.4.2

"10s of kms in optical fibre or 1000 kms in free space"

Reformulate to use "kilometers" or "km". Using plural in the unit seems very non-SI compliant.

- Section 5.3.2

"Quantum routers" vs. "Quantum repeater"

This section defines "Quantum router" as a special kind of quantum repeater. Quantum Repeater is not defined in this section but used much more than quantum router in the document. Seems like the term "quantum repeater" should be defined.

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 29 Mar 2021 19:30:49 +0000

Hi John,

Thanks for your feedback! Apologies for the delay - I was waiting to see if more feedback arrives after the last call so that I could address all of them in one go.

Github diff: https://github.com/Wojtek242/draft-irtf-qirg-principles/commit/96067861320826ce8a75bf38bab4cd360b364f3c

Replies in-line below. I left out two of your suggestions. However, if others agree with those two points, let me know, and I'll incorporate them.

Wojtek

> -----Original Message-----
> From: Qirg <[email-masked]> On Behalf Of John Mattsson
> Sent: 11 March 2021 11:09
> To: [email-masked]
> Subject: [Qirg] Review of draft-irtf-qirg-principles-06
> 
> Hi,
> 
> I think this document is very well-written. It is also a very useful document. I
> have some comments below but otherwise I think this document is ready for
> WGLC and publication.
> 
> Cheers,
> John
> 
> 
> 
> - Abstract:
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__en.wikipedia.org_wiki_Quantum-
> 5Fnetwork&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =JjIraP3t060tJhFYfYDD_Dq5vZBTobY4U7kxyArRc9s&s=HxacZxiood58Hsl0odcR
> YJreezpnltqpcW--xUUcilQ&e=

 [WK] Rephrased to "quantum entanglement networks" 

> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__en.wikipedia.org_wiki_Quantum-
> 5Fcryptography&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =JjIraP3t060tJhFYfYDD_Dq5vZBTobY4U7kxyArRc9s&s=_OX5epJ9iPFcDUZQu0
> 3bkjxdIvku6D-hIYnZfM4Jrso&e=
> 
> 
> - Section 2.1:
> 
> "a |0> + b |1>"
> 

 [WK] It does already say that

> Might also be good to mention some other theorems like the no-
> communication theorem, no-teleportation theorem, no-deletion theorem...
> Especially no-communication theorem, no-teleportation theorem would be
> good to mention with a few sentences each.
> 

[WK] I'm not so sure. I've been trying to avoid going too deep into the details to keep the document high-level. I could include it if others support this modification though.

> Maybe change to "photons are hard to store". A easy way to "store" a
> photon for a short period of time is to send it through a local optical fibre
> loop.
> 

[WK] Done

> Reformulate to use "kilometers" or "km". Using plural in the unit seems very

[WK] Done

> This section defines "Quantum router" as a special kind of quantum repeater.
> Quantum Repeater is not defined in this section but used much more than
> quantum router in the document. Seems like the term "quantum repeater"
> should be defined.
> 

[WK] Repeaters are defined when discussing entanglement swapping and then used multiple times. I'm not sure a definition here would add much. I can add something if others find this confusing as well.

> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-
> CornpT4QE19xOJBbRy-
> TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m
> =JjIraP3t060tJhFYfYDD_Dq5vZBTobY4U7kxyArRc9s&s=R-
> xrqnlUeincohmBxa2aBM8mNXXmwAQ543X893EdBJA&e=