Subject: [Qirg] (hardware) roadmap discussion

From: Rodney Van Meter <[email-masked]>
Date: Wed, 3 Mar 2021 08:11:58 +0900

A few days ago, I posted a link to this roadmap:
https://journals.aps.org/prxquantum/abstract/10.1103/PRXQuantum.2.017002

Wojtek and I put a discussion of it on the agenda for next week. I’m not intending to present the contents directly, just open the floor to discussion of it and its relationship to QIRG work. If you want to contribute productively to the conversation, it would be helpful to take at least a quick look at it beforehand.

It’s mostly a hardware roadmap, with focus on components. They divide interconnects into two classes: modular interconnects (which I would call system area networks, but others would call something different), and Quantum Internet. Nothing in between. No real discussion of network architecture, protocols and software. Tons of excellent references on technology and on various demonstrations, including free-space links using balloons and drone that I wasn’t aware of.

This NFS QuICS roadmap isn’t the world’s only roadmap, but it’s the most complete and detailed that is public to date.

—Rod

Rodney Van Meter
[email-masked]
Professor, Faculty of Environment and Information Studies, Keio University, Japan

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 8 Mar 2021 17:07:38 +0100

Hi,

Le 03/03/2021 à 00:11, Rodney Van Meter a écrit :
>  Wojtek and I put a discussion of it on the agenda for next week.
> I’m not intending to present the contents directly, just open the
> floor to discussion

It says 'roadmap', but is there a notion of timeline?  By when (what
year) could a user telnet into a quantum computer over the Internet?

> of it and its relationship to QIRG work. If you want to contribute 
> productively to the conversation, it would be helpful to take at 
> least a quick look at it beforehand.

I read the abstract.

It says 'internet' maybe a couple of times.

I wonder whether that is the Internet that links together two quantum
computers over the existing maze of links, or is it a new and different
internet?

That is a question that appears often in local discussions when we say
'quantum internet'.

I might wonder as well whether an existing IP addressing mechanism used
to identify classical computers is also used to identify quantum
computers.  Maybe an existing quantum computer at IBM, at Google or at
CNRS already has an IPv6 address(?)

Alex

> 
> It’s mostly a hardware roadmap, with focus on components. They divide
> interconnects into two classes: modular interconnects (which I would
> call system area networks, but others would call something 
> different), and Quantum Internet. Nothing in between. No real 
> discussion of network architecture, protocols and software. Tons of 
> excellent references on technology and on various demonstrations, 
> including free-space links using balloons and drone that I wasn’t 
> aware of.
> 
> This NFS QuICS roadmap isn’t the world’s only roadmap, but it’s the 
> most complete and detailed that is public to date.
> 
> —Rod
> 
> Rodney Van Meter [email-masked] Professor, Faculty of Environment
> and Information Studies, Keio University, Japan
> 
> _______________________________________________ Qirg mailing list 
> [email-masked] https://www.irtf.org/mailman/listinfo/qirg
>

---

From: Rodney Van Meter <[email-masked]>
Date: Tue, 9 Mar 2021 16:09:29 +0900

Rodney Van Meter
[email-masked]

> On Mar 9, 2021, at 1:07, Alexandre Petrescu <[email-masked]> wrote:
> 
> Hi,
> 
>> A few days ago, I posted a link to this roadmap: https://journals.aps.org/prxquantum/abstract/10.1103/PRXQuantum.2.017002
>> 
>> 
>> 

The appendices have tables listing 3-, 5- and 10-year timelines, but I think those are aspirational.  They are fairly low-level, component-oriented milestones, rather than true system milestones, at least in my reading. I think that’s a valuable point for discussion.

> 
>> of it and its relationship to QIRG work. If you want to contribute productively to the conversation, it would be helpful to take at least a quick look at it beforehand.
> 
> I read the abstract.
> 

Keep in mind that in the minds of many of the authors, “Internet” means “some vague system that connects a lot of stuff”. Many of them can spell TCP/IP, not many can spell AS or have thought about the issues in either scale or autonomous operation of participating networks.  So when they say “Internet”, they probably mean something different than you do.

> computers over the existing maze of links, or is it a new and different

To create quantum entanglement, you have to have quantum channels, for sure. Some experiments have demonstrated wavelength multiplexing of quantum traffic with classical traffic in the same fiber. I was in one recent discussion, however, where someone was grumbling about the cost in dB of doing that. But others, of course, believe we have to run over the current global fiber plant.

> CNRS already has an IPv6 address(?)

Addressing is certainly one of the architecture issues that needs to be, um, addressed.

A quantum computer has a multi-tiered classical control infrastructure, culminating in an outward-facing web interface. It’s already possible to access a number of quantum computers via the classical Internet that way, but that doesn’t get you E2E entanglement and its associated benefits.

Talk to you tomorrow!

—Rod

>> call system area networks, but others would call something different), and Quantum Internet. Nothing in between. No real discussion of network architecture, protocols and software. Tons of excellent references on technology and on various demonstrations, including free-space links using balloons and drone that I wasn’t aware of.
>> _______________________________________________ Qirg mailing list [email-masked] https://www.irtf.org/mailman/listinfo/qirg
> 
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Gelard Patrick <[email-masked]>
Date: Tue, 9 Mar 2021 16:51:10 +0000

Yep, It only evokes the interconnection challenges at the physical quantum data plane (Interconnects between bosonic and atomic systems, Interconnects between two bosonic photonic platform, ..., Atomic-photonic interconnects, Photonic-photonic interconnects). I have not seen the challenges of the control and management related to quantum network interconnection (Link-layer, Network and Transport control layer, fault management, security management, ....), neither synchronization challenges of certain elements of the quantum network (eg of entanglement sources for example https://arxiv.org/abs/0912.5312 : Reaching such a high visibility therefore appears to be a hard task since a perfect synchronization between independent sources is necessary to prevent any kind of distinguishability between the interfering photons).

In the introduction of the document, in the quantum interconnection example, I would also have mentioned detector (e.g Avalanche Photo Diode "APDs" ; superconducting transition-edge sensors "TES" ; Superconducting nanowire single photon detector » "SNSPD"), entanglement distillation devices  and Bell measurement device (challenges to distinguish the four states of Bell in linear optics).

Best regards
Patrick
-----Message d'origine-----
De : Qirg <[email-masked]> De la part de Rodney Van Meter
Envoyé : mardi 9 mars 2021 08:09
À : Alexandre Petrescu <[email-masked]>
Cc : Rodney Van Meter <[email-masked]>; [email-masked]
Objet : Re: [Qirg] (hardware) roadmap discussion

Rodney Van Meter
[email-masked]

> computers over the existing maze of links, or is it a new and 
> different internet?

> I might wonder as well whether an existing IP addressing mechanism 
> used to identify classical computers is also used to identify quantum 

Talk to you tomorrow!

—Rod

>> [email-masked] https://www.irtf.org/mailman/listinfo/qirg

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 10 Mar 2021 17:30:23 +0100

>>> I’m not intending to present the contents directly, just open
>>> the floor to discussion
>> 
>> It says 'roadmap', but is there a notion of timeline?  By when
>> (what year) could a user telnet into a quantum computer over the
>> Internet?
> 
> The appendices have tables listing 3-, 5- and 10-year timelines, but
> I think those are aspirational.  They are fairly low-level,
> component-oriented milestones, rather than true system milestones, at
> least in my reading. I think that’s a valuable point for discussion.
> 
>> 
>>> of it and its relationship to QIRG work. If you want to
>>> contribute productively to the conversation, it would be helpful
>>> to take at least a quick look at it beforehand.
>> 
>> I read the abstract.
>> 
> Keep in mind that in the minds of many of the authors, “Internet”
> means “some vague system that connects a lot of stuff”. Many of them
> can spell TCP/IP, not many can spell AS or have thought about the
> issues in either scale or autonomous operation of participating
> networks.  So when they say “Internet”, they probably mean something
> different than you do.
> 
>> I wonder whether that is the Internet that links together two
>> quantum computers over the existing maze of links, or is it a new
>> and different internet?
> 
> To create quantum entanglement, you have to have quantum channels,
> for sure. Some experiments have demonstrated wavelength multiplexing
> of quantum traffic with classical traffic in the same fiber. I was in
> one recent discussion, however, where someone was grumbling about the
> cost in dB of doing that. But others, of course, believe we have to
> run over the current global fiber plant.
> 
>> 
>> That is a question that appears often in local discussions when we
>> say 'quantum internet'.
>> 
>> used to identify classical computers is also used to identify
>> quantum computers.  Maybe an existing quantum computer at IBM, at
>> Google or at CNRS already has an IPv6 address(?)
> 
> A quantum computer has a multi-tiered classical control
> infrastructure, culminating in an outward-facing web interface. It’s
> already possible to access a number of quantum computers via the
> classical Internet that way,

Is there an URL to a web server on a computer that might have a quantum 
coprocessor attached to it?

How to try a quantum computer in practice right away?

Alex

  but that doesn’t get you E2E
> entanglement and its associated benefits.
> 
> Talk to you tomorrow!
> 
> —Rod
> 
>> 
>> Alex
>> 
>>> It’s mostly a hardware roadmap, with focus on components. They
>>> divide interconnects into two classes: modular interconnects
>>> (which I would call system area networks, but others would call
>>> something different), and Quantum Internet. Nothing in between.
>>> No real discussion of network architecture, protocols and
>>> software. Tons of excellent references on technology and on
>>> various demonstrations, including free-space links using balloons
>>> and drone that I wasn’t aware of. This NFS QuICS roadmap isn’t
>>> the world’s only roadmap, but it’s the most complete and detailed
>>> that is public to date. —Rod Rodney Van Meter [email-masked]
>>> Professor, Faculty of Environment and Information Studies, Keio
>>> University, Japan _______________________________________________
>>> Qirg mailing list [email-masked]

---

From: Santanu Ganguly <[email-masked]>
Date: Thu, 11 Mar 2021 18:10:52 +0000

Hi Alexandre,

It is possible to use simulators such as D-Wave's qbsolve, Riggetii's QVM
(quantum virtual machine), Cirq simulator or Qiskit qasm and run codes and
test algorithms on your laptop. I regularly run D-Wave, Rigetti and Cirq on
Linux on my laptop and they are quite efficient in solving NP-hard problems
(for example).

If you are looking for access to actual hardware then IBM Q Experience has
been offering free limited access to their hardware via cloud access since
2017. D-Wave has the similar free limited access via D-Wave Leap and Google
is shaping up to offer the same via GCP. AWS opened up Braket with access
to hardware from Rigetti, D-Wave and IonQ

Thanks and best regards

Santanu

Rodney Van Meter
[email-masked]
Professor, Faculty of Environment and Information Studies, Keio University,
Japan

> year) could a user telnet into a quantum computer over the Internet?

The appendices have tables listing 3-, 5- and 10-year timelines, but I
think those are aspirational.  They are fairly low-level,
component-oriented milestones, rather than true system milestones, at least
in my reading. I think that’s a valuable point for discussion.

>> of it and its relationship to QIRG work. If you want to contribute
productively to the conversation, it would be helpful to take at least a
quick look at it beforehand.
> It says 'internet' maybe a couple of times.

Keep in mind that in the minds of many of the authors, “Internet” means
“some vague system that connects a lot of stuff”. Many of them can spell
TCP/IP, not many can spell AS or have thought about the issues in either
scale or autonomous operation of participating networks.  So when they say
“Internet”, they probably mean something different than you do.

> computers over the existing maze of links, or is it a new and different

To create quantum entanglement, you have to have quantum channels, for
sure. Some experiments have demonstrated wavelength multiplexing of quantum
traffic with classical traffic in the same fiber. I was in one recent
discussion, however, where someone was grumbling about the cost in dB of
doing that. But others, of course, believe we have to run over the current
global fiber plant.

> CNRS already has an IPv6 address(?)

Addressing is certainly one of the architecture issues that needs to be,
um, addressed.

A quantum computer has a multi-tiered classical control infrastructure,
culminating in an outward-facing web interface. It’s already possible to
access a number of quantum computers via the classical Internet that way,
but that doesn’t get you E2E entanglement and its associated benefits.

Talk to you tomorrow!

—Rod
Show quoted text
Hi Alexandre,

It is possible to use simulators such as D-Wave's qbsolve, Riggetii's QVM
(quantum virtual machine), Cirq simulator or Qiskit qasm and run codes and
test algorithms on your laptop. I regularly run D-Wave, Rigetti and Cirq on
Linux on my laptop and they are quite efficient in solving NP-hard problems
(for example).

If you are looking for access to actual hardware then IBM Q Experience has
been offering free limited access to their hardware via cloud access since
2017. D-Wave has the similar free limited access via D-Wave Leap and Google
is shaping up to offer the same via GCP. AWS opened up Braket with access
to hardware from Rigetti, D-Wave and IonQ

Thanks and best regards

Santanu
Show quoted text
--
--
"Education is what remains after one has forgotten everything he learnt in
school" - Albert Einstein
Hi Alexandre,

Many thanks for this indeed! I am not sure if there have been other posts
like this but am happy to re-post this to the wider audience.

Thanks and best regards

Santanu
Show quoted text