Subject: [Qirg] Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

From: Wojciech Kozlowski <[email-masked]>
Date: Fri, 26 Mar 2021 15:32:40 +0000

Hi QIRG,

At the IETF meeting on 10 March, I raised some concerns about how the stages were expressed in this draft. I have read through carefully now and discussed it with some people and I have the following comments:

The network stages are defined based on application capabilities and NOT based on distance. Therefore, when summarising the network stages from the paper, the draft should not be mentioning distances. Currently there's a lot of focus put on distance. This means that stage-1: "trusted repeater stage" means basically QKD-only. Stage-2: "prepare-and-measure" means we can do QKD *and* other applications that only require prepare-and-measure functionality. Note that there is no statement about achievable distances - only about the end-node capabilities. Stage-3 allows end-to-end entanglement creation and so on.

Therefore, my practical feedback to the I-D authors is to forget about distances and rephrase in terms of application capabilities.

However, this raises an interesting point that perhaps the QIRG/I-D authors may want to consider is whether one may want to put some further thought as how distance capabilities affect the use cases as that is not covered by these aforementioned stages. I think it would be valuable if the community has any thoughts on this point.

Best,
Wojtek

---

From: Gelard Patrick <[email-masked]>
Date: Fri, 26 Mar 2021 16:42:19 +0000

Hi Wojtek , hi all,

Can we implement step 2 "prepare and measure" whatever the distance between the two end points which separate the preparation of the qubit (e.g by Alice) and its measurement (e.g by Bob) ? Attenuation caused by distance may prevent the application from functioning.

Best regards,
Patrick
De : Qirg <[email-masked]> De la part de Wojciech Kozlowski
Envoyé : vendredi 26 mars 2021 16:33
À : [email-masked]
Objet : [Qirg] Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi QIRG,

Best,
Wojtek

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 29 Mar 2021 18:36:43 +0000

Hi Patrick,

Yes, you are correct. But that is not what that paper was about. The Quantum Internet stages paper, and thus the definitions of the stages, was purely about application functionality - not length scales of quantum networks.

I agree that based on those definitions, the "prepare and measure" stage is most likely bound to short distances (think optical network with switches, but no amplifiers). What places it above trusted repeater networks is that it can do more than QKD even though distance-wise it seems like a step back (though once again - the stages are defined independently of distances).

That is what made me raise the point that perhaps in the QIRG, where we're more interested in the network itself we may want to use different stages (such as the three generations).

Wojtek

From: Gelard Patrick <[email-masked]>
Sent: 26 March 2021 17:42
To: Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi Wojtek , hi all,

Best regards,
Patrick
De : Qirg <[email-masked]<mailto:[email-masked]>> De la part de Wojciech Kozlowski
Envoyé : vendredi 26 mars 2021 16:33
À : [email-masked]<mailto:[email-masked]>
Objet : [Qirg] Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi QIRG,

Best,
Wojtek

---

From: Chonggang Wang <[email-masked]>
Date: Mon, 29 Mar 2021 23:23:48 +0000

Hi Wojtek,

Thanks for your suggestion on Section 6.1.
"Therefore, my practical feedback to the I-D authors is to forget about distances and rephrase in terms of application capabilities."

According to your suggestion above, we revised Section 6.1 by removing "distance" but focusing on "application capabilities".

Our revision was just uploaded as v05 (https://datatracker.ietf.org/doc/draft-irtf-qirg-quantum-internet-use-cases/). Please let us know if you have any further comments.

Best regards,
Chonggang

From: Qirg <[email-masked]> On Behalf Of Wojciech Kozlowski
Sent: Friday, March 26, 2021 11:33 AM
To: [email-masked]
Subject: [Qirg] Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi QIRG,

Best,
Wojtek
[Banner]

[Banner]<https://www.interdigital.com/features/sustainability-in-a-wireless-world>

Sustainability in a Wireless World: Research dedicated to understanding the impact of our technologies on the planet.<https://www.interdigital.com/features/sustainability-in-a-wireless-world>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Gelard Patrick <[email-masked]>
Date: Tue, 30 Mar 2021 06:57:20 +0000

Hi Wojtek

If space and time (e.g latency)  are not take in account in Quantum Internet stages paper, what application functionality justifies quantum repeaters ?  For Artur Ekert information is physical : https://www.youtube.com/watch?v=XrKl38ZVofo

Are there maybe scaffolding that was used to define the various stages and then they were removed (or forgotten) ?

What can be the meaning of network itself for quantum "data plan" which is exclusively physical (i.e not encapsulation possible) ?

Patrick

De : Qirg <[email-masked]> De la part de Wojciech Kozlowski
Envoyé : lundi 29 mars 2021 20:37
À : [email-masked]
Objet : Re: [Qirg] Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi Patrick,

Wojtek

From: Gelard Patrick <[email-masked]<mailto:[email-masked]>>
Sent: 26 March 2021 17:42
To: Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi Wojtek , hi all,

Best regards,
Patrick

Hi QIRG,

Best,
Wojtek

---

From: Wojciech Kozlowski <[email-masked]>
Date: Tue, 30 Mar 2021 20:01:36 +0000

Hi Patrick,

Quantum repeaters are simply not a concern for the quantum internet stages paper. It's a tangential concern. They are not scaffolding. Quantum repeaters do not help one answer the question of "what can one do with an end-node". The paper is written with the idea of "as my end-node capabilities increase what can I achieve". Achievable distance is a separate concern. Quantum repeaters serve as a means to extend the network distance for any stage above trusted repeater networks. But in themselves, they do not allow new functionality.

Wojtek

From: Gelard Patrick <[email-masked]>
Sent: 30 March 2021 08:57
To: Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi Wojtek

If space and time (e.g latency)  are not take in account in Quantum Internet stages paper, what application functionality justifies quantum repeaters ?  For Artur Ekert information is physical : https://www.youtube.com/watch?v=XrKl38ZVofo<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.youtube.com_watch-3Fv-3DXrKl38ZVofo&d=DwMFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=QZjDzR7P6KBXpTLAl0Ro4PSxKs8LEUaSB9sTLKyDsQo&s=3UrInx8LaHgZqjStO6n1Qi6YWV_mW7f6UDzevuJqEJQ&e=>

Patrick

Hi Patrick,

Wojtek

Hi Wojtek , hi all,

Best regards,
Patrick

Hi QIRG,

Best,
Wojtek

---

From: Rodney Van Meter <[email-masked]>
Date: Wed, 31 Mar 2021 06:54:01 +0900

<list member hat on>
I agree with Wojtek’s point here that distance is a separate axis from capability. Capability, in fact, is essentially the AND of the capabilities of nodes along the path — if any node doesn’t support the operation, then it won’t be possible end-to-end.  Without some sort of discovery protocol that might, in fact, be hard to determine, but the most likely minimum-capability node is the end node, anyway.  (You know, this is a point I hadn’t really thought of in these terms until now.  Might be worth writing down in one draft or the other…)

Actually, I guess that’s not *exactly* true; the Qunnect nodes discussed at last week’s excellent seminar can store qubits, but not do anything sophisticated with them.  If you want purification, QEC or any sort of computation, that can be done at further nodes that have more capabilities, e.g. memory and a general gate set.

Hmm, so what’s the right way to express that…good question.

BUT:

Latency figures in as a *practical* constraint.  If you are trying to execute an application that requires end-to-end communication while storing qubits, as in some true distributed quantum applications, then you have to have long-lived memories. How long is probably expressed as a multiple of RTT.

So, the Wehner roadmap’s talk of stages of development is important, and plenty complex and nuanced as it is, but the reality is that networks and internetworks will likely be deployed in incremental, heterogeneous fashion and what a path is capable of might be different from the nominal stage of development of the network itself.

In short, the existing stages taxonomy is a guideline, and might help network operators define requirements as they consider deploying networks, but it’s not an exact spec.

—Rod

Rodney Van Meter
[email-masked]
Professor, Faculty of Environment and Information Studies, Keio University, Japan

> On Mar 31, 2021, at 5:01, Wojciech Kozlowski <[email-masked]> wrote:
> 
> Hi Patrick,
>  
> Quantum repeaters are simply not a concern for the quantum internet stages paper. It’s a tangential concern. They are not scaffolding. Quantum repeaters do not help one answer the question of “what can one do with an end-node”. The paper is written with the idea of “as my end-node capabilities increase what can I achieve”. Achievable distance is a separate concern. Quantum repeaters serve as a means to extend the network distance for any stage above trusted repeater networks. But in themselves, they do not allow new functionality.
>  
> Wojtek
>  
> If space and time (e.g latency)  are not take in account in Quantum Internet stages paper, what application functionality justifies quantum repeaters ?  For Artur Ekert information is physical : https://www.youtube.com/watch?v=XrKl38ZVofo <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.youtube.com_watch-3Fv-3DXrKl38ZVofo&d=DwMFAw&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=QZjDzR7P6KBXpTLAl0Ro4PSxKs8LEUaSB9sTLKyDsQo&s=3UrInx8LaHgZqjStO6n1Qi6YWV_mW7f6UDzevuJqEJQ&e=>
>  
> What can be the meaning of network itself for quantum “data plan” which is exclusively physical (i.e not encapsulation possible) ?
>  
> Patrick
>  
> De : Qirg <[email-masked] <mailto:[email-masked]>> De la part de Wojciech Kozlowski
> À : [email-masked] <mailto:[email-masked]>
> Yes, you are correct. But that is not what that paper was about. The Quantum Internet stages paper, and thus the definitions of the stages, was purely about application functionality – not length scales of quantum networks.
>  
> I agree that based on those definitions, the “prepare and measure” stage is most likely bound to short distances (think optical network with switches, but no amplifiers). What places it above trusted repeater networks is that it can do more than QKD even though distance-wise it seems like a step back (though once again – the stages are defined independently of distances).
>  
> That is what made me raise the point that perhaps in the QIRG, where we’re more interested in the network itself we may want to use different stages (such as the three generations).
>  
> Wojtek
>  
> From: Gelard Patrick <[email-masked] <mailto:[email-masked]>> 
> To: Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> De : Qirg <[email-masked] <mailto:[email-masked]>> De la part de Wojciech Kozlowski
> À : [email-masked] <mailto:[email-masked]>
> The network stages are defined based on application capabilities and NOT based on distance. Therefore, when summarising the network stages from the paper, the draft should not be mentioning distances. Currently there’s a lot of focus put on distance. This means that stage-1: “trusted repeater stage” means basically QKD-only. Stage-2: “prepare-and-measure” means we can do QKD *and* other applications that only require prepare-and-measure functionality. Note that there is no statement about achievable distances – only about the end-node capabilities. Stage-3 allows end-to-end entanglement creation and so on.
>  
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Fred Baker <[email-masked]>
Date: Tue, 30 Mar 2021 15:11:27 -0700

I would ask about the set of nodes comprising the “path”, however. The way you say this suggests that there is exactly one route, and the capability is the AND of the individual capabilities of those nodes on the path chosen. The most common path may contain an incapable node, but selecting a different route will identify a set of nodes that are capable of whatever is chosen. 

That concept is basic to anycast, at least as used in DNS. My request will go to the nearest node advertising the indicated destination address for which I have a viable route or path, but the choice of node may not be as predictable as I would like. If the path fails, that may change the node my packet goes to. As a result, DNS on UDP to a root server has a very high probability of working (it gets somewhere, and whoever it gets to responds), but DNS/TCP might not. I might do the SYN/SYN-ACK exchange only to have the path change, so that the request in the first data packet goes to a system that has no idea of the session state and responds RST.

Sent from my iPad

> On Mar 30, 2021, at 2:54 PM, Rodney Van Meter <rdv=[email-masked]> wrote:
> 
> 
> <list member hat on>

---

From: Rodney Van Meter <[email-masked]>
Date: Wed, 31 Mar 2021 07:17:11 +0900

Yeah, that’s exactly the kind of issue we are going to face as the engineering gets concrete.

At the moment, though, for 1G networks, I can only imagine this working with substantial amounts of connection state held in every node on the path.  That means that any change to routing mid-connection will involve renegotiating at least part of the path and connection setup.

We’re going to end up with something closer to circuit switched than packet switched, but the exact form is TBD. Many of you here are much more up to date than I am on the reality of router implementation; the semantics are (close to?) statistical muxing with fully independent switching/routing decisions packet by packet, and that’s not going to be feasible when you are managing E2E entanglement swapping and purification.

Rodney Van Meter
[email-masked]

> On Mar 31, 2021, at 7:11, Fred Baker <[email-masked]> wrote:
> 
>> [email-masked] <mailto:[email-masked]>
>>> On Mar 31, 2021, at 5:01, Wojciech Kozlowski <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi Patrick,
>>>  
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.irtf.org/mailman/listinfo/qirg <https://www.irtf.org/mailman/listinfo/qirg>

---

From: Gelard Patrick <[email-masked]>
Date: Wed, 31 Mar 2021 09:56:10 +0000

Hi Wojtek

"as my end-node capabilities increase what can I achieve",  I suppose what can I achieve for quantum communication rather than for quantum computation.
What could be a quantum end-node  ? Quantum sensors, quantum computer, ...

At the end-node, capabilities need to increase in what  for quantum communication ? number of Qubit, quantum circuit size, quantum circuit depth, quantum memory   capacity,  error resilience at the level of the quantum memory,  ...

Patrick
De : Qirg <[email-masked]> De la part de Wojciech Kozlowski
Envoyé : mardi 30 mars 2021 22:02
À : [email-masked]
Objet : Re: [Qirg] Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi Patrick,

Wojtek

Hi Wojtek

Patrick

Hi Patrick,

Wojtek

Hi Wojtek , hi all,

Best regards,
Patrick

Hi QIRG,

Best,
Wojtek

---

From: Wojciech Kozlowski <[email-masked]>
Date: Wed, 31 Mar 2021 12:50:45 +0000

Hi Patrick,

Those questions are exactly the ones the stages paper aims to answer so I would refer you to the paper for details. Most of it is summarized in Table 1 which I include below

Wojtek

From: Gelard Patrick <[email-masked]>
Sent: 31 March 2021 11:56
To: Wojciech Kozlowski <[email-masked]>; [email-masked]
Subject: RE: Comments about stages in draft-irtf-qirg-quantum-internet-use-cases

Hi Wojtek

Patrick

Hi Patrick,

Wojtek

Hi Wojtek

Patrick

Hi Patrick,

Wojtek

Hi Wojtek , hi all,

Best regards,
Patrick

Hi QIRG,

Best,
Wojtek