Subject: [Qirg] Anonymity in quantum networks

From: Wojciech Kozlowski <[email-masked]>
Date: Wed, 17 Mar 2021 10:00:19 +0000

A question that has been asked at QIRG meetings a few times is whether quantum communication can also be anonymous. In this theme I saw an article on the arXiv today that I thought would be interesting for the QIRG: Anonymous and secret communication in quantum networks<https://arxiv.org/abs/2103.08722>. This is an experimental demonstration of the anonymous conference key agreement protocol proposed in "Anonymous Quantum Conference Key Agreement"<https://journals.aps.org/prxquantum/abstract/10.1103/PRXQuantum.1.020325>. It is also worth noting that multipartite entanglement is key to this protocol.

Best regards,
Wojtek

---

From: Michele AMORETTI <[email-masked]>
Date: Mon, 29 Mar 2021 16:52:01 +0000

Dear Wojtek,

thank you for pointing out this topic, which I think is very interesting.

Another notable (previous) work on the same topic is:  https://arxiv.org/abs/1811.04729

In 2019, one of my MSc students simulated the protocol proposed by that paper, using SimulaQron and Qiskit:
https://github.com/qis-unipr/qsip-practical-anonymity  (the code is not up to date, unfortunately)

Best,
Michele

Michele Amoretti, Ph.D.
Associate Professor of Computer Engineering
http://dsg.ce.unipr.it/people/michele-amoretti/
- Distributed Systems Group, Department of Engineering and Architecture
- Quantum Information Science http://www.qis.unipr.it<http://www.qis.unipr.it/>
University of Parma, Italy
IEEE Senior Member
Associate Editor of the IEEE Transactions on Quantum Engineering<https://tqe.ieee.org/>
Associate Editor of the International Journal of Distributed Sensor Networks<https://journals.sagepub.com/home/dsn>

________________________________
Da: Qirg <[email-masked]> per conto di Wojciech Kozlowski <[email-masked]>
Inviato: mercoledì 17 marzo 2021 11:00
A: [email-masked] <[email-masked]>
Oggetto: [Qirg] Anonymity in quantum networks

A question that has been asked at QIRG meetings a few times is whether quantum communication can also be anonymous. In this theme I saw an article on the arXiv today that I thought would be interesting for the QIRG: Anonymous and secret communication in quantum networks<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Farxiv.org%2Fabs%2F2103.08722&data=04%7C01%7Cmichele.amoretti%40unipr.it%7Cf5db074897d64ffccf6508d8e92b9136%7Cbb064bc5b7a841ecbabed7beb3faeb1c%7C0%7C0%7C637515721207704966%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=50ruQ42hQmFn12%2BgpZndrqK3Fhrk9lNiWytpFszKoiM%3D&reserved=0>. This is an experimental demonstration of the anonymous conference key agreement protocol proposed in “Anonymous Quantum Conference Key Agreement”<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fjournals.aps.org%2Fprxquantum%2Fabstract%2F10.1103%2FPRXQuantum.1.020325&data=04%7C01%7Cmichele.amoretti%40unipr.it%7Cf5db074897d64ffccf6508d8e92b9136%7Cbb064bc5b7a841ecbabed7beb3faeb1c%7C0%7C0%7C637515721207714962%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=WcuDhdmPvvimolaZ42euFZkN4LMxsykmyCimCnHS%2BP0%3D&reserved=0>. It is also worth noting that multipartite entanglement is key to this protocol.

Best regards,

Wojtek