Subject: [Qirg] multiplexing?

From: Rodney Van Meter <[email-masked]>
Date: Tue, 27 Apr 2021 16:35:23 +0900

Wojtek,

Just dinking around I noticed that we never use the word “multiplexing” in our I-D.
https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/
We do refer to “resource management”.

QIRGers, what do y’all think?  Should we use muxing in some form in this to discuss the problem of managing access to resources along the path?

—Rod

P.S. Yes, we said in IETF a few weeks ago that this would be sent to IRSG by now, but we haven’t gotten it sent. I do think it’s ready.

Rodney Van Meter
[email-masked]
Professor, Faculty of Environment and Information Studies, Keio University, Japan

---

From: Bruno Rijsman <[email-masked]>
Date: Tue, 27 Apr 2021 10:35:37 +0200

I vote for updating the draft to mention multiplexing.

It is too important of a concept for achieving practically usable entanglement rates.

— Bruno

> On Apr 27, 2021, at 9:35 AM, Rodney Van Meter <rdv=[email-masked]> wrote:
> 
> Wojtek,
> 
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Rodney Van Meter <[email-masked]>
Date: Tue, 27 Apr 2021 17:39:43 +0900

Mmm, one problem is that it is used at many levels, and perhaps you and I are using it in different ways here.  I’m thinking of stat mux v. circuit switching, a very networky thing, but it’s also used to refer to frequency allocation in WDM and the quantum folks also use it to mean being able to connect multiple qubit memories to a single optical channel.

Rodney Van Meter
[email-masked]

> On Apr 27, 2021, at 17:35, Bruno Rijsman <[email-masked]> wrote:
>

---

From: Bruno Rijsman <[email-masked]>
Date: Tue, 27 Apr 2021 10:52:58 +0200

Ah, yes, I was thinking of a more quantum-specific flavor of multiplexing: having multiple entanglements attempts going in parallel.  

If you need to do attempts sequentially (waiting for a round-trip time to receive the heralding result before starting the next attempt) entanglement generation is going to be very slow for reasonable distances.

For example, this paper https://arxiv.org/abs/1309.3202 <https://arxiv.org/abs/1309.3202> discusses spectral multiplexing where parallelism is achieved spectrally.

Or in NV centers parallelism (multiplexing) can be achieved by moving the communication qubit to a storage qubit to free up the communication qubit for the next entanglement attempt before the previous attempt was finished, i.e. before the heralding result was received (there is a paper on this, but I can’t locate it just right now).

But you are right, statistical muxing vs TDM muxing vs WDM muxing are also important considerations in quantum networks.

You need some TDM-ish clock synchronization to achieve indistinguishable photon arrivals at the heralding midpoint.  If you are also doing “parallelism” multiplexing in the sense of the start of this e-mail, then this almost inevitably leads to some sort of “time slot” concept.

And it is also often highly desirable (but not always practical) to WDM-mux the classical control channel onto the same fiber as the quantum data channel (and possibly even other classical data channels) to avoid having to use multiple fibers.

— Bruno

> On Apr 27, 2021, at 10:39 AM, Rodney Van Meter <[email-masked]> wrote:
>

---

From: Bruno Rijsman <[email-masked]>
Date: Tue, 27 Apr 2021 11:18:48 +0200

Would you like me to propose some specific language for the draft in a pull request?  (Not much, just one or two paragraphs mentioning the different kinds of multiplexing and why they are relevant.)

— Bruno

> On Apr 27, 2021, at 10:52 AM, Bruno Rijsman <[email-masked]> wrote:
> 
>> On Apr 27, 2021, at 10:39 AM, Rodney Van Meter <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>

---

From: Joseph D Touch <[email-masked]>
Date: Tue, 27 Apr 2021 20:08:43 +0000

Hi, all,

I'm curious at the phrase too.

Muxing is what happens to the path or link when it is shared by multiple entanglement-creation or teleportation operations, which is different from how individual qubits on a link are muxed either in time (TDM), space (parallel links), wavelength (FDM), or some other encoding that is distinct from how the quantum info is encoded (i.e., you can't mux by polarization and use it for quantum info at the same time).

I'd suggest discussing both levels of "path sharing"...

Joe

-- 
Dr. Joseph Touch
Principal Scientist
Information Systems and Cyber Division
The Aerospace Corporation
424-254-4357 cell

On 4/27/21, 1:41 AM, "Qirg on behalf of Rodney Van Meter" <[email-masked] on behalf of rdv=[email-masked]> wrote:

    Rodney Van Meter
    [email-masked]

---

From: Wojciech Kozlowski <[email-masked]>
Date: Wed, 28 Apr 2021 14:28:09 +0000

Hi all,

I myself don't see much point in adding anything about multiplexing.

As Bruno pointed out there are two meanings of multiplexing to cover:

1)      Resource sharing – I’m not sure what benefit we will gain in the draft from saying that multiplexing will be one particular way for resource sharing, be it TDM/WDM/etc. Furthermore, even in the description below the discussion descends to quite a low level at the physical layer which is an area that this draft is explicitly trying not to cover.

2)      Multiple entanglement attempts – this is a very low-level physical detail and for the same reason as above I wouldn’t say it fits in the draft.

Both concepts are important, but I’m not convinced that a mention of multiplexing would bring much to the draft that’s not already there. Having said that, if somebody submits a pull request on GitHub, I can happily help in editing it into the draft.

Thanks,

Wojtek

From: Qirg <[email-masked]> On Behalf Of Bruno Rijsman
Sent: 27 April 2021 11:19
To: Rodney Van Meter <[email-masked]>
Cc: [email-masked]; Rodney Van Meter <rdv=[email-masked]>
Subject: Re: [Qirg] multiplexing?

— Bruno

On Apr 27, 2021, at 10:52 AM, Bruno Rijsman <[email-masked]<mailto:[email-masked]>> wrote:

For example, this paper https://arxiv.org/abs/1309.3202<https://urldefense.proofpoint.com/v2/url?u=https-3A__arxiv.org_abs_1309.3202&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=rHseDIvPhlc-tZ1QRgND-UyfLPX4lVD9A1L-MGoQQEc&s=ugMseTdfsAultDmBJm4h1VnpFhlv8X7X3UqFJIJPUU4&e=> discusses spectral multiplexing where parallelism is achieved spectrally.

— Bruno

On Apr 27, 2021, at 10:39 AM, Rodney Van Meter <[email-masked]<mailto:[email-masked]>> wrote:

Rodney Van Meter
[email-masked]<mailto:[email-masked]>
Professor, Faculty of Environment and Information Studies, Keio University, Japan

On Apr 27, 2021, at 17:35, Bruno Rijsman <[email-masked]<mailto:[email-masked]>> wrote:

— Bruno

On Apr 27, 2021, at 9:35 AM, Rodney Van Meter <rdv=[email-masked]<mailto:rdv=[email-masked]>> wrote:

Wojtek,

Just dinking around I noticed that we never use the word “multiplexing” in our I-D.
https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-2Dprinciples_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=rHseDIvPhlc-tZ1QRgND-UyfLPX4lVD9A1L-MGoQQEc&s=TNZB2jajBPA7N0aAWrUc3DEMyshSR0UPpQp3ImDn0Kw&e=>
We do refer to “resource management”.

—Rod

Rodney Van Meter
[email-masked]<mailto:[email-masked]>
Professor, Faculty of Environment and Information Studies, Keio University, Japan

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwQFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=rHseDIvPhlc-tZ1QRgND-UyfLPX4lVD9A1L-MGoQQEc&s=3YrvPDa7iO9bNQ53zT3sBLXdnvX2G7aG-CYTKqWYlck&e=>