Subject: Re: [Qirg] IPv6 and the Quantum Internet

From: Melchior Aelmans <[email-masked]>
Date: Sat, 3 Apr 2021 14:04:21 +0200

Hi Alex,

Seems like no IPv6 connectivity or at least doesn't resolve a v6 address:

$ host quantum-computing.ibm.com
quantum-computing.ibm.com has address 104.18.1.130
quantum-computing.ibm.com has address 104.18.0.130
$

Cheers,
Melchior

On Wed, Mar 31, 2021 at 3:46 PM Alexandre Petrescu <
[email-masked]> wrote:

> I am trying to connect to IBM Quantum Experience but it does not work
> https://quantum-computing.ibm.com/
>
> I am using my IPv6-only computer - a Windows computer with IPv4 turned
> off in the interface properties.
>
> If I could connect on IPv6 to IBM Quantum Experience then I could think
> about Quantum Internet.
>
> Alex
>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 6 Apr 2021 16:31:55 +0200

Le 03/04/2021 à 14:04, Melchior Aelmans a écrit :
> $ host quantum-computing.ibm.com <http://quantum-computing.ibm.com> 
> quantum-computing.ibm.com <http://quantum-computing.ibm.com> has
> address 104.18.1.130 quantum-computing.ibm.com
> <http://quantum-computing.ibm.com> has address 104.18.0.130 $

Hi,

If it does not resolve,

As an research and development approach, I think it would be good to
suggest the owner of the computer to put it on IP (IPv6).  That is to
assign an IP (IPv6) address to it, decide an attractive name for it
and insert it into DNS.

Alex

> Cheers, Melchior
> 
> On Wed, Mar 31, 2021 at 3:46 PM Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
> I am trying to connect to IBM Quantum Experience but it does not
> work https://quantum-computing.ibm.com/
> <https://quantum-computing.ibm.com/>
> 
> I am using my IPv6-only computer - a Windows computer with IPv4
> turned off in the interface properties.
> 
> If I could connect on IPv6 to IBM Quantum Experience then I could
> think about Quantum Internet.
> 
> Alex
> 
> _______________________________________________ Qirg mailing list 
> [email-masked] <mailto:[email-masked]> 
> <https://www.irtf.org/mailman/listinfo/qirg>
>

---

From: Melchior Aelmans <[email-masked]>
Date: Wed, 7 Apr 2021 15:02:13 +0200

Hi Alex,

> assign an IP (IPv6) address to it, decide an attractive name for it

You don't have to give it another attractive name. You can have an AAAA
record for the existing hostname so it will give you back an A and AAAA
record and the same hostname resolves to both an IPv4 and IPv6 address.
But yes excellent suggestion to contact the admin and ask to enable this on
IPv6.

Cheers,
Melchior

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 8 Apr 2021 09:43:28 +0200

Le 07/04/2021 à 15:02, Melchior Aelmans a écrit :
> Hi Alex,
> 
> On Tue, Apr 6, 2021 at 4:31 PM Alexandre Petrescu 
> <http://quantum-computing.ibm.com> <http://quantum-computing.ibm.com 
> <http://quantum-computing.ibm.com>>
>> quantum-computing.ibm.com <http://quantum-computing.ibm.com>
> <http://quantum-computing.ibm.com <http://quantum-computing.ibm.com>>
> has
> <http://quantum-computing.ibm.com>
>> <http://quantum-computing.ibm.com
> <http://quantum-computing.ibm.com>> has address 104.18.0.130 $
> 
> Hi,
> 
> If it does not resolve,
> 
> suggest the owner of the computer to put it on IP (IPv6).  That is
> to assign an IP (IPv6) address to it, decide an attractive name for
> it and insert it into DNS.
> 
> 
> You don't have to give it another attractive name. You can have an
> AAAA record for the existing hostname so it will give you back an A
> and AAAA record and the same hostname resolves to both an IPv4 and
> IPv6 address. But yes excellent suggestion to contact the admin and
> ask to enable this on IPv6.

Right, but how can one find the admin's email address if that webpage is
invisible to one's IPv6-only computer?  Maybe someone with an IPv4
computer can help to find the admin's email address, otherwise it is a 
chicken and egg problem.

Once the frontend is put on IP (IPv6) then one can try to figure out the 
addressing architecture for connecting the quantum computers to the
Internet, hence a certain view of the Quantum Internet.

It might be that the access control (login page) to the quantum
experience must be on IPv4, then the IBM Q classical cloud (frontend?)
could be on IP (IPv6), and then the attached quantum co-processor might
be again on IPv4, or on serial with ptp addressing, I dont know.

These are  unknowns, but might be very simple to find out.  They are
much simpler than the hard computing problems that quantum computing
might solve, or than the future quantum interconnects, but solving these
simple addressing problems might contribute to building a Quantum
Internet, or certain aspects of it.

Alex