Subject: Re: [Qirg] qirg - Requested session has been scheduled for IETF 108

From: Gelard Patrick <[email-masked]>
Date: Mon, 6 Sep 2021 15:28:24 +0000

Dear Wojciech 

This very interesting overview shows a considerable work, now QKD Network seem to be more oriented to "Trusted Node Network Relay" than Entanglement Swapping. In this scheme, key are stored in QKD nodes (trusted nodes) and relayed to other distant QKD nodes via highly secure encryption, with OTP (one-time-pad) recommended. 

Best regards
Patrick

-----Message d'origine-----
---------- Message transféré ---------
De : Wojciech Kozlowski <[email-masked]>
Date : lun. 6 sept. 2021 à 10:48
Objet : [Qirg] Liaison statement from ITU
À : [email-masked] <[email-masked]>

Dear QIRG,
 
The ITU-T SG-13 have sent the QIRG a liaison statement: [sp16-sg13-oLS-00213] LS on work progress on Quantum Key Distribution (QKD) network in SG13 (as of July 2021).
 
You can view the full text and attachments on the datatracker: https://datatracker.ietf.org/liaison/1752/.
 
My brief take on it is that it is a very interesting snapshot of the ITU's current QKD network standardization efforts.
 
Thanks,
Wojtek

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Mon, 6 Sep 2021 16:27:19 +0000

Ok, I'll ask the obvious question: if we assume that we have a deployable OTP system available, what does QKD bring to the table?  QKD's claim to fame is that its security is based on QM; OTP has an even better security guarantee (informational; that is, the attacker literally does not have enough information to attack the system).  Given that OTP does not have QKD's downsides (e.g. cost, range limitations, or restrictions to certain types of media), why would we use QKD?

-----Original Message-----
From: Qirg <[email-masked]> On Behalf Of Gelard Patrick
Sent: Monday, September 6, 2021 11:28 AM
To: [email-masked]; [email-masked]
Subject: Re: [Qirg] qirg - Requested session has been scheduled for IETF 108

Dear Wojciech 

Best regards
Patrick

-----Message d'origine-----
---------- Message transféré ---------
De : Wojciech Kozlowski <[email-masked]> Date : lun. 6 sept. 2021 à 10:48 Objet : [Qirg] Liaison statement from ITU À : [email-masked] <[email-masked]>

Dear QIRG,

 
 
Thanks,
Wojtek

_______________________________________________
Qirg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/qirg

---

From: Gelard Patrick <[email-masked]>
Date: Mon, 6 Sep 2021 16:43:15 +0000

Dear Scott Fluhrer,

QKD allows two distant entity  to share a secret, protected from listening by property of the quantum world, which can then be used for a secret key cryptosystem like OTP but also AES (Advanced Encryption Standard).

Best regards
Patrick

-----Message d'origine-----
De : Scott Fluhrer (sfluhrer) <[email-masked]> 
Envoyé : lundi 6 septembre 2021 18:27
À : Gelard Patrick <[email-masked]>; [email-masked]; [email-masked]
Objet : RE: [Qirg] qirg - Requested session has been scheduled for IETF 108

-----Original Message-----
From: Qirg <[email-masked]> On Behalf Of Gelard Patrick
Sent: Monday, September 6, 2021 11:28 AM
To: [email-masked]; [email-masked]
Subject: Re: [Qirg] qirg - Requested session has been scheduled for IETF 108

Dear Wojciech 

Best regards
Patrick

-----Message d'origine-----
---------- Message transféré ---------

Dear QIRG,

 
 
Thanks,
Wojtek

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 6 Sep 2021 09:56:35 -0700

Hi, Scott,

Because OTP consumes keys; QKD generates them.

Joe

—
Joe Touch, temporal epistemologist
www.strayalpha.com

> On Sep 6, 2021, at 9:27 AM, Scott Fluhrer (sfluhrer) <sfluhrer=[email-masked]> wrote:
>

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Mon, 6 Sep 2021 21:49:34 +0000

It appears that I assumed the term "OTP" had a different meaning than what was intended.

Where I'm from, an OTP is a process where both the sender and the receiver share a large preconfigured set of random bits (generally produced at a central site and physically transported securely); they use those bits to protect the data (encryption usually by XOR; integrity protection can be done but is a little more complicated (universal hash)).  Any other process for generating those bits on the two sides, be it QKD or a deterministic cryptographical process, is specifically not an OTP.

Obviously, you're using OTP to include any mechanism to share the bits (specifically including QKD).

With my meaning of OTP, there are obviously logistical problems (not unsolvable, but are also nontrivial), hence my puzzlement on whether those were considered solved (at least for part of the network).

-----Original Message-----
From: Gelard Patrick <[email-masked]> 
Sent: Monday, September 6, 2021 12:43 PM
To: Scott Fluhrer (sfluhrer) <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: [Qirg] qirg - Requested session has been scheduled for IETF 108

Dear Scott Fluhrer,

Best regards
Patrick

-----Message d'origine-----
De : Scott Fluhrer (sfluhrer) <[email-masked]> Envoyé : lundi 6 septembre 2021 18:27 À : Gelard Patrick <[email-masked]>; [email-masked]; [email-masked] Objet : RE: [Qirg] qirg - Requested session has been scheduled for IETF 108

-----Original Message-----
From: Qirg <[email-masked]> On Behalf Of Gelard Patrick
Sent: Monday, September 6, 2021 11:28 AM
To: [email-masked]; [email-masked]
Subject: Re: [Qirg] qirg - Requested session has been scheduled for IETF 108

Dear Wojciech 

Best regards
Patrick

-----Message d'origine-----
---------- Message transféré ---------

Dear QIRG,

 
 
Thanks,
Wojtek

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 6 Sep 2021 15:26:30 -0700

OTP is the name of the encryption algorithm that *uses* a key.

The key it uses could be preconfigured and then endpoints separated, distributed using a physical media ("sneaker net”), distributed over-the-air (OTA), either using an existing encryption algorithm (e.g., AES), or generated at endpoints using QKD (QKD is really QKG; it doesn’t distribute a given key, it computes a key at both endpoints).

Nothing about OTP specifies which of these are used per se, though the benefits of using OTP would be somewhat undermined by using OTA.

Joe

—

> On Sep 6, 2021, at 2:49 PM, Scott Fluhrer (sfluhrer) <sfluhrer=[email-masked]> wrote:
>

---

From: Gelard Patrick <[email-masked]>
Date: Tue, 7 Sep 2021 07:07:37 +0000

Yep, the QKD protocol can be considered as the classic counterpart of the Diffie-Hellman protocol. A quantum key agreement protocol.

In a simplified way we can say that there are two large families of protocols "prepare and measure" (Alice sends coded pulses to Bob who decodes according to a specific protocol) and "entanglement based" (both parties receive photons in an entangled state and perform appropriate measurements. ) which are based on different principles of quantum physics : 

- Heisenberg's inequalities: Alice sends a random signal to Bob, by "encoding" it on two "conjugated" physical quantities Eve, not knowing which quantity is used, will try to measure, but in doing so, any significant information that she will acquire on one of the quantities will disturb the other and introduce "noise", in other words errors, in the transmission between Alice and Bob. The latter will be able to statistically evaluate these errors, by publicly comparing part of their data, which will no longer be used subsequently.

- EPR violation based on quantum entanglement : Entangled particles (eg Bell's pair) from any source are received by both Alice and Bob, which can measure a degree of freedom (eg polarization, time-bin, frequency-bin, energy-time, …) to randomly generate 0 or 1. Eve's measure will break the entanglement, which will be seen by a non-violation of Bell's inequalities.

Note that in the "prepare and measure" approach, a random number must be generated by Alice and then encoded in Alice's preparation phase. It is this random number that is used to generate the shared secret (random seed used to generate the key).

In the entanglement-based approach the shared random number is actually generated by the quantum measurement of Alice's side and Bob's side. Indeed the quantum measurement is purely probabilistic.

Best Regards
Patrick
-
De : [email-masked] <[email-masked]> 
Envoyé : mardi 7 septembre 2021 00:27
À : Scott Fluhrer (sfluhrer) <sfluhrer=[email-masked]>
Cc : Gelard Patrick <[email-masked]>; [email-masked]; [email-masked]
Objet : Re: [Qirg] qirg - Requested session has been scheduled for IETF 108

Joe

—
Joe Touch, temporal epistemologist
http://www.strayalpha.com

On Sep 6, 2021, at 2:49 PM, Scott Fluhrer (sfluhrer) <mailto:sfluhrer=[email-masked]> wrote:

-----Original Message-----
From: Gelard Patrick <mailto:[email-masked]> 
Sent: Monday, September 6, 2021 12:43 PM
To: Scott Fluhrer (sfluhrer) <mailto:[email-masked]>; mailto:[email-masked]; mailto:[email-masked]
Subject: RE: [Qirg] qirg - Requested session has been scheduled for IETF 108

Dear Scott Fluhrer,

Best regards
Patrick

-----Message d'origine-----
De : Scott Fluhrer (sfluhrer) <mailto:[email-masked]> Envoyé : lundi 6 septembre 2021 18:27 À : Gelard Patrick <mailto:[email-masked]>; mailto:[email-masked]; mailto:[email-masked] Objet : RE: [Qirg] qirg - Requested session has been scheduled for IETF 108

-----Original Message-----
From: Qirg <mailto:[email-masked]> On Behalf Of Gelard Patrick
Sent: Monday, September 6, 2021 11:28 AM
To: mailto:[email-masked]; mailto:[email-masked]
Subject: Re: [Qirg] qirg - Requested session has been scheduled for IETF 108

Dear Wojciech 

Best regards
Patrick

-----Message d'origine-----
---------- Message transféré ---------
De : Wojciech Kozlowski <mailto:[email-masked]> Date : lun. 6 sept. 2021 à 10:48 Objet : [Qirg] Liaison statement from ITU À : mailto:[email-masked] <mailto:[email-masked]>

Dear QIRG,

Thanks,
Wojtek

mailto:[email-masked]

mailto:[email-masked]