Subject: [Qirg] new quantum networking papers

From: Rodney Van Meter <[email-masked]>
Date: Fri, 17 Dec 2021 19:07:01 +0900

qirgers,

For your holiday season reading pleasure:

QuISP, our Quantum Internet Simulation Package. Master's student Ryosuke Satoh as first author, though it is very much a team effort spanning several years.
https://arxiv.org/abs/2112.07093 <https://arxiv.org/abs/2112.07093>

Progress on the software is actually accelerating. A lot of work recently has gone into improved testing and improved clarity in the code. Some interesting new functionality should be coming out next month, as well, we hope.
https://github.com/sfc-aqua/quisp#quisp <https://github.com/sfc-aqua/quisp#quisp>

And, if you want to try QuISP, you can do so directly in the browser now, via a WASM version that runs locally on your machine without installing any software! (Don't worry, it can't read or write files on your machine without special permission.)
https://aqua.sfc.wide.ad.jp/quisp-online/0.2.1/ <https://aqua.sfc.wide.ad.jp/quisp-online/0.2.1/>

A Quantum Internet Architecture, with me in the lead but the result of fifteen years of thinking about how networks should be built, and with many great collaborators who deserve much thanks but didn’t make the author list.
https://arxiv.org/abs/2112.07092 <https://arxiv.org/abs/2112.07092>

Shota has a new standalone paper on an end-to-end error management scheme.
https://arxiv.org/abs/2112.07185 <https://arxiv.org/abs/2112.07185>

—Rod

Rodney Van Meter
[email-masked]
Professor, Faculty of Environment and Information Studies, Keio University, Japan

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 17 Dec 2021 11:29:29 +0100

When will the bandwidth of quantum networks overcome the bandwidth of 
traditional networks?

Alex

Le 17/12/2021 à 11:07, Rodney Van Meter a écrit :
> QuISP, our Quantum Internet Simulation Package. Master's student Ryosuke 
> Satoh as first author, though it is very much a team effort spanning 
> several years.
> Progress on the software is actually accelerating. A lot of work 
> recently has gone into improved testing and improved clarity in the 
> code. Some interesting new functionality should be coming out next 
> month, as well, we hope.
> https://github.com/sfc-aqua/quisp#quisp 
> <https://github.com/sfc-aqua/quisp#quisp>
> 
> And, if you want to try QuISP, you can do so directly in the browser 
> now, via a WASM version that runs locally on your machine without 
> installing any software! (Don't worry, it can't read or write files on 
> your machine without special permission.)
> https://aqua.sfc.wide.ad.jp/quisp-online/0.2.1/ 
> <https://aqua.sfc.wide.ad.jp/quisp-online/0.2.1/>
> 
> A Quantum Internet Architecture, with me in the lead but the result of 
> fifteen years of thinking about how networks should be built, and with 
> many great collaborators who deserve much thanks but didn’t make the 
> author list.
> [email-masked] <mailto:[email-masked]>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Rodney Van Meter <[email-masked]>
Date: Fri, 17 Dec 2021 20:33:38 +0900

Bandwidth, in terms of bits per second transferred, is the wrong way to think about quantum networks.  The new capabilities are the point; you can do numerous things with end-to-end entanglement.

QIRG’s own I-D is a good place to start, if you haven’t yet read much.
https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/

—Rod

Rodney Van Meter
[email-masked]

> On Dec 17, 2021, at 19:29, Alexandre Petrescu <[email-masked]> wrote:
> 
> When will the bandwidth of quantum networks overcome the bandwidth of traditional networks?
> 
> Alex
>

---

From: Marcello Caleffi <[email-masked]>
Date: Fri, 17 Dec 2021 13:39:32 +0100

Well, there are “special configurations” of quantum channels where you can indeed achieve higher bit rate.

We’re talking on something — very, in the near future, although having already been experimented — far to be practical, but the key aspect is that you can exceed classical bounds on information transmission, such as the bottleneck one:
given a sequence of links, the capacity/throughput through the sequence is the minimum of the capacity/throughput of the individual links

These special configurations, aka quantum trajectories, represent a sort of second degree of quantumness, where not only the information carrier, but also the placement of channels is quantum.
And, since they challenge the fundamental bounds, they represents a phenomenon much more interesting (for us, at least) than superdense coding and similar stuff.

This is a technical reference from our group:
http://www.quantuminternet.it/files/pub/CacCal-19-2.pdf

But there is also this less-math more-broad survey where we tried to discuss several intriguing and recently discovered quantum phenomena which challenge classical networks
https://arxiv.org/abs/2108.07108

Not sure whether this somehow replies to Alexandre's question.

Marcello

------------------------------------------------------------------------------------------------

Prof. Marcello Caleffi

FLY Lab Co-Director
http://www.quantuminternet.it
	Department of Electrical Engineering and Information Technologies
	University of Naples Federico II

> Il giorno 17 dic 2021, alle ore 12:33, Rodney Van Meter <rdv=[email-masked]> ha scritto:
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 17 Dec 2021 13:55:32 +0100

Le 17/12/2021 à 12:33, Rodney Van Meter a écrit :
> Bandwidth, in terms of bits per second transferred, is the wrong way
> to think about quantum networks.  The new capabilities are the point;
> you can do numerous things with end-to-end entanglement.
> 
> QIRG’s own I-D is a good place to start, if you haven’t yet read
> much. https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/

I am trying to catch up.  I will read it.

But if bandwidth in terms of BPS are the wrong way to think about 
quantum networks then I would like to ask which part of BPS is the wrong 
way?

Is it that the quantum networks dont transfer Bits but Qubits?

Or is it that the quantum networks dont consider a notion of Seconds?

Or is it that the bandwidth is infinite in quantum networks?  The 
message is not transmitted but it is just somehow mirrored instantaneously?

Alex

> 
> —Rod
> 
> Rodney Van Meter [email-masked] Professor, Faculty of Environment
> and Information Studies, Keio University, Japan
> 
>>> qirgers, For your holiday season reading pleasure: QuISP, our
>>> Quantum Internet Simulation Package. Master's student Ryosuke
>>> Satoh as first author, though it is very much a team effort
>>> spanning several years. https://arxiv.org/abs/2112.07093
>>> <https://arxiv.org/abs/2112.07093> Progress on the software is
>>> actually accelerating. A lot of work recently has gone into
>>> improved testing and improved clarity in the code. Some
>>> interesting new functionality should be coming out next month, as
>>> well, we hope. https://github.com/sfc-aqua/quisp#quisp
>>> <https://github.com/sfc-aqua/quisp#quisp> And, if you want to try
>>> QuISP, you can do so directly in the browser now, via a WASM
>>> version that runs locally on your machine without installing any
>>> software! (Don't worry, it can't read or write files on your
>>> machine without special permission.) 
>>> <https://aqua.sfc.wide.ad.jp/quisp-online/0.2.1/> A Quantum
>>> Internet Architecture, with me in the lead but the result of
>>> fifteen years of thinking about how networks should be built, and
>>> with many great collaborators who deserve much thanks but didn’t
>>> make the author list. https://arxiv.org/abs/2112.07092
>>> <https://arxiv.org/abs/2112.07092> Shota has a new standalone
>>> paper on an end-to-end error management scheme. 
>>> https://arxiv.org/abs/2112.07185
>>> <https://arxiv.org/abs/2112.07185> —Rod Rodney Van Meter 
>>> [email-masked] <mailto:[email-masked]> Professor, Faculty
>>> of Environment and Information Studies, Keio University, Japan 
>>> _______________________________________________ Qirg mailing
>>> list [email-masked] https://www.irtf.org/mailman/listinfo/qirg
>> 
>> _______________________________________________ Qirg mailing list 
>> [email-masked] https://www.irtf.org/mailman/listinfo/qirg
>

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 17 Dec 2021 07:23:04 -0800

Hi, Alex,

> On Dec 17, 2021, at 2:29 AM, Alexandre Petrescu <[email-masked]> wrote:
> 

In brief, never.

As Rod pointed out, bandwidth is a rate of information transfer measured in bits per second.

Quantum networking either creates entanglement or transfers superposition; neither is measured as bits per second and neither can be used to communicate information.

Finally, quantum networking typically requires classical communication for coordination, e.g., to exchange measurement basis values, typically at the rate of raw quantum transfer. Even if that is 1:1, other overheads in the classical channel to detect errors (in both quantum and classical) mean that the classical channel will always exceed the rate of quantum transfer.

I.e., not only can quantum not exceed classical, it cannot operate *without* classical running *faster* (at least as far as we currently know).

Joe

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 17 Dec 2021 16:34:07 +0100

Le 17/12/2021 à 16:23, [email-masked] a écrit :
> Hi, Alex,
> 
>> On Dec 17, 2021, at 2:29 AM, Alexandre Petrescu 
>> <[email-masked]
>> <mailto:[email-masked]>> wrote:
>> 
> Quantum networking either creates entanglement or transfers 
> superposition; neither is measured as bits per second

Is there a notion of a quantum network being faster than another quantum
network?

You say it 'transfers' superposition - the transferring takes some time,
normally, or is it instantaneous?  If so, then it would be another term
than 'trnasferring' - maybe 'instantaneous mirroring'?

> and neither can be used to communicate information.

Ah? what can it be useful for if it does not transfer information?

If quantum networking does not transfer information is it for just 
linking things together so they become dependent?

For example, a bit b in city c is linked to bit B in city C such that 
whenever bit b is turned green by some force the bit B is 
instantaneously turned green, right?

Isn't that information transfer?

> 
> Finally, quantum networking typically requires classical
> communication for coordination, e.g., to exchange measurement basis
> values, typically at the rate of raw quantum transfer. Even if that
> is 1:1, other overheads in the classical channel to detect errors (in
> both quantum and classical) mean that the classical channel will
> always exceed the rate of quantum transfer.
> 
> I.e., not only can quantum not exceed classical, it cannot operate 
> *without* classical running *faster* (at least as far as we currently
> know).

I can agree to that.  Faster classical networks can help with 
implementing quantum networks.

Alex

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 17 Dec 2021 16:59:19 -0800

Hi, Alex,

> On Dec 17, 2021, at 7:34 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
>>> On Dec 17, 2021, at 2:29 AM, Alexandre Petrescu <[email-masked]
>> Quantum networking either creates entanglement or transfers superposition; neither is measured as bits per second
> 

Yes, if you measure them by how fast they either create entanglement or transfer superposition.

However, we also care about fidelity, which may change your preference vs. raw speed. 

> normally, or is it instantaneous?

All kinds of communication take time - both classical and quantum. 

>  If so, then it would be another term

I’m not sure what you’re asking. Here’s the summary of time delay effects:

- you can transfer information classically in advance if you know that info in advance (and where to send it)
- you can create entanglement in advance if you know where in advance, but that entanglement doesn’t persist forever (it fades, basically; fidelity decreases over time)
- you can transfer superposition in advance if you know where AND have that superposition in advance, but again it ‘fades’ over time (superposition destabilizes)

> Ah? what can it be useful for if it does not transfer information?

See the docs from this WG. Basically:
	- to teleport other quantum information
	- to create distributed shared random classical state (QKD)
	- for quantum measurement

> If quantum networking does not transfer information is it for just linking things together so they become dependent?

Linking quantum things “quantum-ly” (in a quantum manner; that’s what the above three all do or use.

> For example, a bit b in city c is linked to bit B in city C such that whenever bit b is turned green by some force the bit B is instantaneously turned green, right? 

No. That would achieve faster-than-light classical communication and is not possible.

What you can say is that bit b flips randomly; however it flips, B flips in a correlated way (typically the opposite way, rather than the same).

You CANNOT control how the bit flips, though. That’s why QKD is incorrectly named. QKD doesn’t distribute a key; it is more like QKG - quantum key generation. It either uses entanglement (E91, BBM92) or transfers superposition (BB94) between two endpoints so they can both independently compute the same key.

> Isn't that information transfer?

No. See above.

> I can agree to that.  Faster classical networks can help with implementing quantum networks.

Yes, but quantum networks are roughly 20,000x slower than classical ones (classical links can support 1 Tbps). Although quantum can get faster, I think it will typically remain 100-1000x slower, for many reasons (but that’s a longer discussion).

Joe