Subject: [Qirg] I-D Action: draft-irtf-qirg-principles-09.txt

From: [email-masked]
Date: Mon, 07 Feb 2022 00:49:03 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Quantum Internet Research Group RG of the IRTF.

        Title           : Architectural Principles for a Quantum Internet
        Authors         : Wojciech Kozlowski
                          Stephanie Wehner
                          Rodney Van Meter
                          Bruno Rijsman
                          Angela Sara Cacciapuoti
                          Marcello Caleffi
                          Shota Nagayama
	Filename        : draft-irtf-qirg-principles-09.txt
	Pages           : 45
	Date            : 2022-02-07

Abstract:
   The vision of a quantum internet is to enhance existing Internet
   technology by enabling quantum communication between any two points
   on Earth.  To achieve this goal, a quantum network stack should be
   built from the ground up to account for the fundamentally new
   properties of quantum entanglement.  The first quantum entanglement
   networks have been realised [Pompili21.1], but there is no practical
   proposal for how to organise, utilise, and manage such networks.  In
   this draft, we attempt to lay down the framework and introduce some
   basic architectural principles for a quantum internet.  This is
   intended for general guidance and general interest, but also to
   provide a foundation for discussion between physicists and network
   specialists.  This document is a product of the Quantum Internet
   Research Group (QIRG).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-qirg-principles/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-irtf-qirg-principles-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-qirg-principles-09

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Wojciech Kozlowski <[email-masked]>
Date: Mon, 7 Feb 2022 09:12:07 +0000

I have uploaded the latest version from GitHub as a new draft as no further comments were received.

I also attach the docx with my responses to the original comments and Bruno's responses.

-----Original Message-----
From: Qirg <[email-masked]> On Behalf Of [email-masked]
Sent: maandag 7 februari 2022 09:49
To: [email-masked]
Cc: [email-masked]
Subject: [Qirg] I-D Action: draft-irtf-qirg-principles-09.txt

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dirtf-2Dqirg-2Dprinciples_&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=KAnGdvV_DMIMDEZaeuFfv86IhJ6fNnxI_nMC-nbMTxE&s=W_k5MpTg59fwn5o7x64eQl77R_ksr7UdnkPrPTILYSU&e= 

There is also an htmlized version available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dirtf-2Dqirg-2Dprinciples-2D09&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=KAnGdvV_DMIMDEZaeuFfv86IhJ6fNnxI_nMC-nbMTxE&s=P9YW9KHVp1EhATG6rKnd6ZQkaJ86If_uvIMskIg6vB0&e= 

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dirtf-2Dqirg-2Dprinciples-2D09&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=KAnGdvV_DMIMDEZaeuFfv86IhJ6fNnxI_nMC-nbMTxE&s=UlwCd5BWKH0oLVypHy3qzdc9bXl3POFUO0sBcdD9yVo&e= 

_______________________________________________
Qirg mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=KAnGdvV_DMIMDEZaeuFfv86IhJ6fNnxI_nMC-nbMTxE&s=6XDaND1f0-nZZnO1dEyxPAqHxvYnElLcAdGGIG0QjSw&e=

---

From: Shota NAGAYAMA <[email-masked]>
Date: Thu, 10 Feb 2022 12:12:42 +0900

Oops, sorry, I missed recent emails.
Yesterday I made a pull request about my comments on how classical
messaging impacts the performance, replying Marie-Jose's comment.
Could you check it?

------------------------------------------------
永山翔太 Shota Nagayama, Ph.D.
[email-masked]
https://shota.io/
https://qitf.org/
https://r4d.mercari.com

On Mon, Feb 7, 2022 at 6:12 PM Wojciech Kozlowski <[email-masked]>
wrote:

> https://www.irtf.org/mailman/listinfo/qirg
>

---

From: Wojciech Kozlowski <[email-masked]>
Date: Fri, 11 Feb 2022 12:46:12 +0000

Hi Shota,

PR link: https://github.com/wkozlowski-tudelft/draft-irtf-qirg-principles/pull/12

Thanks for the PR. I think it’s a very important point you made. I’ve made a suggestion on how to combine the two paragraphs you split into one to make it more concise though and I threw out some other text which was now redundant. Let me know what you think.

Wojtek

From: Qirg <[email-masked]> On Behalf Of Shota NAGAYAMA
Sent: donderdag 10 februari 2022 04:13
To: Wojciech Kozlowski <[email-masked]>
Cc: [email-masked]; Marie-Jose Montpetit <[email-masked]>
Subject: Re: [Qirg] I-D Action: draft-irtf-qirg-principles-09.txt

Oops, sorry, I missed recent emails.
Yesterday I made a pull request about my comments on how classical messaging impacts the performance, replying Marie-Jose's comment.
Could you check it?

------------------------------------------------
永山翔太 Shota Nagayama, Ph.D.
[email-masked]<mailto:[email-masked]>
https://shota.io/<https://urldefense.proofpoint.com/v2/url?u=https-3A__shota.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=0chUnQD7IeIpk2qpN0GoCKLcG_MBH_sc1PIftdlOohM&e=>
https://qitf.org/<https://urldefense.proofpoint.com/v2/url?u=https-3A__qitf.org_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=Hk3dDDUP4oTgjsuJX0YQIlPPcOLczIamZyvhTnBjWDY&e=>
https://r4d.mercari.com<https://urldefense.proofpoint.com/v2/url?u=https-3A__r4d.mercari.com&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=K89yaC3S2QA4dBhfUmi2YywBjGy5zBv5EfVZJndSz9E&e=>

On Mon, Feb 7, 2022 at 6:12 PM Wojciech Kozlowski <[email-masked]<mailto:[email-masked]>> wrote:
I have uploaded the latest version from GitHub as a new draft as no further comments were received.

-----Original Message-----
From: Qirg <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: maandag 7 februari 2022 09:49
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Qirg] I-D Action: draft-irtf-qirg-principles-09.txt

Abstract:

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwICAg&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=KAnGdvV_DMIMDEZaeuFfv86IhJ6fNnxI_nMC-nbMTxE&s=6XDaND1f0-nZZnO1dEyxPAqHxvYnElLcAdGGIG0QjSw&e=
_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=LIOefg9sSehe24VmFzpjv1sTNq7OcpkDYjGEk-9ut4I&e=>

---

From: Shota NAGAYAMA <[email-masked]>
Date: Sat, 12 Feb 2022 07:48:27 +0900

Hi Wojciech,

Looks reasonable. Thanks :)

Shota

On Fri, Feb 11, 2022 at 9:46 PM Wojciech Kozlowski <[email-masked]>
wrote:

> Hi Shota,
>
>
>
> PR link:
> https://github.com/wkozlowski-tudelft/draft-irtf-qirg-principles/pull/12
>
>
>
> Thanks for the PR. I think it’s a very important point you made. I’ve made
> a suggestion on how to combine the two paragraphs you split into one to
> make it more concise though and I threw out some other text which was now
> redundant. Let me know what you think.
>
>
>
> Wojtek
>
>
>
> *From:* Qirg <[email-masked]> *On Behalf Of *Shota NAGAYAMA
> *Sent:* donderdag 10 februari 2022 04:13
> *To:* Wojciech Kozlowski <[email-masked]>
> *Cc:* [email-masked]; Marie-Jose Montpetit <[email-masked]>
> *Subject:* Re: [Qirg] I-D Action: draft-irtf-qirg-principles-09.txt
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__shota.io_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=0chUnQD7IeIpk2qpN0GoCKLcG_MBH_sc1PIftdlOohM&e=>
>
> https://qitf.org/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__qitf.org_&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=Hk3dDDUP4oTgjsuJX0YQIlPPcOLczIamZyvhTnBjWDY&e=>
>
> https://r4d.mercari.com
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__r4d.mercari.com&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=K89yaC3S2QA4dBhfUmi2YywBjGy5zBv5EfVZJndSz9E&e=>
>
>
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_qirg&d=DwMFaQ&c=XYzUhXBD2cD-CornpT4QE19xOJBbRy-TBPLK0X9U2o8&r=xRe3k8UnFVGCjuC7RWUARpslGfYlRaP7D3dVZXHUEVc&m=l6NgmTW6q_KdQWRlFtFcEEqblPePHIHgHPOH6WreYKk&s=LIOefg9sSehe24VmFzpjv1sTNq7OcpkDYjGEk-9ut4I&e=>
>
>