Subject: [Qirg] apps draft comments

From: Rodney Van Meter <[email-masked]>
Date: Sun, 13 Mar 2022 17:04:38 +0900

Chonggang et al.,

I took another look at the current draft. My comments:

Still needs some copyediting/wordsmithing, which I can’t do right now.

Hopefully the copy-pasting here doesn’t mangle formatting unintelligibly...

 The connections between the various nodes in the Quantum Internet are
   expected to be primarily fiber optics and free-space optical lasers.
 
Mmm, not quite.

At the physical layer, channels can be either waveguides such as optical fibers or free space.

The physical-layer signals are typically but not necessarily single photons; it is reasonable for pedagogical purposes to refer to them as single photons. They are generally accompanied by stronger laser pulses for timing synchronize and other signalling purposes.

  Classical Internet.  The Quantum Internet will run in conjunction
   with the Classical Internet to form a new Hybrid Internet.  The

Hmm, I wonder if there is consensus on the notion and term “Hybrid Internet”.

“Bell pair” doesn’t need a hyphen most places in this document.

   *  Packet - Formatted unit of multiple related bits.  The bits
      contained in a packet may be classical bits, or the measured state
      of qubits expressed in classical bits.
Since the output of a quantum measurement is a classical bit, this sentence is confusing.

   *  Quantum Key Distribution (QKD) - A method that leverages quantum
      mechanics such as no-cloning theorem to let two parties (e.g., a
      sender and a receiver) securely establish/agree on a key.

to agree on a *classical* key useful for cryptographic purposes.

   *  Quantum Network - A new type of network enabled by quantum
      information technology where qubits are transmitted between nodes
      to convey information.  (Note: qubits must be sent individually
      and not in packets).  The Quantum Network will use both quantum
How do networks that create entanglement fit into this definition? “Transmitting qubits” is certainly done, but starting from that as an explanation I find leads classical people down the wrong path in understanding quantum networks.

      before it is measured and termed to be in superposition.  The
      Degrees of Freedom (DOF) of a photon (e.g., polarization) or an
      electron (e.g., spin) can be used to encode a qubit.

Any of several degrees of freedom can be used. For photons, it can be polarization, time bin, or frequency, for example.

  *  Quantum sensors applications - Refers to the use of quantum
      information technology for supporting distributed sensors (e.g.,
      clock synchronization [Jozsa2000]).

I think we talked about the fact that there are at least three different clock sync proposals; you cite Komar later but not here.

       which has been mathematically proven to be unbreakable.
Yeah, IETF people will push back on this. Proofs always depend on a set of assumptions, and there are known vulnerabilities in some single photon-based QKD implementations. (You mention this later; mention here that caveats to this will be discussed below.)

   3.  Quantum imaging - The highly sensitive quantum sensors show great
       potential in improving the domain of magnetoencephalography.
       Unlike the current classical strategies, with the help of a
       network of quantum sensors, it is possible to measure the
       magnetic fields generated by the flow of current through neuronal
       assemblies in the brain while the subject is moving.  It reveals
       the dynamics of the networks of neurons inside the human brain on
       a millisecond timescale.  This kind of imaging capability could
       improve the diagnosis and monitoring the conditions like
       attention-deficit-hyperactivity disorder [Hill].

I don’t see how this is relevant to quantum networks. Yes, it’s a quantum sensing application, but a local one, not distributed. I think this can just be deleted.

       limitation can easily be avoided using quantum teleportation.  In
“easily” —no, this is actually really, really hard! Performance requirements for this to be effective will be tremendous. Also, it doesn’t really depend on teleportation, it depends on E2E (telescope to telescope) entanglement.

      two classical bits by sending only one qubit).  This approach does
      not need classical channels.  Quantum superdense coding can be
In practice, *all* quantum network applications require supporting classical communication.

      secrets between two parties [Wang].  This secret sharing
      application based on quantum superdense encoding can be classified
      as control plane functionality.
Mmm, I’m increasingly dubious whether the terms control plane and data plane are taking us where we want to go, but at any rate quantum secret sharing is definitely a data plane operation.

   4.  Although the addresses of Source Quantum Node A and Destination
       Quantum Node B could be identified and exposed, the identity of
       users, who will use the secret cryptographic key for secure
       communications, will not necessarily be exposed during QKD
       process.  In other words, there is no direct mapping from the
       addresses of quantum nodes to the user identity; as a result, QKD
       protocols do not disclose user identities.

I’m not sure how that helps us here. As with any other key agreement mechanism, depends on how you integrate it into larger information systems. I think you will get pushback on this one.

   As an example illustrated in Figure 3, a terminal node such as a home
   gateway has collected lots of data and needs to perform computation
   on the data.  The terminal node could be a classical node without any
Blind quantum computation isn’t much of a help on processing your classical data. It will be useful for e.g. running Shor’s factoring algorithm on a remote mainframe quantum computer when you have only a small quantum computer connected to the network. You create individual qubits and send them to the server, which entangles them, calculates on them, then measures them and returns the classical measurements to you. Those measurement results look like 100% random data to the server, because you have chosen their initial states in a cryptographically secure fashion.

Hope these comments help,

—Rod

Rodney Van Meter
[email-masked]
Professor, Faculty of Environment and Information Studies, Keio University, Japan

---

From: "[email-masked]" <[email-masked]>
Date: Sun, 13 Mar 2022 10:39:05 -0700

HI, all,

Comments below - as useful...

> On Mar 13, 2022, at 12:04 AM, Rodney Van Meter <rdv=[email-masked]> wrote:
> 
> Chonggang et al.,
> 

I wonder if this is too limiting. Single photons are useful for entanglement, but not necessarily superposition-based communication (we’re still overlooking that, AFAICT). I agree that waveguide is a better term.

> Hmm, I wonder if there is consensus on the notion and term “Hybrid Internet”.

I don’t think this is a useful term. A quantum Internet depends on classical communication, but that doesn’t make it “hybrid” unless classical information transfer/sync is one of the services of a quantum Internet. I haven’t seen that presented anywhere.

> Since the output of a quantum measurement is a classical bit, this sentence is confusing.

Agreed; it also goes against the classical definition of a packet, which is (parentheses mine):

A self-identified (with in-band addresses or other value that can be used for forwarding) message (an ordered set of bits of determinate number).

The bits are only “related’ in that they arrive in the same packet and in a fixed order. The only format is that the identifier is indicated. 

As to the rest of the sentence, just say “classical bits”; whether they represent measured qubit state or anything else is irrelevant.

> to agree on a *classical* key useful for cryptographic purposes.

And it should say “to let two parties each create the same arbitrary classical key”

The additional words help reinforce the notion that the key contents are NOT under control. It might even be useful to say that QKD is more accurately “quantum ‘key creation’” (QKC), not distribution. (Note the nested quotes).

> How do networks that create entanglement fit into this definition? “Transmitting qubits” is certainly done, but starting from that as an explanation I find leads classical people down the wrong pat…

This also implies a persistent misconception about quantum nets. A qubit doesn’t convey classical information. As one example, QKD conveys NO information. It creates two classical bit strings that are the same, but conveys NO information because the key bit string cannot be controlled.

And I don’t know what it means that qubits are sent in packets ever - largely because a packet implies in-band identification used to forward, but it cannot persist (no-cloning).

> Any of several degrees of freedom can be used. For photons, it can be polarization, time bin, or frequency, for example.

FWIW, if electrons can be used to encode, then waveguide more appropriate than fiber (at the beginning of this message).

> Yeah, IETF people will push back on this. Proofs always depend on a set of assumptions, and there are known vulnerabilities in some single photon-based QKD implementations. (You mention this later;…

I think “unbreakable in principle” is fine.

> I don’t see how this is relevant to quantum networks. Yes, it’s a quantum sensing application, but a local one, not distributed. I think this can just be deleted.

Question - is it not distributed on cm-m spatial scales? (Not km, of course).

> In practice, *all* quantum network applications require supporting classical communication.

Again, that’s a good reason to say that a quantum network requires a hybrid implementation (but not a hybrid network, as I noted above).

> Mmm, I’m increasingly dubious whether the terms control plane and data plane are taking us where we want to go, but at any rate quantum secret sharing is definitely a data plane operation.

Agreed - applications NEVER use control plane (unless the purpose of the application is actually the control plane itself).

> I’m not sure how that helps us here. As with any other key agreement mechanism, depends on how you integrate it into larger information systems. I think you will get pushback on this one.

Also, I think this is a stretch. Addresses of quantum notes do reveal something, e.g., the identification of the quantum nodes. 

We haven’t really talked much (AFAIR) about user identities (or more to the point, application identities) and how they tie into quantum node addresses… (a QNS? Or just the DNS with new TEXT fields?)

> [email-masked] <mailto:[email-masked]>
> _______________________________________________
> Qirg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/qirg

---

From: Chonggang Wang <[email-masked]>
Date: Fri, 18 Mar 2022 15:11:58 +0000

Hi Joe, Rodney,

Thank you very much for taking your time in reviewing the document and offering your valuable comments.

Please see my inline replies with the initial “[CW]”. Please let us now if you are ok with the replies and/or if you have any additional suggestions.

Your feedback is very helpful. We are willing to upload a new version of our document right after IETF 113, to incorporate your comments/suggestions.

Bess regards,
Chonggang

From: Qirg <[email-masked]> On Behalf Of [email-masked]
Sent: Sunday, March 13, 2022 1:39 PM
To: Rodney Van Meter <rdv=[email-masked]>
Cc: Rodney Van Meter <[email-masked]>; [email-masked]
Subject: Re: [Qirg] apps draft comments

HI, all,

On Mar 13, 2022, at 12:04 AM, Rodney Van Meter <rdv=[email-masked]<mailto:rdv=[email-masked]>> wrote:

Chonggang et al.,

Mmm, not quite.

[CW]: Agreed and will change it to “waveguide” without limiting to single photons.

[CW]: We used “Hybrid Internet” here and in the document to show the fact of the co-existence and integration of “classical” and “quantum”, a kind of hybrid from two senses: 1) quantum technologies such as QKD needs classical transmissions; 2) classical protocols/mechanisms (e.g., TLS, etc.) can be benefited from quantum technologies such as QKD, etc. If the group agrees, we can remove and avoid the use of “Hybrid Internet” in the document.

“Bell pair” doesn’t need a hyphen most places in this document.
[CW]: Sorry about it. Will double check and fix them throughout the document.

[CW]: Do you feel the following revised definition is better and properly reflects what you were suggesting:
Packet - A self-identified message with in-band addresses or other information that can be used for forwarding the message. The message contains an ordered set of bits of determinate number. The bits contained in a packet are classical bits.

[CW]: Thanks for the good suggestions. Should we change the definition to the following one based on your suggestions?
Quantum Key Distribution (QKD) - A method that leverages quantum mechanics such as no-cloning theorem to let two parties each create the same arbitrary classical key.

[CW]: I am sorry but I am not sure what you were exactly suggesting to revise the definition of Quantum Network. It could be very lengthy or very concise. What you do think the following one:
Quantum Network - A new type of network enabled by quantum information technology where quantum resources such as qubits and entanglement are transmitted and utilized between quantum nodes.  The Quantum Network will use both quantum channels, and classical channels provided by the Classical Internet, referred to as a hybrid implementation.

[CW]: Agreed and will rephase the sentence to: “Any of several Degrees of Freedom (DOF) of a photon (e.g., polarization, time bib, and/or frequency) or an electron (e.g., spin) can be used to encode a qubit.”

      clock synchronization [Jozsa2000]).
I think we talked about the fact that there are at least three different clock sync proposals; you cite Komar later but not here.
[CW]: It was somehow overlook here. Sorry about it. Thanks for the good catch and will fix it.

[CW]: Agreed with both of you. Will adopt Joe’s proposal and reword it to: “…which is unbreakable in principle.”

[CW]: Ok and we can remove this scenario.

       limitation can easily be avoided using quantum teleportation.  In
“easily” —no, this is actually really, really hard! Performance requirements for this to be effective will be tremendous. Also, it doesn’t really depend on teleportation, it depends on E2E (telescope to telescope) entanglement.
[CW]. How about revising it too: “..limitation can be potentially avoided using quantum teleportation.”

[CW]: Ok and we can remove “This approach does not need classical channels.”. I also liked “…requires a hybrid implementation”.

[CW]: Ok and we can remove “This secret sharing application based on quantum superdense encoding can be classified as control plane functionality”. To me, certain applications do have “control part”; for instance, TCP connection establishment (and TCP disconnection) is “control part”, while data transmission right after establishing TCP connection is “data part”. In some other cases (e.g., small data transmission in 5G), an application (e.g., an IoT application) does use “control plane” (e.g., NAS in 3GPP). If the group agrees, we can remove all “control plane” and “data plane” from the document, but I personally feel it helps people (at least for me with more previous background on classical internet) to understand better about this type of “hybrid implementation” of  quantum internet.

[CW]: This paragraph was added to address one of comments raised in a previous IETF meeting. We can remove it if the group agrees.

   on the data.  The terminal node could be a classical node without any
Blind quantum computation isn’t much of a help on processing your classical data. It will be useful for e.g. running Shor’s factoring algorithm on a remote mainframe quantum computer when you have only a small quantum computer connected to the network. You create individual qubits and send them to the server, which entangles them, calculates on them, then measures them and returns the classical measurements to you. Those measurement results look like 100% random data to the server, because you have chosen their initial states in a cryptographically secure fashion.
[CW]: Thanks for suggesting this nice scenario. Will incorporate it into the new version.

Hope these comments help,
[CW]: It indeed helps a lot to improve the document furthermore. Thank you very much again Rodney for your time and useful feedback/thoughts.

—Rod

Rodney Van Meter
[email-masked]<mailto:[email-masked]>
Professor, Faculty of Environment and Information Studies, Keio University, Japan

_______________________________________________
Qirg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/qirg

[Banner]

[Banner]<https://www.interdigital.com/features/sustainability-in-a-wireless-world>

Sustainability in a Wireless World: Research dedicated to understanding the impact of our technologies on the planet.<https://www.interdigital.com/features/sustainability-in-a-wireless-world>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Rodney Van Meter <[email-masked]>
Date: Tue, 22 Mar 2022 23:05:55 +0900

Re: appropriate, more generic word for moving qubits from node to node…

Transfer?

That would give us a three-term taxonomy:

* transmit — encode a qubit into a faster carrier (i.e., typically photon) and pass it through a channel from a sender (transmitter) to a receiver
* teleport — use quantum teleportation to move a qubit from one node to another (sender to receiver?)
* transfer — data is moved from one node to another, but means of moving data unspecified; could be transmit, teleport, or carry via container ship

In my earlier work, I coined the terms “teledata” and “telegate” to refer to two of the primary uses of entanglement: teleporting data versus remote execution of a two-qubit gate, called a “teleported gate” by others.  My terms didn’t really catch on, though a few people have used them.

—Rod

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 22 Mar 2022 07:45:20 -0700

Hi, Rod (et al.),
—
Dr. Joe Touch, temporal epistemologist
www.strayalpha.com

> On Mar 22, 2022, at 7:05 AM, Rodney Van Meter <[email-masked]> wrote:
> 

I don’t think “faster” is required; just to a “mobile” carrier.

> * teleport — use quantum teleportation to move a qubit from one node to another (sender to receiver?)

Teleportation seems to me to require something more than just a carrier, i.e., "an operation on two or more carriers in succession to move a qubit…"

> * transfer — data is moved from one node to another, but means of moving data unspecified; could be transmit, teleport, or carry via container ship

That seems reasonable. Note that container ship is still a “mobile” carrier; it’s just fermions instead of bosons. I would still call that “transmission” but not “teleportation”.

I don’t think it’s useful to differentiate between fermion and boson transmission.

Joe

---

From: Chonggang Wang <[email-masked]>
Date: Wed, 23 Mar 2022 12:59:00 +0000

Rod,

We can add those three definition to the application draft. Just wanted to make sure if you were suggesting other changes to the draft.

Thanks,
Chonggang

From: [email-masked] <[email-masked]>
Sent: Tuesday, March 22, 2022 10:45 AM
To: Rodney Van Meter <[email-masked]>
Cc: Chonggang Wang <[email-masked]>; Rodney Van Meter <rdv=[email-masked]>; [email-masked]
Subject: Re: transfer? was Re: [Qirg] apps draft comments

Hi, Rod (et al.),
—
Dr. Joe Touch, temporal epistemologist
www.strayalpha.com<http://www.strayalpha.com>

On Mar 22, 2022, at 7:05 AM, Rodney Van Meter <[email-masked]<mailto:[email-masked]>> wrote:

Transfer?

Joe

—Rod

[Banner]