Subject: Consensus notification: QUIC advertisement description (#87)

From: Mike Bishop <[email-masked]>
Date: Tue, 31 Jan 2017 21:28:25 +0000

This issue<https://github.com/quicwg/base-drafts/issues/87> tracks the definition of HTTP/QUIC's ALPN identifier and the version-negotiation hint to Alt-Svc.  Text was originally proposed in PR #90 and incorporated in draft -01.

During the interim in Tokyo, we agreed to use quic= instead of v=, since the format has changed from Google's existing use, and because v= is a bit generic.  This change, along with some editorial feedback, is in PR #235<https://github.com/quicwg/base-drafts/pull/235>.

I'd like to get more eyes on it, and if there's still consensus, merge the change and close the issue.

---

From: Ryan Hamilton <[email-masked]>
Date: Tue, 31 Jan 2017 17:43:40 -0800

As I read this, it make two changes with respect to what Google is
currently doing:

Old: Alt-Svc: quic=“:443”;v=“32,33”
New: AltSvc: hq=":443";quic=1;quic=51303334​

So it renames v= to quic= (and changes the format somewhat) and renames
quic= to hq.

Am I correct in understanding that a server that wanted to advertise QUIC
to both "old" and "new" clients could do:

Alt-Svc: quic=“:443”;v=“32,33”, hq=":443";quic=1;quic=51303334​

Cheers,

Ryan​

On Tue, Jan 31, 2017 at 1:28 PM, Mike Bishop <[email-masked]>
wrote:

> This issue <https://github.com/quicwg/base-drafts/issues/87> tracks the
> definition of HTTP/QUIC’s ALPN identifier and the version-negotiation hint
> to Alt-Svc.  Text was originally proposed in PR #90 and incorporated in
> draft -01.
>
>
>
> During the interim in Tokyo, we agreed to use quic= instead of v=, since
> the format has changed from Google’s existing use, and because v= is a bit
> generic.  This change, along with some editorial feedback, is in PR #235
> <https://github.com/quicwg/base-drafts/pull/235>.
>
>
>
> I’d like to get more eyes on it, and if there’s still consensus, merge the
> change and close the issue.
>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 1 Feb 2017 12:50:09 +1100

On 1 February 2017 at 12:43, Ryan Hamilton <[email-masked]> wrote:
> Am I correct in understanding that a server that wanted to advertise QUIC to
> both "old" and "new" clients could do:
>
> Alt-Svc: quic=“:443”;v=“32,33”, hq=":443";quic=1;quic=51303334

This is correct.