Subject: No support for multipath in QUIC?

From: Simon Pietro Romano <[email-masked]>
Date: Wed, 15 Feb 2017 19:49:47 +0100

Hi all,

as part of a research project here at the University of Napoli, we are working on a multipath enabled version of QUIC. Though, through interactions with the Chromium guys on the "proto-quic” mailing list (which, as you know, is developing a code base for QUIC implementation), we just discovered that they’re actively removing the multipath code from the active repo. Does this also mean that the QUIC wg at the IETF does not look at multipath as a desirable functionality to be (optionally) offered by the protocol? If so, can I dare to ask why?

Thanks a lot for your feedback,

Simon

                     				            _\\|//_
                           				   ( O-O )
      ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked] <mailto:[email-masked]>

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
       ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Ryan Hamilton <[email-masked]>
Date: Wed, 15 Feb 2017 11:03:15 -0800

The IETF QUIC Working Group is tasked with, among other things:

- Enabling multipath and forward error correction extensions;

As such, I'm sure this group will eventually tackle multipath. However, it
will likely be done via an extension to the core protocol. The experimental
multipath support in Google's QUIC implementation was not via an extension,
and was never complete. Instead it was a core part of the protocol and
hence is being removed.

Cheers,

Ryan

On Wed, Feb 15, 2017 at 10:49 AM, Simon Pietro Romano <[email-masked]>
wrote:

> Hi all,
>
> as part of a research project here at the University of Napoli, we are
> working on a multipath enabled version of QUIC. Though, through
> interactions with the Chromium guys on the "proto-quic” mailing list
> (which, as you know, is developing a code base for QUIC implementation), we
> just discovered that they’re actively removing the multipath code from the
> active repo. Does this also mean that the QUIC wg at the IETF does not look
> at multipath as a desirable functionality to be (optionally) offered by the
> protocol? If so, can I dare to ask why?
>
>              Phone: +39 081 7683823 <+39%20081%20768%203823> -- Fax: +39
> 081 7683816 <+39%20081%20768%203816>
>                                            e-mail: [email-masked]
>

---

From: Simon Pietro Romano <[email-masked]>
Date: Sat, 18 Feb 2017 10:20:13 +0100

Hello Ryan,

thank you for answering my question (both here and on the proto-quic ML). It’s a pity that the community decided to stop the engines (for now) on multipath. We do believe this functionality might prove of paramount importance in a number of different scenarios. We’ll definitely keep on working on that, by focusing on our (alas, non standard) fork of the chromium code base. In the meanwhile, we’ll wait for the standard extension promised by the WG.

Cheers,

Simon

                     				            _\\|//_
                           				   ( O-O )

> On 15 Feb 2017, at 20:03, Ryan Hamilton <[email-masked]> wrote:
> 
> As such, I'm sure this group will eventually tackle multipath. However, it will likely be done via an extension to the core protocol. The experimental multipath support in Google's QUIC implementation was not via an extension, and was never complete. Instead it was a core part of the protocol and hence is being removed.
> 
> Cheers,
> 
> Ryan
> 
> On Wed, Feb 15, 2017 at 10:49 AM, Simon Pietro Romano <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
> 	             Phone: +39 081 7683823 <tel:+39%20081%20768%203823> -- Fax: +39 081 7683816 <tel:+39%20081%20768%203816>