Subject: Adjustments to the issue resolution documentation

From: Mark Nottingham <[email-masked]>
Date: Tue, 7 Mar 2017 11:52:05 +1100

Hi everyone,

Based on our experience so far in running the process, and after discussion with Lars and the Editors, I've made a few changes to the documentation in CONTRIBUTING.md regarding how issues are resolved.

See:
  https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md#resolving-issues

In particular, we now have an explicit `has-consensus` label to reflect those issues where we've declared WG consensus.

`Closed` issues are merely those that have a proposal reflected in the document that we *believe* reflects consensus, but that hasn't been confirmed yet.

Does that make sense to everyone? Hopefully this will reflect the process more clearly, and be easier to understand. If this causes concern or if you have other suggestions, please bring it up.

Cheers,

P.S. Keen observers will note that we only have declared consensus on one issue -- hopefully that number will increase once we get a new set of drafts out and reviewed.

--
Mark Nottingham   https://www.mnot.net/

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 6 Mar 2017 17:08:35 -0800

​​

On Mon, Mar 6, 2017 at 4:52 PM, Mark Nottingham <[email-masked]> wrote:

> Hi everyone,
>
> Based on our experience so far in running the process, and after
> discussion with Lars and the Editors, I've made a few changes to the
> documentation in CONTRIBUTING.md regarding how issues are resolved.
>
> See:
> In particular, we now have an explicit `has-consensus` label to reflect
> those issues where we've declared WG consensus.
>
> `Closed` issues are merely those that have a proposal reflected in the
> document that we *believe* reflects consensus, but that hasn't been
> confirmed yet.
>
> Does that make sense to everyone?

​This makes a lot of sense to me, since it makes it very explicit which
issue have consensus and which we believe to have consensus.​ Thanks for
doing this!

> Hopefully this will reflect the process more clearly, and be easier to
> understand. If this causes concern or if you have other suggestions, please
> bring it up.
>
> Cheers,
>
> P.S. Keen observers will note that we only have declared consensus on one
> issue -- hopefully that number will increase once we get a new set of
> drafts out and reviewed.
>
> --

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 7 Mar 2017 10:59:50 -0800

Sounds good to me!

On Mon, Mar 6, 2017 at 4:52 PM, Mark Nottingham <[email-masked]> wrote:

> Does that make sense to everyone? Hopefully this will reflect the process
> more clearly, and be easier to understand. If this causes concern or if you
> have other suggestions, please bring it up.
>
> Cheers,
>