Subject: Reference Implementation

From: Brett Jackson <[email-masked]>
Date: Thu, 20 Apr 2017 20:58:03 -0500

Are there currently any reference implementations in progress?

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 21 Apr 2017 12:04:02 +1000

Hi Brett,

> On 21 Apr 2017, at 11:58 am, Brett Jackson <[email-masked]> wrote:
> 

We haven't yet nominated a draft to implement; people have done some informal coding, and of course there's the gQUIC implementation, but nothing more. Additionally, the IETF doesn't generally nominate "reference" implementations, since that implies that a failure to interoperate with one implementation is a failure to conform to the specification.

We hope to designate a first draft for implementation after our next Interim meeting in early June; early implementations should start to emerge after that.

Cheers,

--
Mark Nottingham   https://www.mnot.net/