Subject: nits in draft-ietf-quic-recovery-05

From: Roni Even <[email-masked]>
Date: Mon, 11 Sep 2017 06:16:57 +0000

Hi,

In section 3.1 the bullet before the last one "a QUIC sender marks a packet as lost when a packet larger than it is acknowledged" should be "with higher packet number" instead of "larger"?

In section 3.2.7.4 "if (retransmittable_packets_outstanding = 1):"   should be "==" instead of "="?

Thanks

Roni

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 11 Sep 2017 11:44:56 -0700

Hi Roni,

Thanks for your careful read of the draft!

> In section 3.1 the bullet before the last one “a QUIC sender marks a
> packet as lost when a packet larger than it is acknowledged” should be
> “with higher packet number” instead of “larger”?
>
We've consistently used "larger" packet number, so I'm inclined to stick
with that, even if "higher" is slightly more correct?

In section 3.2.7.4 “if (retransmittable_packets_outstanding = 1):”   should
> be “==” instead of “=”?
I'll fix this.

Thanks!
- jana

---

From: Matthew Kerwin <[email-masked]>
Date: Tue, 12 Sep 2017 07:30:43 +1000

On 12 Sep. 2017 04:45, "Jana Iyengar" <[email-masked]> wrote:

Hi Roni,

A "larger packet", and a "packet with a higher/larger/greater/whatever id"
are two different things. I think that's the contention.

Cheers
--
Matthew Kerwin

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 11 Sep 2017 14:41:30 -0700

> are two different things. I think that's the contention.

Oh, right, I missed that. Thanks for clarifying, I'll fix it (change to
"marks a packet as lost when a packet with a larger packet number is
acknowledged.")

---

From: Christian Huitema <[email-masked]>
Date: Mon, 11 Sep 2017 18:09:58 -0700

On 9/11/2017 2:41 PM, Jana Iyengar wrote:
>
> Oh, right, I missed that. Thanks for clarifying, I'll fix it (change
> to "marks a packet as lost when a packet with a larger packet number
> is acknowledged.")

Except that's not true, because that simple statement does not take into
account possible out of order deliveries. Indeed, the overview says: "A
packet is marked as lost if at least one packet that was sent a
threshold number of packets (kReorderingThreshold) after it has been
acknowledged." But the overview is not correct either, because it does
not consider time. A packet could still be marked as lost if
"time_reordering_fraction + kDelayedAckTimeout" has elapsed since
receiving an acknowledgement of a packet with a larger number.

-- 
Christian Huitema

---

From: Roni Even <[email-masked]>
Date: Tue, 12 Sep 2017 05:06:15 +0000

HI Jana,
Thanks, this was my comment about just saying “larger”
Roni

From: Jana Iyengar [mailto:[email-masked]]
Sent: יום ג 12 ספטמבר 2017 00:42
To: Matthew Kerwin
Cc: Roni Even; IETF QUIC WG
Subject: Re: nits in draft-ietf-quic-recovery-05

On Mon, Sep 11, 2017 at 2:30 PM, Matthew Kerwin <[email-masked]<mailto:[email-masked]>> wrote:

On 12 Sep. 2017 04:45, "Jana Iyengar" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Roni,

In section 3.1 the bullet before the last one “a QUIC sender marks a packet as lost when a packet larger than it is acknowledged” should be “with higher packet number” instead of “larger”?
We've consistently used "larger" packet number, so I'm inclined to stick with that, even if "higher" is slightly more correct?

A "larger packet", and a "packet with a higher/larger/greater/whatever id" are two different things. I think that's the contention.

Oh, right, I missed that. Thanks for clarifying, I'll fix it (change to "marks a packet as lost when a packet with a larger packet number is acknowledged.")

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 14 Sep 2017 18:00:09 -0700

Christian -- yes, the overview needs rework. I'll try to do a rewrite
before the next set of drafts comes out.