Subject: Consensus Call on issues closed by the -06 drafts

From: Mark Nottingham <[email-masked]>
Date: Tue, 26 Sep 2017 10:32:21 +1000

Everyone,

The -06 drafts incorporate the proposed resolutions to another group of issues, as listed below.

Please have a look through them. If there are any resolutions that you feel need more discussion, please bring it up, either here on the mailing list or by commenting on the issue itself. In either case, please explicitly ask for the issue to be re-opened if you want it to be reconsidered.

If folks do this before the Seattle interim, we can hopefully have any necessary discussions before or during the meeting.

See <https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md#resolving-issues> for a reminder about the process we're using here. Even when we have consensus, we can reopen an issue if new information emerges (and that can take a variety of forms).

This list is also available at <https://github.com/quicwg/base-drafts/issues?utf8=✓&q=is%3Aissue%20is%3Aclosed%20-label%3Ainvalid%20-label%3Aeditorial%20-label%3Ahas-consensus%20>.

* #748: Introduce draining period for connection termination   (transport)
* #733: Acknowledging *_CLOSE   (transport)
* #729: Keep alive advice   (transport http)
* #709: Make Push ID sequential   (http)
* #702: Concurrent server pushes for the same resource   (http)
* #700: Can a DATA frame be empty?   (http)
* #696: Move GOAWAY to HTTP draft   (transport http)
* #690: Do we need endofearlydata?   (tls)
* #684: Simplify Client Initial size   (transport)
* #637: Suggest linking CCID to SCID   (transport)
* #635: Ack frame has two framings that specify a single range   (transport)
* #628: Move stream close forward   (transport)
* #622: Proxy context   (transport)
* #620: Move stream IDs to the front of frames   (transport)
* #606: Transport: Client IP change reason   (transport)
* #601: Transmitting ACK frames   (recovery)
* #599: Public Resets should be triggered by only QUIC packets   (transport)
* #596: Guard initial packet against amplification attack via compression   (transport)
* #588: Server chosen connection ID design   (transport)
* #572: Should we transition to Open state when recv even MAX_STREAM_DATA or RST on idle   (transport)
* #564: loosen MUST requirement around close-on-ack-of-unsent   (transport)
* #563: ACK prohibitions   (transport)
* #557: PUSH_PROMISE ordering guarantee   (http)
* #554: Reconsider the use of FNV-1a for "cleartext" integrity   (transport)
* #547: Version fields in transport parameters for NewSessionTicket   (transport)
* #546: What to do if a skipped packet is acknowledged   (transport recovery)
* #545: Add congestion control   (recovery)
* #544: Incorporate F-RTO   (recovery)
* #509: Proof of receipt of packets in ACK   (transport)
* #508: Stream ID encoding   (transport)
* #489: Propose SLOT Frame   (transport)
* #477: Use positive phrasing instead of double negative   (http)
* #436: Move SETTINGS into TLS Handshake   (http)
* #433: Propose compressed zero stream frames or TRIM frames (and partially reliable streams)   (transport)
* #426: QUIC header format/demultiplexing   (transport)
* #383: Maximum packet size   (transport)
* #353: Replace CONNECTION_CLOSE with Public Reset   (transport)
* #330: CONNECTION_CLOSE semantics   (transport)
* #328: TIME_WAIT   (transport)
* #281: Promising more than the client concurrency limit   (transport http)
* #245: Single stream for headers and body   (http)
* #215: Public reset   (transport)
* #177: CONNECTION_CLOSE reliability   (transport recovery)
* #165: Resetting Streams   (transport http)
* #126: Separate transport parameters for 0-RTT   (transport)
* #121: Version downgrade vulnerability   (transport tls)
* #68: Explicit Congestion Notification (ECN)   (transport recovery)
* #51: QUIC version number scheme   (transport)

--
Mark Nottingham   https://www.mnot.net/

---

From: Mikkel Fahnøe Jørgensen <[email-masked]>
Date: Tue, 26 Sep 2017 00:24:03 -0700

I don’t agree with closing #637
https://github.com/quicwg/base-drafts/issues/637, but a new issue
https://github.com/quicwg/base-drafts/issues/714
has been raised which largely covers the same issue, and it appears there
are discussing on keeping client ID in error message responses, though I
don’t have an overview on that.

Kind Regards,
Mikkel Fahnøe Jørgensen

On 26 September 2017 at 02.32.33, Mark Nottingham ([email-masked]) wrote:

637

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Sep 2017 15:45:46 +0000

#637 was closed, not because it was resolved in-draft, but because it advocated a particular solution to a problem rather than reflecting a problem by itself.  Perhaps we should mark it with a different tag than has-consensus, but I believe its June closure is still correct.

From: QUIC [mailto:[email-masked]] On Behalf Of Mikkel Fahnøe Jørgensen
Sent: Tuesday, September 26, 2017 12:24 AM
To: QUIC WG <[email-masked]>; Mark Nottingham <[email-masked]>
Cc: Lars Eggert <[email-masked]>
Subject: Re: Consensus Call on issues closed by the -06 drafts

I don’t agree with closing #637 https://github.com/quicwg/base-drafts/issues/637<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fissues%2F637&data=02%7C01%7Cmichael.bishop%40microsoft.com%7C9734db73328a49002cae08d504af9652%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636420074550095904&sdata=bjp440FcW7LhWZGoZV68OKFkAFPyxce8AmH42Rn1hU4%3D&reserved=0>, but a new issue
https://github.com/quicwg/base-drafts/issues/714<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fquicwg%2Fbase-drafts%2Fissues%2F714&data=02%7C01%7Cmichael.bishop%40microsoft.com%7C9734db73328a49002cae08d504af9652%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636420074550095904&sdata=bbu%2BXJe4PRDTehlAAGiV%2BQup67i%2FAynE2bF1P2RumZk%3D&reserved=0>
has been raised which largely covers the same issue, and it appears there are discussing on keeping client ID in error message responses, though I don’t have an overview on that.

Kind Regards,
Mikkel Fahnøe Jørgensen

On 26 September 2017 at 02.32.33, Mark Nottingham ([email-masked]<mailto:[email-masked]>) wrote:
637

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 27 Sep 2017 11:36:45 +1000

Marked as 'invalid' which covers both 'not well formed' and 'duplicate'.

Let's try to keep the issues as just that -- issues. If you have a proposal, there are many ways to convey that:

* As a message on the mailing list
* As a pull request
* As a comment on an issue (that describes the issue it's trying to address).

Cheers,

> On 27 Sep 2017, at 1:45 am, Mike Bishop <[email-masked]> wrote:
> 
> I don’t agree with closing #637 https://github.com/quicwg/base-drafts/issues/637, but a new issue