Subject: Error reporting on handshake

From: Jānis Čoders <[email-masked]>
Date: Wed, 13 Sep 2017 16:26:16 +0300

Hi, how should QUIC server respond while performing TLS handshake and
there is a server internal error - too many parallel authentications,
no memory or other?
Should it respond with ConnectionClose Frame encapsulated into
LongHeader-ServerCleartext or some other?

Thank you

-- 
Ar cieņu,
Jānis Čoders

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 19 Sep 2017 12:14:33 -0700

Hi Jānis,

That's the only mechanism we have right now, so yes, a ConnectionClose
frame in a Server Cleartext packet would be the way to send it.

- jana

---

From: Patrick McManus <[email-masked]>
Date: Tue, 19 Sep 2017 17:09:22 -0400

https://github.com/quicwg/base-drafts/issues/608

---

From: Jānis Čoders <[email-masked]>
Date: Wed, 20 Sep 2017 09:33:17 +0300

Thank you

-- 
Ar cieņu,
Jānis Čoders